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Introduction 

1 Grass Valley Product Support 

International 
Support Centers 

France 
24 x 7 

 

+800 8080 2020 or +33 1 48 25 20 20 
United States/Canada 

24 x 7 

 

+1 800 547 8949 or +1 530 478 4148 

 
 
 

Local Support 
Centers 

(available 
during normal 

business hours) 

 
Asia 

Hong Kong, Taiwan, Korea,  Macau:  +852 2531 3058 Indian Subcontinent: +91 22 24933476 
Southeast Asia/Malaysia: +603 7492 3303 Southeast Asia/Singapore: +65 6379 1313 
China: +861 0660 159 450 Japan: +81 3 5484 6868 

Australia  and New Zealand:  +61 1300 721 495 Central/South  America:  +55 11 5509 3443 

Middle  East: +971 4 299 64 40 Near East and Africa: +800 8080 2020 or +33 1 48 25 20 20 

 

 
Europe 

Belarus, Russia,  Tadzikistan,  Ukraine,  Uzbekistan:  +7 095 2580924 225 Switzerland:  +41 1 487 80 02 
S. Europe/Italy-Roma: +39 06 87 20 35 28 -Milan: +39 02 48 41 46 58 S. Europe/Spain:  +34 91 512 03 50 
Benelux/Belgium: +32 (0) 2 334 90 30 Benelux/Netherlands: +31 (0) 35 62 38 42 1 N. Europe: +45 45 96 88 70 
Germany, Austria,  Eastern Europe: +49 6150 104 444 UK, Ireland, Israel: +44 118 923 0499 

 

 

2 About his document 

This document describes Composer for GV Director for release 1.7.2-gvd. 

 

 

3 Composer 

Composer is the animation and compositing tool for designing the look and feel of live productions. It 

allows for designing GV Director Production Elements (Effects, Transitions and Compound Elements).  
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3.1 Objects  

  

Composer works with Objects such as Clip, Box, Still, 

Animation, Plane and so on. Objects have properties, 

such as opacity, position and scale that can be 

modified and animated.  

The example shows the Object properties window for 

a Clip Object. 

 

 

The Objects window lists all the Objects added to a 

Project (or all Objects included in the selected 

Template when the Filter icon is active as shown in the 

example on the left.) 

Each Object is placed on its own layer. Objects on 

higher layers overlap Objects on lower layers.  

 

 

One and the same Object can be used in different 

Templates while its properties can have different 

values per Template. 
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3.2 Templates 

 

 

Templates are used to transform Objects’ properties such as opacity, position and scale in time. The 

example above shows a Template used to play a Clip. The column on the left lists the Objects 

included in the Template. Each Object has its own track on the Timeline. The player head (the yellow 

vertical line) can be moved, paused and rewinded to preview animations on the Stage.  
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3.3 Project Assets, Scene Parameters and Test Media 

3.3.1 Project Assets 

All the fixed files that belong to a Production design are added to the Project as Assets. These Assets 

are included in the Production Pack when the Project is exported to the GV Director system. Thus, all 

the fixed design elements needed for production are available on the GV Director system.  

 

3.3.2 Scene Parameters 

Objects can refer to fixed or dynamic values. 

 Example fixed value: a fixed text string. 

 Example dynamic value: specify the width of a banner or a logo file during production. 
 
Scene Parameters are used to define dynamic values. 
 

 

Example Text Object that uses a scene parameter Free Text. 
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3.3.3 Test media 

For testing purposes, test media (images, videos) can be added to the Test Media library. Note that 

test media will not be included in the Production Pack when the Project is exported. 

 
 

3.4 Projects and Production Packs  

Production elements are authored in Composer: 

 Transitions 

 Templates (used to build Effects) 

 Effects 

 Compound Elements 

 

These elements are edited in a Project. The Project also contains fixed design elements such as 

straps and logos. Once the design is ready for production, the Project is bundled in a Production Pack 

and exported to the GV Director system, thus making all design elements available for live production. 

Production Elements can then be assigned to buttons on the GV Director Panel. 
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Getting Started 

4 Composer Installation 

 

 

We recommend the following image editors: 

 Windows: Paint.NET http://www.getpaint.net/index.html 

 OSX: GIMP http://www.gimp.org/ 

 

These editors can export to the TARGA-format, Composer’s native still format (with alpha support).  

 

4.1 System Requirements (Mac) 

 A Mac computer with a multi-core Intel processor (64-bit). 

 Mac OS X v10.6 (Snow Leopard) or later. 

 Memory: 4GB of RAM. 

 Video card:  

o 512MB of VRAM or more.  

o OpenGL 2.1 and the following OpenGL extensions: 

 EXT_framebuffer_multisample 

 EXT_framebuffer_blit 

 ARB_texture_rectangle 

 APPLE_flush_buffer_range 

o NOT recommended: Nvidia Quadro cards.  

o Recommended: ATI Radeon HD5670 or better, Nvidia Geforce GT320 or better. 

 

[See the following link for an overview of the OpenGL support on Mac OS X for your system and video 

card: http://developer.apple.com/graphicsimaging/opengl/capabilities/] 

[See the readme included with the installation image for most recent requirements.] 

 

http://www.getpaint.net/index.html
http://www.gimp.org/
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4.2 Installation Mac 

 Double-click the Composer image (.dmg file) to mount the disk image.  

The disk image icon appears on the desktop and the next window opens. 

 Drag the Composer icon on the Applications folder, to copy Composer to your Applications folder. 

 

You can now start Composer from the Applications folder. 

 

4.3 Requirements (Windows) 

 An Intel/AMD 64-bit multiprocessor PC.  

 A 64bit edition of Windows Vista, Windows 7 or Windows 8. 

 Memory: 4GB of RAM. 

 Video card: 

o 512MB of VRAM or more. 

o OpenGL 2.1 and the following OpenGL extensions: 

 EXT_framebuffer_multisample 

 EXT_framebuffer_blit 

 ARB_texture_rectangle 

 ARB_map_buffer_range 

o    NOT recommended: Nvidia Quadro cards.  

o Recommended: Nvidia Geforce GTS250 or better. 

[See the readme included with the installation image for most recent requirements.] 

 

 

 

It is not possible to run Composer via Windows Remote Desktop.  
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4.4 Installation Windows 

 Double-click the installer exe file and follow the instructions. 

 

 

It is recommended to run Composer as an Administrators group user. The easiest way to achieve this 

is to mark the application to run as Administrator: in Windows Explorer, access 'Composer.exe' 

properties, navigate to 'Compatibility' tab and tick 'Run as Administrator' checkbox. Composer does 

not really require elevated privileges to run, but in doing so a wider range of thread scheduling 

priorities become available thus allowing for faster response times. Note that Composer does not 

create or modify any files unless instructed by the user, i.e. to save a project on disk. To that effect it is 

perfectly safe to run Composer as Administrators group user. 
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5 Starting Composer 

 

To start Composer, double-click the 
Composer icon. 

 

Composer opens. You can now start working 

on a Project.  
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6 Setting Composer Preferences  

File > Preferences > Nexos 

 

Note that these settings only affect (the design's visual quality on) your workstation, not actual 

playout. 

 

 Format: the broadcast format. 

 Multi-Sampling Anti Aliasing: use to improve the design's visual quality on your 

workstation (remove edge line roughness and jagged edges). Note that higher sample rates 

impact performance of your workstation. 

 Players: set the big buffer pool size in MB. Default 500. If a project includes a high number 

of HD-players, the player output can be blocked. In that case, the buffer pool size needs to 

be increased. 

 Texture Cache Size: a higher cache size improves performance, but note that not all 

graphic cards have sufficient RAM. A minimum of 512 MB is required. 

 Deinterlacing Method:  

◦ Weave: this is the default. Consecutive fields are added together and all lines are 

shown. For animations this can result in combing artifacts (jagged edges). 

◦ First-field: use to avoid combing effects. Keep in mind that for interlaced content, half 

of the fields’ lines are missing.  
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File  Specify the default Project folder. 

 Autosave: disable (this is the default) or enable autosave every x 

minutes. 

History  The number of actions tracked in history. 

Backup System  The number of backups to keep. 

Networking  Specify the FTP transfer mode, passive or active. 
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7 The Composer Workspace 

The Composer workspace consists of the Stage and a number of windows that can be arranged and 

customized. The example below shows a default empty Composer workspace (Mac) in Template 

editing mode.  

 

A The title bar shows the broadcast format and Project name. 

B The main menu. 

C The main toolbar. 

D The Objects window lists the Objects available in the Project and shows their layering. 

E The Stage’s rulers. 

F The Stage represents the Production. 

G The Project window lists the Production Elements that have been defined for a Production. Three windows 

are docked on this window (K): the Object window (view and edit an Object's properties), the Library (the 

prefabs and test media libraries) and the Project Assets window (view and edit the Project's Assets and 

metadata). To dock more or less windows, on the main menu go to View > Windows. 

H Actions can be viewed and redone or undone in the History window. Two windows are docked on this 

window: the Scene Parameters window (view and edit Scene Parameters) and the Text Styles window 

(view and edit text styles) (J). To dock more or less windows, on the main menu go to View > Windows. 

I Objects are animated in time on the Template Timeline. Each Template is displayed on its own tab. 

Compound Elements are edited in the Compound Element Timeline (not activated in the example above). 

Each Production Element is displayed on its own tab. 
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8 Customizing the Composer Workspace  

8.1 Windows 

The Composer workspace can easily be customized.  

 One way to do this is by displaying or hiding windows [View > Windows].  

 Activate [View > Clean View Mode] to hide all windows and display the Stage only, 

deactivate to show windows and the Stage. 

 Click  to close a window. 

 Windows can be scaled by selecting the window’s border and then drag while keeping the 

mouse pressed.  

 Windows can be repositioned by selecting the title bar and then drag while keeping the mouse 

pressed. The white dotted line shows where the window will be placed. Windows can be 

docked by dragging one window on top of another. 

 Double-click the window's title to dock and undock windows or click  to undock. 

 

8.2 Zoom and Fit in Window 

Main menu > View 

Main toolbar 

 

 

 

 

 Zoom In: zoom in on the Stage. 

 Zoom Out: zoom out from the Stage. 

 Zoom to 100%: scale the Stage to 100%. 

 Fit in Window: fit the Stage in the available workspace. 

 

8.3 Curtains 

Objects may be placed outside of the active Stage area to allow animation on to and off of the Stage. 

Use curtains to cover this outside area for a clear view of what the final output will be. 
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8.4 Rulers, Grid and Guides 

Main menu > View  Rulers: show or hide rulers. 

 Grid: show or hide the grid. 

 Guides:  show or hide guides.  

To add a guide, click the appropriate position on the ruler. To 

move, select and drag while keeping the mouse pressed. 

 Snap to Guides: enable or disable ‘snap to guides’. 

 Snap to Grid: enable or disable ‘snap to grid’. 

 

 

To set the color of the guides and snap distance, go to File > Preferences > Guides or click the guide 

on top of the ruler. 

To set the color of the grid, spacing and snap distance, go to File > Preferences > Grid. 

 

 

Example Stage in 3D-mode showing rulers, the grid and a guide. The ruler’s blue highlighted numbers 

show the position of the cursor on the stage. 
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Projects 

Production elements are authored in Composer: 

 Transitions 

 Templates (used to build Effects) 

 Effects 

 Compound Elements 

 

These elements are edited in a Project. The Project also contains fixed design elements such as 

straps and logos. Once the design is ready for production, the Project is bundled in a Production Pack 

and exported to the GV Director system, thus making all design elements available for live production. 

Production Elements can then be assigned to buttons on the GV Director Panel. 
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9 Working with Projects 

9.1 Creating a new GV Director Project 

You can create a new Project from the Composer Welcome window or if Composer is already opened, 

on the main menu go to File. 

 Select New Project > Type > GV Director. 

 Specify a Name and the Location where the Project will be saved. 

 

The Format tab displays the following properties for the Project: 

 Broadcast format 

 Frame Size  

 Frame Aspect Ratio  

 FPS  

 Interlaced settings 

 
 

 

Composer opens with the broadcast format that was last used and new projects will automatically 

have this format. To change, go to File > Preferences or in the Welcome window click Preferences. 

You will have to restart Composer after you changed preferences. Then open or create the Project 

again with the new broadcast format. 

 
 
Info (optional) 

  Author  

  Description  

 

 
Export  

Do not use for GV Director Projects. 
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9.2 Opening on an existing Project 

 

 

Following options are available from the Composer 

Welcome screen, and from the File option on the main 

menu: 

 Open an existing Project from disk. 

 Open an existing Project from a list of recent 

Projects. 

 Import a Production Pack from disk and open as 

a Project.  

 Restore a Project Backup. 

 

Composer opens with the broadcast format that was last used and new Projects will automatically 

have this format. To change, go to File > Preferences or in the Welcome window click Preferences. 

You will have to restart Composer after you changed preferences. Then create the Project again with 

the new broadcast format. 

When opening an existing Project and this Project was made for a different broadcast set than is 

currently active, a warning appears. 

 

Example. 

To change Composer’s broadcast set, go to File > Preferences or in the Welcome window click 

Preferences. You will have to restart Composer after you changed preferences. 

Instead of changing the broadcast format, you can load the Project with the currently active format 

and thus change the Project’s broadcast format. Note that this can result in an incorrect output 

resolution and playback speed.  
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File > Merge Project 

 

Merging Projects is an easy means to reuse elements of 

a Project. To reuse elements, place these items in a 

separate Project and then merge this Project with other 

Projects to reuse. Merging Projects can also be useful 

when working with several people on a Project. 

The Merge Project functionality includes the option to do 

a replacement merge. Using this type of merge, Objects 

and Assets in the merged-in project replace Objects and 

Assets with the same name in the original Project. 

 

 Select File > Merge Project. 

 Select the type of merge and Project you want to 

merge with the current projects. 

 Select the appropriate option if performing a 

replacement merge. 

 Click Open to merge, Cancel to discard. 

File > Import Project > from Disk 
Projects can be imported from a Production Pack on 

disk. 

 Select File > Import Project > from Disk. 

 Browse to the folder the where the Production 

Pack is located and select the applicable Pack. 

 Click Next, Cancel to discard. 

 Select a destination folder and click Next to start 

import. 

File > Restore Backup 
Each time a Project is saved, a backup is automatically 

created. This backup contains all project data, except for 

Project Assets. 

 Select File > Restore Backup. 

 Close the Project that is currently open. 

 Select the backup you want to restore and click 

Restore or Cancel to discard. 
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9.3 Saving the Project and Export to disk 

While working on a Project, save the Project or export the Production Pack to disk. When sharing a 

Project, we advise to export the Project to disk; the Project is zipped in one single file (the Production 

Pack) that can be imported using the Composer import option. 

 File > Save Project | Save Project As. 

 File > Export Project > to Disk. 

Once the design is ready for live production, the Project is exported to the GV Director system. 

 

9.4 Exporting a Production Pack to the GV Director System 

 To export a Project to the GV Director system, on the main menu click File > Export Project 

> to GV Director. 

 Click the   icon, then specify the GV Director system’s IP-address. 

 Click Next, or Cancel to cancel. 

 Specify a folder name. You cannot use the same folder name more than once. 

 Click Next to start export, Back to go to the previous step or Cancel to cancel export. 

 

The Project is packed, exported to the GV Director system and unpacked. 

  



 

Composer for GV Director - document version: 1.7.2-gvd - Page 28 

 

 

Template Editing 

10 Templates 

 

Effects have Actions, each Action corresponds with a Template. A Template is a 

series of keyframes that animate one or more of your Objects’ properties. 

 

 

  

Example Headshot Effect built of actions On and Off, linked to Templates Headshot – IN and 

Headshot – OUT. 

 

 

Template names are only used in Composer, while Action names are shown on the GV Director 

Panel. 
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10.1 The Template Timeline 

Double-click a Template in the Project window to open the Template Timeline. Each Template is 

displayed on its own tab. 

 

Example. 

 

 
Rewind (the player head on the Timeline). 

 
Play (the player head on the Timeline). 

 
Pause (the player head on the Timeline). 

 
Shows the position of the player head on the Timeline in mm:ss:ff, or enter 

values to place the player head on the Timeline. 

 
Click to add a keyframe.  

The  icon on the Timeline indicates the keyframe is added to an Object or 

property.  

The   icon indicates that the keyframe is added to an Object or sub-property   

on a lower level.  

 

 

 Double-click a keyframe to select. The keyframe icon turns white when 

selected. 

 
Click to update the selected keyframe.  
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Click to go to the previous or next keyframe.  

 
Define interpolation for the selected keyframes. Options are: 

 Constant Speed 

 Ease In 

 Ease Out 

 Ease In & Out 

 Step 

 
Select all items on the Timeline. 

 
Copy the selected keyframes or commands to the clipboard. 

 
Paste clipboard items on the Timeline.  

 
Delete the selected keyframes or commands. 

 
Reverse the selected keyframes / timescale the selected keyframes’ duration (in 

frames). 

 
Duplicate a Template. 

 

Note that Objects in the source Template are not duplicated; in other words, 

both templates, the original and the source will use one and the same Object. If 

this Object is modified in Template A, it will also be modified in Template B.  

 

 
Define settings for hard (default) or soft cuts. When soft cuts are used,  the 

property values of this Template are slowly blended in. 

 

Enable or disable grid snap and set snap distance. The snap distance is in 

seconds. 

 This option can be found in the bottom left corner of the Template Timeline. 

Click the arrow to define what information is displayed on the Template 

Timeline: 

 Command Tracks: Display or hide command tracks. 

 Object Properties: Display or hide Object properties. 
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To display not only Objects, but also Object properties on the Timeline, select the Show > Object 

Properties option in the Timeline’s left bottom corner. 

 

 

Example. 

 

Note how the distinction between Changing and Unchanging properties is made. 

A green segment between keyframes indicates that the property value changes in between the 

keyframes. When this segment is grey, property values do not change. 

 

 

  

 
When the pickup button is deactivated [as shown in the example on the left], the 

Object, sub object or property will not be modified by the Template.  

As a default, this option is activated: . 

 
Click the hide and lock icons to hide/unhide and lock/unlock Objects on the 

Stage. 

 This option can be found in the bottom left corner of the Template Timeline. 

Use the slider to zoom the Timeline in or out. 
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10.2 Basic editing 

 To add a Template to your Project, in the Project window click the  icon, or on the main 

menu, click Project > Add Template. 

 To rename, right-click in the Project window or double-click the Template tab in the Template 

Timeline, then rename. 

 To edit an existing Template, double-click in the Project window or select the editor in the 

Template Timeline. 

 To duplicate, right-click in the Project window and select Duplicate, or click the  icon in 

the Template Timeline. 

 To edit settings, right-click in the Project window and select Settings. 

 

 

 Folders can be used to organize elements in a Project. To add an element to a folder, either 

drag and drop into an existing folder, or right-click in the Project window and select Add to 

Folder. A new folder is created and the element is added to this folder. Note that folders only 

exist in Composer and not on the playout nodes, and can be used to organize elements. 

 To delete a Template, right-click in the Project window and select Delete, or select and press 

the [Delete]-key, or select and click the  option in the Template Timeline. 
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10.3 Template Rules 

Template Rules can be used to start a Template based on a predefined Event, for example start a 

Template at Ticker End (the Event). A Ticker End Event is generated by the Ticker Player when the 

last pixel of the last ticker story has been played out. 

 

The Template Rules window. 

 

 

: Click to add a Rule.  

 

: Click to delete the selected Rule.  

Rule : Click a Rule to edit. 

 

 

Example Template Rule. 
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10.4 Previewing Templates 

Preview Templates using the Template Timeline player options or in Try-out Mode. 

 

 

 

Note that Players only run in Try-out mode. 

 

In try-out mode, the Stage shows a preview of 

your Templates. Note that the output will be 

exactly the same as on the playout system, but 

will not be guaranteed real-time. 

 

Using the Opt-out filter makes it possible to 

preview each Channel separately. 

 

 

To preview Templates in try-out mode: 

 
On the main toolbar, click the Try out mode icon to switch to try-out mode.  

Note that when in Tryout mode, you cannot edit. 

 In the Try-out mode window, double-click Templates to cue.  

In the cue, drag Templates to change order. 

Restart Click Restart to empty the cue. 

Exit Click Exit to exit Tryout mode. 

Colors Orange indicates that Templates are loading. 

Blue indicates that Templates are playing.  

Grey indicates that Templates have been played.  
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11 Objects 

Composer works with different Object Types: 

 Stage Objects, such as the Clip, Mixer, Box and Still Objects. 

 Players, such as the   Still Player, Clip Player and Text player. 

 Controllers, such as Oscillate and Stack. 

 Materials, such as Standard Texture and Gooch. 

 Commands, such as the Ticker Command. 

 Layer Effects, such as Blur, Pixelate and Ripple. 

 Template Rules. 

 Others: the Stage, Scene Parameters, Text Styles, GV Director Effects and Effect Actions. 

 

This chapter describes a number of these Objects after explaining basic editing options for Objects. 

 

 

Note that in Composer, one and the same Object can be used in different Templates with different 

properties per Template. The properties of an Object are saved uniquely in each Template. 

 

11.1 Adding Objects to a Template 

To add an Object to a Template: 

On the Template Timeline, first select the Template you want to add the Object to.  

Now there are three different options for adding Objects: 

 
On the toolbar, click the Add Object icon, then select the type of Object 

you want to add and double-click. 

Assets window 

Test Media window 

Prefabs window 

You can select an Asset form the Library (prefab or test media) or Project 

Assets (Asset) window and drag this Asset on the Stage. An Object that 

refers to this Asset is automatically created.  

Objects window You can also select an existing Object in the Objects window. Then right-

click > Add to Template, or drag the Object on the Template. 
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11.2 Modifying Objects’ properties   

There are several ways to edit an Object's properties: 

Object window To open an Object's properties window: click the Object on the Stage, in 

the Objects window or on the Template Timeline. 

(If the Object window is not visible, enable the window: toolbar > View > 

Windows > Object). 

Or double-click the Object in the Objects window, on the Template 

Timeline or Stage. 

Stage Objects can also be transformed on the Stage. Select the Object and 

drag the handles to modify the Object. 

 

 

11.3 2D and 3D-mode 

Use this option to toggle the 2D and 3D handles of the transform gizmo: 

 
Click the 2D-icon to enable the 2D-handles. 

 
Click the 3D-icon to switch to 3D-handles.  

 
Show or hide 3D editing guides when editing a Group. 
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11.4 The Transform Gizmo 

You can transform Objects (position, scale, rotation) either in the Object window, or on the Stage using 

the transform gizmo. Note that how the handles work depends on if the gizmo is in 2D or 3D-mode. 

 
Scale: move the cursor over the inside of the Object handlers until this cursor appears. 

Then drag to scale the object. 

 
Rotate: move the cursor over the Object handlers until this cursor appears. Then drag to 

rotate the Object around the Z-axis. 

 
Free rotate or arc ball rotate (3D only): move the cursor over the center of the Object’s 

movement axes to activate this cursor and rotate the Object around its X, Y and Z-axes.  

 
Move the Object on the Z-axis (3D): move the cursor over the movement axes’ arrow head 

to activate. 

 
Grab the Object to move on the Stage.  

 

The movement axes can be customized in the main toolbar: 

 View: the axes are aligned with the current view. 

 Group: the axes are aligned with the group the Object is in. 

 Object: the axes are aligned with the Object. When the Object rotates, the axes will rotate as well. 

 

 

Example 3D Box with the X, Y and Z-movement axes aligned with the Object. 

 

11.5 Layering Objects 

The Objects window lists all Objects in a Project or Template. Each Object is placed on its own layer. 

Objects on higher layers overlap Objects on lower layers. To change, drag Objects into the 

appropriate order, or use the Arrow icons. 
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11.6 Grouping Objects 

Objects can be grouped, so they can be modified and animated as a group. To group objects: 

 Select the Object you want to group, either by [CTRL/CMD]+clicking them in the Objects 

window, or by drawing a selection with the cursor around the relevant Objects on the Stage. 

 On the main menu select Objects > Group, or on the Stage right-click the selection > Group. 

 You can open the group to edit individual Objects within the group: Objects > Open Group, 

or on the Stage right-click the group > Open Group. When finished, close the group. 

 To ungroup Objects: Objects > Ungroup, or on the Stage right-click the group > Ungroup.  

 

11.7 Locking Objects 

Lock Objects to prevent unwanted selection, or to protect the Object from being selected and modified 

accidently.  

 
To lock or unlock Objects, in the Objects window or on the Template Timeline, select 

the Object. Then click the Lock icon. 

 

11.8 Copying Objects 

To copy an Object (duplicate): 

 In the Objects window or on the Stage, select the Object > right-click > Copy, or use the 

hotkeys.  

 To paste  > right-click the Objects window or the Stage > Paste, or use the hotkeys.  

Note that the Object is also added to the active Template. 

 

11.9 Prefabs 

Objects and all the properties you defined for them can be exported to the Prefabs library for reuse. 

 
To export an Object to the Prefabs library: select the Object, then in the Object window click 

the Export icon. 

 
In the Library > Prefabs, the star icon (as shown in the example on the left) indicates that 

the prefab is a custom made Object. 
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11.10 Deleting Objects 

When deleting an Object, there are two options: 

 Remove the Object from a Template, but the Object is still available in the Project. 

 Delete the Object from the Project. 

 

11.10.1 Removing an Object from a Template 

 To remove an Object from a Template, select the Object on the Template Timeline or Stage > 

right-click > Remove from Template. Or select on the Stage and press the [Delete]+key.  

11.10.2 Removing an Object from the Project 

 To delete an Object from a Project, select the Object in the Objects window > Delete. Note 

that the Object will be removed from all Templates it was used in. 

 

11.11 The Activity Segment: Objects’ on-screen Audibility and Visibility 

 

Example Play Ticker Template with an Out Point set. 

 

The Objects’ activity segment on the Template Timeline shows the Object’s audibility and visibility. As 

a default, the In Point for Objects is set at 00:00:00 and no Out Point is defined. To remove an Object 

from screen (audio and visual), set an Out Point. Note that the Object Player will not automatically stop 

when the Object is no longer active (unless Auto-stop at Out Point is activated, which is the default). 
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11.12 In Points and Out Points 

In and Out Points specify when an Object is active, i.e. audible, visible, and so on. As a default, the In 

Point is set at 00:00:0 and no Out Point is defined.  

 To add an In Point, drag the Object’s In Point (the Object’s activity segment’s start on the 

Timeline) to the appropriate position, or right-click the Timeline on the appropriate position > 

Set In Point. 

 To add an Out Point, right-click the Object > Enable Out Point, or right-click the Timeline on 

the appropriate position > Set Out Point. 

 Then drag the Object’s Out Point (the activity segment’s end) to the appropriate position, or 

right-click the Timeline on the appropriate position > Set Out Point. 

 

When the Player > Auto-stop at Out Point option is activated (in the Object window), a Stop 

Playback action is automatically inserted when an Out Point is added on the Template Timeline.  

 

 

The Example Project Optimization explains how to work with In and Out Points. 

 

Example Audio Object with In and Out Point. Because the Auto-stop at Out Point has been enabled 

for the Player, the Stop Player action is added to the Out Point, as indicated by the Stop Player icon 

. 
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11.13 Hints and Tips for navigating through the Object Window 

Use the buttons below to navigate through the Object window: 

 

: Go to the previous Object. 

 

: Go to the next Object. 

 

: Go to the parent Object. 

 

: Export the Object to the prefabs library. 

 

: Close all groups in the properties window. 
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12 Transforming and Scaling Objects 

These properties define the Stage Object’s on-screen position and scaling. 

 

12.1 Transform 

 

 

See also the chapter on Quality > Scaling and Pixel Perfect and the example project Scaling. 

 

 

To scale the Player’s output (instead of the Object itself) edit the Player’s Source Scale/Crop 
property. 

 

  

Use these options to position Objects from center (default), or from the 

upper left corner. 

Place on 2D Plane Place the front of the object on the 2D plane (i.e. on z-coordinate 0). 

 
Lock aspect ratio when scaling. 

 
Scale in pixels instead of in %. 

 
Reset the Object (scaling/rotation) to 100%. 

Counter scale for 16:9 Select to scale back the Object in screen horizontal direction to 

counter the horizontal stretching that occurs when the object is viewed 

in 16:9 anamorphic widescreen mode. 

Rotation Angles are relative to the axes of the Group the Object resides in. For 

example, if the Object is on the Stage, the Stage is the Group. The 

Object is rotated in the following order: x, y, z. The Group’s axes will 

not rotate. 

Euler interpolation Generate the Object's rotation by combining the individually animated 

rotation angles. Needed when animating individual rotation angels, for 

instance when using a Controller. 

Camera You can either use a perspective (depth) and specify its angle (default 

55%), or use an orthographic view (no perspective). 
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Scaling Tools: 

 Scale to fit screen: scale the Object to fit the output screen’s 
dimensions; play out a full screen (no aspect ratio). 

 W: scale object to fit screen width (keeping aspect ratio). 

 H: scale object to fit screen height (keeping aspect ratio). 

 Scale 1:1: scale object to 1:1 aspect ratio, based on height. 

 Scale 4:3: scale object to 4:3 aspect ratio, based on height. 

 Scale 16:9: scale object to 16:9 aspect ratio, based on height. 

 Straighten: remove skewing. An Object is skewed if its axes 
are not perpendicular to each other. This sometimes happens 
to Objects within a Group when the Group is scaled and then 
ungrouped. 

 
 

12.2 Scaling 

You can either scale the Object or the Player’s output. 

 

 

See also the chapter on Quality > Scaling and Pixel Perfect and the example project Scaling. 

 

12.2.1 Scaling the Object 

Use the Transform properties in the Object window to scale the Object, or scale on the Stage using 

the transform gizmo. 

 

12.2.2 Scaling the Player’s output 

Use the Source Scale/Crop option in the Object window to scale the Player’s output, instead of the 

Object.  

Specify a rectangle that is scaled/cropped from the source (the Player’s output) onto the Object’s 

plane. If the scaled source is smaller than the Object, the source is either repeated or empty space is 

filled with the source’s borders’ pixels (clamp). 
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In this example a Still is scaled and repeated on a 

Cylinder’s plane. 

 

 

 

Mode Coordinates: scale/crop the source to absolute 

coordinates on the Object. 

Margins: scale/crop relative to the Player's output borders. 

 

Use the slider to specify margins or coordinates in pixels. 

 

Select to lock the source’s width and height. 

This option is highlighted as shown on the left when 

activated. 

Wrapping If the source is smaller than the Object: 

Repeat: the source is repeated. 

Clamp: empty space is filled with the source’s borders’ 

pixels. 

 

 

 

To scale the Object instead of the source, scale on the Stage or in the Object window > Transform.  
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13 Blending Objects 

Use to blend an Object with the layer(s) beneath. 

 

Example. 

 

Following blending modes can be selected: 

 
 

 

In the examples below, a Plane with a flower 

still is blended with a background that consists 

of a purple Plasma Plane and a yellow 

Cylinder. 

Blended Object. Background. 

 

Normal: no blending, unless opacity is set. 

When opacity is set, the selected Object is 

blended without mixing colors with the 

background. Colors are blended based upon 

the source layer’s alpha channel. 

In this example opacity is set to 50%. 



 

Composer for GV Director - document version: 1.7.2-gvd - Page 46 

 

 

 

Lighten: adds RGB-color values from the 

selected Object to RGB-values from the 

background. 

 

 

Multiply: multiplies RGB-color values from the 

selected Object with RGB-values from the 

background. 

 

 

Maximum: the maximum of the selected 

Object’s and the background’s RGB-values. 
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Darken: subtracts RGB-values from the 

selected Object from the background’s RGB-

values. 

The example blends a grey Plane with a lighter 

grey Plane.  

 

 

Mask: use the selected Object to mask the 

background, based on greyscales. In the 

mask, white is full transparency and the 

background is completely visible. Black 

completely hides the background. 

 

Opaque: No blending (no alpha channels). 
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An Object blends with all Objects on all layers within the Group. Note that the Stage is also a Group 

and therefore the top Object will blend with all layers including the background. To only blend with 

specific Objects, place these Objects in a Group:  

 Select the Objects you want to group, either by [CTRL/CMD]+clicking them in the Objects 

window, or by drawing a selection with the cursor around the relevant Objects on the Stage. 

 On the main menu select Objects > Group, or on the Stage right-click the selection > Group. 

 Open the group and specify blending for the top Object: Objects > Open Group, or on the 

Stage right-click the group > Open Group. When finished, close the group. 

 

In the examples below in a Plane is used as a mask. 

 

The Plane Object masks all layers in the 

background (Plasma and Cylinder). 

 

The Plane and Cylinder are grouped and 

together mask the Plasma background. 
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The Plane and Cylinder are grouped. The 

group is opened and the Plane only masks the 

Cylinder (the layer beneath in the group). The 

Plasma background is not masked. 

 

This is the result when the Group is closed 

again. The Plane masks the cylinder. The 

Plasma background is not masked. 
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14 Players  

Objects such as ‘Clip’, ‘Audio’ and ’Still’ use a Player to play out content. Players can be used to 

control playout. Different actions can be defined. The default is: Play. Players can be modified in the 

Object and Objects window. Example Players: 

 Still Player 

 Ani Player 

 Plasma Player 

 Clip Player 

 Audio Player 

 Gradient Player 

 Live Player 

 Text Player 

 Ticker Player 

 Subtitle Player 

 

 

 No Action: The Player's current action is continued. 

 Play: Start the Player. 

 Stop: Stop the Player. 

 Link to: Link this Player to another Player. The Object will now play out 

the content from the Player you linked to. This option can be used to 

save resources (only one stream will be used).  

 

For clips, animations and tickers additional options are: 

 Pause: Pause the Player. 

 Resume: Resume the Player after a Pause. 

Auto-stop at Out 

Point 

If this option is selected, a Stop Playback action is automatically inserted when 

an Out Point is added to a Player on the Template Timeline. This will stop the 

Player. 
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For some Objects, a test feed (procedurally generated video) can be used 

during editing. 

 

 

 

 

As a default, Player actions are defined from 00:00:00. To define an action at another point in time, 

work with keyframes or move the Object’s In Point. 

 

 

Example Pause player icon on the Timeline. 

  

 

To stop a Player, three options are available:  

 Set an Out Point and leave the Player’s Auto-Stop at Out Point option activated (default).  

 Create a separate Template with a Player Stop Action. 

 Keyframe a Player Stop Action. 

 
 
An icon is inserted on the Timeline for each Player action: 

 

Link the Player. 

 

No Action. 

 

Pause the Player. 

 

Start the Player. 

 

Resume the Player. 

 

Stop the Player. 
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14.1 Linking a fixed file or Scene Parameter to a Player 

14.1.1 Linking a fixed file 

 

In the Object Window, go to the Player 

properties. 

Click the File option. 

 

 

Click the  sign, browse to the 

appropriate folder on your desktop or 

network and select the file you want to 

add.   
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In this example an ANI-file has been 

added. Select and click OK to link to the 

Player. 

 

 

In this example a fixed file has been 

linked to the Player. 
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14.1.2 Linking a scene parameter 

 

Select the  icon after the File option. 

 

Select Link to Scene Parameter. 

 

Select New to define a new parameter 

or select an existing parameter. 

 

 

In this example a scene parameter has 

been added to the File property, as 

indicated by the  and  icons. 
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15 Keyframing 

15.1 Introduction 

Keyframes are used to animate Objects’ properties such as position, size and effects over time. A keyframe is a snapshot of the properties of one 

or more Objects at a specific point in time. Keyframes are used to define start, intermediate and end points of an animation. The frames in between 

these keyframes are then automatically filled in by Composer. 

 

    

You can also use Controllers to animate Objects. For an explanation, see File > Example Projects > Controllers. 

 

Example animation of a Box and Sphere Object using three keyframes. The frames in between these keyframes are automatically filled in by 

Composer. 
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Keyframe 1  

 

  

Keyframed Transform properties for this point in time of the 

Sphere and Box Objects. 

The and   icons indicate that properties have been 

keyframed. 
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Keyframe 2  

 

 

Keyframed Transform properties for this point in time of the 

Sphere and Box Objects. 

The and   icons indicate that properties have been 

keyframed. 
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Keyframe 3  

 

  

Keyframed Transform properties for this point in time of the 

Sphere and Box Objects. 

The and   icons indicate that properties have been 

keyframed. 
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Animating the Material  

 

The color of the Sphere (the Gooch Material) is animated 

using two keyframes. 

 

 

To show not only Objects, but also the Objects’properties on 

the Template Timeline, click the Show > Object Properties 

option in the bottom left corner of the Template Timeline. 

Changing and unchanging properties are listed. 
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15.2 Adding a Keyframe 

Animations consist of at least two keyframes, one for the start and one for the end point of the 

animation. Intermediate keyframes can be added. The frames in between two keyframes are 

automatically filled in by Composer.  

 

A keyframe can contain more than one Object. 

 

To create a keyframed animation, add at least two keyframes, one for the start and one for the end of 

the animation.  

To add a keyframe: 

 

First select the Template you want to edit. 

 

On the Timeline select the point in time where you want to add the keyframe. Either 

specify mm:ss:ff , or move the player head to the appropriate position on the 

Timeline. 

 

Select the Object you want to animate. You can also create an animation that 

contains more than one Object. In that case select the Objects you want to 

animate. 

Define the Object's or Objects’ properties at the specified point in time. 

 
Click the Add keyframe icon.  

A keyframe is added and the Objects’ properties are keyframed. 

On the Timeline: 

The  icon indicates that a keyframe has been added for an Object on a lower level at this point in 

time.   

The   icon indicates that a keyframe has been added at this point in time. 

 

In the Object window: 

The   icon indicates that the property has been keyframed.  

The  icon indicates that a property in the property group has been keyframed. 

Repeat these steps for each keyframe in the animation. 
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Move the player head on the Timeline to preview animations. 

 

Example: 

 

Example Timeline with five keyframes inserted.  

 

 The Stage row shows all keyframes that have been added to the Template. The  icon 

indicates that keyframes have been added for Objects on lower levels. 

1, 3, 5 This animation consists of three keyframes and contains three Objects, the Cylinder, 

Rounded Plane and the Box.  

One of the Box’s keyframes [3] has been detached from the animation and can thus be 

moved, copied or deleted independently from the Cylinder and Rounded Plane. 

 
The grey color indicates that keyframes are selected, as described in more detail in the next 

paragraph. 

2, 4 These keyframes animate one Object - the Circle Plane Object - and contain the properties 

of this Object at this point in time. 
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To show not only Objects, but also the Objects’properties on the Template Timeline, click the Show > 

Object Properties option in the bottom left corner of the Template Timeline. Changing and 

unchanging properties are listed. 

 

 

 

Example.  
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15.3 Selecting a Keyframe 

There are two reasons to select a keyframe: 

 To update the keyframe with changed properties. 

 To move, copy or delete the keyframe. 

 

15.3.1 Selecting a keyframe for updating 

There are several ways to select a keyframe for updating: 

 Double-click the keyframe on the Timeline.  

 

 

Use the Next and Previous keyframe buttons to go to the next or previous keyframe 

on the Timeline. 

][ Use the hotkeys ] and [ to go to the next or previous keyframe. 

    

The keyframe icon on the Timeline turns white when the keyframe is selected for 

updating and the player head is placed on top of the keyframe. 

 

15.3.2 Selecting a keyframe for moving, copying or deletion 

There are several ways to select a keyframe for moving, copying or deletion. You can select more 

than one keyframe: 

 Click the keyframe on the Timeline. Keep the [CTRL] or [CMD] key pressed to select 

more than one keyframe. 

Object 

Keyframes 

> Select  

To select all keyframes for an Object, right-click the Object > Object Keyframes > 

Select > All or All + Ripple to select all keyframes for the Object plus its sub objects. 

 
To select all items on the Timeline, click the Select all button. 

   

The keyframe icon on the Timeline turns grey when the keyframe is selected for 

moving, copying or deletion. 
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15.3.3 Example 

 

The example shows: 

 The animation contains three keyframes. 

 The keyframes animate the Cylinder and Plane Objects’ properties. 

 The first keyframe is selected for updating (white). 

 The first, second and third keyframes are selected for moving, copying or deleting (grey). 

 The Box’s keyframes are detached and not selected (black). 

 

   

1.1 Updating a Keyframe  

A keyframe is a snapshot of the properties of one or more Objects at a specific point in time. To modify 

keyframed properties, edit and then update the keyframe with the new properties. 

To update a keyframe with new properties: 

  
Select the keyframe you want to edit. 

 

The keyframe icon on the Timeline turns white when the keyframe is selected for 

updating. 

 Edit the applicable Objects’ properties. 

 

 

Click the update icon to update the selected keyframe with the properties defined for 

the Object(s). 

 

To update all properties of a keyframe for all selected Objects, select the Object(s) > right-click > 

Object Keyframes > Update Keyframe.   
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15.4 Reverse, Timescale and Speed 

 
Reverse or timescale the selected keyframes. 

 Reverse: (part of) the animation is reversed; the first keyframe becomes the 

last keyframe and vice versa. 

 Timescale: scale (part of) the animation’s duration, in percentage or frames. 

Either scale selected keyframes [of Keyframes] or all keyframes [All]. 

 
Define the type of interpolation for the selected keyframes. Options are: 

 Constant Speed 

 Ease In 

 Ease Out 

 Ease In & Out 

 Step 

 

 

15.5 Copying Keyframes  

 
Use to copy a keyframe (or keyframes) and paste at another point in time: 

On the Timeline select the keyframe(s) you want to copy. Then click the Copy icon.  

 
To paste, select the position where you want to paste the keyframe and click the Paste 

icon. 

Copy All Use to copy an Object’s keyframes and paste on another Object:  

Right-click the Object > Object Keyframes > Copy All. 

Paste Select the Object you want to paste the keyframes on, right-click > Object Keyframes > 

Paste. 
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15.6 Repositioning a Keyframe 

 

To reposition a keyframe on the Timeline, select and drag while keeping the mouse 

pressed. The position on the Timeline is indicated as shown in the example. 

 

 

15.7 Detaching Keyframes 

When an animation contains several Objects, these Objects’ keyframes are attached as shown in the 

example below. When you select a keyframe for one Object, the keyframe is selected for the other 

Objects in the animation as well. 

 

 

Keyframes can be detached from an animation, as shown in the example below in which the 

Capsule’s second keyframe is detached. You can now move, copy or delete the keyframe 

independently. 

 

Detach To detach an Object from selected keyframes in an animation, right-click the Object > 

Object Keyframes > Detach. Options are: 

 From All: detach the Object from all keyframes.  

 From All + Ripple: detach an Object including its underlying objects from 

all keyframes. 

 From Selection: detach the Object from the selected keyframe(s) only. 
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15.8 Deleting a Keyframe  

 

To delete keyframe(s): on the Timeline, select the keyframe(s)you want to delete. 

Then click the Delete icon. 

All 

 

To delete all keyframes for a selected Object: right-click the Object > Object 

Keyframes > Delete > From All. 

All + Ripple To delete all keyframes for a selected Object including its sub objects’ keyframes: 

right-click the Object > Object Keyframes > Delete > All + Ripple. 

From Selected To delete the selected keyframes: right-click the Object  > Object Keyframes > 

Delete > From Selected. 
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16 Scene Parameters 

Use scene parameters to define dynamic values.   

 

16.1 Defining Scene Parameters 

 To define a Scene Parameter, go to the Scene Parameters window. 

 Click the  icon to add a Scene Parameter, then specify a name (characters and/or 

numbers). 

You can also create Scene Parameters directly in the Object window. 

 

 Click the  icon for the property you want to link to a Scene Parameter. 

 Select Link to Scene Parameter > New and specify a new Scene Parameter. 

 Click the  icon to delete the selected Scene Parameter. 

 

 

The yellow icons in the Object window and on the 

Properties page indicate that a Scene Parameter has been 

defined for an underlying Object , Object  or property 

. 

 

 

16.2 Linking a Property to a Scene Parameter 

 In the Object window, go to the property that you want to link to a scene parameter and click 

the  icon. 

 Select Link to Scene Parameter and select the appropriate Scene Parameter. You can also 

create a new Scene Parameter and link. 
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17 Controllers 

 

A Controller automatically animates properties of an Object. Controllers can be an 

alternative to keyframing. Controllers are ideal for animations that are endlessly 

repeating, or animations that depend on real-time data.  

 

 

Controllers are also described in the Example Project Controllers. 

 

Available Controllers are: 

 Anchor 

 FromTo 

 Link 

 Oscillate 

 Stack 

 

All Objects’ properties can be animated.  

Per frame, the Object property values for rendering are determined as follows: 

Value0 = a value from keyframes or the default Template value. 

Value(N, for the Nth Controller for the property, with N > 0 and Wet-dry in [0…1] =  

(1 – Wet-dry)  * Value(N - 1) + Wet-dry * Controller-value. 

 

Example: property Opacity has a constant value 50 and a Controller Link with Wet-dry 25% and 
Oscillate with Wet-dry 75%. The value for the Opacity property will be: 

( 0.75 * 50 + 0.25 * Link-value ) * 0.25 + Oscillate-value * 0.75 
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17.1 Anchor 

Use an Anchor to keep (one or more sides of) an Object in a specific position: align the Object’s Left, 

Right, Bottom, Top, Back or Front to an Anchor Point X, Y or Z.  

 
Example Anchor. 

 

17.2 Stack 

The Stack Controller is used to tightly stack grouped Objects on the X, Y or Z-axis and avoid overlap, 

for example to align a number of Text Groups. Note that this Controller can only be used for Groups. 

 

Example Stack Controller for a Group.  
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17.3 FromTo 

Use a FromTo Controller to animate a property from one to another value, for example move from 

Position Z 5000 to Position Z 0 using a FromTo controller with a Duration taken from the Scene 

Parameter Move Duration. This Controller is similar to a keyframed animation with two keyframes. 

However, the ‘From’ and ‘To’-values can be linked to a Scene Parameter. This cannot be done with 

keyframes. 

 

Example FromTo Controller. 

 

17.4 Oscillate 

Use an Oscillate Controller to oscillate (Sinus, Sawtooth, Square or Triangle) an Object’s properties 

(note that only one property can be oscillated).  
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Example Oscillate Controller (Spin Z prefab). 

17.5 Link 

The Link Controller is used to link a property of a source Object to a property of a target Object. In the 

example below, the target’s color amount is linked to the height of a Cylinder using a Link Controller. 

The target property is calculated as Offset + Scale x Source. 

 

 

Example Link Controller. 
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17.6 Controllers How to 

 To add a Controller to an Object, right-click the Object in the Objects window or on the Stage 
> Add Controller > select the Controller you want to add > OK. 

 Controllers are edited in the Object window. 

 To work with real-time data to control properties, use Scene Parameters. 

 

 

Example Controller using a Scene Parameter to dynamically set the Max Value for the oscillation of a 

Height property. 

 

 

When animating individual Rotation properties, Euler Interpolation should be enabled for the target 

Object. 

 

To rotate around separate axes (for example, only the y-axis), we advise to use Controllers. Also, you 

need to enable Euler interpolation. 

 

The example Project Controllers shows a number of examples of Controllers.  
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18 Layer Effects 

Effects such as Bevel or Drop Shadow can be defined for Stage Objects. To define an Effect, go to 

the Effect section in the Object window. 

 

18.1 Defining an Effect 

 

Click the Effect button to open the Effects window. 

 

Example. 

In the left menu and then in the main window, select 

the effect you want to add. . 

Click OK to confirm. 

 

In the Object window in the Effect section, click the 

arrow to edit the effect. 

  

 

Click the Delete icon to delete the Effect. 

 

Wet/Dry: defines the balance between the effect 

(wet) and the original (dry). 

 

Click this arrow to link to a scene parameter, or add 

or edit a keyframe.  
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18.2 Colorize 

Use the colorize effect to map a color to the Object’s black and white tones.  

Following prefabs are available: 

 

 

The example shows the colorize effect with settings that result in a sepia tone effect. 
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18.3 Ripple 

Use to create a ripple effect.  

Following prefabs are available: 

 

 

Example rippled Clock Object and its properties: 

 

 

 

Center: specifies the center of the ripple effect. 

Wavelength: the distance from one ripple wave crest to the next crest. 

Amplitude: height of the ripple waves. 

Phase: specifies the point along the waveform at which a wave cycle begins.  
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18.4 Blur 

Use to add a blurring effect.  

Following prefabs are available: 

 

 

Example blurred Clock Object and its properties: 

 

 

 

Blur: blur in x/y direction in pixels. 

Quality: the number of samples taken. 

Downsample: downscale the Object for a blurrier effect after applying the effect. 

Overlay on original: overlay the blurred Object on the original, specify Opacity for the overlay. 

Luma: blur bright sections only, specify a luminance threshold (Luma Thresh). 
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18.5 Bevel and Emboss 

Use to add depth to Objects.  

Following prefabs are available: 

 

 

The example shows a Still before and after bevel and its properties when the effect has been applied: 

 

 

 

 

Mode: select a mode: Bevel, Emboss or Emboss Overlay (emboss output with overlayed original). 

Opacity: opacity. 

Contrast: contrast used for the effect (higher contrasts will create the illusion of a deeper bevel). 

Angle: specifies the light angle. 

Size: depth in pixels. 

Color: select a color for the bevel. 
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18.6 Chroma Keying 

Use to create a chroma key.  

Following prefabs are available: 

 

 

Example: 

 

 

 

The example shows a rabbit against a key 

colored background 

 

 

The Chroma Keying effect is applied and the 

background is keyed out. 
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The Object is placed against a grass background. 

 

Key color: key color (blue or green). 

Edge: 

 Offset: tolerance. 

 Smoothness: smoothen edges. 

 Spill Suppress: remove fringing from the key color around the foreground’s edges. 

 Light Wrap: blend colors and lightness values from the inserted background with the keyed 

foreground edges. 
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18.7 Pixelate 

Use to create a mosaic effect.  

Following prefabs are available: 

 

 

Example: 
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18.8 Drop Shadow 

Use to add a shadow to an Object.  

Following prefabs are available: 

 

 

Example: 

 

 

 

Blur: amount of blur. 

Quality: the number of samples taken. 

Downsample: downscale the Object for a blurrier effect after applying the effect. 

Angle: angle of the shadow. 

Scaling: size of the shadow relative to the original.  

Distance: distance of the shadow relative to the original. 

Color: shadow color. 

Opacity: opacity. 

Hide Object: hide Object to edit shadow. 
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19 Materials 

 

Composer offers a selection of material types that represent most of the popular 

real-time shading models: 

 Standard (Textured): uses Phong shading. This is the most commonly 

used shading model. 

 Gooch: a non-realistic shading model that is often used for technical 

illustrations. 

 Reflections/Refraction: a material type specialized in sharp reflections 

and refractions. 

 IBL: the Image Based Lighting shading model in which a capture of a 

real-world environment is used to lighten 3D objects. 

 

 

 

Example Objects with Standard Textured Wood, Skin Gooch and Standard Plastic materials applied. 

 

 

Most materials are available as prefabs, ready to use. 
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Meshes have roles that are filled in by a Material 

type. 

For example, a Box’s Front Side role is filled in 

with the Material type Standard Textured. 

 

Standard Textured materials use a Player to 

generate a texture that is mapped on the Object. 

Example textures: a Still, Clip, Text, Gradient 

Plasma and so on. 

 

 

 

 

Example projects Materials and Refraction are available via File > Example Projects. 
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19.1 Working with Materials 

 To edit a Material, select in the Objects window or in the Template Editor. 

 Or, in the Object window > Material, select the Material you want to edit and click the  

icon. 

 Click Replace to replace with another Material. 

 

Example showing Materials for a Box Object: 

 

Template Editor. 

 

Object window. 

 

Objects window. 
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19.2 Material Properties 

 

Example material properties. 

Lighting 

Ambiant: the color of the Object where it is not 

illuminated, i.e. in the shadow. 

Diffuse: the color of the Object when it is 

illuminated. This is the color of the Object itself in 

pure white light. 

Specular: the color of specular reflections 

(highlights). 

 

Power: specular highlight’s sharpness. 

Alpha: defines transparency, ranging from 0 (full 

transparency) to 255 (no transparency). 

 

Miscellaneous 

Quality: Low, Medium, High or best. 

Cull: Back facing, Front facing or none. 

Fill Mode: Solid, Point or Wireframe (lines only). 

Depth Occlusion: enable or disable depth 

occlusion. 
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19.3 Gooch Materials 

Use gooch shading to create a technical illustration style.  

Following prefabs are available: 

 

 

19.4 Standard Materials 

These are the standard materials. The Phong shading model is used. This is the most commonly used 

shading model. The following prefabs are available: 
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19.5 Image Based Lights (IBL) Materials 

Image Based Lighting uses a capture of a real-world environment to lighten 3D-objects. The lighting 

information is stored in diffuse-, specular- and reflection stills (TGA or Clip).  

Following prefabs are available: 

 

 

Example IBL material using three stills for reflection, diffuse and specular lighting. 
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19.6 Reflection Materials 

Reflections/Refraction is a material type specialized in sharp reflections and refractions (TGA or Clip). 

Following prefabs are available: 

 

 

 

Example Object with reflection and refraction. 
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You can easily enable ground reflections for the members of a Group, as shown in the example below. 

See also the example project Ground Reflections. 

 

Example Group with Ground Reflection enabled. 
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20 Clips 

 

Use the Clip Object to play out a video clip. 

 

The File > Example Project Play Video shows different options for Clip playout. 

 

 
To play out Clips on other Objects than the Clip Object, for example on the side(s) of a Box, use the 

Standard Texture material with a Clip Player. 

 

 

This chapter gives an overview of the Clip Object. For more detailed information on the topics 

mentioned here, please refer to this manual’s applicable chapters. 

 

20.1 Prefabs 

A number of Clip prefabs are available in Composer. 

 

 Clip: play out a video clip. 

 Clip HD 1080 Quality Scaled: includes a Quality Scaler often used for downscaling from HD to 

SD. 

 Key Fill: includes a Key Player (the clip is the fill). 

 Quality Scaled clip: includes a Quality Scaler often used for downscaling. 
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20.2 Supported Formats 

Format Codec Bit Rate Mb/s Supported Wrappers 

SMPTE D10 30 / IMX 
30 

SMPTE D10 
(MPEG-2 4:2:2P@ML) 

30 MXF 

SMPTE D10 40 / IMX 
40 

SMPTE D10 
(MPEG-2 4:2:2P@ML) 

40 MXF 

SMPTE D10 50 / IMX 
50 

SMPTE D10 
(MPEG-2 4:2:2P@ML) 

50 MXF 

DV25 DV25 25 MOV, MXF 

DVCPRO25 DVCPRO25 25 MOV, MXF 

DVCPRO50 DVCPRO50 50 MOV, MXF 

XDCAM HD (LP, SP, 
HQ) 

MPEG HD 
(MPEG-2 MP@HL) 

18, 25, 35 MXF 

XDCAM HD422 MPEG HD422 
(MPEG-2 4:2:2P@HL) 

50 MXF 

MPEG-2 4:2:0 SD MPEG-2 MP@ML Max 15 MPG, MXF 

MPEG-2 4:2:2 SD MPEG-2 4:2:2P@ML Max 50 MPG, MXF 

MPEG-2 4:2:0 HD MPEG-2 MP@HL Max 50 MPG, MXF 

MPEG-2 4:2:2 HD MPEG-2 4:2:2P@HL Max 50 MPG, MXF 

 

The following restrictions apply: 

 Embedded Audio: 

Format Details 

BWAV / WAV 16 or 24 bit LPCM, sampled at 48 kHz 

MPEG 1 Layer 2 / MP2 16 bit, sampled at 48 kHz 

 

 GOP size: 

The maximum GOP size for all video file formats/codecs is 15 frames. 

 MPEG-2 4:2:0 SD, MPEG-2 4:2:2 SD, MPEG-2 4:2:0 HD, MPEG-2 4:2:2 HD formats:  

Both I-frame only and long-GOP formats are supported. Note above restriction on GOP size. 

 MPG wrapper:  

Supported are MPEG-2 Transport Stream and MPEG-2 Program Stream. 

 MXF wrapper: 

Only Operational Pattern OP1a is supported. 

A maximum number of 36 embedded streams are supported. 
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20.3 Example 

 

 

Example Template that plays out a full screen Clip. The Clip is scaled to fit the output screen’s dimensions and is placed on top of the color bars. The Stage 

shows a test feed. The Clip Player refers to a scene parameter ‘play-clip’. On the Template Timeline, the Main Player Command is added to command track 0.
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20.4 The Activity Segment: on-screen Audibility and Visibility 

 

Example Play Clip Template. 

 

The Clip Objects’ activity segment shows the clip’s audibility and visibility. As a default, the In Point for 

Objects is set at 00:00:00 and no Out Point is defined. Usually the Clip Object stays on-screen and 

when a clip finishes, the Clip Object will start play out of the next clip. To remove a Clip from screen 

(audio and visual), set an Out Point. Note that the Clip Player will not automatically stop when the 

Object is no longer active (unless Auto-stop at Out Point is activated). 

 

20.5 The Clip Player 

The Clip Object’s Player plays out the video clip. Several actions can be defined, play, pause, stop, 

and more. The Player can play out a fixed clip or can be linked to a scene parameter.  

 

Example Clip Player. The File property is linked to a scene parameter. 
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To view or edit the Player’s properties, select the Object, either in the Objects window, on the Stage 

or the Template Timeline. Then select (Material) > Clip Player.  

The Player properties are: 

 
Click to refresh the Clip Player with new settings. 

 
Click to enable a test feed. 

 

Action  

Player actions: 

 No Action 

 Link this Player to another Player. 

 Start playout. 

 Stop playout. 

 Pause playout. 

 Resume playout. 

Auto-Stop at 

Out Point 

When activated (default), the Player is stopped when an Out Point is inserted. 

The  icon shows that Stop Player action has been inserted at the Out Point. 

File Select a file (fixed Project Asset) or scene parameter (dynamic reference). 

Loop Select to loop the clip. 

Advanced Not used anymore. 

 

 

Note that the Clip Player will not automatically stop when the Object is no longer active. There are 

several ways to stop the Clip Player (recommended to save resources): 

 Insert an Out Point and make sure the Clip Player’s Auto-Stop at Out Point property is 

enabled. This option is default enabled. 

 Insert a Stop Player action.  

 Use the Clear All Command. This command stops all Players except for the Players in the 

current Template. 
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Example Clip with an In and Out Point. The Clip Object is active (visible and audible) from 00:00:05 to 

00:01:00. The  icon represents a Stop Player action that was automatically set at the Out Point. 

 

20.5.1 Linking Clips 

 

Use the Player Action Link to play out the same Clip on more than one Object, 

linking Player A’s output to Player B. This is more efficient in terms of performance 

than playing back the same video clip twice. 

 

 

The example shows the Clip Object playing out a full screen clip and a Sphere Object playing out the 

same source. 
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The Sphere Object’s Player is linked to the Clip Object’s Player. 

 

 
 
20.5.2 Previewing Player Actions 

 

Preview Player actions in Try-out mode. Note that Players only run in Try-out mode. 
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20.6 Link to File or Scene Parameter 

 

Example Clip Player. The File property is linked to a Scene Parameter. 

 

The Clip Player can be linked to a fixed file from the Project Assets pool (use when always playing 

out the same Clip), or to a Scene Parameter. Scene Parameters are dynamically updated with the 

clip’s filename, usually when Events are scheduled. Example: 

Scene Parameter Event ID Scene Parameter Value when scheduled 

clip 12345 a0000548.avf 

clip 12346 a0000978.avf 

clip 12347 a0000564.avf 

 
 
 

20.7 Layering 

In the Objects window, if applicable place the Object on the correct layer. Objects on higher layers 
overlap Objects on lower layers. In this example, the Clip Object is placed (full screen) on top of the 
color bars which are thus hidden. 
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20.8 Scaling and on-screen Position 

 

See the Transform paragraph for an explanation of all properties and options. 

 

 

The Transform section defines the Clip Object’s 

on-screen properties such as size and position.  

 

To play out a full screen Clip, scale the Clip 

Object to fit the output screen’s dimensions, click 

the Scale to Fit Screen Option. 

 

 

Other options: 

W: scale object to fit screen width (keeping 

aspect ratio). 

H: scale object to fit screen height (keeping 

aspect ratio). 

Scale 1:1: scale object to 1:1 aspect ratio, based 

on height. 

Scale 4:3: scale object to 4:3 aspect ratio, based 

on height. 

Scale 16:9: scale object to 16:9 aspect ratio, 

based on height. 

Straighten: remove skewing.  

 

 

See also the chapter on Quality > Scaling and 

Pixel Perfect. 

 

 

To scale the Player’s output (instead of the Object 

itself) edit the Player’s Source Scale/Crop 

property. 
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20.9 Audio Levels/Routing 

 

These properties define audio levels and routing 

(optional): 

 Fade: specify a linear fade in % (for all audio 

channels). 

 Set for all input channels: set output audio 

levels (in db). 

 Set per input channel: set output audio 

levels (in db) per channel. 

 Routing: link input channels to output 

channels. 

-120 db is mute, or deselect in the routing table. 
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20.10 The Main Player 

 

The main Player Command  is automatically added for the first Clip or Live Object that is added 

to a Template.  

The main player has following properties [see also the chapter on the main player]: 

 The main Player has priority over other Players when resources are assigned. 

 If the main Player contains an embedded Closed Caption subtitle stream, this stream will be 

played out. If other Clips contain subtitle streams, these streams will not be played out. In 

other words, only the main Player’s subtitle stream will be played out.  

The main Player is the source for the ATC (HD) or VITC (SD) timecode signal in the SDI-output. Only 

one signal can be sent out, i.e. from the main Player. 
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21 Stills 

 

Use the Still Object to play out a still. 

 

21.1 Supported Formats 

Format Details 

BMP 24 bit, uncompressed 

TGA 32 bit, uncompressed, with alpha channel 

 

21.2 Prefabs 

Following prefabs are available: 

 

The Key Fill Still Object has two Players, for key and fill. 

 

21.3 Example 

 

Example Still Object. The Player (File) is linked to  

a scene parameter. 

 

Please refer to the relevant paragraphs for an 

explanation of Players, quality, on-screen 

visibility and audibility, properties such as 

transform and blending, and so on. 
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22 Text, Counters and Autoclocks 

 

Use the Text Object to display a text, digital autoclock or counter. 

 

22.1 Supported Formats 

Format Details 

TTF True Type Fonts 

 

22.2 Prefabs 

 

A number of prefabs are available: 

 Autoclock: a digital clock (displays playout system time). 

 Multiline Text: a multi-line text (with hard returns). 

 Text: a single line text 

 Up Counter HMS: an up counter in format: hh:mm:ss. 
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22.3 The Activity Segment: on-screen Visibility 

 

Example Text Object with Out Point and Stop Player Command at Out Point. 

 

The Text Objects’ activity segment shows the text’s on-screen visibility. As a default, the In Point for 

Objects is set at 00:00:00 and no Out Point is defined. To remove a Text from the screen, set an Out 

Point. Note that the Text Player will not automatically stop when the Object is no longer active (unless 

Auto-stop at Out Point is activated). 
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22.4 Scaling and on-screen Position 

 

The Transform section defines the Text Object’s 

on-screen properties such as size and position.  

 

Options: 

 Scale to Fit Screen: scale to fit the 
output screen’s dimensions (full screen) 

 W: scale object to fit screen width 
(keeping aspect ratio). 

 H: scale object to fit screen height 
(keeping aspect ratio). 

 Scale 1:1: scale object to 1:1 aspect 
ratio, based on height. 

 Scale 4:3: scale object to 4:3 aspect 
ratio, based on height. 

 Scale 16:9: scale object to 16:9 aspect 
ratio, based on height. 

 Straighten: remove skewing.  

 

 

See also the chapter on Quality > Scaling and 

Pixel Perfect. 
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22.5 The Text Player 

The Text Object uses a Text Player to play out text. The Player can play out a fixed text or can be 

linked to a scene parameter.  

 

 
To play out Text on other Objects than the Text Object, for example on the side(s) of a Box, use the 

Standard Texture material with a Text Player. 

 

 

Example Player linked to a fixed text: Grass Valley. 

 : Click to refresh the Text Player with new 

settings. 

Action: 

Player actions: 

 No Action 

 Link this Player to another Player. 

 Start playout. 

 Stop playout. 

 Pause playout: does not apply. 

 Resume playout: does not apply. 

Auto-Stop at Out Point: When activated 

(default), the Player is stopped when an Out 

Point is inserted. On the Timeline, the  icon 

shows that a Stop Player action has been 

inserted at the Out Point. 

Progressive Image: When scaling text, enable 

the Player’s Progressive Image option. See the 

chapter on Quality for more information on 

scaling and quality. 

Auto-update: Enable for clocks and counters 

and set an update Resolution in seconds or 

frames. 

Auto-adjust: select to auto-adjust the text 

frame’s size to its content. 
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22.6 Text Frame 

Text lines are displayed in a text frame. The frame’s size can be set in the properties window.  

 

You can also specify width and height on the transform gizmo, and then use the Copy from 

Transform Gizmo option. Using this option, the text is automatically scaled to100%. 

 

22.7 Link to fixed Text or Scene Parameter 

Link the Player to a fixed text, as shown in the example (Grass Valley), or to a Scene Parameter. 

 

22.8 Style 

 

22.8.1 Font 

Size: font size in points 

Font File: if applicable, select (or add first) a font 

file. This file is added to the Channel/Production 

Pack. 

True Type Font files are supported. The default font 

file is bauhaus.ttf (included in Composer). 

Kerning: kerning in % 

Interline: space between lines in in % 

Char Width: character width in % 

Anti-alias: Light, Medium or Normal 

 

22.8.2 Alignment 

H-Mode (horizontal mode): 

Normal: normal mode 

Fill width: scale text horizontally (stretch or 

squeeze) to fit in the text frame 

Fill kern: horizontal kerning to fit text in the text 

frame 

AutoFit: scale text horizontally ( squeeze only, no 

stretch) to fit in the text frame 

Word Wrap: word wrap text to fit in the text frame 

H-Align: horizontal alignment: left, center or right 

V-Align: vertical alignment: top, center or bottom 
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22.8.3 Styling 

Face Color: font face color 

Opacity: font face opacity  

Border and Drop  

You can specify a font border and drop (shadow) 

with color, opacity, size and blur. The text below 

uses the settings as shown in the example on the 

left. 

 

Example font with borders and drop. 

 

Image used as fill. 

 

Text and Still Object. 

22.8.4 Example Key – Fill with Image 

In this example a Text Object is used as key and 

placed on top of a Still (keying by Object). 

 

You can also key by Player, see also the example 

project Keying. 

 

The Text Object is used as mask with a white 
font (full transparency). 

   

Result. 
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22.9 Text Styles  

 

The Text Styles window lists and lets you manage Text Styles for 

the Project. 

Composer supports True Type Font (.ttf ) files. 

 

 

 

Add a Text style. 

 

Delete the selected Text style. 

 

Edit the Text style in the Object window. See the paragraph on Style for an explanation of 

available options. 
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22.10 Special Strings for Character and Font Formatting 

Use special strings to format texts. There are special strings for text formatting, counters and time.  

 

 

All special string identifiers are case sensitive. 

 

Character set 

'$3xxxx' Set the character set, with xxxx = 

1250 (Central Europe) 

1251 (Cyrillic) 

1252 (Latin I) 

1253 (Greek) 

1254 (Turkish) 

1255 (Hebrew) 

1256 (Arabic) 

1257 (Baltic) 

1258 (Vietnam) 

 

Font size 

'$7xxx ' Change the font size (for the current line): values between 005 -150. 

NOTE: trailing space. 

 

Foreground color 

'$1AABBGGRR ' Set the foreground color for text (ALPHA, B, G, R). 

Example: 'The color is $1FF0000FF red!' 

NOTE: trailing space. 
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Indents 

'$9xxx ' Indent, use 3 digits: values between 0-999 in horizontal pixels. 

 

NOTE: trailing space. 

 

Code 

'$4xxx' Display the special character with decimal code (normal font mapping 

table), with xxx = decimal code. 

 

Example: '$4128' displays the special character with code 128 in the 

normal font mapping table. 

'$5xxxx' Interprets a string as unicode input (double byte characters), 

hexadecimal notation. 

'$6xxxx' Interprets strings as glyph code (double byte characters), hexadecimal 

notation. Advised for special codes which are not in the normal 

character map. 

 

Example (Arabic text): 'Some Arabic text will follow 

$603D2$603B8$603BB$603F0$6039B$603AE$6039B .' 

 

 
Returns 

'$0 ' Return. 

NOTE: trailing space. 

 

Tabs 

'$2xxx ' Tab, offset in horizontal pixels from the utter left of the displayed font 

map. 

 

NOTE: trailing space. 
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Vertical offsets 

'$8xxxx ' Vertical offset in pixels, use 4 digits: values between -999 -9999. 

 

NOTE: trailing space. 

 

 

22.11 Counters 

Counters are displayed using a Text Player. Counter Commands are used to set, start and stop the 

counter. Special strings specify the type of counter and format. Example: 

 $D: specifies an up counter. 

 $C:  specifies a down counter. 

 

An example project Clocks and Counters is available in File > Example Projects. 

 

 

Example Template that uses a Text Object to display the counter and Set and Stop Counter 

Commands. No Stop Command is added since this Project uses Clear All Commands to stop Players 

that are not used in the current Template. 
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22.11.1 Defining a Counter 

 

Example Text Object with the Text Player 

defining a down counter. 

  The steps for defining a counter are: 

  

 Add an Object to the Stage to place the 

counter on-screen. This can be any Object 

that can be linked to a Text Player, for 

example a Text Object or a Box. 

 Specify the Object’s look and feel. 

 Go to the Text Player tab and in the text field, 

specify the type of counter, using the counter 

special strings. 

 Add separate Counter Commands to the 

Template Timeline to set, start and stop the 

counter. Link these Commands the counter’s Text 

Player: 

1. Set Counter Value: set the counter’s start value 

(in seconds). 

2. Start: start the counter. 

3. Stop: stop the counter’s Text Player to save 

resources once the counter has been taken off-

screen. You can also stop the counter using the 

Clear All Command or using Out Points. 

 

Example Counter Command used to start the counter 

and linked to the counter’s Text Player. 
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22.11.2 Counter Command 

Use the Counter Command to stop, start or set a counter. 

 

 

 

Example. 

 
Properties 

Player: select a Text Player (Text Players that have been added to the Canvas are listed). 

Sub command: 

 Set Counter Value: set the counter’s start value (in seconds). 

 Start: start the counter. 

 Stop: stop the counter. 
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22.11.3 Special Strings for Counters 

Use special strings to specify how a counter will be displayed. 

 

 

All special string identifiers are case sensitive. 

$D Specifies an up counter. 

$C Specifies a down counter. 

'$C' Down counter in format ":ss" if counting < 60 seconds, and "m:ss" if 

counting > 60 seconds. 

'$CD<C-syntax>' Display formattable seconds count. Specify a C-language printf() style 

integer format string behind the D. 

Example: “$CD%3d”.  

'$CM' Displays minutes from down counter. 

'$CS' Displays seconds from down counter (always 2 digits 0-59). 

'$CX<C-syntax>' Displays formattable string seconds from down counter. Specify a C-

language printf() style integer format string behind the X. 

Example: "$CXsec: %03d". 

'$CT' Displays a down counter (>1 hour hh:mm) (>1 minute mm:ss) (< 1 > 

minute :ss). 

'$CF<C-syntax>' Formattable string down counter, 2 arguments (h, m). Specify a C-

language printf() style integer format string behind the F. 

Example: ‘$CFtime: %02d.%02d’ will result in: time: 09.34 

Example: ‘$CF%d:%02d' will result in: 9:34 

'$CG<C-syntax>' Formattable string down counter, 2 arguments (m, s). Specify a C-

language printf() style integer format string behind the G. 

Example: '$CGmin and sec: %02d.%02d' will result in: min and sec: 

34.56 

'$CV<C-syntax>' Formattable string down counter, 3 arguments: (h, m, s). Specify a C-

language printf() style integer format string behind the V. 

Example: '$CVtime: %02d.%02d.%02d' will result in: time: 09.34.56 
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'$CW<C-syntax>' Formattable down counter, 4 arguments: days, h, m, s. Specify a C-

language printf() style integer format string behind the W. 

Example: '$CW%d days %02d:%02d:%02d' displays: 2 days 23:57:26  

'$D' Up counter in format ":ss" if < 60 secs, and "m:ss" if > 60 seconds. 

'$DD<C-syntax>' Display formattable seconds count. Specify a C-language printf() style 

integer format string behind the D. 

Example: “$DD%3d”. 

'$DM' Minutes from up counter. 

'$DS' Seconds from up counter (always 2 digits 0-59). 

'$DX<C-syntax>' Displays formatable string seconds from up counter. Specify a C-

language printf() style integer format string behind the X. 

 

Example: "$DXsec: %03d". 

'$DT' Up counter (>1 hour hh:mm) (>1 minute mm:ss) (< 1 minute :ss). 

'$DF<C-syntax>' Formatable string up counter, 2 arguments (h, m). Specify a C-language 

printf() style integer format string behind the F. 

 

Example: ‘$DFtime: %02d.%02d’ will result in: time: 09.34 

Example: ‘$DF%d:%02d' will result in: 9:34 

'$DG<C-syntax>' Formatable string up counter, 2 arguments (m, s). Specify a C-language 

printf() style integer format string behind the G. 

 

Example: '$DGmin and sec: %02d.%02d' will result in: min and sec: 

34.56 

'$DV<C-syntax>' Formatable string up counter, 3 arguments: (h, m, s). Specify a C-

language printf() style integer format string behind the V. 

 

Example: '$DVtime: %02d.%02d.%02d' will result in: time: 09.34.56 

'$DW<C-syntax>' Formatable string up counter, 3 arguments: (h, m, s). Specify a C-

language printf() style integer format string behind the V. 

 

Example: '$DVtime: %02d.%02d.%02d' will result in: time: 09.34.56 
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22.12 Autoclock (digital time) 

 

Various examples of clocks can be found in File > Example Projects > Clocks and Counters. 

 

  The steps for defining a counter are: 

  

 Add an Object to the Stage to place the clock on-screen. This can be any Object that can be 

linked to a Text Player, for example a Text Object or a Box. 

 Specify the Object’s look and feel. 

 Go to the Text Player tab and in the text field, specify the type of time formatting, using the 

time formatting  special strings. 

22.12.1 Special Strings for Time Formatting 

Formats 

'$T' Displays time in h:mm (%2d:%02d). 

'$Th' Will show hours only. 

'$Th0' Will show hours only, always 2 digits with leading 0. 

'$Tm' Will show minutes only. 

'$Tm0' Will show minutes only, always 2 digits with leading 0. 

'$Ts' Will show seconds only.  

'$Ts0' Will show seconds only, always 2 digits with leading 0.   

'$TS' Displays time with seconds h:mm:ss (%2d:%02d:%02d). 

'$TZ' Will show seconds only, always 2 digits with leading 0.   

'$TQ' Displays time with seconds h:mm:ss (%2d:%02d:%02d). 
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Offsets 

'$TO' Time with offset defined in minutes, displayed in minutes. 

Example: '$TO-3' 

'$TM' 

Time with offset defined in seconds, displayed in minutes. 

 

Example: '$TM-180' 

Example: 'it is $TM10' 

'$TN' Time with offset defined in minutes, displayed in seconds. 

 

Some examples 

'$Th0+3' Zero leading hours, +3 hours offset. 

'$Th03' Zero leading hours, +3 hours offset. 

'$Th0-3' Zero leading hours, -3 hours offset. 

'$Th-3' Hours, -3 hours offset. 

 

 

The same applies to $Tm (minutes) and $Ts (seconds). 
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23 Animations 

 

Use the ANI Object to play out an animation. 

 

Use the ANI Generator to create an animation from a series of TGAs. 

 

23.1 Supported formats 

Animated graphics are played back using the Composer native animation file format. Composer 

animation files are compressed video files and can be generated from TGA sequences. The TGA files 

must be in 32-bit, uncompressed, with alpha channel format. 

 

23.2 Prefabs 

Following prefabs are aviable: 
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23.3 Example 

 

Example ANI Object playing out a fixed ANI-file. 

 

 

Please refer to the relevant paragraphs for an 

explanation of Players, quality, on-screen visibility 

and audibility, properties such as transform and 

blending, and so on. 

 

 

 

 

23.4 The ANI Generator 

The ANI Generator converts a sequence of TARGA files to an animation (ANI-file). The animation is 

added as Project Asset and will be included in the Production Pack when the Project is exported, or as 

Test Asset in the Library. 

 

23.4.1 Working with the ANI Generator 

 To create an animation, go to Project Assets > Tools > Generate Ani. 

 Select a TARGA from the directory that contains the files you want to add to the sequence. A 

sequence is created of all files with the same file name. 
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Example. 

 Select a Decimation value. A higher quality results in a bigger file size. 

 Select a Bitrate. A higher quality results in a bigger file size. 

 Select applicable options: 

o Top field first: the top field of each frame in the animation is played out first in time. 

o Flip targas vertically. 

o Reverse targa sequence: the last TARGA in the sequence becomes the first frame in 

the animation. 

 
23.4.2 TARGA Requirements 

 Files must be 32-bits uncompressed TARGA-files. 

 All files must have the same dimensions 

 File dimensions must be a factor of 2; for example 32 and not 7. 

 File dimensions must be a factor of 16. If not, the encoder will add pixels resulting in slightly 

larger dimensions than the input TARGAs. 

 TARGAs should be numbered sequentially: for example targa_01.tga, targa_02.tga, 

targa_03.tga and not targa_01.tga, targa_03.tga, targa_04.tga. Numbering does not have to 

start at 0. 

 Numbering should be added to the end of the filename: for example targa_01.tga and not 

01_targa.tga. 

 The sequence must contain at least 2 files. 
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24 Tickers 

 

Use the Ticker Object to place a ticker on-screen. 

Use the Ticker and Add Ticker Story Commands to pause or unpause, and set or 

clear stories for a Ticker. 

Please refer to the chapter on Commands for an explanation of these Commands. 

 

 

Action: select a Ticker Player action: 

Player actions: 

 No Action 

 Link this Player to another Player. 

 Start playout. 

 Stop playout. 

 Pause playout. 

 Resume playout. 

 

: click to refresh the Player settings. 

Speed: ticker speed in 1/10
th
 pixel 

Repeat: repeat ticker stories after the last story 

has been played out. 

Width: Ticker Object width. 

Height: Ticker Object height. 

Copy from Transform Gizmo: you can also 

specify width and height on the transform gizmo, 

and then click this option. Using this option, the 

text is automatically scaled to100%. 

Graphic Players: add a still or ANI to the Ticker. 

 

Please refer to the relevant chapters for an 

explanation of the Transform, Blending, Effect, 

Quality and Miscellaneous options. 

 

 

Please refer to the chapter on Text for special strings that can be used for formatting. 
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25 Mesh Clips 
 

 

Use to import and add a 3D-Object from Autodesk 3D Studio to your design.  

 

 

25.1 Supported formats 

The Mesh Clip format offers a simple but effective mesh animation system in which each frame of 

animation is defined by a 3D object. Industry standard 3D object files can be converted into Mesh 

Clips by an import feature in GVD Composer. The following standard 3D object file formats are 

supported by this conversion: 

 

Format Details 

3ds Autodesk 3D Studio file format 

 
The following is imported:  

 Mesh data (vertices, faces, uv coordinates, smoothing groups).  

 Materials; a GVD Composer material is automatically made for each 3ds material.  

 The first keyframe of the animation track.  

 

The following is not imported:  

 Any non-mesh objects, like lights and cameras.  

 The rest of the keyframes.  

 

25.2 Prefabs 

Following prefabs are predefined: 
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25.3 Importing a 3DS-file 

When importing a mesh clip, the following window opens: 

 

Import 3DS scene as: 

One object: import as a single file 

Separate objects: import separate objects in 

the file as separate Mesh Clip.  

 

Smoothing 

From file: import the normal map form 3DS. 

From custom angle: generate normal based 

on a custom angle 

 

Animation: not supported. 

 

Output: Select the Only create .meshclip(s) 

option if you want to add the Mesh Clip(s) to 

the Production Pack only, and not to the 

Stage. 
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Example imported 3DS Object. The Object’s material was 

imported and is replaced with the Composer Soft Plastic 

material. 
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26 Audio Object 

 

Use the Audio Object to play out audio. 

 

26.1 Supported Formats 

Format Details 

BWAV / WAV 16 or 24 bit LPCM, sampled at 48 kHz 

MPEG 1 Layer 2 / MP2 16 bit, sampled at 48 kHz 

 

26.2 Audio Levels/Routing 

 

These properties define audio levels and routing 

(optional): 

 Fade: specify a linear fade in % (for all 

audio channels). 

 Set for all input channels: set output 

audio levels (in db). 

 Set per input channel: set output audio 

levels (in db) per channel. 

 Routing: link input channels to output 

channels. 

-120 db is mute, or deselect in the routing table. 
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27 Commands 

 

Use Composer Commands to run nexos commands. 

 

 

27.1 Working with Commands 

Commands can be found here: Library > Prefabs > Commands. Commands are edited on the 

Template Timeline, where they are placed on command tracks. 

 

To add a Command to a Template, go to the Library > Prefabs > 

Commands drag the Command onto the applicable Template Editor. 

A command track is automatically inserted when a Command is dragged 

upon the Timeline, below any existing tracks. 

Once a command track has been added, you can also click the   icon 

to add a track. 

The example on the left shows the Timeline with two Commands inserted 

on two command tracks:  

 A Clear all Command  on track 0. 

 A Ticker Command   on track 1. 

 

To change the order of Commands within a track, or move between 

tracks, drag and drop the Command. The position on the Timeline is 

indicated as shown in the example on the left. 

 
Copy the selected Commands to the clipboard. 

 
Paste clipboard items onto the Timeline. 

 To delete a Command, select and on the tool bar click the   icon.  

  To delete a command track, click the  icon. 
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To display or hide command tracks on the Template Timeline, click the 

Show > Command Tracks option. This option can be found in the 

bottom left corner of the Template Timeline. 
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27.2 AFD Command 

Use to enable or disable AFD (Active Format Description) in the video signal. AFD can be used in all 

broadcast formats. 

 

 

 

Example. 

 

27.2.1 Properties 

Mode: enable or disable AFD. 

Line: the VBI line number. Line numbers start at 0. 

Aspect Ratio: 4:3 or 16:9. 

AFD Code:  
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27.3 Add Ticker Story Command 

Use to set stories for a Ticker.  

 

 

 

Example. 
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27.3.1 Properties 

 

Ticker stories are numbered starting from 0.  

 

Player: the Ticker (Player) you want to update. 

Number: the story number you want to update. 

Text: a story (or a scene parameter). 

Story Graphics: if you want to include stills or animations in your stories, select a Still or ANI-Player. 

You can either select a TGA-graphic or ANI-animation to include in your stories (or link a scene 

parameter). 

Custom Font, Alignment and Styling: optional custom font, alignment and styling used for stories. 
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27.4 Clear All Command 

Use the Clear All Command to stop all Players in all Templates, except for the Players in the current 

Template. 

 

 

 
Example. 
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27.5 Counter Command  

Use the Counter Command to stop, start or set a counter. 

 

 

 

See also the chapter on counters in this manual for a more detailed explanation on how to define a 

counter. 

 

Example. 

 
 
27.5.1 Properties 

Player: select a Text Player (Text Players that have been added to the Canvas are listed). 

Sub command: 

 Set Counter Value: set the counter’s start value (in seconds). 

 Start: start the counter. 

 Stop: stop the counter. 
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27.6 GPIO Command 

The GPIO Command can be used to manipulate one of the configured GPIO devices’ output pins. 

 

 

 

Example. 

 

27.6.1 Properties 

Device Supported device names are:  

 DB9M – Represents the internal GPIO device, available through the DB9 

socket on the back of the machine. 

 VBI – Represents the virtual GPIO device that does GPIO-over-VBI on the 

video output(s) of the associated nexos channel. Alternatively, real device 

names VBI0, VBI1, VBI2, etc. can be used to explicitly address the GPIO 

devices dedicated to channels 0, 1, 2, etc.  

 

 
Note that GPIO devices must be defined in the nexos-gpio-params.txt file in 

order to use them here. In case of VBI devices, only the real devices VBI0, 

VBI1, etcetera should be defined.  

Output pin The number of the GPIO output pin to be manipulated. The first pin is 1.  

Value  Supported values are:  

 0 – Disables the pin, a logical 'off' or 'low'. 

 1 – Enables the pin, a logical 'on' or 'high'. 
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27.7 Rating Command 

Use the rating Command to send rating messages (also known as Content Advisory, V-Chip or 

Program Rating) in the video signal. 

 

 

 

Example. 

 

27.7.1 Rating systems 

The following Systems are supported. 

Value  Description  

MPA  MPA  

U.S.TV PG U.S. TV Parental Guideline system  

Canadian English Canadian English Language Rating  

Canadian French Canadian French Language Rating  

 

27.7.2 Rating values for U.S. Parental Guideline Rating system 

Category  Field value  Description  

TV-Y  TV-Y  All children.  

TV-Y7  TV-Y7  

TV-Y7,FV  
Children aged 7 and above  

TV-G  TV-G  General audience.  
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TV-PG  TV-PG  

TV-PG,D  

TV-PG,D,L  

TV-PG,D,L,S  

TV-PG,D,L,S,V  

TV-PG,D,L,V  

TV-PG,D,S  

TV-PG,D,S,V  

TV-PG,D,V  

TV-PG,L  

TV-PG,L,S  

TV-PG,L,S,V  

TV-PG,L,V  

TV-PG,S  

TV-PG,S,V  

TV-PG,V  

Parental guidance suggested.  

TV-14  TV-14  

TV-14,D  

TV-14,D,L  

TV-14,D,L,S  

TV-14,D,L,S,V  

TV-14,D,L,V  

TV-14,D,S  

TV-14,D,S,V  

TV-14,D,V  

TV-14,L  

TV-14,L,S  

TV-14,L,S,V  

TV-14,L,V  

TV-14,S  

TV-14,S,V  

TV-14,V  

Parents strongly cautioned.  

TV-MA  

 

 

 

 

 

TV-MA  

TV-MA,L  

TV-MA,L,S  

TV-MA,L,S,V  

TV-MA,L,V  

TV-MA,S  

TV-MA,S,V  

TV-MA,V  

Mature audience only.  

None  None  No blocking intended.  
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27.8 Set Main Player Command 

 

 

The main Player Command is automatically added for the first Clip or Live Object that is added to a 

Template.  

The main player has following properties [see also the chapter on the main player]: 

 The main Player has priority over other Players when resources are assigned. 

 If the main Player contains an embedded Closed Caption subtitle stream, this stream will be 

played out. If other Clips contain subtitle streams, these streams will not be played out. In 

other words, only the main Player’s subtitle stream will be played out.  

The main Player is also the source for the ATC (HD) or VITC (SD) timecode signal in the SDI-output. 
Only one signal can be sent out, i.e. from the main Player.  
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27.9 Ticker Command 

Use the Ticker Command to clear, pause or unpause stories for a Ticker. 

 

 

27.9.1 Properties 

Player: the Ticker (Player). 

Command: 

 Clear 

 Story Pause 

 Story Unpause 

 

 

Example. 
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27.10 Video Index Command 

Use the VIC-command to blank certain VBI-lines, or to write Video Index data into VBI-lines.  

 

 

27.10.1 Properties 

Line: the target VBI-line number. Line numbers start at 0. 

Scanning:  

 

AFD:  

 

 
Signal Form:  

 
 
Sampling: select the sampling structure: 
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Pan: a number in the range [0, 127]. 

Tilt: a number in the range [0, 127]. 

Zoom: a number in the range [0, 127]. 

XY Flags: 

 
Example. 
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28 Effects  

 

Use Effects to define overlays. 

 

Effects are built of Templates (actions). Create Templates first and then define Effect actions using 

these Templates. 

 

28.1 Basic editing 

 To create a new Effect, in the Project window, click the  icon. 

 To rename, right-click in the Project window and then rename. 

 To edit an existing Effect, double-click in the Project window. 

 Add actions by clicking the   icon. 

 The Action Name window opens. 

 Specify a Name for the action. This is the name that will be displayed on the GV Director 

Panel. 

 Click OK to confirm, Cancel to discard. 

 

 To link a Template to an action, double-click the action in the actions list. 

The Pick Template window opens. 

 Select a Template from the list. 

 Click OK to confirm, Cancel to discard. 

 

 To delete an action, click the  icon. 

 Click Yes to confirm, Cancel to discard. 
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 To add the Effect to a folder, either drag and drop into an existing folder, or right-click in the 

Project window and select Add to Folder. A new folder is created and the element is added 

to this folder. Note that folders only exist in Composer and not on the production nodes, and 

can be used to organize elements. 

 

 To delete an Effect, right-click in the Project window and select Delete, or select and press 

the [Delete]-key. 

 

28.2 Previewing Effects 

Preview Effects in Try-out Mode. Add the Templates that the Effect is built of to the Try-out list and 

preview. 

 

 

Note that Players only run in Try-out mode. 
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29 Transitions  

 

Use to define a transition from one background (black, input or shotbox) to another 

background. 

 

 

 

Example transition that crossfades (using a keyframed animation of the back plane’s opacity) from a 

front plane (A) to a back plane (B) and plays out a text on top. Note that no streaming Players are 

used, and that all Players start at 0%. 
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 Transitions use the Mixer Object. 

  

 

 Transitions use the Mixer Player, one for the front and one for the back. 

 

 

 Transitions move from A (front) to B (back). 

 

The Mixer Player for the front uses the Mixer Buffer Front. 

 

 

The Mixer Player for the back uses the Mixer Buffer Back. 

 

 Transitions move from 100% (Front) to 100% (Back).   
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 Transitions can be scratched, for example reversed or accelerated, for example using the T-

bar on the GV Director Panel.  

 All Objects in a Transition should be grouped under the Mixer Object, as shown in the 

example below. 

 

 

 Prefabs Back Plane and Front Plane are available in the Objects Library. Note that you can 

also use other Objects than the Plane for the back and front, then link the Mixer Player to (one 

of the) the Object’s material(s). 

 

Restrictions 

 You cannot add streaming Players such as Animations or Clips to a standard Transition.  

 All Players in a standard Transition must start at 0%. 

 

 

These restrictions do not apply for Animated Transitions.  
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29.1  Basic editing 

 To add a Transition to your Project, in the Project window click the  icon, or on the main 

menu, click Project > Add a Transition. 

 To rename, right-click in the Project window or double-click the Transition tab in the Timeline, 

then rename. 

 To edit an existing Transition, double-click in the Project window or select the editor in the 

Timeline. 

 To duplicate, right-click in the Project window and select Duplicate, or click the  in the 

Timeline. 

 To edit settings, right-click in the Project window and select Settings. 

 To delete, right-click in the Project window and select Delete, or select and press the 

[Delete]-key, or select and click the  option in the Template Timeline. 

 Folders can be used to organize elements in a Project. To add an element to a folder, either 

drag and drop into an existing folder, or right-click in the Project window and select Add to 

Folder. A new folder is created and the element is added to this folder.  

Folders can be used to organize elements in Composer. Note that folders only exist in 

Composer and not on the GV Director system. 
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29.2 Defining a Transition 

 To add a Transition to your project, in the Project window click the  icon. 

The Mixer Object is automatically added to the Objects window.  

 To rename the Transition, right-click in the Project window or double-click the name tab in the 

Timeline, then rename. 

 Add an Object to the Stage for the transition’s front and an Object for the transition’s back. 

 Edit these Objects in the Object window and animate properties on the Timeline as described 

in the Composer manual. Note that all Objects should start at 0%. 

 For both the back and front Object, link the Mixer Player to (one of the) the Object’s 

material(s). 

 Select the Material , either in the Objects or Object window. 

 (Double)-click to edit. Select Players > Fill: Mixer Player. 

 Select the Mixer Player Object in the Objects window , or click the arrow icon in the Object 

window to define the Mixer Player. 

 

 

 The Mixer Player for the front uses the Mixer Buffer Front. 
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 The Mixer Player for the back uses the Mixer Buffer Back. 

 

 

 If applicable, add more Objects to the Transition and finish your design. Note that you cannot 

add streaming Players to the design. 

 Make sure all Objects are grouped under the Mixer Object. 

 

29.3 Previewing Transitions 

Preview Transitions using the Timeline player options, move the player head or in Try-out Mode. 

 

 

 

Note that Players only run in Try-out mode.  
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30 Animated Transitions  

 

Use to define an animated transition from one background (black, input or shotbox) 

to another background. Animated Transitions can include streaming Players such as 

Animations, Clips and Tickers. Animated Transitions cannot be scratched but are 

always linear.   

 

 

 

Example animated transition that crossfades from the Back Plane (A) to the Front Plane (B) and plays 

out an animation on top. Note that a streaming Player (animation) is used, and that not all Objects 

start at frame 0. 
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 Transitions use the Mixer Object. 

  

 

 Transitions use the Mixer Player, one for the front and one for the back. 

 

 

 Animated Transitions move from A (Front) to B (Back). 

 

The Mixer Player for the front uses the Mixer Buffer Front. 

 

 

The Mixer Player for the back uses the Mixer Buffer Back. 

 

 Animated Transitions cannot be scratched, for example reversed or accelerated, but are 

linear.  
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 Streaming Players such as Animations or can be added to an Animated Transition.  

 In an Animated Transitions, Objects do not have to start at frame 0. 

 You must define a duration for Animated Transitions. 

 All Objects in a Transition should be grouped under the Mixer Object, as shown in the 

example below. 

 

 

 Prefabs Back Plane and Front Plane are available in the Objects Library. Note that you can 

also use other Objects than the Plane for the back and front, then link the Mixer Player to (one 

of the) the Object’s material(s). 
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30.1 Basic editing 

 To add an Animated Transition to your Project, in the Project window click the  icon, or on 

the main menu, click Project > Add Animated Transition. 

 To rename, right-click in the Project window or double-click the Animated Transition tab in the 

Timeline, then rename. 

 To edit an existing Transition, double-click in the Project window or select the editor in the 

Timeline. 

 To duplicate, right-click in the Project window and select Duplicate, or click the  in the 

Timeline. 

 To edit settings, right-click in the Project window and select Settings. 

 Folders can be used to organize elements in a Project. To add an element to a folder, either 

drag and drop into an existing folder, or right-click in the Project window and select Add to 

Folder. A new folder is created and the element is added to this folder.  

Folders can be used to organize elements in Composer. Note that folders only exist in 

Composer and not on the GV Director system. 

 To delete a Transition, right-click in the Project window and select Delete, or select and press 

the [Delete]-key, or select and click the  option in the Template Timeline. 

 

30.2 Defining an Animated Transition 

 To add an Animated Transition to your Project, in the Project window click the  icon. 

The Mixer Object is automatically added to the Objects window.  

 To rename the Transition, right-click in the Project window or double-click the Transition tab in 

the Timeline, then rename. 

 Add an Object to the Stage for the transition’s front and an Object for the transition’s back. 

 Edit these Objects in the Object window and animate properties on the Timeline as described 

in the Composer manual. 

 For both the back and front Object, link the Mixer Player to (one of the) the Object’s 

material(s): 

 Select the Material , either in the Objects or Object window. 

 (Double)-click to edit. Select Players > Fill: Mixer Player. 
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 Select the Mixer Player Object in the Objects window , or click the arrow icon in the Object 

window to define the Mixer Player. 

 

 

 The Mixer Player for the front uses the Mixer Buffer Front. 

 

 

 The Mixer Player for the back uses the Mixer Buffer Back. 

 

 

 

 If applicable, add more Objects to the Transition and finish your design. 

 Make sure all Objects are grouped under the Mixer Object. 

 Specify the duration for the transition. In the Timeline, click the   icon and specify 

Duration. 
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Example. 

 

 

When hovering over the Timeline, the position on the Timeline is displayed in Composer´s left 

bottom corner. 

 

Example. 

 

30.3 Previewing Animated Transitions 

Preview Transitions using the Timeline player options, move the player head or in Try-out Mode. 

 

 

 

 

Note that Players only run in Try-out mode. 

 

 

To step through an animation, on the Timeline move the player head to the appropriate position and 

click the Refresh Players button, or press CTRL+F or CMD+F. 
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Compound Editing  

31 Compound Elements  

 

Compound elements are used to create timed, ordered lists of production elements. 

. 

 

 

Compound Elements are defined in the Compound Element Timeline. To open the Compound 

Element Timeline, double-click a Compound Element in the Project window. 

 

Example. 

 

Each row in the Compound Element Timeline represents an Effects Block or scene. Effect Blocks are 

composed of one or more of the following Production Elements: 

 Background: either a black, input or shotbox (clip, animation or still)  

 Transition: defines the transition from the previous background to this scene’s background 

 Effects: graphical overlays  

 GPOs 

 Pause: either a user or timed pause. This is a fixed element and cannot be removed. 

 

The elements on each row (Background, Transition, Effects and Pause) are started simultaneously. 

Effect Blocks are run sequentially from top to bottom and are separated by pauses, either a user or 

timed pause. 

When previewing the Compound, the currently active Effects Block is highlighted in red. User Pauses 

will start blinking. 
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31.1 Basic editing: Compound Elements 

 To create a new Compound Element, in the Project window, click the   icon, or on the 

main menu, click Project > Add Compound Element. 

 To rename, right-click in the Project window or double-click the Compound tab in the 

Compound Element Timeline and then rename 

 Folders can be used to organize elements in a Project. To add an element to a folder, either 

drag and drop into an existing folder, or right-click in the Project window and select Add to 

Folder. A new folder is created and the element is added to this folder. Note that folders only 

exist in Composer and not on the GV Director system. 

  To delete the Compound Element, right-click in the Project window and select Delete, or 

select and press the [Delete]-key, or select and click the  option in the Compound Element 

Timeline. 
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31.2 Basic editing: the Compound Element Timeline 

 
Add an Effects Block. 

 
Start the player to preview the Compound. The Compound is played back on the Stage. Some 

elements are simulated. 

 
Stop the Player. 

 
Copy the selected Production Element or Effect Block. You can also use hotkeys. 

 
Paste the copied Production Element or Effect Block. You can also use hotkeys. When an 

element cannot be pasted, the Paste option is disabled. 

 
Remove the selected Production Element or Effect Block. You can also right-click and 

remove. 

 
Duplicate the Compound Effect. 

 

To change the order of Elements or Blocks, select and drag while keeping the mouse pressed. The 

drop indicator shows where the Element or Block will be placed. 

 

Example: the white drop indicator shows where the Element will be placed. 
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31.3 Effect Blocks 

 To add an Effects Block, in the Compound Timeline click the  button. 

 To remove an Effects Block, right-click and remove or click the  button. 

 To copy click the  button, to paste click the  button, or use the CTRL|CMD+C and 

CTRL|CMD+V hotkeys. 

 

31.4 Backgrounds 

 

 

Following Backgrounds are available: 

 Black: this is a full screen black plane. 

 Input: select an input number (SDI). 

 Shotbox: select a shotbox location. Clips, animations and stills are assigned to shotbox 

locations on the GVD-Panel. 

 

 Backgrounds can be dragged and dropped from the Production Elements window onto the 

Effects Block in the Compound Element Timeline. If a Background is already defined for the 

Block, you can replace the existing Background, or cancel. 

 

31.5 Transitions 

 To add a Transition to an Effects Block, drag and drop from the Project window onto the 

Effects Block in the Compound Element Timeline. If a Transition is already defined for the 

Block, you can replace this Transition, or cancel. 

 

31.6 Effects 

 To add one or more Effects to an Effects Block, drag and drop from the Project window on to 

the Effects Block in the Compound Element Timeline.  
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 Double-click to select an action.  

 

 

Example. 

 

 

If no action is defined (NONE), actions are toggled. 

 

 

31.7 GPOs 

Use for third party automation purposes. 

 

 To add a GPO to an Effects Block, drag and drop from the Production Element window onto 

the Effects Block in the Compound Element Timeline. 

 Double-click to edit. 

 

Example. 

 

 Click OK to save changes, Cancel to discard. 
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You cannot use the same pin number twice in an Effects Block. Pin numbers are automatically 

incremented when dropping a GPO Object on an Effect Block from the Production Element window. 

 

 

31.8 Pauses 

Pauses define the time between Blocks. They can either be timed or user pauses. When a user pause 

is defined, playback will pause until the user continues playback by manual intervention, either on the 

Panel (press button) or in Composer (click pause). The last pause in a sequence of Effect Blocks 

keeps its properties but cannot be edited in Composer; the edit option is disabled.  

 

 

When a Transition exceeds the Effect Blocks (timed pause) duration, A (front) and B (back) are not 

flipped. 

 

 To edit a Pause, double-click. 

 Select either User Pause or Timed pause. 

 For timed pauses, specify a duration in hh:mm:ss:ff. 

 Click OK to confirm, Cancel to discard. 

 

 

Example. 
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32 Snapshots 

Create a snapshot of a Transition or Effect, then display on the GV Director Panel, on the Panel button 

linked to the Transition or Effect. 

 To create a snapshot, in the Timeline move the player head until the Stage displays the scene 

you want to take a snapshot of.  

 Click the Snapshot button. 

 

 A Snapshot is created and the snapshot icon is replaced by the snapshot.  

 

 To change, move the player head until the Stage displays the scene you want to take a 

snapshot of and click the Snapshot button again. 
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33 Quality 

This chapter describes a number of options for Quality Assurance. 

 

33.1 Anti-Aliasing  

Use the Object’s Quality > anti-aliasing option to avoid jagged edges. 

 

 

 

A plane with anti-aliasing enabled. 

 

 

  

A plane with anti-aliasing disabled. 

 

 

This setting can be costly in terms of performance, so be sure to only enable for Objects for which ant-

aliasing is really needed. Multi-sampling must be enabled in File > Preferences to see the effect. 
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33.2 Pixel Perfect 

An Object is pixel perfect when it maps its content straight to playout and does not transform the 

content's pixels during the rendering process. Distortions can occur for many reasons. For example: 

the Object is rotated, scaled, positioned in front or behind the 2D plane or on sub pixel coordinates, 

the content is stretched over the surface of a 3D object, texture filtering and/or effects are applied, 

etcetera. These distortions are often unwanted, especially for 2D-elements such as text and main 

clips. 

To display pixel perfect information, on the toolbar select the View > Pixel Perfect option or use the 

hotkey CTRL|CMD+P to toggle pixel perfect information. 

 

An exact match is displayed in green: Pixel perfect. Discrepancies are displayed in red: 

 Material distortion: the material applied transforms pixels. 

 Not on 2D plane: the plane on which content is displayed is not on the 2D plane (not on the z-

coordinate 0). 

 Shape/size mismatch: the plane on which content is displayed is bigger or smaller than the 

content's dimensions.  

 Rotated: the plane on which content is displayed is rotated. 

 Sub-pixel coordinates: one or more edges of an Object are on sub-pixel coordinates. 

 Texture filtering on: texture filtering is enabled. 

 Effect on: the Object has an effect. 

 Height is not an even value: the interlaced content is displayed on a plane that does not 

have a height that is an even number (in pixels). 

 

The Example Project Quality Assurance explains various Composer techniques that can be used to 

counter graphics artifacts commonly seen in broadcasting.  
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Example pixel perfect information: Shape/size mismatch. 

The Plane displays a Still that does not match the Plane’s 

dimensions.  

 

 

33.3 Scaling 

There are several options for improving the quality of scaled clips, texts, stills, and so on: 

Enable Progressive Image. For texts and stills only. 

Use Texture Filtering. For all Objects. 

Use a Quality Scaler. For all Objects. results in the highest quality. 

 

33.3.1 Progressive Image 

(Only) when scaling, for stills and text: enable the Player’s Progressive Image option. 

 

Example. 

 
 
33.3.2 Texture Filtering 

Texture Filtering can be used for all Objects. 

To enable, set the Object’s Quality > Texturing option to Normal Quality. 

The High Quality option can be used for rotated (3D) Objects. 
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Example. 

 
33.3.3 The Quality Scaler 

The Quality Scaler can be used for all Objects. Use when scaling an Object and quality is important.  

Some examples: 

 Scaling a clip from HD to SD or vice versa. 

 Credit squeeze. 

 Picture-in-picture.  

 

 

Apply the Quality Scaler on the Player, not on the Object. 

 

Example. 

 

To enable the Quality Scaler, select the Player > Effect > select the Quality Scaler. 

Specify the Quality Scaler’s properties: 

 Target: specify the target’s width and height in pixels. 

 Scaling Modes: select a scaling mode for up and down scaling. Different scaling methods 

produce slightly different effects. If you are not sure which one to use, try different options.  

Lanzcos-3 is the default. Options are: 

o Up: Bicubic/Lanzcos-3/Lanzcos-4 

o Down: Lanzcos-2/Lanzcos-3/Lanzcos-4 
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Example. 

 

 

When using the Quality Scaler, make sure the Object’s Quality > Texturing option is set to No 

Filtering. 

 

Example. 
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33.4 Template Rating 

Use the Objects > Rate Templates option to estimate the performance of Templates. 

 

 

Example. 

 

Two scores are shown: 

 first score: the time in milliseconds to process the template (total) 

 second score:  time in milliseconds to process the template (GPU only) 

Near frames shows on which frames these two values peak (in this example 0 because all In Points 

start at frame 0). 

 

Values > 10 should be validated on the playout system 

 

 

Please refer to the Example Project for an explanation n how values can be improved if load is too 

high. 
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34 Hotkeys 

 

Replace the CMD-key with the CTRL-key when working on a Windows workstation. 

 

34.1 Global  

These hotkeys are accessible from everywhere. 

CMD-O : open Project. 

CMD-P  : Toggle Pixel Perfect Information. 

CMD-S : save Project. 

CMD-SHIFT-S : save Project as. 

CMD-Z : undo. 

CMD-Y : redo. 

CMD-C : copy. 

CMD-V : paste. 

CMD-A : select all. 

CMD-D : select none. 

CMD-+ : zoom in. 

CMD-- : zoom out. 

CMD-ALT-F : zoom to 100%. 

CMD-ALT-N : fit Stage in window. 

CMD-ALT-R : toggle ruler’s visibility. 
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CMD-ALT-G : toggle grid visibility. 

CMD-ALT-U : toggle guides’ visibility. 

CMD-SHIFT-G : toggle snap to grid. 

CMD-SHIFT-U : toggle snap to guides. 

CMD-1 : toggle Project Navigator visibility. 

CMD-2 : toggle History visibility. 

CMD-3 : toggle Library visibility. 

CMD-4 : toggle Project Assets visibility. 

CMD-5 : toggle Objects visibility. 

CMD-6 : toggle Object Properties visibility. 

CMD-7 : toggle Template Timeline visibility. 

CMD-8 : toggle Text Styles visibility. 

CMD-9 : toggle Scene Parameters visibility. 

CMD-SHIFT-T : new Template. 

G : group Objects. 

U : ungroup Object. 

ALT-A : add Object to Stage. 

SHIFT-SPACE : toggle Clean View Mode. 
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SHIFT-2 : toggle allow only 2D transformations. 

SHIFT-3 : toggle allow 2D and 3D transformations. 

SHIFT-A : toggle lock Object aspect ratio. 

SHIFT-M  : toggle 16:9 (anamorphic widescreen) mode 

SHIFT-Z : toggle 3D editing guides visibility. 

O : open group. 

C : close group. 

SHIFT-C : toggle curtains. 

CMD-T : toggle Template Try-out Mode. 

CTRL+Shift+T Add a Transition. 

CTRL+Shift+R Add an Animated Transition. 

CTRL+Shift+E Add a Template. 

CTRL+Shift+C Add a Compound Element. 
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34.2 Stage 

Mouse wheel : zoom in/out. 

left/right/up/down/pgdn/pgup : nudge (=move by one pix) left/right/up/down/fwd/bck 

SHIFT + left/right/up/down/pgdn/pgup : big nudge left/right/up/down/fwd/bck 

Middle mouse (hold) : grab Stage. 

R : reset rotation of selection. 

SHIFT + Object movement : constrain movement to X or Y axis. 

Del : remove selected Objects from Template. 

Del : delete selected Objects. 

      

34.3 Template Timeline 

A 
: select all Timeline items. 

D 
: delete Timeline selection. 

[/] : go to previous/next keyframe. 

left/right : decrease/increase player head time by one frame. 

+/- : zoom in/out. 

R 
: rewind. 

Space : toggle play/pause. 

K 
: insert/update keyframe for selection. 

 


