
 
 

 
 
 
 
 
 
 
 
 
 

COMPOSER 
FOR GV DIRECTOR 

 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 



 

 GV Director Composer 1.8.0 - 2 

Contents 
1 ABOUT THIS GUIDE 5 

1.1 What’s in this guide ............................. 5 
1.2 How to use this guide .......................... 5 
1.3 Document conventions ........................ 5 
1.4 Useful resources .................................. 5 
1.5 Grass Valley technical support ........... 5 
1.6 Corporate head office .......................... 6 
2 GET TO KNOW COMPOSER 7 

2.1 Basic features ....................................... 7 
2.2 Production elements ............................ 7 

2.2.1 Objects .................................................. 7 
2.2.2 Transitions ........................................... 16 
2.2.3 Templates ............................................ 16 
2.2.4 Effects ................................................. 16 
2.2.5 Compound elements ........................... 16 

2.3 The workspace ................................... 17 

2.3.1 The Template Timeline ........................ 19 
2.3.2 The Compound Element Timeline ....... 19 

2.4 The tools.............................................. 19 

2.4.1 Rulers .................................................. 19 
2.4.2 Gridlines .............................................. 19 
2.4.3 Alignment guides ................................. 20 
2.4.4 Template rules ..................................... 20 
2.4.5 Keyframes ........................................... 20 
2.4.6 Controllers  .......................................... 21 
2.4.7 Scene parameters ............................... 22 
2.4.8 The ANI Generator .............................. 22 
2.4.9 View pixel perfect information .............. 22 

3 GET STARTED 23 

3.1 System requirements ......................... 23 

3.1.1 Mac OSX ............................................. 23 
3.1.2 Windows .............................................. 23 

3.2 Install Composer ................................ 23 

3.2.1 Install Composer on a Mac .................. 23 
3.2.2 Install Composer on a Windows PC .... 24 

3.3 Basic actions ...................................... 24 

3.3.1 Open Composer .................................. 24 
3.3.2 Quit Composer .................................... 24 
3.3.3 Navigate the Object pane .................... 25 
3.3.4 Open and edit items ............................ 25 
3.3.5 Select a keyframe ................................ 26 
3.3.6 Move the player Head ......................... 26 
3.3.7 Open the Compound Element Timeline26 
3.3.8 Open an existing project ...................... 26 

3.3.9 Create a new project ........................... 26 
3.3.10 Save a project ..................................... 26 
3.3.11 Add a production element to a project . 27 
3.3.12 Delete a production element from a 

project.................................................. 27 
3.3.13 Rename a production element ............ 28 
3.3.14 Duplicate a production element ........... 28 

3.4 Customize the workspace.................. 28 

3.4.1 Customize panes ................................. 28 
3.4.2 Customize the Stage ........................... 29 
3.4.3 Customize the Template Timeline ....... 31 

4 CHANGE THE PREFERENCES 31 

4.1 Change the NexOS settings .............. 31 

4.1.1 Change the broadcast format .............. 31 
4.1.2 Change the image quality  ................... 32 
4.1.3 Adjust the multi-sampling anit-aliasing 32 
4.1.4 Adjust the texture cache size ............... 33 
4.1.5 Change the de-interlacing method ...... 33 

4.2 Change the file settings ..................... 33 

4.2.1 Change the default project folder ........ 33 
4.2.2 Enable / disable Autosave ................... 33 

4.3 Change the history settings .............. 34 
4.4 Change the alignment guide settings34 

4.4.1 Change the color of the alignment guide34 
4.4.2 Change the snap distance of the 

alignment guide ................................... 34 

4.5 Change the grid settings.................... 34 

4.5.1 Change the color of the grid ................ 35 
4.5.2 Change the horizontal spacing of the 

grid ...................................................... 35 
4.5.3 Change the vertical spacing of the grid 35 
4.5.4 Change the snap distance of the grid .. 35 

4.6 Change the backup settings .............. 35 
4.7 Change the FTP transfer mode ......... 35 

5 MANAGE A PROJECT 36 

5.1 Merge a project ................................... 36 
5.2 Import and export projects and 

elements .............................................. 36 

5.2.1 Import a project ................................... 36 
5.2.2 Export a project ................................... 36 
5.2.3 Import a production pack ..................... 37 
5.2.4 Export a production pack ..................... 37 
5.2.5 Import a template ................................ 37 
5.2.6 Export a template ................................ 37 



 

 GV Director Composer 1.8.0 - 3 

5.2.7 Importing assets .................................. 37 
5.2.8 Import a 3DS Studio Max file ............... 38 

5.3 Restore a project ................................ 38 
5.4 View a example project ...................... 38 
5.5 Organize project elements ................ 38 

5.5.1 Add a production element to a folder ... 38 
5.5.2 Add an object to the library .................. 38 
5.5.3 Manage text styles............................... 38 

6 WORK ON AN OBJECT 40 

6.1 Copy and paste an object .................. 40 
6.2 Lock or unlock an object ................... 40 
6.3 Work on a group ................................. 40 

6.3.1 Group or ungroup multiple objects ...... 40 
6.3.2 Edit a group object............................... 40 
6.3.3 Add ground reflections to a group ....... 40 

6.4 Change object handling in 2D or 3D 41 
6.5 Change the object layer ..................... 41 
6.6 Change the spatial properties of an 

object ................................................... 41 

6.6.1 Move an object .................................... 41 
6.6.2 Change the size or shape of an object 42 
6.6.3 Rotate an object .................................. 44 
6.6.4 Add or remove a camera perspective .. 45 

6.7 Change the image quality of an object45 

6.7.1 Enable or disable anti-aliasing ............. 45 
6.7.2 View pixel perfect information .............. 45 
6.7.3 Enable or disable progressive image... 46 
6.7.4 Change the texture quality ................... 46 

6.8 Blend an object ................................... 46 
6.9 Work on a player ................................ 47 

6.9.1 Refresh the preview of a player ........... 47 
6.9.2 Show a test feed .................................. 47 
6.9.3 Set a player action ............................... 47 
6.9.4 Change the size of a player ................. 48 
6.9.5 Player linkage ...................................... 49 
6.9.6 Automate player action properties ....... 50 
6.9.7 Preview the output of a player ............. 51 
6.9.8 Play out a video as object texture ........ 51 
6.9.9 Change audio levels and/or routing ..... 51 
6.9.10 Work on a text ..................................... 52 
6.9.11 Work on a ticker .................................. 61 

6.10 Work on a command .......................... 62 

6.10.1 Add a command to a template ............. 62 
6.10.2 Move a command ................................ 62 
6.10.3 Copy a command ................................ 62 
6.10.4 Paste a command ............................... 62 
6.10.5 Edit an AFD command ........................ 62 

6.10.6 Edit a ticker story command ................ 64 
6.10.7 Edit a Counter command ..................... 65 
6.10.8 Edit a GPIO command......................... 66 
6.10.9 Edit a Rating command ....................... 66 
6.10.10 Edit a Main Player command ............... 69 
6.10.11 Edit a Ticker command ........................ 69 
6.10.12 Edit a Video Index command ............... 69 

6.11 Work with materials ............................ 72 

6.11.1 Replace a material .............................. 72 
6.11.2 Change the lighting of a material ......... 72 
6.11.3 Change the image quality of a material 73 
6.11.4 Change the cull property ..................... 73 
6.11.5 Change the fill mode ........................... 73 
6.11.6 Enable or disable depth occlusion ....... 73 

6.12 Work with layer effects....................... 74 

6.12.1 Add and delete a layer effect ............... 74 
6.12.2 Set the intensity of a layer effect ......... 74 
6.12.3 Edit a ripple effect ................................ 74 
6.12.4 Edit a blur effect .................................. 76 
6.12.5 Edit a bevel or emboss effect .............. 77 
6.12.6 Edit a chroma key effect ...................... 77 
6.12.7 Edit a pixelate effect ............................ 78 
6.12.8 Edit a drop shadow effect .................... 78 

6.13 Animate an object ............................... 79 

6.13.1 Generate an animation from TGAs ...... 79 
6.13.2 Animate with keyframes ...................... 80 
6.13.3 Animate with controllers ...................... 85 
6.13.4 Animate with scene parameters .......... 86 

7 WORK ON A TEMPLATE 87 
7.1 Add and delete objects ...................... 87 

7.1.1 Add an object to a template ................. 87 
7.1.2 Remove an object from a template ...... 87 
7.1.3 Delete an object from the project ......... 87 

7.2 Use template rules .............................. 87 

7.2.1 Add a template rule ............................. 87 
7.2.2 Delete a template rule ......................... 87 
7.2.3 Edit a template rule ............................. 87 

7.3 Change the template settings ........... 89 

7.3.1 Open the template settings .................. 89 
7.3.2 Edit the template settings .................... 89 

7.4 Use the timeline controls ................... 89 

7.4.1 Use the player control buttons ............. 89 
7.4.2 Add a keyframe ................................... 90 
7.4.3 Select all timeline items ....................... 90 
7.4.4 Copy and paste items .......................... 90 



 

 GV Director Composer 1.8.0 - 4 

7.4.5 Delete an item from the timeline .......... 90 
7.4.6 Scale the time ...................................... 91 
7.4.7 Use the snap controls .......................... 91 
7.4.8 Hide and unhide items ......................... 91 
7.4.9 Enable or disable the pickup ............... 91 
7.4.10 Lock or unlock an object ...................... 92 
7.4.11 Zoom in or out of the timeline .............. 92 

7.5 Preview a template ............................. 93 
7.6 Take a snapshot ................................. 93 
7.7 Rate all templates ............................... 94 

8 WORK ON TRANSITIONS 95 
8.1 Edit the transition settings ................ 95 

8.1.1 Open the transition settings ................. 95 
8.1.2 Edit the transition settings ................... 95 

8.2 Change the A/B objects of a 
transition ............................................. 95 

8.3 Preview a transition ........................... 96 
8.4 Take a snapshot ................................. 96 
8.1 Rate all transitions ............................. 96 
8.2 Work on animated transitions ........... 96 

8.2.1 Set the duration ................................... 96 

9 WORK ON EFFECTS 98 

9.1 Add an action to an effect ................. 98 
9.2 Link an action to a template .............. 98 
9.3 Delete an action .................................. 98 
9.4 Preview an effect ................................ 98 

9.5 Take a snapshot .................................. 98 

10 WORK ON COMPOUND ELEMENTS 99 

10.1 Add and delete items .......................... 99 

10.1.1 Add an effects block ............................ 99 
10.1.2 Delete an effects block ........................ 99 
10.1.3 Add a transition to an effects block ...... 99 
10.1.4 Add one or multiple effects to an effects 

block .................................................... 99 
10.1.5 Add a GPO .......................................... 99 

10.2 Copy and paste items ......................... 99 

10.2.1 Copy an effects block .......................... 99 
10.2.2 Paste an effects block ....................... 100 

10.3 Change the order of production 
elements or effects blocks............... 100 

10.4 Replace items .................................... 100 

10.4.1 Replace a background ...................... 100 
10.4.2 Replace a transition ........................... 100 

10.5 Edit a pause ....................................... 100 

11 USE A KEYBOARD SHORTCUT 101 

11.1 Use a shortcut that works anywhere101 
11.2 Move through and edit the Stage .... 102 
11.3 Edit the Template Timeline .............. 102 

 

 
Copyright © Grass Valley USA, LLC. All rights reserved. 

 

Belden, Belden Sending All the Right Signals, and the Belden logo are trademarks or registered trademarks of Belden, Inc. or its 

affiliated companies in the United States and other jurisdictions. Grass Valley is a trademark or registered trademark of Grass 

Valley USA, LLC, Belden, Inc., Grass Valley USA, LLC, and other parties may also have trademark rights in other terms used 

herein. 

 



 

 GV Director Composer 1.8.0 - 5 

1 About this guide 
The Composer 1.8.0 User Guide gives users the latest 
information and instructions about how to use Composer 1.8.0 
for GV Director. 
 
 

1.1 What’s in this guide 
• Chapter 2, provides a general description of the Composer characteristics. 
• Chapter 3, helps you to get familiar with the window that opens when you launch Composer. It 

describes its toolbars, panes and tabs, as well as its basic elements. 
 

1.2 How to use this guide 
You can use Chapter 2 of this guide to find general information about Composer, such as a brief 
explanation of this application, and its basic elements. This chapter also explains the setup of the 
Composer workspace and the tools it includes.
 

1.3 Document conventions 
The formatting of this user guide is designed to help you easily and quickly find information. The 
following table explains what the different formats in this document mean. 
 
Format Refers to Example 
Bold An onscreen object for which a user action is 

needed. Keyboard keys are not emphasized. 
Click Save As. 

Italic Placeholder text. 
Hyperlink or cross-reference. 

Type password. 
See Chapter 2, Get to know Composer. 

■  Single-step procedures. ■ On the View menu, click Ruler. 
1.  Multiple-step procedures. 1. On the Tools menu, click Options. 

2. Click the Edit tab. 
& Note: A note. & Note: Only administrators can publish 

to a server. 

•  A list item. A user can edit: 
• Objects 
• Materials 
• Visual effects. 

 

1.4 Useful resources 
The following related resources might also help you to learn about the features of Composer: 
Composer topic library located on the Grass Valley website (www.grassvalley.com). 
 

1.5 Grass Valley technical support 
For technical assistance, contact our international support center, at 1-800-547-8949 (US and 
Canada) or +1 503-478-4148. 



 

 GV Director Composer 1.8.0 - 6 

To obtain a local phone number for the support center nearest you, please consult the Contact Us 
section of Grass Valley’s website (www.grassvalley.com). 
An online form for e-mail contact is also available from the website.  
 

1.6 Corporate head office 
Grass Valley 
3499 Douglas-B.Floreani 
St-Laurent, Quebec H4S 2C6 
Canada 
Telephone +1 514-333-1772 
 

http://www.grassvalley.com/
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2 Get to know Composer 
 
This chapter introduces you to Composer, its basic features 
and the production elements within the application. 
 
Composer is an animation and compositing tool with which you can design the graphic identity of live 
productions. It has been developed for broadcast professionals. To make things easy, Grass Valley 
has made various templates and has made them part of Composer. With these templates you can 
build a variety of production elements, such as effects, transitions and compound elements. 
 
Composer is part of the GV Director platform, an out-of-the-box, multipurpose tool for live production. 
It integrates video switching, multi-layer effects, animated graphics, multi-viewer monitoring, and more. 

2.1 Basic features 
With Composer you can design and compose production elements, such as: 
• Transitions 
• Templates (used to build effects) 
• Effects 
• Compound elements. 
 
These elements are edited in a project. The project also contains other design elements such as 
straps and logos.  
 
The process of working with Composer can be divided into several steps: 
 
1. Create a project. 
2. Add and edit objects. 
3. Add and edit transitions. 
4. Add and edit templates. 
5. Add and edit effects. 
6. Add and edit compound elements. 
7. Create a production pack.  

Once the design of the production elements is ready, you can bundle them in a production pack 
and export this pack to GV Director. The production elements can then be linked to buttons on the 
GV Director Panel. 

 

2.2 Production elements 
This section describes the production elements that you can design and compose in Composer: 
• Transitions 
• Templates (used to build effects) 
• Effects 
• Compound elements.  
 
These elements are the building blocks of a production pack. 
 
 

2.2.1 Objects 

Composer works with objects. Objects have properties, such as opacity, position and scale that you 
can edit and animate. You can edit objects in the Object and Objects pane. 
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The following prefabricated objects (prefabs) are available in the Composer library: 
Category Icon Object type Description 
Canvases  Players You can use players to control how content is played out. You 

can assign different actions to a player, such as Play (default), 
Stop, Pause and Resume. 

 

 

Animations You can use an animation to play out an animation. You can 
create an animation from a series of TGAs with the ANI 
Generator. There are two different presets for ANI players: Ani 
and Quality Scaled Ani. 

 

 

Audio You can use the audio object to play out audio. 

 

 

Clips You can use clips to play out a video clip. There are four different 
presets for clips: 
• Clip 
• Clip HD 1080 Quality Scaled: with a quality scaler to 

downscale from HD to SD. 
• Key Fill: where the clip is used as a fill and with a key player. 
• Quality Scaled Clip: with a quality scaler suited for 

downscaling.  
 

 

Mesh clips You can use a mesh clip to play out mesh clips. There are three 
different presets of mesh clips: 
• Circle Ticker 
• Helix Ticker 
• Single Material Cube. 

 

 

Stills You can use a still to play out a still. There are two presets for 
stills: Still and Key Fill Still. The Key Fill Stills has two players, one 
for key and one for fill. 

 

 

Texts You can use a text to play out a text and several digital clocks in 
TrueType fonts. It is possible to play out a static text or a dynamic 
text with the use of so-called scene parameters. Use the 
Standard Texture material with a text player to play out text on 
other objects. Text is shown in a text frame. You can change the 
size of this frame in the Object pane or on the GV Director panel, 
and then choose the Copy from Transform Gizmo option. There 
are four different presets of the text object: 
• Autoclock; a digital clock that shows the system time. 
• Multiline Text: a text of multiple lines separated by hard 

returns. 
• Text: a text of one single line. 
• Up Counter HMS: a clock in hh:mm:ss format. 

 

 

Tickers Use a Ticker to play out so-called ticker stories (text). 

3D shapes    
  Boxes  
  Cylinders  
  Spheres  
2D shapes  Planes  
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Commands 

 

 Use a command to run a specific command. Commands are 
edited on the Template Timeline, where they are placed on 
command tracks. There are ten different types of command that 
can be used: 
• AFD Command 
• Add Ticker Story 
• GPIO Command 
• Rating Command 
• Ticker Command 
• Video Index Command 
• WSS Command 

 
 

Supported formats 
 

Stills 

Format Details 

BMP 24 bit, uncompressed 

TGA 32 bit, uncompressed, with alpha channel  

GIF 8 bit 

JPEG 24 bit 

PNG 32 bit, with alpha channels 

TIFF 32 bit, uncompressed with alpha channel 

• Interlaced PNG is not supported. 
• Both bottom-to-top and top-to-bottom Targa is supported. 
• Tiff JPEG compression is not supported. 
• GIF transparent color pixels are painted black, no alpha is produced 
 
We recommend the following image editors with which you can export to the TGA format, Composer’s 
native still format (with alpha support). 
• Windows: Paint.NET http://www.getpaint.net/index.html 
• OSX: GIMP http://www.gimp.org/ 
 
 

Animations 
Animations are played out in a native animation file format. Composer animation files are compressed 
video files and can be generated from TGA sequences.  
 
TGAs that are used for animations must meet the following requirements: 
• 32 bit, uncompressed, with alpha channel 
• Image size: a factor of 16, such as 32. If an image has a different size, the encoder adds pixels. 

The result is that the output image is slightly larger than the input image. 
• All images must have the same size. 

http://www.getpaint.net/index.html
http://www.gimp.org/
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• You must number TGAs sequentially, such as targa_01.tga, targa_02.tga, targa_03.tga. You do 
not have to start at 0. 

• The file number must be at the end of the file name, such as targa_01.tga.  
• The minimum number of TGAs for an animation is 2.  
 
Composer automatically crops full screen animations with a transparent background. 
 

Clips 
 
Format Codec Bit Rate 

Mb/s 
Supported Wrappers 

SMPTE D10 30 / IMX 30 SMPTE D10 
(MPEG-2 4:2:2P@ML) 

30 MOV, MXF 

SMPTE D10 40 / IMX 40 SMPTE D10 
(MPEG-2 4:2:2P@ML) 

40 MOV, MXF 

SMPTE D10 50 / IMX 50 SMPTE D10 
(MPEG-2 4:2:2P@ML) 

50 MOV, MXF 

DV25 DV25 25 MOV, MXF, GXF, LXF 
DVCAM DV25 25 MOV, MXF, GXF, LXF 
DVCPRO25 DVCPRO25 25 MOV, MXF, GXF, LXF 
DVCPRO50 DVCPRO50 50 MOV, MXF, GXF, LXF 
DVCPROHD DVCPROHD 115 MOV, MXF, GXF, LXF 
XDCAM HD (LP, SP, HQ) MPEG HD 

(MPEG-2 MP@HL) 
18, 25, 35 MOV, MXF 

XDCAM HD422 MPEG HD422 
(MPEG-2 4:2:2P@HL) 

50 MOV, MXF 

XDCAM EX SP MPEG HD 
(MPEG-2 MP@HL-1440) 

25 MOV, MXF 

XDCAM EX HQ MPEG HD 
(MPEG-2 MP@HL) 

35 MOV, MXF 

MPEG-2 4:2:0 SD  MPEG-2 MP@ML Max 15 MOV, MPG, MXF 6, GXF, 
LXF 

MPEG-2 4:2:2 SD MPEG-2 4:2:2P@ML Max 50 MOV, MPG, MXF 6, GXF, 
LXF 

MPEG-2 4:2:0 HD  MPEG-2 MP@HL Max 100 MOV, MPG, MXF 6, GXF, 
LXF 

MPEG-2 4:2:2 HD  MPEG-2 4:2:2P@HL Max 100 MOV, MPG, MXF 6, GXF, 
LXF 

AVC Intra 50 H.264  
(MPEG-4 AVC Hi10-Intra-
P@L4) 

50 MXF, GXF 

AVC Intra 100 H.264 
(MPEG-4 AVC Hi4:2:2-
Intra-P@L4.1) 

100 MXF, GXF 

H.264/AVC  H.264 (MPEG-4 AVC  
HiP@L4.1) 

Max 50 MOV, MXF 

Apple ProRes 4:2:2 LT Apple ProRes 4:2:2 LT Max 100 MOV 
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• For supported embedded audio formats, see the Audio section below. 
• Grass Valley works hard to ensure compatibility with all leading industry formats. However, to 

uphold reliable playout, we strongly recommend the validation of content files for new projects. 
 

Restrictions for embedded audio 

Format Details 

BWAV / WAV 16 or 24 bit LPCM, sampled at 48 kHz 

MPEG 1 Layer 2 / MP2 16 bit, sampled at 48 kHz 

 

GOP size restrictions 
• The maximum GOP size for all video formats is 15 frames. 
• Both I frame only and long GOP formats are supported. 
• Supported are MPEG-2 Transport Stream and MPEG-2 Program Stream. 
• H.264/AVC format: 4:0:0 (monochrome) is not supported. 
• Only Operational Pattern (OP) 1a is supported. 
• For MXF wrappers, only the Operational Pattern (OP)1a is supported. 
• A maximum of 36 embedded streams is supported. 
• Frame accurate seeking requires availability of a Random Access Pack (RIP) for MXF files 

encoded with variable frame size (VBE). 
 

Audio 

Format Details 

BWAV / WAV 16 or 24 bit LPCM, sampled at 48 kHz 

MPEG 1 Layer 2 / MP2 16 bit, sampled at 48 kHz 

 

Fonts 
Composer supports TrueType fonts. 
 
 
 
 
 
 

Mesh clips 
The mesh clip format offers a simple but effective mesh animation system in which each frame of 
animation is defined by a 3D object. An import feature in Composer converts industry standard 3D 
object files into mesh clips. The following 3D formats are supported in this conversion: 
  
Format Details 

3ds Autodesk 3D Studio file format 

 
Composer imports the following data: 
• Mesh data, such as vertices, faces, UV coordinates and smoothing groups.  



 

 GV Director Composer 1.8.0 - 12 

• Materials. A Composer material is automatically made for each 3ds material.  
• The first keyframe of the animation track.  
 
Composer does not import this data: 
• Non-mesh objects, like lights and cameras.  
• Other keyframes. 
 

Materials  
Composer offers a selection of material types that represent some of the popular real-time shading 
models. You can apply one or multiple materials to an object to control the appearance of its surface. 
There are four types of materials: 
• Gooch materials 
• Image Based Lights (IBL) materials 
• Reflection materials 
• Standard materials. 
 

Gooch materials 
You can use gooch materials to create a style with non-realistic shading that is often used in technical 
illustrations. The following gooch materials are available: 
• Gooch 
• Poison 
• Skin 
 

 

 

IBL materials 
You can use IBL materials to imitate real-world lighting of 3D objects. The following IBL materials are 
available: 
 
• Antique Gold 
• Black Car Paint 
• Brushed Metal 
• Cheramic White 
• Dark Gold 
• Gold 
• Industrial 
• Industrial II 
• Industrial III 
• Industrial IV 
• Marble 
• Marble II 
• Red Car Paint 
• Soft Plastic. 
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Reflection materials 
You can use Reflection materials to create sharp reflections and refractions. The following reflection 
materials are available: 
• Car Glass 
• Copper 
• Reflection 
• Silver 

 
 

Standard materials 
You can use Standard materials. For these materials, the Phong shading model is used. This is the 
most commonly used shading model. The following standard materials are available: 
• Color 
• Color Shaded 
• Pink Plastic 
• Plastic 
• Rubber 
• Standard Textured 
• Wood  
 

& Note: You can use the Standard Texture material to play out a video on other objects that are not 
clips. With this material, for instance, it is possible to play out a video on the side of a Box. You 
must add a Clip to the textured material.  

 

Layer effects (FX) 

Bevel 
You can use the bevel effect to add depth to objects. 
 

The following layer effects are available: 
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Blur 
Use a blur to blur an object.  
 
The following blurs are available: 
 

 

Chroma keying 
You can use a chroma keying effect to add a chroma key to an object for background removal. 
 

The following layer effects are available: 
 

Colorize 
Use the colorize effect to apply a color effect to an already existing object during playout.  
 
The following layer effects are available: 

Drop shadow 
You can use a drop shadow effect to add a shadow to an object. 
 
The following drop shadow effects are available: 
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Pixelate 
You can use a pixelate effect to create a low resolution effect. 
 
The following pixelate effects are available: 

 

Ripple 
Use the ripple effect to create a ripple effect.  
 
The following layer effect is available: 
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2.2.2 Transitions 

 
An important part of Composer are transitions. A transition is a background change from a front plane 
(A) to a back plane (B) that you can edit. Each plane has a GVD Mixer Player to play them out. There 
are two types of transitions:  
• (regular) transitions: all objects must start at frame 0 and you cannot add players such as 

animations or clips to them. You can reverse or accelerate regular transitions with the handle on 
the GV Director Panel. 

• animated transitions: these transitions can include players such as animations, clips and tickers 
and objects do not have to start at frame 0. These transitions are always linear. You cannot 
accelerate or reverse them. You must set a duration for animated transitions. 

 
 
The am example of the hierarchy transitions types is as follows: 

 
 

& Note: All transition objects must be grouped under the IPA Mixer. 
 
 

You can use other objects than planes for the front (A) and back (B). 
 

 

2.2.3 Templates 

A template contains one or multiple objects that change in time. You can edit these objects and 
transformations. To transform an object, you can use keyframes and controllers. 
 

2.2.4 Effects 

An effect is a series of templates that you can link action name that is visible on the GV Director Panel, 
such as On, Off or Update. Create one or multiple templates first, and then set effect actions that use 
these templates. 
 
 

2.2.5 Compound elements 

 
A compound element is a timed, ordered collection of effects blocks. You can edit a compound 
element on the Compound Element Timeline. Each effects block has a separate row on the 
Compound Element Timeline. Each block consists of one or multiple of the following production 
elements that start simultaneously: 
• Background: You can add the following backgrounds to an effects block: 

o Black: a full screen black plane. 

Transition IPA Mixer 

Front Plane 
Standard 
Textured 
Material 

GVD Mixer 
Player 

Back Plane 
Standard 
Textured 
Material 

GVD Mixer 
Player 
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o Input: an SDI input line. 
o Shotbox: a shotbox location. On the GVD-Panel you can select which clips, animations or 

stills are visible in this shotbox location. 
You can drag and drop backgrounds from the Production Elements pane to the Effects Block 
section on the Compound Element Timeline. If a background has already been selected, you can 
replace the existing background. 

• Transition: defines the transition from the previous background to this scene’s background 
• Effects: graphical overlays  
• GPOs: You can use a GPO for third party automation purposes. 
Effect blocks run chronologically from top to bottom and are separated by pauses. With a pause, you 
can specify the amount of time between two effects blocks. There are two types of pauses: timed 

pauses and user pauses. A user pause pauses playout until the user manually continues playout, 
either on the Panel or in Composer.  You cannot edit the last pause in a sequence of effects blocks.  
When you preview a compound element, the active effects block is highlighted in red. A user pause 
will blink when it is active. 
 
To open the Compound Element Timeline: 
■ Double-click a compound element in the Project pane. 
 
 
 

2.3 The workspace 
This section introduces you to the Composer workspace and its bars, panes and tabs. 
 
The composer workspace has several bars and panes: 
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A Title bar: shows the broadcast format and name of the project. 
B Menu bar. 
C Tool bar. 
D Objects pane: it lists the objects available in the open project and shows how they are layered. 
E Stage rulers. 
F Stage: You can drag and drop a Library object onto the stage to add it to a template or transition. 
G Project pane: it lists the production elements of a production.  
H History tab: to view actions and to redo or undo them. 
I Template Timeline: you can use this timeline to animate objects in time. It shows each template on a 

separate tab. If you are editing compound elements, this changes into the location of the Compound 
Element Timeline (not shown in the example above). On the Compound Element Timeline each production 
element is shown on a separate tab. 

J Two other tabs are underneath the History tab:  
• Text Styles tab: to view and edit text styles. The Text Styles tab lists and lets you manage Text Styles 

for the open project.  
• Scene Parameters tab: to view and edit scene parameters. 

K Three other panes are stacked under the Project pane:  
• Object pane: to view and edit object properties. 
• Project Assets pane: to view and edit the project assets and metadata. All the design elements of a 

production are visible in this pane. The design elements are included in the Production Pack for GV 
Director. 

• Library pane, which contains the: 
o Prefabs tab. You can add your own objects to the Prefabs tab in the Library. This makes it 

easy to reuse them in another project. 
o Test media tab. To test production elements, test media such as stills and videos can be 

added to the Test Media tab. The test media is not included in a production pack. 
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2.3.1 The Template Timeline 

 

2.3.2 The Compound Element Timeline 

You can use the Compound Element Timeline to edit a compound elements and the production 
elements it contains. 

 

 

2.4 The tools 
 

2.4.1 Rulers 

You can use rulers to fine-tune the position of one or multiple objects. 
 

2.4.2 Gridlines 

Gridlines help you to align objects with other objects, or to put the object on a specific spot on the 
stage.
 

Title bar 

Tabs 
Button 
bar 

Object list 

Pickup 
button 

View 
options 

Zoomer Command 
icon 

Keyframe Scroll bar 

Playerh
ead 

Object 
tracks 
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2.4.3 Alignment guides 

You can use alignment guides to align objects on the stage. 

 

2.4.4 Template rules 

You can use template rules to trigger the start of a template by an event, such as the end of a ticker. 
 

2.4.5 Keyframes 

Keyframes are used to animate objects. With keyframes you can let objects appear, disappear and 
transform in time. A keyframe is a snapshot of the properties of one or multiple objects at a specific 
point in time. The frames between two keyframes are automatically generated by Composer. 
Keyframes cannot be linked to scene parameters. Keyframe can be linked to several objects. 
 
You need at least two keyframes to animate an object, one for the start and one for the end point of 
the animation. Intermediate keyframes can be added. The frames in between two keyframes are 
automatically filled in by Composer. In the Object Pane, the and  icons indicate that a property 
has been keyframed. On the Timeline, the  icon indicates that a keyframe is added for an object on 
a lower layer. The  icon indicates that a keyframe is added. 
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 The Stage track shows all keyframes that are added to the template. 

1, 3, 5 This animation has three keyframes and contains three objects, a cylinder, rounded plane 
and box. Keyframe 3 of the Box is diconnected from the animation and can be moved, copied 
or deleted independently from the cylinder and rounded plane. 

 
The grey color indicates that keyframes are selected. 

2, 4 These keyframes animate one object - the circle pane - and contain the properties of this 
object at these points in time. 

 
& Note: You can also use controllers to animate objects. 

 

IN points 
An IN point defines the moment at which an objects starts audio visual rendering. As a default, the IN 
point for an object is set at 00:00:00. 

OUT points 
 
An OUT point defines the end of the objects audio visual rendering. As a default, no Out Point is set 
for an object. If you wish to remove an object from the screen, set an Out Point.  
 

& Note: If you want a player to automatically stop when an object is no longer visible, you must also 
enable Auto-stop at Out Point. 

 

2.4.6 Controllers  

You can use a controller if you wish to automatically animate an object. It is an alternative to using 
keyframes and is ideal for: 
• animations with loops 
• animations that depend on real-time data. 
Controllers are also described in the Example Project Controllers. 
 
Available controllers are: 
• Anchor 

Use an anchor to keep one or multiple sides of an object or an entire object in a specific position: 
align the left, right, bottom, top, back or front to a anchor point on the X, Y or Z axis. 

• From-To 
Use a FromTo controller to let a property change from one value to another value. This Controller 
is equal to an animation with two keyframes. However, the ‘From’ and ‘To’ values can be linked to 
a scene parameter. You cannot do this with keyframes. 

• Link 
You can use a link controller to link a property of a source object to a property of a target Object. 

• Oscillate 
Use an Oscillate controller to oscillate (in Sinus, Sawtooth, Square or Triangle mode) an object 
property. You can only oscillate one property. This controller is often used for endlessly repeating 
animations. 

• Stack 
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Use a stack controller to tightly stack grouped objects, such as a text group, on the X, Y or Z axis 
and avoid overlap. This Controller can only be used for groups. 

 
You can add a controller to all object properties and you can link a controller value to a scene 
parameter to make the property dynamic. 
 

2.4.7 Scene parameters 

A scene parameter is a variable which value can be set on the GV Director panel. You can link an 
object property to a scene parameter if you want its values to be dynamic or variable. This can be 
useful for objects such as tickers, which dynamic ticker texts (called ticker stories). 
 
 

2.4.8 The ANI Generator 

You can use the ANI Generator to convert a sequence of TARGA files to an animation (ANI file). The 
animation is added to the Project Assets pane and is included in the Production Pack when you export 
the project. You can also add the animation to the Library. 
 
 

2.4.9 View pixel perfect information 

 
An object is pixel perfect when the pixels of the content are not changed in the rendering process. This 
change can happen for many reasons, such as the stretching of an object, texture filtering and/or the 
application of layer effects. The changes are often unwanted, especially in 2D elements such as texts 
and clips. 
 
To view pixel perfect information: 
1. On the Toolbar, click View and select Pixel Perfect Info  
2. Push CTRL+ P or CMD P. 
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3 Get started 
 

3.1 System requirements 
3.1.1 Mac OSX 

• A Mac with a multi-core Intel processor (64 bit). 
• Mac OS X 10.6 (Snow Leopard) or higher. 
• RAM: 4 GB. 
• Video card:  

o VRAM: 768 MB or more.  
o OpenGL 2.1 and the following OpenGL extensions: 

 EXT_framebuffer_multisample 
 EXT_framebuffer_blit 
 ARB_texture_rectangle 
 APPLE_flush_buffer_range 

o We advise not to use Composer with: NVIDIA Quadro cards.  
o Recommended: ATI Radeon HD5670 or higher, NVIDIA Geforce GT320 or higher. 

 
& Note: For more information about the OpenGL support for Mac OS X for and compatible video 

cards, see http://developer.apple.com/graphicsimaging/opengl/capabilities/. 
& Note: For the latest system requirements, see the readme document in the installation package. 

 

3.1.2 Windows 

• An Intel or AMD 64 bit multiprocessor PC.  
• A 64 bit edition of Windows Vista, Windows 7 or Windows 8. 
• RAM: 4 GB. 
• Video card: 

o VRAM: 768 MB or more. 
o OpenGL 2.1 and the following OpenGL extensions: 

 EXT_framebuffer_multisample 
 EXT_framebuffer_blit 
 ARB_texture_rectangle 
 ARB_map_buffer_range 

o Discouraged: NVIDIA Quadro cards.  
o Recommended: NVIDIA Geforce GTS250 or better. 

& [See the readme included with the installation image for most recent requirements.] 

 
You cannot run Composer on a Windows Remote Desktop. 
We advise you not to use NVIDIA Quadro cards  

3.2 Install Composer 
3.2.1 Install Composer on a Mac 

Double-click the Composer image (.dmg file) to mount the disk image.  
The disk image icon appears on the desktop and the next window opens. 
Drag the Composer icon on the Applications folder, to copy Composer to your Applications folder. 
 
You can now launch Composer from the Applications folder. 

http://developer.apple.com/graphicsimaging/opengl/capabilities/
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3.2.2 Install Composer on a Windows PC 

Double-click the installer exe file and follow the instructions. 
 

& Note: It is recommended to run Composer as an Administrators group user. The easiest way to 
achieve this is to mark the application to run as Administrator: in Windows Explorer, access 
'Composer.exe' properties, navigate to 'Compatibility' tab and tick 'Run as Administrator' checkbox. 
Composer does not really require elevated privileges to run, but in doing so a wider range of thread 
scheduling priorities become available thus allowing for faster response times. Note that Composer 
does not create or modify any files unless instructed by the user, i.e. to save a project on disk. To 
that effect it is perfectly safe to run Composer as Administrators group user. 

3.3 Basic actions 
3.3.1 Open Composer 

 
To open Composer: 

1. Double-click the Composer icon ( ). 
2. In the Welcome window, do one of the following: 

a. If you wish to open a recent project, click a 
recent project in the list of recent projects. 

b. If you wish to create a new project, click New 
Project. 

c. If you wish to open an existing project, click 
Open Project. 

d. If you wish to import a project, click Import 
Project. 

e. If you wish to restore a project from a backup, 
click Restore Backup. 

f. If you wish to open a sample project, click 
Browse Example Projects. 

 

 

 

3.3.2 Quit Composer 

To quit Composer, do one of the following: 
■ Click File > Exit. 
■ Click Composer > Quit Composer. 
■ Press CTRL+Q (for Windows) or Press CMD+Q. (for OSX) 
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3.3.3  Navigate the Object pane 

Use the buttons at the top of the Object pane to navigate through it, add objects to the Library and close groups: 

■ Click  to go to the previous selected object. 

■ Click  to go to the next selected object. 

■ Click  to go to the parent object. 

■ Click  to add the object to the Prefabs Library. 

■ Click  to collapse all expanded sections in the Object pane. 

 

3.3.4 Open and edit items 

Open the Object pane  
You can open and edit an object in the Object pane. 
 
To open the Object pane, do one of the following: 
■ On the Stage, click the object that you wish to edit. 
■ In the Objects pane, double-click the object. 
■ On the Template Timeline, double-click the object. 
■ On the Stage, double-click the object. 
 

& Note: If the Object pane is not visible, go to the Toolbar and click View > Windows and enable Object properties. 

 

Open a template or transition 
To open and edit an existing template or transition, do one of the following: 
■ In the Project pane, double-click the template or transition that you wish to open. 
■ Select the tab of the template or transition that you wish to open in the Template Timeline. 
 

Open a layer effect 
To open and edit a layer effect: 

1. In the Object pane, expand the Effect section. 
2. Click > to edit the effect. 

 
A section with the name of the effect appears in the 
Object pane.  

 

 
 

Open a material 
To open and edit a material, do one of the following: 
■ In the Objects pane, click the material that you wish to edit and go to the Object pane. 
■ On the Template Timeline, click the material that you want to edit and go to the Object pane. 
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Open an effect 
To open and edit an effect: 
■ In the Project pane, double-click the effect. 
 
 

3.3.5 Select a keyframe 

To select a keyframe: 
■ Double-click a keyframe.  

 
& Note: Before you can select a keyframe, you must open the Template Timeline. 

3.3.6 Move the player Head 

To move the player to a specific location on the Timeline, do one of the following: 
■ Enter specific values in the mm ss and ff boxes. 
■ Drag the player to the desired location. 
■ Press left or right to nudge 

 

3.3.7 Open the Compound Element Timeline 

To open the Compound Element Timeline: 
■ In the Project pane, double-click a compound element. 

 

3.3.8 Open an existing project 

To open an existing project, do one of the following: 

■ Double-click the Composer icon ( ) and in the Welcome window, click Open Project. 
■ On the Menu bar, click File > Open Project. 
■ On the Menu bar, click File > Open Recent. 
■ On the Menu bar, click File > Import Project and then select from Disk. 
■ On the Menu bar, click File > Open Project and then select from TX/MAM Database. 
■ On the Menu bar, click File > Restore Backup. 
 

3.3.9 Create a new project 

To create a new project, do one of the following: 

■ Double-click the Composer icon ( ) and in the Welcome window, click New Project. In the new window, type a 
project name, click Browse to select a location, click Open and click OK. 

■ On the Menu bar, click File > New Project. In the New Project window, type a project name, click Browse to 
select a location, click Open and click OK. 

 
& Note: The the New Project has three tabs for project properties: 

• The Format tab, which shows the broadcast format, the frame size, frame aspect ratio, FPS  and interlaced 
settings. You cannot edit these. 

• The Info tab, where you enter the author and a description of the project. 
 

3.3.10 Save a project 

To save a project, do one of the following: 
■ On the Menu bar, click Save. 
■ Type CTRL+S (Windows) or  type CMD+S (OSX). 
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3.3.11 Add a production element to a project 

Add a template 
To add a template to a project, do one of the following: 

■ In the Project pane click the  icon. 
■ On the Menu bar, click Project > Add Template. 
 

Add a transition 
To add a transition to a project, do one of the following: 

■ In the Project pane, click the  icon. 
■ On the Menu bar, click Project and select Add a Transition. 
 

& Note: An IPA Mixer is automatically added to the Objects pane.  

 

Add an animated transition 
To add an Animated Transition to a project, do one of the following: 

■ In the Project pane click the  icon. 
■ On the Menu bar, click Project > Add Animated Transition. 
 

Add an effect 
To add a new effect to a project: 

■ In the Project pane, click . 

Add a compound element 
To add a compound element to a project, do one of the following: 

■ In the Project pane, click . 
■ On the Menu bar, click Project > Add Compound Element. 
 

3.3.12 Delete a production element from a project 

Delete a template 
To delete a template from a project, do one of the following: 

■ In the Project pane, click . 
 
 

Delete a transition or animated transition 
To delete a transition or animated transition from a project, do one of the following: 

■ In the Project pane, select the transition or animated transition that you wish to delete and click . 
■ In the Project pane, select the transition or animated transition that you wish to delete and press Delete. 

■ On the Template Timeline, select the transition that you wish to delete and click   
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Delete an effect 
To delete an effect from a project: 
■ In the Project pane, right-click the effect you wish to delete and select Delete. 
 

Delete a compound element 
To delete a compound element from a project, do one of the following: 

■ In the Project pane, select the compound element that you wish to delete and click . 
■ In the Project pane, select the compound element that you wish to delete and press Delete. 
 

3.3.13 Rename a production element 

 
To rename a production element, do one of the following: 
■ In the Project pane, right-click the production element, select Rename and type a new name in the new window. 
■ On the Template Timeline, double-click the applicable template or transition tab and type a new name in the 

new window. 
■ On the Compound Element Timeline, double-click the applicable template tab and type a new name in the new 

window. 
 
 

3.3.14 Duplicate a production element 

 
To duplicate a production element, do one of the following: 
■ In the Project pane, right-click the production element you wish to duplicate and select Duplicate. 

■ On the tool bar of the Template Timeline, click . 

■ On the tool bar or the Compound Element Timeline, click . 
 

& Note: The objects of the original template or transition are not duplicated. Both original and duplicate use the same 
objects. If an object is changed in template or transition A, it is also changed in template B. 

 

3.4 Customize the workspace 
The Composer workspace can easily be customized. This section explains you how to do that. 
 

3.4.1 Customize panes 

Hide or unhide panes 
To hide or unhide panes: 
■ Click View > Windows, and then select or clear the panes that you wish to hide or unhide. 
 

Close a pane 
To close a pane: 

■ In the pane you wish to close, click . 
 

Resize a pane 
To scale or resize a pane: 
1. Click the pane you wish to resize. 
2. Hover over the pane’s border until the cursor changes into  
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3. Drag the border while keeping the mouse pressed. 
 

Move a pane 
To move a pane: 
■ Click the Title bar and keep the mouse pressed while you drag the pane to another location.  
 

& Note: A white dotted line shows where the pane will be put.  

 

Dock or undock a pane 
To dock or undock a pane, do one of the following: 
■ Double-click the pane’s title to dock or undock. 

■ Click  to undock. 
 

3.4.2 Customize the Stage 

Enter or exit Clean View mode 
In Clean View Mode all panes are hidden and only the Stage is visible. 
 
To enter or exit Clean View Mode: 
■ On the Menu bar, click View > Clean View Mode. 
 

Change the size of the Stage 
To change the size of the Stage, do one of the following: 
■ Click Menu > View, select the applicable option (Zoom In, Zoom Out, Zoom to 100% or Fit in Window). 

■ On the Toolbar, use one of the following buttons:   
■ Use the scroll wheel of your mouse to zoom in or out 
 

Add curtains 
You can put objects outside of the Stage. This is useful if you wish let an object move onto or off of the Stage. You 
can use curtains to cover this outside area for a clear view of what the final output is. 
 
To add curtains: 

■ On the Toolbar, click . 
 
 

Hide or unhide rulers 
To hide or unhide rulers: 
■ On the Menu bar, click View and then select Rulers. 

Hide or unhide the grid 
To hide or unhide the grid: 
■ On the Menu bar, click View and then select Grid. 

Hide or unhide alignment guides 
To hide or unhide alignment guides: 
■ On the Menu bar, click View and then select Guides. 
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Add an alignment guide 
To add an alignment guide: 
■ On a ruler, click the location to which you wish to add the alignment guide. 
 

Move an alignment guide 
To move an alignment guide: 
■ Hover over the location of the alignment guide on the ruler, and drag the guide to the new location. 
 

Delete an alignment guide 
To delete an alignment guide: 
■ Double click on the guide in the location grid 
■ In the pop-up window, press delete 

Enable or disable snap to guides 
When you resize or move an object on the Stage, you can let it align or "snap” to the nearest alignment guide. 
 
To enable or disable snap to guides: 
■ On the Menu bar, click View and then select or clear Snap to Guides. 
 

Enable or disable snap to grid 
When you resize or move an object on the Stage, you can let it align or "snap” to the nearest intersection in the grid, 
even if the grid is not visible.  
 
To enable or disable snap to grid: 
■ On the Menu bar, click View and then select or clear Snap to Grid. 
 
 

Change the color of the alignment guides 
 
To change the color of the alignment guides: 
1. On the Menu bar, click File > Preferences, 
2. In the new window, click Guides. 
3. Click the Guide Color box. 
4. In the new window, select a color and click OK. 
5. Click Apply and OK. 
 

Adjust the snap distance 
 
To change the snap distance: 
1. On the Menu bar, click File > Preferences, 
2. In the new window, click Guides. 
3. Enter a number of pixels (px) in the Snap distance box. 
4. Click Apply and OK. 
 

Change the grid color 
 
To change the color of the grid: 
1. On the Menu bar, click File > Preferences, 
2. In the new window, click Grid. 
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3. Click the Grid color box. 
4. In the new window, select a color and click OK. 
5. Click Apply and OK. 
 

3.4.3 Customize the Template Timeline 

Show properties or commands on the timeline 
 To make object properties and/or command tracks visible: 

■ In the left bottom corner of the Template Timeline, click Show and then 
select Object Properties or Command Tracks. 

  

 
& Note: There is a color difference between changing and unchanging keyframe lines. A green line between two 

keyframes indicates that a property changes. When this line is grey, a property does not change.

 

4 Change the preferences 
4.1 Change the NexOS settings 
4.1.1 Change the broadcast format 

 
Composer opens with the broadcast format that was last used and new projects will automatically have this format. 
 
To change the broadcast format of the current project: 

Figure 1. Sample of visible object properties 
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1. On the menu bar, click File (Windows) or 
Composer (Mac). 

2. Select Preferences.  
3. In the new window, click Nexos. 
4. In the Format box, select pal or NTSC. 
5. Click Apply and then OK. 
6. Click Yes to restart. 
7. Open the existing project. 

 
The default buffer size is 1000 mb. We recommend you choose a higher buffer size if a project includes a high 
number of HD players. This will avoid the blocking issues with players.  
 

& Note: A warning appears when you open an existing project that was created in a different broadcast format. The 
change can result in incorrect output and playback speed. 

To change the broadcast format for a new project: 
1. Close Composer. 
2. Click the Composer icon ( ) to open the application. 
3. In the Welcome window, click Preferences and then Nexos.  
4. Select the correct broadcast format from the Format box. 
5. Click OK. 
6. Click Yes to restart. 
7. Add a new project. 
 
 
 
 

4.1.2 Change the image quality  

To adjust the image quality of the Stage: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the new window, click Nexos. 
4. Select the Multi-Sampling Anti Aliasing checkbox. 
5. If necessary, select a higher or lower sample rate.  

 

 
& Note: a higher sample rate can remove blurry or jagged edges of an object, but it can also negatively affect the 

performance of your PC or Mac. 

 

4.1.3 Adjust the multi-sampling anit-aliasing 

To adjust the mulit-sampling aliasing: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences. 
3. In the new window, click Nexos. 
4. Under Players in the Big Buffer Pool Size dropdown box, select the correct size in MB.  
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& Note: The default buffer size is 1 GB. We recommend you to choose a higher buffer size if a project includes a high 
number of HD-players. This will avoid the blocking issues with players.

 

4.1.4 Adjust the texture cache size 

To adjust the texture cache size: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the new window, click Nexos. 
4. In the Texture Cache Size box, select Normal or Large. 

 

 
 

4.1.5 Change the de-interlacing method 

To change the de-interlacing method: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the new window, click Nexos. 
4. In the Deinterlacing Method box, select Weave or First field. 

 

 
& Note: With de-interlacing, half of the field lines are not rendered. The default de-interlacing method is Weave. 

Consecutive fields are added together and all lines are visible. In animations this can result in combing (jagged 
edges). Use First-field to avoid combing. 

 

4.2 Change the file settings 
4.2.1 Change the default project folder 

To change the default project folder: 
1. On the menu bar, click File (Windows) or Composer 

(Mac). 
2. Select Preferences.  
3. In the new window, click File. 
4. In the Default Project Folder box, click Browse. 
5. In the new window, select the folder that you wish to 

use and click OK (windows) or Choose (Mac). 

 

 

4.2.2 Enable / disable Autosave 

To enable or disable Autosave: 
1. On the menu bar, click File (Windows) or Composer 

(Mac). 
2. Select Preferences.  
3. In the new window, click File. 
4. In the Default Project Folder box, select or clear the 

Enable checkbox. 
5. If you select the Enable checkbox, in the Save every 

x minutes box, select the correct number of minutes 
from the dropdown menu. 
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4.3 Change the history settings 
To change the history size: 
1. On the menu bar, click File (Windows) or Composer 

(Mac). 
2. Select Preferences.  
3. In the new window, click History. 
4. Under History Settings, in the Limit to x actions 

box, select the correct number of actions. 
5. Click Apply and then OK. 
 

& Note: A large number of history actions will use more 
memory. 

 
 

4.4 Change the alignment guide settings 
 

4.4.1 Change the color of the alignment guide 

To change the color of guides: 
1. On the menu bar, click File (Windows) or Composer 

(Mac). 
2. Select Preferences.  
3. In the new window, click Guides. 
4. Click the Guide color box. 
5. In the Select Color window, select the color that you 

want to use and click OK. 

 

4.4.2 Change the snap distance of the alignment guide  

To change the snap distance of the guides: 
1. On the menu bar, click File (Windows) or Composer 

(Mac). 
2. Select Preferences. 
3. In the new window, click Guides. 
4. In the Snap distance box, select the number of 

pixels (px) from the dropdown list. 

 

 

4.5 Change the grid settings 
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4.5.1 Change the color of the grid  

To change the grid color: 
1. On the Menu bar, click Composer > Preferences. 
2. In the new window, click Grid. 
3. Click the Grid color box. 
4. In the Select Color window, select the color that you 

want to use and click OK. 

 

4.5.2 Change the horizontal spacing of the grid 

To change the horizontal spacing of the grid: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the new window, click Grid. 
4. In the Horizontal spacing box, select the correct number of pixels (px) from the 

dropdown list.. 

 

4.5.3 Change the vertical spacing of the grid 

To change the vertical spacing of the grid: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the new window, click Grid. 
4. In the Vertical spacing box, select the correct number of pixels (px) from the dropdown list. 

 

4.5.4 Change the snap distance of the grid 

To change the snap distance of the grid: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences. 
3. In the new window, click Grid. 
4. In the Snap distance box, select the number of pixels (px) from the dropdown list. 

 

 

4.6 Change the backup settings 
To change the backup settings of Composer: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the Preferences window, click Backup System. 
4. In the Limit to x backups per project box, select the correct number from the dropdown list. 

 

 

4.7 Change the FTP transfer mode 
To change the FTP transfer mode: 
1. On the menu bar, click File (Windows) or Composer (Mac). 
2. Select Preferences.  
3. In the Preferences window, click Networking. 
4. In the Transfer Mode box, select Active Mode or Passive Mode from the dropdown list. 
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5 Manage a project 
 
This chapter instructs you about all the actions involved in managing a 
project. Learn how to merge a project, import and export projects and 
production elements, restore a project, view a sample project and 
organize project elements. 
 

5.1 Merge a project 
You can merge projects to easily reuse production elements in another a project or substitute the elements in one 
project with elements with the same name in another project. This can be useful when you work with several people 
on the same project.  
 
To merge a project: 
1. Click File > Merge Project. 
2. Select the applicable CCP file and click Open. 
3. In the new window, select Rename conflicting merged-in objects/assets or Replace existing objects/assets 

with merged-in objects/assets. 
4. Click OK. 
 

5.2 Import and export projects and elements 
5.2.1 Import a project 

You can import a project from a production pack on a disk. 
 
To import a project from a production pack on a disk: 

1. Double-click the Composer icon ( ). 
2. In the Welcome window, click Import Project. 
3. Click Browse. 
4. Select the applicable PPK file and click Open. 
5. Click Next. 
6. Click Browse. 
7. Select a destination folder and click Open. 
8. Click Next. 
9. Click Close. 
 

& Note: By default, the imported project is opened after import. You can disable this in the new window after step 8. 

Another way to do this is: 
1. On the Menu bar, click File > Import Project. 
2. In the new window, click Browse. 
3. Select the applicable PPK file and click Open. 
4. Click Next. 
5. Click Browse. 
6. Select a destination folder and click Open. 
7. Click Next. 
8. Click Close. 
 

5.2.2 Export a project 

When you share a project, we recommend that you export a production pack with the project to disk. 
 
To export a project to disk, do one of the following: 
■ Click File > Export Project and then select to Disk. 
■ Click File > Save Project As. 
 
Once the design is ready for live production, the Project you can export a production pack with a project to GV 
Director. 
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To export a project to GV Director: 
1. Click File > Export Project and then select to GV Director. 
2. Click the  icon and then type the IP address of GV Director. 
3. Click Next. 
4. Select a folder. 
5. Click Next to start export. 
6. Click Close. 
 

5.2.3 Import a production pack 

You can import a production pack to import a project. For more information about how to import a production pack, 
see, section 5.2.1, Import a project. 
 

5.2.4 Export a production pack 

You can export a production pack to export a project. For more information about how to export a production pack, 
see, section 5.2.2, Export a project. 
 
 

5.2.5 Import a template 

To import or reuse a template from another project, you must merge a project. 
 
For more information about how to merge a project, see section 5.1, Merge a project. 
 

5.2.6 Export a template 

You can export a template as part of a production pack.  
 
For more information about how to export a production pack, see section 5.2.4, Export a production pack. 
 

5.2.7 Importing assets 

You can either insert an asset by adding them to your Project Assets library or adding them directly to an object. 
 
To import assets into Composer from the Project Assets pane, do the following: 
 
1. Go to the Project Pane. 
2. Go to the Assets tab. 
3. Click on the + button. 
4. Select the asset you would like to import. 
5. Press Open. 
 
To import and asset and add it directly to an object, do the following: 
 
1. Select an object on the stages. 
2. In the Object pane, unfold the first object property group and click on the File bar.  

• In the window that popped up, select the Test Media tab to add an asset as test media.  
3. In the pop-up window, click on the + button. 
4. Select the asset you would like to import.  
 

& You can also choose to add an asset as test media. The selected test media asset will only be visible within 
Composer but will not be used on GV Director. 
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5.2.8 Import a 3DS Studio Max file 

To import a mesh clip in 3DS Studio Max format, do the following: 
1. Click File > Import Project > from Disk. 
2. Click Browse, select the production pack that includes the mesh clip and click Open. 
3. In the 3DS Importer window, do the following: 

a. If you wish to import the mesh clip as a single file, under Import 3DS scene as, select One object. 
b. If you wish to import the separate objects in the mesh clip as separate mesh clips, select Separate objects. 
c. If you wish to import the normals from 3DS Studio Max, select From file. 
d. If you wish to import generate the normals based on a custom angle, select From custom angle. 
e. If you wish to add one or multiple mesh clips to the production pack but not to the Stage, select Only create 

.meshclips. 
f. Click OK. 

 
 
 

5.3 Restore a project 
To restore a project from a backup, do one of the following: 
■ Double-click the Composer icon ( ) and in the Welcome window, click Restore Backup, select the backup you 

wish to restore and click Restore. 
■ On the Menu bar, click File > Restore Backup, close the open project, select the backup you wish to restore and 

click Restore. 
 

5.4 View a example project 
To view various examples of texts and clocks: 

■ Click File > Example Projects. 
 

5.5 Organize project elements 
You can use folders to organize production elements in a project. 
 

5.5.1 Add a production element to a folder 

To add an element to a folder, do one of the following: 
■ Drag and drop a production element into an existing folder. 
■ In the Project pane, right-click a production element and select Add to Folder.  

In this last instance, a new folder is created to which the element is added.  
 

5.5.2 Add an object to the library 

You can add your own objects to the Prefabs tab in the Library. This makes it easy to reuse them in 
another project. 
 
To add an object to Prefabs tab in the Library: 

■ Select the object, and in the Object pane, click the Export icon ( ) 
 
& Note: On the Prefabs tab in the Library, a star on the object icon ( ) indicates that it is a custom made 

object. 
 

5.5.3 Manage text styles 

You can use text styles to easily format text. 

Add a text style 
To add a text style: 
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■ In the Text Styles tab, click . 
 

Delete a text style 
To delete a text style: 

■ In the Text Styles tab, click . 
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6 Work on an object 
 
This chapter explains how you can edit objects in a template or 
transition. 
 

6.1 Copy and paste an object 
To duplicate an object, you must copy and paste it in the Object pane or on the stage: 
1. Right-click the object that you wish to duplicate and select Copy.  
2. Right-click the Object pane or the Stage. 
3. Select Paste. 

 
Another way to copy an object is: 
■ Select the object that you wish to duplicate and use the Copy and Paste shortcuts (CTRL+C and CTRL+V or 

CMD+C and CMD+V). 
  

& Note: When you do this, the object is added to the active template. 

 

6.2 Lock or unlock an object 
■ To lock or unlock an object on the stage do one of the following: 
■ On the template timeline behind the name of an object, click . 
■ In the Objects window, behind the name of an object click  
 

6.3 Work on a group 
6.3.1 Group or ungroup multiple objects 

Objects can be grouped, so you can edit and animate them as a group. 
 
To group objects: 
1. In the Objects pane, Ctrl-click (Windows) or Command-click (Mac) to select the objects you wish to group 
2. On the Menu bar, select Objects > Group or right-click the selection on the Stage and then select Group. 
 
To ungroup objects, do one of the following: 
■ On the menu bar, click Objects > Ungroup. 
■ On the Stage right-click the group and then select Ungroup. 

6.3.2 Edit a group object 

To edit an individual object within a group, do one of the following: 
■ On the menu bar, click Objects > Open Group. 
■ On the Stage right-click the group and select Open Group. 
 

& Note: When you have completed editing, close the group. 

 

6.3.3 Add ground reflections to a group 

 
To add ground reflections to a group of objects: 
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1. On the Stage, click the group. 
a. In the Object pane, under Ground 

Reflection, select Enable. 
 

 
 
 

6.4 Change object handling in 2D or 3D 
You can use this feature to change between the 2D and 3D handles of the object on the Stage. 
To change to 2D mode: 

■ On the Toolbar, click . 
 
To change to 3D mode: 

■ On the Toolbar, click . 
 
To enable the 3D alignment guides for a group: 

■ On the Toolbar, click . 
 
 

6.5 Change the object layer  
The Objects pane lists all objects in a project or template. When you add an object to the Stage, it will have a separate 
layer. Objects on higher layers overlap objects on lower layers.  
 
To change the order in which objects are layered, do one of the following in the Objects pane: 
■ Select an object and drag it to another location on the object list. 

■ Select an object and click the Up and Down arrows (  ). 
 

& You can view objects of other templates by disabeling the filter button 
 

6.6 Change the spatial properties of an object 
You can change the spatial properties of an object (position, scale and/or rotation) in the Transform section in the 
Object pane, or on the Stage.  
 
 

6.6.1 Move an object 

To move an object on the Stage: 
1. Hover over the object. 
2. When the cursor changes into , drag it and drop it on a new location. 

 

The coordinates define the position of the object’s center 
1. In the Object pane, expand Transform. 

2. Under Position, click . 
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The coordinates define the position of the top left object’s center: 
1. In the Object pane, expand Transform. 

2. Under Position, click . 
 

Put an object on a 2D plane 
To put the front of the object on the 2D stage (setting the Z axis coordinate to 0): 
1. In the Object pane, expand Transform. 
2. Under Position, click Place on 2D Plane. 
 

Move an object on the Z-axis (3D) 
To move a 3D object on the Z axis (3D): 

■ Hover over the movement axes of the arrow head ( ). 
  
 
 

& Note: The movement axes can be customized on the tool bar of Composer: 
View: the axes are in line with the current view. 
Group: the axes are in line with the group to which the object belongs. 
Object: the axes are in line with the object. When the object rotates, the axes rotate as well. 

Sample 3D Box with the X, Y and Z axes in line with the object. 

 

6.6.2 Change the size or shape of an object 

You can change the size or shape of an object on stage. 
 
To change the size or shape of an object: 

■ Select the object and drag the handles ( ).  
■ In the Object pane under Transform > Scaling, move the sliders of the X, Y and Z boxes. 
 
For more information, see chapter Quality > Scaling and Pixel Perfect and the sample project Scaling. 
 

& Note: To scale the output of a player instead of the object, edit the Source Scale/Crop property of the object. 
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Change the size of the output of a player 
You can scale the output of a player instead of the object in the Source Scale/Crop section of the Object pane. This 
can be useful when you wish to play out a video on a side of the object, and the video size is smaller than the side of 
the object. You can choose to repeat the video as a tile or to fill the empty space with border pixels of the video. 

To change the size of the output of player: 
1. On the Stage, select the object that you wish to edit. 
2. In the Object pane, do one of the following: 

a. If you wish to scale/crop the source relative to the margins, select 
Margins in the Mode box. 

b. If you wish to scale/crop the source to absolute coordinates on the 
object, select Coordinates. 

3. Adjust the sliders of the X1, X2, Y1 and Y2 boxes to specify margins or 
coordinates in pixels. 

4. If you wish to lock the aspect ratio of the source file, click the double  
button. 

 
 
 

Use the scaling buttons 
You can change the size of an object to completely fit the stage. The original aspect ratio will be changed by this 
action. 

To scale an object to fit the Stage:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click Scale to Fit Screen. 
 
To scale an object to fit the width of the stage:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click W. 
 

& Note: When you perform this action, the aspect ratio is not changed. 
 

To scale an object to fit the height of the stage:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click H. 
 
To scale an object to a 1:1 aspect ratio, based on the object’s height:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click Scale to 1:1. 
 
To scale an object to a 4:3 aspect ratio, based on the object’s height:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click 4:3. 
 
To scale an object to a 16:9 aspect ratio, based on the object’s height:  
1. In the Object pane, expand Transform. 
2. At the bottom of the Transform section, click 16:9. 
 
To make a skewed object straight: 
1. In the Object pane, expand Transform. 
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2. At the bottom of the Transform section, click Straighten. 
 

& Note: When a group is scaled to which the object belongs and the group is then ungrouped, an object can become 
skewed. 

Lock the aspect ratio 
To lock the aspect ratio during scaling: 
1. In the Object pane, expand Transform. 

2. Under Scaling, click .  
Or this can be activated by the button in the main toolbar 

Change the measurement unit  
To measure the size of an object, you can choose between pixels (px) and a percentage (%) of the original size of the 
object. 
 
To change the measurement unit to pixels: 
1. In the Object pane, expand Transform. 

2. Under Scaling, click .  
 
To change the measurement unit to a percentage: 
1. In the Object pane, expand Transform. 
2. Under Scaling, click .  
 

Reset an object to its original size 
To reset an object to its original size: 
1. In the Object pane, expand Transform. 
2. Under Scaling, click .  
 

Counter scale for widescreen mode (16:9) 
You can enable automatic correction for widescreen mode stretching by toggling the Counter-scale checkbox.  
 
To counter-scale an object for widescreen mode: 
1. In the Object pane, expand Transform. 
2. Under Scaling, select the Counter-scale for 16:9 box. 
 

6.6.3 Rotate an object 

By default, the angles that express the rotation of an object are relative to the axes of the group to which the object 
belongs. When an object does not belong to a group of objects, the angle is relative to the axes of the Stage.  
 
The rotation order is XYZ. 
 
There are two ways to rotate an object: 
- Normal rotation 
- Free or arc ball rotation 
 

Normally rotate an object 
To normally rotate an object: 

1. Hover over the object handles until this cursor ( ) appears. 
2. Drag to rotate the object around the Z axis. 
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Freely rotate an object (3D) 
To freely rotate a 3D object: 

1. Hover over the center of the movement axes of the object until this cursor ((  )appears. 
2. Then drag to rotate the object around its X, Y and Z axes. 
 

Enable or disable Euler interpolation 
You can use this feature if you wish to automatically animate the individual rotation angles, such as with the use of a 
controller. 
 
To enable or disable Euler interpolation: 
1. In the Object pane, expand Transform. 
2. Under Rotation, select or clear the Euler Interpolation checkbox.  
 

6.6.4 Add or remove a camera perspective 

You can view the Stage from a perspective that adds depth or from an orthographic view (two dimensional). If you 
choose to add perspective, you need to specify an angle. The default angle is 55 degrees. 
 
To add or remove a camera perspective: 
1. In the Object pane, expand Transform. 
2. Under Camera in the Projection box, select Perspective or Orthographic. 
3. If you have selected Perspective, move the Angle slider to specify the degrees of the angle that you wish to apply.  
 

6.7 Change the image quality of an object 
6.7.1 Enable or disable anti-aliasing 

You can enable the anti-aliasing feature to avoid jagged edges. 
 
To enable or disable anti-aliasing: 
1. Select the object of which you wish to improve the image quality. 
2. In the Object pane under Quality, in the Anti Aliasing box, select No Anti-Aliasing or Edges. 
 

& Note: This setting is costly in terms of performance. We recommend that you make sure that you only enable this 
feature for objects for which anti-aliasing is really needed. To see the effect, multi-sampling must be enabled in File 
> Preferences. 

 

6.7.2 View pixel perfect information 

An object is pixel perfect when the pixels of the content are not changed in the rendering process. This change can 
happen for many reasons, such as the stretching of an object, texture filtering and/or the application of layer effects. 
The changes are often unwanted, especially in 2D elements such as texts and clips. 
 
To view pixel perfect information: 
3. On the Toolbar, click View and select Pixel Perfect Info  
4. Push CTRL+ P or CMD+P. 
 

& Note: The pixel perfect information is visible on the objects. Below is a list of possible messages. 

 
Message Description 
Pixel perfect The object is pixel perfect. 
Material distortion The applied material transforms pixels. 
Not on 2D Plane The plane on which content is visible is not on the 2D 

plane (with z coordinate 0). 
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Shape/size mismatch The plane on which content is visible is bigger or 
smaller than the size of the content. 

Rotated The plane on which content is visible is rotated. 
Sub-pixel coordinates One or multiple edges of an object are on sub-pixel 

coordinates. 
Effect on The object is changed by an effect. 
Texture filtering on Texture filtering is enabled. 
Height is not an even value The interlaced content is displayed on a plane that 

does not have a height that is an even number (in 
pixels). 

 
 

6.7.3 Enable or disable progressive image 

When you are scaling text or a still, you can enable or disable progressive imaging to improve or lower the image 
quality. 
 
To enable or disable progressive imaging: 
1. On the stage, double-click the player and in the 

Object pane, expand the player section.  
2. Select the Progressive Image checkbox. 
 

& This should only be enabled to improve quality if the 
content is scaled or rotated. 

 

 
 

6.7.4 Change the texture quality 

When you are scaling an object you can change the texture quality to improve or lower the image quality. We 
recommend to change the texture quality to High Quality in case of rotated 3D objects. 
 
To change the texture quality: 
1. On the stage, double-click the player and in the 

Object pane, expand the player section.  
2. Select the Progressive Image checkbox. 

 

 
 

6.8 Blend an object 
With the Blending section of the Object pane you can design how at least two layered objects overlap each other. 
These overlaps are called blends. 
 
To blend an object with one or multiple lower layers: 
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1. In the Object pane under Blending, select a blending mode from the Mode 
box. 

2. Move the slider of the Opacity box to set the opacity. 

 
 
 
The following blending modes can be selected: 
• Normal: There is no blending, unless opacity is set. When opacity is set, the object is blended without mixing its 

colors with the background colors. Instead, the object colors are blended based upon the alpha channel of the 
source layer. 

• Lighten: This feature adds the RGB values from the object to the RGB values from the background layer(s). 
• Multiply: This feature multiplies the RGB values from the object with the RGB values from the background 

layer(s). 
• Maximum: This feature blends based on the highest RGB values of the object and the background. 
• Darken: This feature subtracts the RGB values of the object from the RGB values of the background layer(s). 
• Mask: This feature lets a grey-scaled object mask the background layer(s). If opacity is set to 100%, a black 

object completely masks the background layers. If opacity is set to 0% the object is invisible against the 
background. 

 
 

& Note: An object blends with all objects on all layers within a group. The Stage is also a group and therefore the top 
object will blend with all layers including the background. If you want to blend an object with specific objects, put 
these objects in a separate group. 

 
 

6.9 Work on a player 
 

6.9.1 Refresh the preview of a player  

To refresh the  preview of a player: 

■ Click  to refresh. 
 

6.9.2 Show a test feed 

To show make a test feed visible on the Stage: 

■ Click  to make a test feed visible on the Stage. 
 
 

6.9.3 Set a player action 

1. On the Stage, click the object for which you would like to set a player action. 
2. In the Object pane under X Player, click the Action box. 

3. Select the action that you wish to set (No Action , Link to , Start , Stop , Pause , Resume 

). 
 

& Note: The actions Pause and Resume are only available for clips, animations and tickers. 
& Note: The icons above are inserted on the Template Timeline to indicate a player action. 
& Note: By default, player actions start at 00:00:00. To let an action start at another point in time, use a keyframe or 

move the IN point of an object. 
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& Note: To stop a player, you have three options: add an OUT point and enable Auto-Stop at Out Point; create a 
separate template with a player Stop action; add a keyframe with a player Stop action; add the Clear All Command. 
This command stops all players except for the players in the active template. 

 

6.9.4 Change the size of a player 

To change the size of a player: 
1. On the Stage, double-click the player and in the Object pane, expand the player section. 
2. Move the sliders of in the Width and/or Height boxes, or enter the correct number of pixels in these boxes. 
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6.9.5 Player linkage 

Link a player to another player 
You can link a player to another player to avoid playing out the same video clip twice. This is more 
efficient in terms of system performance.  
 
1. On the Stage, click the object for which you would like to set a player action 
2. In the Object pane under XPlayer, click the Action box. 
3. Select the action that you wish to set [the link to} 
 

Playing a file 
To link a file to a player for playout: 
1. On the Stage, click the object for which you would 

like to set a player action. 
2. In the Object pane, under X player, click the 

Action box. 
3. Select the action that you wish to set the link to. 
4. In the Object pane, expand X Player. 
5. Click the File box. 
6. In the Select File window, select the file that you 

wish to use. 
a. If necessary, click the  sign to browse to a 

folder and select the file you wish to add. 
7. Click OK. 
 

 
 

Link a property to a scene parameter 
You can link any property to a scene parameter. Scene parameters are dynamically updated. 
 
To link a property to a scene parameter: 
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1. In the Object pane in the X Player 
section, go to the property to which 
you wish to link a scene parameter. 

2. Click  on the right side of it and 
select Link to Scene Parameter. 

3. Then, do one of the following: 
■ If you wish to add a new 

parameter, select New. 
■ If you wish to link to an existing 

scene parameter, select one 
from the list. 

 
 

& Note: A property linked to a scene parameter is marked by the  and  icons. 

 
 
 
 
 
 

6.9.6 Automate player action properties 

Enable or disable Auto-update for a text object 
You can use the auto-update feature to automatically update a text object such as a clock. You can 
choose if the text is updated every second or every frame. 
 
To enable or disable Auto-update: 
■ In the Object pane under Text Player, select or clear the Auto-update box. 
 

& Note: If you enable Auto-update, in the Resolution box, select Seconds or Frames. 

 

Enable or disable Auto-adjust size to contents 
This feature auto-adjusts the size of a text frame to its content. 
 
To enable or disable Auto-adjust size to contents:  
■ In the Object pane under Text Player, select or clear Auto-adjust size to contents. 
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Enable or disable Auto-stop at OUT point 
You can enable this feature to let the player stop at the OUT point that is added to the Template 
Timeline for this action. You will see this icon   on the timeline. 
 
To enable or disable Auto-stop at OUT point: 
1. Double-click the player and in the Object pane, expand the player section. 
2. Select or clear the Auto-stop at Out Point checkbox. 
 

Enable or disable a clip loop 
To enable or disable a clip loop: 
■ In the Object pane under X Player, select or clear the Loop checkbox. 
 

6.9.7 Preview the output of a player 

To preview the output of a Player: 
■ In the Toolbar, click the Try-out Mode button. 
 

& Note: Player output is only visible in Try-out mode. 

 

6.9.8 Play out a video as object texture 

To play out a video clip on as a texture on an objects, such as a blue box: 
1. In the Objects pane, select the applicable object. 
2. Make sure that the side of the object on which you wish to play the video clip has a Standard 

Textured material. 
3. In the Objects pane, select the Standard Textured material. 
4. In the Object pane under Players, click the Fill box. 
5. Select the Clip Player and click OK. 
 
 

6.9.9 Change audio levels and/or routing 

Mute all audio 
To mute all audio channels: 
1. On the stage, double-click the audio player that you wish to edit. 
2. Under Audio Levels/Routing, select Mute. 
 

& Note: You can also mute all audio if you set the loudness level for all channels to -120 dB. 
 

Set a fade 
To set a linear fade in % (for all audio channels): 
1. On the stage, double-click the audio player that you wish to edit. 
2. Under Audio Levels/Routing, animate the slider of the Fade box. 
 

Add a linear fade for all audio channels 
To add a linear fade for all audio channels: 
■ In the Object pane under Audio Levels/Routing, animate the Fade slider or enter a percentage in 

the box at the right side of the slider. 
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Set the audio output level for all input channels 
To set the audio output  level (in dB)  for all input channel: 
1. On the stage, double-click the audio player that you wish to edit. 
2. Under Audio Levels/Routing, select Set for all input channels. 
3. Move the slider of the All box or enter a number (-1200 to 300) in the box on the right-hand side of 

the slider. 
 
 

Set the audio output level per input channel 
To set the audio output  level (in dB) for all input channel: 
1. On the stage, double-click the audio player that you wish to edit. 
2. Under Audio Levels/Routing, select Set per input channel. 
3. Move the slider of the box with channel 1 or enter a number (-1200 to 300)  in the box on the right-

hand side of the slider. 
4. Repeat step 3 for the next audio channel until you have configured all channels. 
 
 

Route a channel 
You can make sure that a specific input channel is played out on a specific output channel. This is 
called routing. 
 
To route an input channel to a specific output channel: 
1. Go to the column with the number of the input channel that you wish to route. 
2. In that column, select the row number with the same number as the output channel to which you 

wish to route the input channel. 
3. Repeat these steps if you wish to route multiple audio channels. 
 
 
 

Link input channels to output channels 
To link input channels to output channels: 
■ In the Object pane under Audio Levels/Routing >Routing, in the matrix, select the checkbox on the 

row of the output channel that you wish to use for input channel 1-16. 
 

6.9.10 Work on a text 

 

Change the text in a text player 
To change the text of a text player: 
1. On the stage, double-click the text player and in the Object pane, expand the player section. 
2. Click the Text input box and type the text that you wish to see. 
 

Apply a text style to a text 
To apply a text style to a text: 
1. On the Stage, double-click the object to which you wish to apply the text style. 
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2. In the Object pane, expand the player section.  
3. Under Styling, click the Text Style box (…). 
4. In the Pick a Text Style window, select the style that you wish to apply. 
5. Click OK. 
 
 

Change the appearance of a text 
In the Object pane under Custom Style – Font and Custom Style – Alignment, you can customize the 
text of an object. 
 
To change a text style: 
1. In the Text Styles tab, click the selected text style. 
2. In the Object pane, change the text style. 

 

 
 

Change the font 

Change the font size 
To change the font size: 
■ In the Object pane under Custom Style – Font, move the Size slider or in the box next to it, enter a 

size in points. 
 

Change the font 
To change the font: 
1. In the Object pane under Custom Style – Font, click the Font File box. 
2. In the new window, select a font and click OK. 
 

Change the kerning 
To change the kerning: 
■ In the Object pane under Custom Style – Font, move the Kerning slider or in the box next to it, 

enter a kerning as a percentage. 
 
 

Change the line spacing 
To change the line spacing: 
■ In the Object pane under Custom Style – Font, move the Interline slider or in the box next to it, 

enter a line spacing percentage. 
 
 
Change the character width 
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To change the character width: 
■ In the Object pane under Custom Style – Font, move the Char Width slider or in the box next to it, 

enter a percentage. 
 

Change the anti-aliasing 
To change the anti-aliasing: 
■ In the Object pane under Custom Style – Font, click the Anti-alias box and select Light, Medium 

or Normal. 
 
 

Change the alignment 

Change the horizontal alignment mode 
To change the horizontal alignment: 
■ In the Object pane under Custom Style – Alignment, click the H-Mode box and select Normal, Fill 

width, Fill kern, AutoFit or Word Wrap. 
 

& Note: Select Fill width to scale (stretch or squeeze) text horizontally for it to fit the text frame. 
Select Fill kern to apply horizontal kerning to fit the text into the text frame. Select AutoFit to 
squeeze text horizontally to fit it into the text frame. Select Word Wrap to wrap text into the text 
frame. 

 

Change the horizontal alignment 
To change the horizontal alignment: 
■ In the Object pane under Custom Style – Alignment, click the H-Align box and select Left, Center 

or Right. 
 

Change the vertical alignment 
To change the horizontal alignment: 
■ In the Object pane under Custom Style – Alignment, click the V-Align box and select Top, Center 

or Bottom. 
 

Change the font style 

Change the font color 
To change the font color: 
1. In the Object pane under Custom Style – Styling, click the Face Color box. 
2. In the new window, select the color that you wish to apply and click OK. 
 

Change the font opacity 
To change the font opacity: 
■ In the Object pane under Custom Style – Styling, move the Opacity slider. 
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Change the font border 

Change the color of a font border 

To change the color of a text box border: 
1. In the Object pane under Custom Style – Styling > Border, click the Color box. 
2. In the new window, select the color that you wish to apply and click OK. 
 

Change the font border opacity 

To change the border opacity: 
■ In the Object pane under Custom Style – Styling > Border, move the Opacity slider. 
 

Change the font border size 

To change the border size: 
■ In the Object pane under Custom Style – Styling > Border, move the Size slider to set the size in 

pixels. 
 

Change the blur kernel size of the font border  

To change the blur kernel size of the font border: 
■ In the Object pane under Custom Style – Styling > Border, move the Blur slider to set the blur 

kernel size in pixels. 
 

Change the font shadow 

Change the font shadow color 

To change the font shadow color: 
1. In the Object pane under Custom Style – Styling > Drop, click the Color box. 
2. In the new window, select the color that you wish to apply and click OK. 
 

Change the font shadow opacity 

To change the font shadow opacity: 
■ In the Object pane under Custom Style – Styling > Drop, move the Opacity slider. 
 

Change the font shadow size 

To change the font shadow size: 
■ In the Object pane under Custom Style – Styling > Drop, move the Size slider to set the size in 

pixels. 
 

Change the blur kernel size of the font shadow 

To change the blur kernel size of the font shadow: 
■ In the Object pane under Custom Style – Styling > Drop, move the Blur slider to set the blur 

kernel size in pixels. 
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Format a text or clock with strings 
 

Strings to format text 
Use special strings to format texts. There are special strings for text formatting, counters and time.  
 

& Note: All special strings are case-sensitive. 

 

String to change the character set 
■ In the Text Player in the Object pane, type $3xxxx in the text input box, in front of the text to 

which you wish to apply a different character set. 
 

& Note: xxxx stands for the character set of your choice.  
1250 = Central European 
1251 = Cyrillic 
1252 = Latin I 
1253 = Greek 
1254 = Turkish 
1255 = Hebrew 
1256 = Arabic 
1257 = Baltic 
1258 = Vietnamese 

 

String to change the font size 
■ In the Text Player in the Object pane, type $7xxx in the text input box, in front of the text to which 

you wish to apply the change. 
 

& Note: xxx must be a value between 005 and 150.  
& Note: Trailing space 

 

String to change the foreground color 
■ In the Text Player in the Object pane, type $1AABBGGRR in the text input box, in front of the text to 

which you wish to apply the change. 
 

& Note: AABBGGRR must be a hexadecimal color code. 
& Note: Trailing space 

 

String to add an indent 
■ In the Text Player in the Object pane, type $9xxx  in the text input box. 
 

& Note: xxx represents the horizontal offset in pixels and must be a value between 0 and 999. 



 

GV Director Composer 1.8.0 - 57 

& Note: Trailing space 

 

String to show the decimal code of a special character 
■ In the Text Player in the Object pane, type $4xxx in the text input box, in front of the special 

character to which you wish to apply the change. 
 

& Note: xxx represents the decimal code of a character in the normal font mapping table and must be 
a value between 0 and 999. 

& Note: Trailing space 
 

String for Unicode characters 
■ In the Text Player in the Object pane, type $5xxxx in the text input box. 
 

& Note: xxx represents the hexadecimal code of a character. 
& Note: Trailing space 
 

String for glyph code characters 
 
When you wish to use special characters that are not in the normal character map. 
 
■ In the Text Player in the Object pane, type $6xxxx in the text input box. 

 
& Note: xxx represents the hexadecimal code of a character. 
& Note: Trailing space 
 

String for a return 
■ In the Text Player in the Object pane, type $0 in the text input box. 
 

& Note: Trailing space 

 
 

String to add a tab 
To add a tab: 
■ In the Text Player in the Object pane, type $2xxx in the text input box. 
 

& Note: xxx represents the horizontal offset pixels and must be a value between 0 and 999. 
& Note: Trailing space 

 
 

String to add a vertical offset 
To add a vertical offset: 
■ In the Text Player in the Object pane, type $8xxxx in the text input box. 
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Strings to edit a clock 
You can use special strings to change the type of clock. 
 

& Note: All strings are case-sensitive. 

 

Up counter 
If you wish to change the clock into an up counter: 
■ In the Text Player in the Object pane, type $D in the text 

input box. 
 

 
 

Down counter 
If you wish to change the clock in to a down counter: 
■ In the Text Player in the Object pane, type $C in the text input box. 
 

& Note: If the duration is less than 60 seconds, the clock format is “:ss”. If the duration is longer than 
60 seconds, the format is "m:ss". 

 
If you wish to view the sample project Clocks and Counters: 
■ Click File > Example Projects. 
 
How to define a counter 

Other clock types 
Use special strings to set another, very specific type of clock. 
 
To do this: 
■ In the Text Player in the Object pane, type one of the strings below in the text input box. 
 
String Description 

$CD<C-syntax> Shows a clock in seconds that you can format. 
Note: <C-syntax> stands for a C language printf() style integer format string. 
Example: “$CD%3d”.  

$CM Shows a down-counting clock in minutes. 

$CS Shows a down-counting clock in seconds, always in ss format, from 00 to 59. 
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$CX<C-syntax> Shows a down-counting clock in seconds that you can format.  
Note: <C-syntax> stands for a C language printf() style integer format string. 
Example: "$CXsec: %03d". 

$CT Shows a down-counting clock. 
Note: If the duration is longer than 1 hour, the clock format is “hh:mm”. If the 
duration is longer than 1 minute, the format is " mm:ss". If the duration is less 
than one minute, the format is “:ss”. 

'$CF<C-syntax> Shows a down-counting clock, with two arguments (h, m).  
Note: You must type a C language printf() style integer format string behind the 
F. 
Example: $CFtime: %02d.%02d results in: time: 09.34 
Example: $CF%d:%02d results in: 9:34 

$CG<C-syntax> Shows a down-counting clock with two arguments (m, s). 
Note: You must type a C language printf() style integer format string behind the 
G. 
Example: $CGmin and sec: %02d.%02d results in: min and sec: 34.56 

$CV<C-syntax> Shows a down-counting clock with three arguments: h, m, s.  
Note: You must specify a C language printf() style integer format string behind 
the V. 
Example: $CVtime: %02d.%02d.%02d results in: time: 09.34.56 

$CW<C-syntax> Shows a down-counting clock with four arguments: days, h, m, s.  
Note: You must specify a C language printf() style integer format string behind 
the W. 
Example: $CW%d days %02d:%02d:%02d result in 2 days 23:57:26. 

$D Shows a clock in format ":ss" if the duration is < 60 secs, and "m:ss" if the 
duration is > 60 seconds. 

$DD<C-syntax> Shows a clock in seconds that you can format.  
Note: You must specify a C language printf() style integer format string behind 
the D. 
Example: $DD%3d. 

$DM Shows a clock in minutes. 

$DS Shows a clock in seconds (ss). 

$DX<C-syntax> Shows a clock in seconds that you can format. 
Note: Specify a C language printf() style integer format string behind the X. 
Example: $DXsec: %03d. 

$DT Shows a clock in hh:mm if duration is >1 hour, in mm:ss if duration is >1 minute 
and in :ss if duration is < 1 minute. 

$DF<C-syntax> Shows a clock with two arguments (h, m). 
Note: You must specify a C language printf() style integer format string behind 
the F. 
Example: $DFtime: %02d.%02d results in time: 09.34 
Example: $DF%d:%02d results in 9:34. 

$DG<C-syntax> Shows a clock with two arguments (m, s).  
Note: You must specify a C language printf() style integer format string behind 
the G. 
Example: $DGmin and sec: %02d.%02d results in min and sec: 34.56. 

$DV<C-syntax> Shows a clock with three arguments (h, m, s).  
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Note: You must specify a C language printf() style integer format string behind the 
V. 
Example: $DVtime: %02d.%02d.%02d results in time: 09.34.56. 

$DW<C-syntax> Shows a clock with three arguments (h, m, s).  
Note: You must specify a C language printf() style integer format string behind 
the V. 
Example: $DVtime: %02d.%02d.%02d results in time: 09.34.56. 

String 
$T Shows the time in h:mm (%2d:%02d). 
$Th Shows hours only. 
$Th0 Shows hours only, always 2 digits. 
$Tm Shows minutes only. 
$Tm0 Shows minutes only, always 2 digits. 
$Ts Shows seconds only.  
$Ts0 Shows seconds only, always 2 digits.   
$TS Shows time in h:mm:ss (%2d:%02d:%02d). 
$TZ Show seconds only, always 2 digits.   
$TQ Shows time in h:mm:ss (%2d:%02d:%02d). 
 
 
 
Time offset strings 
'$TO' Time with offset defined in minutes, displayed in minutes. 

Example: '$TO-3' 

'$TM' 

Time with offset defined in seconds, displayed in minutes. 
 
Example: '$TM-180' 
Example: 'it is $TM10' 

'$TN' Time with offset defined in minutes, displayed in seconds. 
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6.9.11 Work on a ticker 

Add a ticker story to a ticker 
If you want to add static text to a ticker, you must add one or multiple ticker stories to a ticker.  
 
To add a ticker story to a ticker: 
1. In the Library pane on the Prefabs tab, select Commands. 
2. Select Add Ticker Story and drag it onto the Template Timeline. 
3. Double-click the Add Ticker Story icon on the timeline. 
4. In the Object pane under Add Ticker Story Command, click the 

Player box (…). 
5. In the Pick a Ticker Player window, select the correct ticker player. 
6. If you are adding multiple ticker stories, move the slider of the 

Number box to give the story a number that corresponds with the 
order of appearance (0 is the first story to appear). 

7.  Click the Text box and type the text that you wish to be visible. 
8. If you wish to apply a text style available to all players, select Text 

Style under Text Styling.  
9. If you wish to apply a style that only available for the player in 

question, select Custom under Text Styling. 

 

 

Set the ticker speed 
To set the speed with which the text of the ticker moves: 
1. On the stage, double-click the ticker.  
2. In the Object pane, expand Ticker Player. 
3. Move the slider of the Speed box. 
 

& Note: The unit of measurement is 0.1 pixel per field (interlaced mode) or frame (progressive mode). 
 

Enable or disable a ticker story loop 
You can choose to play the ticker stories in a loop. To do this: 
1. On the stage, double-click the ticker.  
2. In the Object pane, expand Ticker Player. 
3. Select or clear the Repeat checkbox. 
 

Add a still or animation to a ticker 
You can choose to add a still or animation to a ticker. To do this: 
1. On the stage, double-click the ticker.  
2. In the Object pane, expand Graphic Players. 
3. Click the + button. 
4. In the Add Object pane, click the type of graphic that you wish to add. 
5. Click OK.  
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6.10 Work on a command 
 

6.10.1 Add a command to a template 

To add a command to a template: 
1. In the Library pane on the Prefabs pane, click Command. 
2. Select the command that you wish to use, drag it onto the Template Timeline, under all existing 

tracks. 
 

& Note: A separate command track is automatically created with the command icon on it. As long as 
there is a command track present, you can click the   icon to manually add a command track. 

 

6.10.2 Move a command 

To move a command on the Template Timeline: 
 
■ Drag and drop the command.  

 

6.10.3 Copy a command  

To copy a command to the clipboard: 

■ Click .   

 

6.10.4 Paste a command  

To paste a command to the clipboard: 
■ Click .   
 
 
 

6.10.5 Edit an AFD command 

Enable or disable AFD in the playout signal: 
1. On the Template Timeline, double-click the AFD command. 
2. In the Object pane, click the Mode box and select Enable or Disable. 
 

Change the VBI line number 
To change the VBI line number to which the AFD is added: 
1. On the Template Timeline, double-click the AFD command. 
2. In the Object pane, move the Line slider. 
 

Change the aspect ratio 
To change the aspect ratio of the coded frame: 
1. On the Template Timeline, double-click the AFD command. 
2. In the Object pane, click the Aspect Ratio box and select 4:3 or 16:9. 
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Change the AFD code 
To change the AFD code 
1. On the Template Timeline, double-click the AFD command. 
2. In the Object pane, click the AFD Code box and select the applicable option. See illustration. 
 

 
 
 
 
 
 
  



 

GV Director Composer 1.8.0 - 64 

6.10.6 Edit a ticker story command 

 

Change the ticker player 
To change the ticker player: 
1. On the Template Timeline, double-click the ticker story command. 
2. In the Object pane, click the Player box, select the player and click OK. 
 

Change the story number 
To change the story number of a ticker command: 
1. On the Template Timeline, double-click the ticker story command. 
2. In the Object pane, move the Number slider. 
 

Change the text of a ticker story 
To change the text of a ticker story: 
1. On the Template Timeline, double-click the ticker story command. 
2. In the Object pane, move the Number slider. 
 

Change the text style of a ticker story 
To change the text style of a ticker story: 
1. On the Template Timeline, double-click the ticker story command. 
2. In the Object pane under Text Styling, do one of the following: 

a. If you wish to apply a pre-defined text style, select Text Style, click the … box next to it, select 
the text style that you wish to apply and click OK. 

b. If you wish to apply a custom text style, select Custom and proceed to change the Font, 
Alignment and Styling properties.  

 

Change the story graphics 
You can include stills or animations in your stories. You can either select a TGA-graphic or ANI-
animation to add to a ticker story (or link to a scene parameter). 
 
To change the story graphics: 
1. On the Template Timeline, double-click the Add Ticker Story command. 
2. In the Object pane, click the Still or Ani box (make sure a player is selected, otherwise Still or Ani 

box cannot be selected). 
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6.10.7 Edit a Counter command  

You can use a counter command to stop, start or set a counter. 
 

Add a counter command 
To add a counter command: 
1. Drag a Counter Command onto the 

Template Timeline. 
2. Double-click the command ( ). 
3. In the Object Pane under Counter Command, 

click the Player box to select the clock to 
which you wish to add the command. 

4. In the Sub Command dropdown box, select 
the correct sub-command (Start, Stop or Set 
Counter).  

 
 

Start a clock 
To start a clock, follow the steps in section 0, Add a counter command. 
 

Stop a clock 
To stop a clock, follow the steps in section 0, Add a counter command. 
 

Set the start time of a clock 
 
To set the initial clock time: 
1. Drag a Counter Command onto the 

Template Timeline. 
2. Double-click the command ( ). 
3. In the Object Pane under Counter Command, 

click the Player box to select the clock for 
which you wish to set the initial time. 

4. In the Sub Command dropdown box, select 
Set Counter. 

5. In the input box at the right side of the Value 
slider, enter the correct value in seconds. 
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6.10.8 Edit a GPIO command 

You can use the GPIO command to configure one of the GPIO pins of a device. 
 

Disable a GPIO pin 
To disable a GPIO pin: 

1. On the Template Timeline, double-click the GPIO command ( ). 
2. In the Object pane, click the Device box. 

a. If you wish to disable a GPIO pin of the internal GPIO device available in the DB9 socket at 
the back of the machine, select DB9M. 

b. If you wish to disable a virtual GPIO pins of a GPIO-over-VBI device, select VBI. 
c. If you wish to disable a GPIO pin of a 410E device, select 410E. 

3. Click the Value box and select 0. 
 

Enable a GPIO pin 
To enable a GPIO pin: 

1. On the Template Timeline, double-click the GPIO command ( ). 
2. In the Object pane, click the Device box. 

d. If you wish to enable a GPIO pin of the internal GPIO device available in the DB9 socket at the 
back of the machine, select DB9M. 

e. If you wish to enable a virtual GPIO pins of a GPIO-over-VBI device, select VBI. 
f. If you wish to enable a GPIO pin of a 410E device, select 410E. 

3. Click the Value box and select 1. 
 

6.10.9 Edit a Rating command 

You can use the rating command to add rating data to the playout signal. 
 
To add rating data to the playout signal: 

1. On the Template Timeline, double-click the GPIO command ( ). 
2. In the Object pane, click the System box and select the rating system that you wish to use. 
3. Click the Value box and type the correct value. 
 
 
 

& Note: For an overview of the available rating systems, see section 0, Rating systems overview. For 
more information about the available rating values, see section 0, Rating values for US Parental 
Guideline Ratings. 

Rating systems overview 
The following rating systems are supported: 
Value  Description  

MPA  MPA  

U.S.TV PG U.S. TV Parental Guideline system  

Canadian English Canadian English Language Rating  

Canadian French Canadian French Language Rating  
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Rating values for US Parental Guideline Ratings 
The following table shows the rating values of US Parental Guideline ratings and what they mean: 
Rating value  Description  

TV-Y  All children.  

TV-Y7  
TV-Y7,FV  

Children aged 7 and above  

TV-G  General audience.  

TV-PG  
TV-PG,D  
TV-PG,D,L  
TV-PG,D,L,S  
TV-PG,D,L,S,V  
TV-PG,D,L,V  
TV-PG,D,S  
TV-PG,D,S,V  
TV-PG,D,V  
TV-PG,L  
TV-PG,L,S  
TV-PG,L,S,V  
TV-PG,L,V  
TV-PG,S  
TV-PG,S,V  
TV-PG,V  

Parental guidance suggested.  

TV-14  
TV-14,D  
TV-14,D,L  
TV-14,D,L,S  
TV-14,D,L,S,V  
TV-14,D,L,V  
TV-14,D,S  
TV-14,D,S,V  
TV-14,D,V  
TV-14,L  
TV-14,L,S  
TV-14,L,S,V  
TV-14,L,V  
TV-14,S  
TV-14,S,V  
TV-14,V  

Parents strongly cautioned.  

TV-MA  
TV-MA,L  
TV-MA,L,S  
TV-MA,L,S,V  
TV-MA,L,V  
TV-MA,S  
TV-MA,S,V  
TV-MA,V  

Mature audience only.  
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None  No blocking intended.  
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6.10.10 Edit a Main Player command 

This command is automatically added to the Template Timeline when you add a first clip or live player 
to a template. The main player has priority over other players on the stage. 
 
To change the main player of a template: 

1. On the Template Timeline, double-click the Main Player command ( ). 
2. In the Object pane, click the Player box, select the correct player from the list and click OK. 
 
 

& Note: Only Closed Caption subtitles that are embedded in stream of the main player become part 
of the output.  

& Note: The main player is also the source for the ATC (HD) or VITC (SD) timecode signal in the SDI 
output. 

 

6.10.11 Edit a Ticker command 

You can use a ticker command to clear, pause or unpause a ticker story. 
 
 

Clear a ticker story 
To clear a ticker story: 

1. On the Template Timeline, double-click the Ticker command ( ). 
2. In the Object pane, click the Player box, select the correct ticker player from the list and click OK. 
3. In the Command box, select Clear. 
 

Pause a ticker story 
To pause a ticker story: 

1. On the Template Timeline, double-click the Ticker command ( ). 
2. In the Object pane, click the Player box, select the correct ticker player from the list and click OK. 
3. In the Command box, select Story Pause. 
 

Unpause a ticker story 
To unpause a ticker story: 

1. On the Template Timeline, double-click the Ticker command ( ). 
2. In the Object pane, click the Player box, select the correct ticker player from the list and click OK. 
3. In the Command box, select Story Unpause. 
 
 
 

6.10.12 Edit a Video Index command 

You can use the Video Index command to blank certain VBI lines, or to write video index data onto VBI 
lines. 
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Change the VBI line for VI data 
To change the VBI line for VI data: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, move the Line slider. 
 

Change the scanning system 
To change the scanning system: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, click the Scanning box and select the system that you wish to use (No 

information, 525/59.94/4x3, 625/50/4x3, 525/59.94/16x9 or 625/50/16x9). 
 
 

Change the active format description 
To change the active format description: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, click the AFD box and select the system that you wish to use (Reserved, Box 

16:9 (top), Box 14:9 (top), Box > 16:9 (center), Active format is same as coded frame, 4:3 
(center), 16:9 (center), 14:9 (center), 4:3 (protect 14:9 center), 16:9 (protect 14:9 center) or 
16:9 (protect 4:3 center)). 

 

Change the signal form 
To change the signal form: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, click the Signal Form box and select the signal form that you wish to use (No 

information, RGB, YCbCr, YUV, Monochrome, NTSC, PAL, PAL-M, SECAM). 
 

Change the sample structure 
To change the sample structure: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, click the Sampling box and select the sample structure that you wish to use 

(No information, 4:2;2, 4:2:2 progr., main or 4:2:2 progr., sub). 
 

Change the pan 
You can change the location of the left edge of the viewport relative to the center of the source image. 
 
To change the pan: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, move the Pan slider and select the applicable number of source pixels. 
 

Change the tilt 
You can change the location of the top edge of the viewport relative to the center of the source image. 
 
To change the tilt: 
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1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, move the Tilt slider and select the applicable number of source pixels. 
 

Change the zoom 
You can change the height of the viewport. 
 
To change the zoom: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, move the Zoom slider and select the applicable number of lines. 
 

Change the X and Y flags 
You can change the X and Y flags that a receiving device uses to calculate the width of the viewport. 
 
To change the X and Y flags: 

1. On the Template Timeline, double-click the Video Index command ( ). 
2. In the Object pane, click the XY Flags box and select Normal operation, Height = Zoom or 

Width = Zoom. 
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6.11 Work with materials 
 

6.11.1 Replace a material 

Some objects in Composer come with materials, such as a box, cylinder, plane and sphere. You can 
replace the materials of these objects in Composer. 
 
To replace a material of an object: 
1. On the stage, select the object of which you wish to replace the material. 
2. In the Object pane, expand Materials.  
3. Right-click the material that you wish to replace. 
4. Select Replace. 
 

6.11.2 Change the lighting of a material 

Change the shadow color of an object 
1. In the Objects pane, click the material that 

you wish to edit. 
2. Expand Lighting. 
3. Under Ambient Color, move the RGB 

sliders. 

 

 

Change the color of lighted parts of the object 
You can change the color of the object when it is lighted. 
 
To change the color of lighted parts of the object: 
1. In the Objects pane, click the material that you wish to edit. 
2. Expand Lighting. 
3. Under Diffuse Color, move the RGB sliders. 

 

 

Change the specular color 
To change the color of specular reflections (highlights): 
1. In the Objects pane, click the material that 

you wish to edit. 
2. Expand Lighting. 
3. Under Specular Color, move the RGB 

sliders. 

 

 

Change the specular color power 
To change the specular color power 
1. In the Objects pane, click the material that you wish to edit. 
2. Expand Lighting. 
3. Under Specular Color, move the Power slider. 
 

Change the alpha channel 
To change the alpha channel: 
1. In the Objects pane, click the material that you wish to edit. 
2. Expand Lighting. 



 

GV Director Composer 1.8.0 - 73 

3. Move the Alpha slider. 
 

6.11.3 Change the image quality of a material 

To change the image quality of a material: 
1. In the Objects pane or on the Template Timeline, click the material. 
2. In the Object pane in the Miscellaneous section, in the Quality box, select Low, Medium, High 

or Best. 
 

6.11.4 Change the cull property 

Culling reduces the render time by filtering out all  polygons that are not visible (on the screen). You 
can use the cull feature to specify which part of the object is not rendered. The available 
choices are: 
• Front facing:  The exterior of the polygons (to which the matiral is applied) is rendered 

Back facing:  Theinterior is rendered. 
To change the cull of a 3D object: 
1. In the Objects pane or on the Template Timeline, click the material. 
2. In the Object pane in the Miscellaneous section, in the Cull box, select Front Facing, Back 

Facing or None. 
 

6.11.5 Change the fill mode 

To specify the rasterization mode for front facing polygons: 
1. In the Objects pane or on the Template Timeline, click the material. 
2. In the Object pane in the Miscellaneous section, in the Fill Mode box, select Point, Wireframe or 

Solid. 
 

6.11.6 Enable or disable depth occlusion 

To enable or disable depth occlusion: 
1. In the Objects pane or on the Template Timeline, click the material. 
2. In the Object pane in the Miscellaneous section, select or clear the Depth Occlusion box. 
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6.12 Work with layer effects 
You can add a layer effect such as Bevel or Drop Shadow to objects.  
 
 

6.12.1 Add and delete a layer effect 

Add a layer effect 
To add a layer effect: 

1. In the Object pane, expand the Effect section. 
2. Click the Effect box (…). 
3. In the new window, select the effect that you wish 

to apply. 
4. Click OK. 
5. Move the slider of the Wet/Dry box to set the 

intensity of the effect. 
 

 

Delete a layer effect 
■ Click the Delete object button. 

 
 

6.12.2 Set the intensity of a layer effect 

To set the intensity with which a visual effect is applied, do one of the following: 
■ Move the slider of the Wet/Dry box. 
■ Double-click 100 in the % box to enter the 

intensity of the visual effect (0-100). 
  

 

6.12.3 Edit a ripple effect 

Set the center of a ripple 
To set the center of a ripple effect  
■ In the Objects pane or on the Template Timeline, select the ripple effect and move the sliders of 

the X and Y axes. 
 

Set the wavelength of a ripple 
To set the wavelength of the ripples: 
■ In the Objects pane or on the Template Timeline, select the ripple effect and move the 

Wavelength slider. 
 

& Note: The wavelength unit is pixels. 
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Change the ripple amplitude (ripple height) 
To set the ripple amplitude (ripple height): 
■ In the Objects pane or on the Template Timeline, select the ripple effect and move the Amplitude 

slider. 
 

Change the starting point of ripple cycle 
To set the starting point of ripple cycle: 
■ In the Objects pane or on the Template Timeline, select the ripple effect and move the Phase 

slider. 
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6.12.4 Edit a blur effect 

Change the width of a blur 
 
■ In the Objects pane or on the Template Timeline, select the blur effect and in the Object pane, 

move the X slider. 
 

Change the height of a blur 
To set the height of the blur: 
■ In the Objects pane or on the Template Timeline, select the blur effect and in the Object pane, 

move the Y slider. 
 

& Note: The unit of measurement is pixels. 

 

Change the image quality of a blur 
To set the image quality of the blur: 
1. In the Objects pane or on the Template Timeline, select the blur effect. 
2. In the Object pane, click the Quality box. 
3. Select Low, Medium or High. 

. 
 

Downsample a blur 
With the downsample feature you can make a blur even blurrier. 
 
To downsample a blur: 
1. In the Objects pane or on the Template Timeline, select the blur effect. 
2. In the Object pane, click the Downsample box. 
3. Select None, 4x or 16x. 
 

Put the blurred object over the original 
To put the blurred object over the original:  
1. In the Objects pane or on the Template Timeline, select the blur effect. 
2. In the Object pane, select the Overlay on original checkbox. 
3. Move the Opacity slider to set the opacity of the overlay. 
 

Enable Luma blur 
With Luma blur you can play out a blur in which every pixel has a luminance value above a certain 
threshold. 
 
To enable Luma blur: 
1. In the Objects pane or on the Template Timeline, select the blur effect. 
2. In the Object pane, select the Luma blur checkbox. 
3. Move the Luma Thres. slider to set the luminance threshold. 
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6.12.5 Edit a bevel or emboss effect 

Select a bevel mode 
To select a bevel mode: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, click the Mode box and select Bevel, Emboss or Emboss Overlay. 
 

& Note: The Emboss Overlay effect produces an emboss output and overlays the original object. 

 

Set the contrast of a bevel or emboss effect 
To set the contrast of a bevel or emboss effect: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, move the Contrast slider or enter a percentage in the box at the right. 
 

Change the lighting angle in a bevel or emboss effect 
To set the lighting angle in a bevel or emboss effect: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, move the Angle slider or enter a number of degrees in the box at the right. 
 

Set the size of a bevel or emboss effect 
To set the size of a bevel or emboss effect: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, move the Size slider or enter a number of degrees in the box at the right. 
 

Change the color of a bevel or emboss effect 
To change the color of a bevel or emboss effect: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, click the Color box, move the RGB sliders or enter a RGB values in the boxes 

at the right. 
 

Change the opacity of a bevel or emboss effect 
To change the opacity of a bevel or emboss effect: 
1. In the Objects pane or on the Template Timeline, click the bevel effect. 
2. In the Object pane, move the Opacity slider or enter a percentage in the box at the right. 
 
 

6.12.6 Edit a chroma key effect 

Set a chroma key color 
To set a chroma key color: 
1. In the Objects pane or on the Template Timeline, click the Chroma Keying effect. 
2. In the Object pane in the Key Color box, select Green or Blue. 
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Edit the edge between a keyed and unkeyed area 
To edit the edge between a keyed and unkeyed area: 
1. In the Objects pane or on the Template Timeline, click the Chroma Keying effect. 
2. In the Object pane under Edge, move the Offset and/or Smoothness slider. 
 

Suppress the spilling of a chroma key to the foreground 
To suppress the spilling of a chroma key to the foreground: 
1. In the Objects pane or on the Template Timeline, click the Chroma Keying effect. 
2. In the Object pane, move the Spill Suppress slider or enter a percentage to set the extent to 

which the spilling is suppressed. 
 

Light wrap an unkeyed area 
To wrap an unkeyed area with colors and light from the keyed area: 
1. In the Objects pane or on the Template Timeline, click the Chroma Keying effect. 
2. In the Object pane, move the Light Wrap slider or enter a percentage to set the extent of the light 

wrap. 
 
 
 

6.12.7 Edit a pixelate effect 

Change the pixel size of the pixelate effect 
To change the pixel size of the pixelate effect: 
1. In the Objects pane or on the Template Timeline, click the Pixelate effect. 
2. In the Object pane, move the Pixel Size slider or enter a number of pixels in the box at the right. 
 
 
 
 

6.12.8 Edit a drop shadow effect 

Change the blur of a drop shadow 
To change the blur of a drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane under Blur, move the X and/or Y sliders or enter a number of pixels in the box 

at the right to specify the radius of the blur on the drop shadow. 
 

Change the image quality of the drop shadow 
To change the image quality of the drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane in the Quality box, select Low, Medium or High. 
 

Downsample a drop shadow 
With the downsample feature you can make the shadow blur even blurrier. 
 
To downsample a shadow: 
1. In the Objects pane or on the Template Timeline, select the Drop Shadow or Glow effect. 
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2. In the Object pane, click the Downsample box. 
3. Select None, 4x or 16x. 
 

Change the angle of a drop shadow 
To change the angle a drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane, move the Angle slider or enter a number of degrees in the box at the right. 
 

Change the drop shadow size 
To change the drop shadow size (make it smaller compared to the original shadow): 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane, move the Scaling slider or enter a percentage in the box at the right. 
 
Change the distance of a drop shadow 
To change the distance of a drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane, move the Distance slider or enter a number of pixels (px) in the box at the 

right. 
 
 

Change the drop shadow color 
To change the drop shadow color: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane in the Color box, click the Color box, move the RGB sliders or enter a RGB 

values in the boxes at the right. 
 

Change the opacity of a drop shadow 
To change the opacity of a drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane, move the Opacity slider or enter a percentage in the box at the right. 

Hide or unhide the object of a drop shadow 
To hide or unhide the object of a drop shadow: 
1. In the Objects pane or on the Template Timeline, click the Drop Shadow or Glow effect. 
2. In the Object pane, select or clear the Hide Object checkbox. 
 
 

6.13 Animate an object 
 

6.13.1 Generate an animation from TGAs 

To generate an animation from a sequence of TGA files: 
1. In the Project Assets pane, click Tools. 
2. Select Generate Ani. 
3. In the Pick a Targa File from a Sequence window, select a TGA file that contains the files you 

want to add to the sequence.  
4. In the Ani Generator Settings window, do the following: 

a. In the Decimation box, select the correct decimation value.  
b. In the Bitrate box, select the correct bit rate.  
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c. If you want the top field of each frame in the animation to be played out first, select Top field 
first. 

d. If you want to vertically flip the TGA files, select Flip targas vertically. 
e. If you want the last TGA in the sequence to become the first frame in the animation, select 

Reverse targa sequence. 
5. Click OK. 
 

& Note: A higher decimation value or bit rate results in a bigger file size.  

 
 

6.13.2 Animate with keyframes 

To create an animation with the use of keyframes, you must add at least two keyframes.  The first key 
frame represents the start of the animation. The second (or last) keyframe represents the end of the 
animation.  
 
 

Add and delete a keyframe 

Add a keyframe 
To add a keyframe: 
1. In the Template Timeline pane, click the tab of the template you wish to edit. 
2. On the timeline, move the player to select the point in time where you wish to add a keyframe. 
3. If necessary, in the Object pane, change the object properties at that point in time. 
4. Click the Add keyframe button . 
 

& Note: The sample project Optimization explains how to work with In and Out points. 

Add an IN point 
The appearance of an object as a timeline track is called an IN point. 
 
To add an IN point, do one of the following: 
■ Drag the IN point to the location on the timeline where you want the object to appear. 
■ On the timeline at the point where you want the object to appear, right-click the timeline and select 

Set In Point. 
 

& Note: The sample project Optimization explains how to work with In and Out points. 

 

Add an OUT point 
To add an Out Point: 
1. Do one of the following: 

■ Right-click the object to which you want to add the OUT point and select Enable Out Point.  
■ On the timeline at the point where you want the object to appear, right-click the timeline and 

select Set Out Point. 
2. Then drag the Object’s Out Point (the activity segment’s end) to the appropriate position, or right-

click the Timeline on the appropriate position > Set Out Point. 
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& Note: In the Object pane a Stop action is automatically added when you add an OUT point to an 
object on the Template Timeline and you have enabled Auto-stop at Out Point. A Stop icon  is 
visible on the Timeline. 

Note: The sample project Optimization explains how to work with In and Out points. 
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Delete a keyframe 
To delete a keyframe, do one of the following in the Template Timeline pane: 

■ Select the keyframe(s) that you wish to delete and then click the Delete icon . 
■ On the object list, right-click the object and select Object Keyframes > Delete > From All, All + 

Ripple or From Selection. 
 

& Note: The action All + Ripple deletes all keyframes of a selected object including its sub objects. 

 

Update a keyframe 
 To update a keyframe where you have changed the properties of an object: 
1. On the Template Timeline, double-click the keyframe of which you have changed the properties 

and that you wish to update. 
2. On the tool bar on the timeline, click . 
 
Or do the following: 
1. Right-click a selected keyframe. 
2. Select Object Keyframes and then Update Keyframe. 
 

Move a keyframe 
To move a keyframe 
1. Hover over a keyframe. 
2. Wait until the cursor changes into a two sided arrow. 
3. Then drag and drop the keyframe onto a new location on the timeline. 
 

Copy and paste a keyframe 

Copy a keyframe 
To copy a keyframe: 

■ On the tool bar on the timeline, click .. 
 
To copy the keyframes of one object: 
1. In the Template Timeline pane in the object list, right-click the object. 
2. Select Object Keyframes and then Copy All. 

Paste a keyframe 
To paste a keyframe: 
■ Select the object onto which you want to paste the keyframe. 
■ On the tool bar on the timeline, click . or right-click the object, select Object Keyframes > 

Paste. 
 

Reverse a keyframe couple 
To reverse a selection of keyframes: 

■ On the tool bar on the timeline, click .and then select Scale Time > of Keyframes or of 
All from the dropdown list. 

 
& Note: You have the option to scale selected keyframes [of Keyframes] or all keyframes [of All]. 
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Timescale keyframes 
When you timescale keyframes you scale the duration of an animation as a percentage or an x 
number of frames. 
 

■ On the tool bar on the timeline, click .and then select Reverse Keyframes from the 
dropdown list. 

 

Disconnect a keyframe 
When an animation has several objects, the keyframes of these objects are connected as is visible in 
the sample below. When you select a keyframe for one object, the keyframe is selected for the other 
objects in the animation as well. 

Keyframes can be disconnected from an animation, as is visible in the sample below, in which the 
second keyframe of a capsule is disconnected. You can now move, copy or delete the keyframe 
without moving the other keyframes. 

 
To disconnect an object from other keyframes in an animation: 
■ Right-click the object, select Object Keyframes > Detach > From All, From All + Ripple or 

From Selection. 
 
 

Skip to the next or previous keyframe 
To skip to the next or previous keyframe: 

■ On the tool bar on the timeline, click  or . 
 
 

Change the keyframe interpolation 
To change the keyframe interpolation: 
1. Click a keyframe. 
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2. On the tool bar on the timeline, click  and select the correct interpolation 
method from the dropdown list. 

 
& Note: You can choose the options Constant Speed, Ease In, Ease Out, Ease In & Out and Step. 
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6.13.3 Animate with controllers 

Add a controller 
To add a controller to an object: 
1. In the Objects pane or on the Stage, right-click the object and select Add Controller and then select the controller 

you wish to add. 
2. Click OK. 

Edit an anchor controller 
You can edit an anchor in the Object pane: 
1. Under Anchor Point, move the XYZ sliders or enter values in the boxes next to the sliders. 
2. If applicable, under Align to X, click the Side box and select which side of the object (None, Right or Left) aligns 

with the X anchor point and then move the offset slider to set the offset in pixels. 
3.  If applicable, under Align to Y, click the Side box and select which side of the object (None, Right or Left) aligns 

with the Y anchor point and then move the offset slider to set the offset in pixels. 
4. If applicable, under Align to Z, click the Side box and select which side of the object (None, Right or Left) aligns 

with the Z anchor point and then move the offset slider to set the offset in pixels. 
 
For information about controllers, see ….  
 

Edit a fromto controller 
You can edit a FromTo controller in the Object pane: 
1. In the Property box, select the property that must change in time. 
2. Move the From Value slider to set the start value of the property. 
3. Move the To Value slider to set the end value of the property. 
4. Move the Start Delay slider to set the start delay in frames for the transformation. 
5. Move the Duration slider to set the duration in frames of the transformation. 
6. Click the Interpol. Box and select the type of interpolation (Constant Speed, Ease In, Ease Out, Ease In & Out 

or Step). 
7. Move the Wet-Dry slider to set the intensity of the transformation. 
 

Edit a link controller 
You can edit a link controller in the Object pane: 
1. Click the Src Object box to select a source object and click OK. 
2. Click the Src Prop box to select the source property to which you wish to link the target property. 
3. Click the Tar Prop box to select the target property to which you wish to link the source property. 
4. Move the Offset slider to set the value that must be added to the source property value. 
5. Move the Scale slider to set the percentage with which the source property must be scaled. 
6. Move the Min Value slider to set the minimal target property value. 
7. Move the Max Value slider to set the maximal target property value. 
8. Move the Wet-Dry slider to set the intensity of the transformation. 
 

Edit an oscillate controller 
You can edit an oscillate controller in the Object pane: 
1. Click the Property box to select the property that you wish to oscillate. 
2. Click the Shape box to select the shape of the oscillation wave (Sinus, Sawtooth, Square, Triangle). 
3. Move the Min Value slider to set the minimum value of the oscillator wave. 
4. Move the Max Value slider to set the maximum value of the oscillator wave. 
5. Move the Phase slider to set the starting point inside an oscillation wave, as a percentage of the wavelength. 
6. Move the Lenght slider to set the length of the oscillator wave in frames. 
7. Move the Wet-Dry slider to set the intensity of the transformation. 
 

Edit a stack controller 
You can edit an oscillate controller in the Object pane: 
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1. Click the Direction box and select X Axis, Y Axis or Z Axis to select onto which axis the object need closely to 
stacked. 

2. Move the Spacing slider to set the amount of space between objects (in pixels). 
 
 

6.13.4 Animate with scene parameters 

Add a new scene parameter 
To add a new scene parameter: 
1. Click the Scene Parameters pane. 
2. Click . 
3. In the new window, type a name for the scene parameter. 
 
Or do the following: 
1. In the Object pane, click the  icon next to the property to which you wish to link to a scene parameter. 
2. Select Link to Scene Parameter > New and type a name for the new scene parameter. 
 

& Note: The yellow icons in the Object pane indicate that a scene parameter is linked to an underlying object , 
object  or property . 

Delete a scene parameter 
To delete a scene parameter 

■ In the Scene Parameters pane, select the scene parameter that you wish to delete and click the  icon to delete 
it. 

 
 
 

Link an object property to a scene parameter 
To link an object property to a scene parameter: 
1. In the Object pane and next to the property to which you wish to link to a scene parameter, click the  icon. 
2. Select Link to Scene Parameter and select the correct scene parameter or New to create a new one. 

 



 

GV Director Composer 1.8.0 - 87 

 

7 Work on a template 
 

7.1 Add and delete objects 
7.1.1 Add an object to a template 

To add an object to a template: 
1. On the Template Timeline, select the template to which you wish to add the object. 
2. Do one of the following: 

a. On the toolbar, click the icon, then select the type of Object you wish to add and double-click. 
b. In the Library or Project Assets pane, select an object and drag it onto the Stage. 
c. In the Objects pane, select an object. Then right-click > Add to Template or drag the object onto the Stage. 

 
Drag an object to a template from the objects window 
Drag an object to the template timeline from the objects window 

7.1.2 Remove an object from a template 

To remove an object from a template: 
■ On the Template Timeline or Stage, right-click the object you wish to remove and select Remove from Template.  
■ On the Stage, click the object and press Delete and click Yes. 
 

& When an object is removed from a template, the object will still be available in the object window. 

 

7.1.3 Delete an object from the project 

To delete an object from a project: 

■ In the Objects pane, select the object and click .  
 

& Note: The object is removed from all templates in which it was used. 

 

7.2 Use template rules 
7.2.1 Add a template rule 

& Note: At this moment, it is only possible to create template rules triggered by a ticker end. 

 
To add a template rule: 
1. Make sure that the Template Rules pane is visible. 
2. In the Template Rules pane, click . 
 
For information about how to hide and unhide panes, see section 0, Hide or unhide panes. 
 

7.2.2 Delete a template rule 

To delete a template rule: 
1. Make sure that the Template Rules pane is visible. 
2. In the Template Rules pane, click . 
 

7.2.3 Edit a template rule 

& Note: At this moment, it is only possible to create template rules triggered by a ticker end. 
 

To edit a template rule: 
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1. Make sure that the Template Rules pane is visible. 
2. In the Template Rules pane, double-click the 

template rule that you wish to edit. 
3. In the new window, select the ticker player that must 

be the trigger. 
4. Select the exact trigger, either the last pixel just 

coming on or just going off. 
5. In the Template box, select the template that you 

wish to trigger. 
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7.3 Change the template settings 
You can change the settings for duration of and cuts within a template.  
With regard to duration, you can choose between an infinite and a finite duration of x frames. With regard to cuts, you 
can choose between hard (default option) and soft cuts. When you choose soft cuts, the property values of this 
template are slowly blended in. 
 

7.3.1 Open the template settings 

To open the template settings, do one of the following: 
■ In the Project pane, right-click the template of which you wish to edit the settings and select Settings. 

■ On the tool bar of the Template timeline, click . 
 

7.3.2 Edit the template settings 

To edit the template settings in the Template Settings window: 
1. Select the applicable duration of the template: 

a. If you want an infinite duration, select Infinite. 
b. If you want a finite duration, select Finite and 

enter a number frames. 
2. Select the type of cuts: 

a. If you want hard cuts, select Hard. 
b. If you want soft cuts, select Soft and enter a 

duration in frames. 

 

 
 
 

7.4 Use the timeline controls 
 

7.4.1 Use the player control buttons 

Rewind a template 

■ On the tool bar of the timeline, click .  
 

Play a template 

■ On the tool bar of the timeline, click . 
 

Pause a template 

■ On the tool bar of the timeline, click . 
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7.4.2 Add a keyframe 

 

There are three options to add a keyframe to the objects timeline. 
 
1. Add keyframe using the tool bar of the timeline 

a. In the template timeline, drag the CTI to a prefered position. 
b. On the tool bar of the timeline, click [use current image] 

 
2. Add keyframe using the objects timeline 

a. In the template timeline, drag the CTI to a prefered position. 
b. Right click on the objects timeline.  
c. Click Object Keyframes > Insert Keyframe 

 
3. 3. Add keyframe using the objects property pane 

a. In the template timeline, drag the CTI to a prefered position. 
b. Select an object on stage or on the timeline 
c. Go to the objects property window 
d. Click on the down arrow of a property 
e. Click Insert Keyframe 

 
 
 

 
 
 

7.4.3 Select all timeline items 

To select all timeline items: 

■ On the tool bar of the timeline, click . 
 

7.4.4 Copy and paste items 

Copy to the clipboard 
To copy to the clipboard: 

■ On the tool bar of the timeline, click . 
 

Paste to the timeline 
To paste to the timeline: 

■ On the tool bar on the timeline, click . 
 

7.4.5 Delete an item from the timeline 

To delete an item from the timeline: 
■ On the tool bar of the timeline, click . 
 
 
To duplicate a production element, do one of the following: 
■ In the Project pane, right-click the production element you wish to duplicate and select Duplicate. 

■ On the tool bar of the Template Timeline, click . 

■ On the tool bar or the Compound Element Timeline, click . 
 

& Note: The objects of the original template or transition are not duplicated. Both original and duplicate use the same 
objects. If an object is changed in template or transition A, it is also changed in template B. 
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7.4.6 Scale the time 

To scale the time: 

1. On the tool bar of the timeline, click . 
2. Select Scale time from the dropdown list, and then select of Keyframes or of All. 
3. In the Scale Time of …. window, select by percentage or by duration. 
4. If you have selected by percentage, type the applicable size as a percentage in the % box. 
5. If you have selected by duration, type the applicable size in frames in the fr box. 
 
 

7.4.7 Use the snap controls 

Enable or disable player head snap 
To enable or disable player head snap: 

■ On the tool bar of the timeline, click . 
 

Set the snap distance 
To set the snap distance: 

■ On the tool bar of the timeline pane, click . 
 

& Note: The snap distance is in seconds. 
 
 

7.4.8 Hide and unhide items 

Hide or unhide an object 
To hide or unhide an object on the stage: 

■ On the timeline behind the name of an object, click . 
 

Hide or unhide command tracks 
To hide or unhide command tracks: 
1. On the bottom left the timeline pane, click . 
2. Select or clear Command Tracks from the dropdown list. 

Hide or unhide object properties 
To hide or unhide object properties: 
1. On the bottom left of the timeline, click . 
2. Select or clear Object Properties from the dropdown list. 
 
 

7.4.9 Enable or disable the pickup 

To enable or disable the pickup: 

■ On the Template Timeline, click .  
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& Note: As a default, the pickup is selected. 
& Note: When the pickup is cleared, the object, sub-object or property is not affected by the template changes. 
 

7.4.10 Lock or unlock an object 

To lock or unlock an object on the stage: 

■ On the timeline behind the name of an object, click . 
 
 

7.4.11 Zoom in or out of the timeline 

To zoom in or out of the timeline: 
 
1. On the bottom left of the timeline, move the slider: 
2. Select or clear Object Properties from the dropdown list.  
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7.5 Preview a template 
To preview a template: 

■ On the Template Timeline, click . 
■ On the toolbar, click the Try-out Mode button and double-click a template. 
 

& Note: Players only play content in Try-out mode. 
& Note: In try-out mode, the Stage shows a preview of your templates. The output is exactly the same as on the 

playout system, but is not guaranteed in real-time.  
& An orange color indicates that a templates is loading. 
& Blue indicates that a template is playing. Grey indicates that a templates has been played. 
& Note: You cannot edit a template in try-out mode. 

 
 

7.6 Take a snapshot 
You can take a snapshot of a template, transition or effect. This snapshot is then visible on the GV Director Panel 
when you push the button that is linked to the transition or effect. 
 
To take a snapshot: 
1. On the Template Timeline, move the player until the scene is visible on the Stage of which you wish to take a 

snapshot. 
2. Click the button. 
 

& Note: When a snapshot is taken it is visible in the snapshot button in Composer. 
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7.7 Rate all templates 
You can the Rate Templates feature to check the performance of all transitions and templates in a 
project. 
 
To rate all transitions and templates: 
■ In the Objects menu, select Rate Templates. 
 

& Note: In the Project pane, two scores are visible after this action. The first score is the total time in 
milliseconds to process the entire template (total). The second score is the  GPU time in 
milliseconds to process the template. 

& Note: We recommend that you validate values higher than 10 on the playout system.  
& Note: Please refer to the Example Project for an explanation n how values can be improved if load 

is too high. 
 

 
A third score is the so-called near frame score. This score is visible when you hover over the two 
scores in the Project pane. The near frame score shows on which frames the two other scores peak. If 
the near frame score is 0/0, the other two scores each peak at frame 0.  
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8 Work on transitions  
 
 
 

8.1 Edit the transition settings 
You can change the settings for duration of and cuts within a transition.  
 
With regard to duration, you can choose between an infinite and a finite duration of x frames. With 
regard to cuts, you can choose between hard (default option) and soft cuts. When you choose soft 
cuts, the property values of this transition are slowly blended in. 
 

8.1.1 Open the transition settings 

To open the transition settings, do one of the following: 
■ In the Project pane, right-click the transition of which you wish to edit the settings and select 

Settings. 

■ On the tool bar of the Template timeline, click . 
 

8.1.2 Edit the transition settings 

To edit the transition settings: 
1. Select the applicable duration of the 

template: 
a. If you want an infinite duration, select 

Infinite. 
b. If you want a finite duration, select 

Finite and enter a number frames. 
2. Select the type of cuts: 

a. If you want hard cuts, select Hard. 
b. If you want soft cuts, select Soft and 

enter a duration in frames. 

 

 
 

8.2 Change the A/B objects of a transition 
To change the A-B objects of a transition: 
1. Drag the objects from the Library or Project Assets pane to the Stage. 
2. Make sure that the objects are grouped under the IPA Mixer. 
3. Link the IPA Mixer to one or multiple object materials of the A and B objects. Repeat the following 

steps until you have linked every material: 
a. In the Objects or Template Timeline pane, select the material  that you wish to link to the 

IPA Mixer. 
b. Double-click the material.  
c. In the Object pane under Players, click the Fill box and select GVD Mixer Player. 
d. On the Template Timeline, expand the selected material and click the GVD Mixer Player 

underneath. 
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e. In the Object Pane, make sure that in the Mixer Buffer box the correct side (Front or Back) is 
selected. 

 
& Note: You cannot add animations to a transition, except when it is an animated transition. 
& Note: Make sure that you group all objects under the IPA Mixer. 

 
 
 
 

8.3 Preview a transition 
To preview a transition, do one of the following: 
■ Click Try-out Mode and use the buttons of the Template Timeline. 
■  Click Try-out Mode or move the Player on the timeline. 

 

 
■ Note: that Players only run in Try-out mode. 
 

8.4 Take a snapshot 
You can take a snapshot of a template, transition or effect. This snapshot is then visible on the GV 
Director Panel when you push the button that is linked to the transition or effect. 
 
To take a snapshot: 
4. On the Template Timeline, move the player until the scene is visible on the Stage of which you 

wish to take a snapshot. 
5. Click the  button. 
 

& Note: When a snapshot is taken it is visible in the snapshot button in Composer. 

 

8.1 Rate all transitions 
Same as Rate all templates. 
 

8.2 Work on animated transitions  
 

8.2.1 Set the duration 

Animated transitions must have a finite duration. 
 
To set the duration: 
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1. In the Project pane, right-click the 
transition of which you wish to edit the 
settings and select Settings. 

2. Under Duration, select Finite and enter a 
number frames. 
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9 Work on effects  
 

9.1 Add an action to an effect 
To add an action to an effect: 
■ In the Project pane, double-click an effect, click , type an action name and click OK. 
 

& Note: The action name is visible on the GV Director Panel. 

 
 

9.2 Link an action to a template 
To link a template to an effect action: 
1. In the Project pane, double-click an effect, then double-click the action you wish to link to a 

template. 
2. In the new window, select a template and click OK. 
 
 

9.3 Delete an action 
To delete an action: 

■ In the Project pane, double-click an effect, select the action that you wish to delete and click . 
 
 

9.4 Preview an effect 
You can preview an effect in Try-out Mode.  
 
To preview an effect: 
1. On the toolbar, click the Try-out Mode button. 
2. In the Try-out Mode pane, double-click the templates in the effect to preview them. 
 
 

9.5 Take a snapshot 
You can take a snapshot of a template, transition or effect. This snapshot is then visible on the GV 
Director Panel when you push the button that is linked to the transition or effect. 
 
To take a snapshot: 
3. On the Template Timeline, move the player until the scene is visible on the Stage of which you 

wish to take a snapshot. 
4. Click the button. 
 

& Note: When a snapshot is taken it is visible in the snapshot button in Composer. 
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10 Work on compound elements  
 

10.1 Add and delete items 
10.1.1 Add an effects block 

1. On the Compound Element Timeline, click .. 
2. Add a background to the effects block: 

a. In the Production Elements pane, drag a Black, Input or Shotbox to the Background section 
of the effects block. 

b. In the Object Pane, drag a transition to the Transition section of the effects block. 
c. Drag Effects from the Object pane or GPOs from the Production Elements pane to the Effects 

section of the effects block. 
 

10.1.2 Delete an effects block 

■ On the Compound Element Timeline, select the effects block you wish to delete and click . 
 

10.1.3 Add a transition to an effects block 

To add a transition to an effects block: 
■ In the Project pane, drag the transition that you wish to add and drop it in the effects block on the 

Compound Element Timeline.  
 

10.1.4 Add one or multiple effects to an effects block 

To add one or multiple effects to an effects block: 
1. From the Project pane, drag the effect that you wish to add and drop it onto the effects block on 

the Compound Element Timeline.  
2. Double-click the effect. 
3. In the new window, select the correct action (such as None, Off, On or Update) and click OK. 
 

10.1.5 Add a GPO 

To add a GPO to an effects block,: 
1. From the Production Element pane, drag and drop it onto the effects block on the Compound 

Element Timeline. 
2. Double-click the GPO. 
3. In the new window in the Output pin box, type the number of the output pin that you wish to use. 
4. In the Output Pin State box, select the state to which the pin must switch (Low, High or Pulse). 
5. In the Pulse Width box, type the correct number of frames. 
6. In the Pulse Phase box, select Positive or Negative. 
 

& Note: You cannot use the same pin number twice in an effects block. When you drop a GPO on an 
effects block, the new pin number is always +1. 

 

10.2 Copy and paste items 
10.2.1 Copy an effects block 

To copy an effects block: 

■ On the Compound Element Timeline, select the effects block you wish to copy and click . 
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10.2.2 Paste an effects block 

To paste an effects block: 

■ On the Compound Element Timeline, click or press Ctrl+V / ⌘V. 
 
 

10.3 Change the order of production elements or effects 
blocks 

To change the order of production elements or effects blocks: 
■ Select and drag the item.  
 

& Note: The drop indicator shows the new location of the item. 

 
 

10.4 Replace items 
10.4.1 Replace a background 

To replace a background: 
1. From the Production Elements pane, drag the new Black, Input or Shotbox to the background 

section of the effects block on the Compound Element Timeline.  
2. In the pop-up window, click Yes to replace the existing background. 
 

10.4.2 Replace a transition 

To replace a transition: 
1. From the Production Elements pane, drag the new transition to the Transition section of the 

effects block on the Compound Element Timeline.  
2. In the pop-up window, click Yes to replace the existing transition. 
 
 

10.5 Edit a pause 
1. Double-click a pause. 
2. In the new window, select User Pause or Timed Pause. 
3. If you have selected a timed pause, in the Duration box, enter a duration in hh:mm:ss:ff. 
4. Click OK. 
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11 Use a keyboard shortcut 
This chapter instructs you how to use keyboard shortcuts that 
work anywhere, as well as keyboard shortcuts that you can 
use to move through and edit the Stage and the Template 
Timeline. 
 

11.1 Use a shortcut that works anywhere 
These hotkeys are accessible from everywhere. 
Windows shortcut Mac OSX shortcut  

Ctrl+O CMD-O : open Project. 

Ctrl+P  CMD-P  : Toggle Pixel Perfect Information. 

Ctrl+S CMD-S : save Project. 

Ctrl+SHIFT-S CMD-SHIFT-S : save Project as. 

Ctrl+Z CMD-Z : undo. 

Ctrl+Y CMD-Y : redo. 

Ctrl+C CMD-C : copy. 

Ctrl+V CMD-V : paste. 

Ctrl+A CMD-A : select all. 

Ctrl+D CMD-D : select none. 

Ctrl++ CMD-+ : zoom in. 

Ctrl+- CMD-- : zoom out. 

Ctrl+ALT-F CMD-ALT-F : zoom to 100%. 

Ctrl+ALT-N CMD-ALT-N : fit Stage in window. 

Ctrl+ALT-R CMD-ALT-R : toggle ruler’s visibility. 

Ctrl+ALT-G CMD-ALT-G : toggle grid visibility. 

Ctrl+ALT-U CMD-ALT-U : toggle guides’ visibility. 

Ctrl+SHIFT-G CMD-SHIFT-G : toggle snap to grid. 

Ctrl+SHIFT-U CMD-SHIFT-U : toggle snap to guides. 

Ctrl+1 CMD-1 : toggle Project Navigator visibility. 

Ctrl+2 CMD-2 : toggle History visibility. 

Ctrl+3 CMD-3 : toggle Library visibility. 

Ctrl+4 CMD-4 : toggle Project Assets visibility. 

Ctrl+5 CMD-5 : toggle Objects visibility. 

Ctrl+6 CMD-6 : toggle Object Properties visibility. 

Ctrl+7 CMD-7 : toggle Template Timeline visibility. 

Ctrl+8 CMD-8 : toggle Text Styles visibility. 

Ctrl+9 CMD-9 : toggle Scene Parameters visibility. 

Ctrl+SHIFT-T CMD-SHIFT-T : new Template. 

G G : group Objects. 

U U : ungroup Object. 

ALT-A ALT-A : add Object to Stage. 
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SHIFT-SPACE SHIFT-SPACE : toggle Clean View Mode. 

SHIFT-2 SHIFT-2 : toggle allow only 2D transformations. 

SHIFT-3 SHIFT-3 : toggle allow 2D and 3D 
transformations. 

SHIFT-A SHIFT-A : toggle lock Object aspect ratio. 

SHIFT-M  SHIFT-M  : toggle 16:9 (anamorphic widescreen) 
mode 

SHIFT-Z SHIFT-Z : toggle 3D editing guides visibility. 

O O : open group. 

C C : close group. 

SHIFT-C SHIFT-C : toggle curtains. 

Ctrl+T CMD-T : toggle Template Try-out Mode. 

Ctrl+Shift+T CTRL+Shift+T Add a Transition. 

Ctrl+Shift+R CTRL+Shift+R Add an Animated Transition. 

Ctrl+Shift+E CTRL+Shift+E Add a Template. 

Ctrl+Shift+C CTRL+Shift+C Add a Compound Element. 

 
 

11.2 Move through and edit the Stage 

left/right/up/down/pgdn/pgup Nudge (to move an object by one pixel) to the left, the right, 
up, down, forward or backward. 

SHIFT + left/right/up/down/pgdn/pgup Big nudge to the left, the right, up, down, forward or 
backward. 

R Reset the rotation of the selection. 

Shift+ move an object Limit the movement to the X or Y axis. 

Del Remove or delete selected objects. 
 
 

11.3 Edit the Template Timeline 

A : select all Timeline items. 

D : delete Timeline selection. 

[/] : go to previous/next keyframe. 

left/right : decrease/increase player head time by one frame. 

+/- : zoom in/out. 

R : rewind. 

Space : toggle play/pause. 

K : insert/update keyframe for selection. 
 


	1 About this guide
	1.1 What’s in this guide
	1.2 How to use this guide
	1.3 Document conventions
	1.4 Useful resources
	1.5 Grass Valley technical support
	1.6 Corporate head office

	2 Get to know Composer
	2.1 Basic features
	2.2 Production elements
	2.2.1 Objects
	Supported formats
	Stills
	Animations
	Clips
	Restrictions for embedded audio
	GOP size restrictions

	Audio
	Fonts
	Mesh clips

	Materials
	Gooch materials
	IBL materials
	Reflection materials
	Standard materials

	Layer effects (FX)
	Bevel
	Blur
	Chroma keying
	Colorize
	Drop shadow
	Pixelate
	Ripple


	1.1.1
	2.2.2 Transitions
	2.2.3 Templates
	2.2.4 Effects
	2.2.5 Compound elements

	2.3 The workspace
	2.3.1 The Template Timeline
	2.3.2 The Compound Element Timeline

	2.4 The tools
	2.4.1 Rulers
	2.4.2 Gridlines
	2.4.3 Alignment guides
	2.4.4 Template rules
	2.4.5 Keyframes
	IN points
	OUT points

	2.4.6 Controllers
	2.4.7 Scene parameters
	2.4.8 The ANI Generator
	2.4.9 View pixel perfect information


	3 Get started
	3.1 System requirements
	3.1.1 Mac OSX
	3.1.2 Windows

	3.2 Install Composer
	3.2.1 Install Composer on a Mac
	3.2.2 Install Composer on a Windows PC

	3.3 Basic actions
	3.3.1 Open Composer
	3.3.2 Quit Composer
	3.3.3  Navigate the Object pane
	3.3.4 Open and edit items
	Open the Object pane
	Open a template or transition
	Open a layer effect
	Open a material
	Open an effect

	3.3.5 Select a keyframe
	3.3.6 Move the player Head
	3.3.7 Open the Compound Element Timeline
	3.3.8 Open an existing project
	3.3.9 Create a new project
	3.3.10 Save a project
	3.3.11 Add a production element to a project
	Add a template
	Add a transition
	Add an animated transition
	Add an effect
	Add a compound element

	3.3.12 Delete a production element from a project
	Delete a template
	Delete a transition or animated transition
	Delete an effect
	Delete a compound element

	3.3.13 Rename a production element
	3.3.14 Duplicate a production element

	3.4 Customize the workspace
	3.4.1 Customize panes
	Hide or unhide panes
	Close a pane
	Resize a pane
	Move a pane
	Dock or undock a pane

	3.4.2 Customize the Stage
	Enter or exit Clean View mode
	Change the size of the Stage
	Add curtains
	Hide or unhide rulers
	Hide or unhide the grid
	Hide or unhide alignment guides
	Add an alignment guide
	Move an alignment guide
	Delete an alignment guide
	Enable or disable snap to guides
	Enable or disable snap to grid
	Change the color of the alignment guides
	Adjust the snap distance
	Change the grid color

	3.4.3 Customize the Template Timeline
	Show properties or commands on the timeline



	4 Change the preferences
	4.1 Change the NexOS settings
	4.1.1 Change the broadcast format
	4.1.2 Change the image quality
	4.1.3 Adjust the multi-sampling anit-aliasing
	4.1.4 Adjust the texture cache size
	4.1.5 Change the de-interlacing method

	4.2 Change the file settings
	4.2.1 Change the default project folder
	4.2.2 Enable / disable Autosave

	4.3 Change the history settings
	4.4 Change the alignment guide settings
	4.4.1 Change the color of the alignment guide
	4.4.2 Change the snap distance of the alignment guide

	4.5 Change the grid settings
	4.5.1 Change the color of the grid
	4.5.2 Change the horizontal spacing of the grid
	4.5.3 Change the vertical spacing of the grid
	4.5.4 Change the snap distance of the grid

	4.6 Change the backup settings
	4.7 Change the FTP transfer mode

	5 Manage a project
	5.1 Merge a project
	5.2 Import and export projects and elements
	5.2.1 Import a project
	5.2.2 Export a project
	5.2.3 Import a production pack
	5.2.4 Export a production pack
	5.2.5 Import a template
	5.2.6 Export a template
	5.2.7 Importing assets
	5.2.8 Import a 3DS Studio Max file

	5.3 Restore a project
	5.4 View a example project
	5.5 Organize project elements
	5.5.1 Add a production element to a folder
	5.5.2 Add an object to the library
	5.5.3 Manage text styles
	Add a text style
	Delete a text style



	6 Work on an object
	6.1 Copy and paste an object
	6.2 Lock or unlock an object
	6.3 Work on a group
	6.3.1 Group or ungroup multiple objects
	6.3.2 Edit a group object
	6.3.3 Add ground reflections to a group

	6.4  Change object handling in 2D or 3D
	6.5 Change the object layer
	6.6 Change the spatial properties of an object
	6.6.1 Move an object
	The coordinates define the position of the object’s center
	The coordinates define the position of the top left object’s center:
	Put an object on a 2D plane
	Move an object on the Z-axis (3D)

	6.6.2 Change the size or shape of an object
	Change the size of the output of a player
	Use the scaling buttons
	Lock the aspect ratio
	Change the measurement unit
	Reset an object to its original size
	Counter scale for widescreen mode (16:9)

	6.6.3 Rotate an object
	Normally rotate an object
	Freely rotate an object (3D)
	Enable or disable Euler interpolation

	6.6.4 Add or remove a camera perspective

	6.7 Change the image quality of an object
	6.7.1 Enable or disable anti-aliasing
	6.7.2 View pixel perfect information
	6.7.3 Enable or disable progressive image
	6.7.4 Change the texture quality

	6.8 Blend an object
	6.9 Work on a player
	6.9.1 Refresh the preview of a player
	6.9.2 Show a test feed
	6.9.3 Set a player action
	6.9.4 Change the size of a player
	6.9.5 Player linkage
	Link a player to another player
	Playing a file
	Link a property to a scene parameter

	6.9.6 Automate player action properties
	Enable or disable Auto-update for a text object
	Enable or disable Auto-adjust size to contents
	Enable or disable Auto-stop at OUT point
	Enable or disable a clip loop

	6.9.7 Preview the output of a player
	6.9.8 Play out a video as object texture
	6.9.9 Change audio levels and/or routing
	Mute all audio
	Set a fade
	Add a linear fade for all audio channels
	Set the audio output level for all input channels
	Set the audio output level per input channel
	Route a channel
	Link input channels to output channels

	6.9.10 Work on a text
	Change the text in a text player
	Apply a text style to a text
	Change the appearance of a text
	Change the font
	Change the font size
	Change the font
	Change the kerning
	Change the line spacing
	Change the anti-aliasing

	Change the alignment
	Change the horizontal alignment mode
	Change the horizontal alignment
	Change the vertical alignment

	Change the font style
	Change the font color
	Change the font opacity
	Change the font border
	Change the color of a font border
	Change the font border opacity
	Change the font border size
	Change the blur kernel size of the font border

	Change the font shadow
	Change the font shadow color
	Change the font shadow opacity
	Change the font shadow size
	Change the blur kernel size of the font shadow



	Format a text or clock with strings
	Strings to format text
	String to change the character set
	String to change the font size
	String to change the foreground color
	String to add an indent
	String to show the decimal code of a special character
	String for Unicode characters
	String for glyph code characters
	String for a return
	String to add a tab
	String to add a vertical offset

	Strings to edit a clock
	Up counter
	Down counter
	Other clock types



	6.9.11 Work on a ticker
	Add a ticker story to a ticker
	Set the ticker speed
	Enable or disable a ticker story loop
	Add a still or animation to a ticker


	6.10 Work on a command
	6.10.1 Add a command to a template
	6.10.2 Move a command
	6.10.3 Copy a command
	6.10.4 Paste a command
	6.10.5 Edit an AFD command
	Enable or disable AFD in the playout signal:
	Change the VBI line number
	Change the aspect ratio
	Change the AFD code

	6.10.6 Edit a ticker story command
	Change the ticker player
	Change the story number
	Change the text of a ticker story
	Change the text style of a ticker story
	Change the story graphics

	6.10.7 Edit a Counter command
	Add a counter command
	Start a clock
	Stop a clock
	Set the start time of a clock

	6.10.8 Edit a GPIO command
	Disable a GPIO pin
	Enable a GPIO pin

	6.10.9 Edit a Rating command
	Rating systems overview
	Rating values for US Parental Guideline Ratings

	6.10.10 Edit a Main Player command
	6.10.11 Edit a Ticker command
	Clear a ticker story
	Pause a ticker story
	Unpause a ticker story

	6.10.12 Edit a Video Index command
	Change the VBI line for VI data
	Change the scanning system
	Change the active format description
	Change the signal form
	Change the sample structure
	Change the pan
	Change the tilt
	Change the zoom
	Change the X and Y flags


	6.11 Work with materials
	6.11.1 Replace a material
	6.11.2 Change the lighting of a material
	Change the shadow color of an object
	Change the color of lighted parts of the object
	Change the specular color
	Change the specular color power
	Change the alpha channel

	6.11.3 Change the image quality of a material
	6.11.4 Change the cull property
	6.11.5 Change the fill mode
	6.11.6 Enable or disable depth occlusion

	6.12 Work with layer effects
	6.12.1 Add and delete a layer effect
	Add a layer effect
	Delete a layer effect

	6.12.2 Set the intensity of a layer effect
	6.12.3 Edit a ripple effect
	Set the center of a ripple
	Set the wavelength of a ripple
	Change the ripple amplitude (ripple height)
	Change the starting point of ripple cycle

	6.12.4 Edit a blur effect
	Change the width of a blur
	Change the height of a blur
	Change the image quality of a blur
	Downsample a blur
	Put the blurred object over the original
	Enable Luma blur

	6.12.5 Edit a bevel or emboss effect
	Select a bevel mode
	Set the contrast of a bevel or emboss effect
	Change the lighting angle in a bevel or emboss effect
	Set the size of a bevel or emboss effect
	Change the color of a bevel or emboss effect
	Change the opacity of a bevel or emboss effect

	6.12.6 Edit a chroma key effect
	Set a chroma key color
	Edit the edge between a keyed and unkeyed area
	Suppress the spilling of a chroma key to the foreground
	Light wrap an unkeyed area

	6.12.7 Edit a pixelate effect
	Change the pixel size of the pixelate effect

	6.12.8 Edit a drop shadow effect
	Change the blur of a drop shadow
	Change the image quality of the drop shadow
	Downsample a drop shadow
	Change the angle of a drop shadow
	Change the drop shadow size
	Change the drop shadow color
	Change the opacity of a drop shadow
	Hide or unhide the object of a drop shadow


	6.13 Animate an object
	6.13.1 Generate an animation from TGAs
	6.13.2 Animate with keyframes
	Add and delete a keyframe
	Add a keyframe
	Add an IN point
	Add an OUT point
	Delete a keyframe

	Update a keyframe
	Move a keyframe
	Copy and paste a keyframe
	Copy a keyframe
	Paste a keyframe

	Reverse a keyframe couple
	Timescale keyframes
	Disconnect a keyframe
	Skip to the next or previous keyframe
	Change the keyframe interpolation

	6.13.3 Animate with controllers
	Add a controller
	Edit an anchor controller
	Edit a fromto controller
	Edit a link controller
	Edit an oscillate controller
	Edit a stack controller

	6.13.4 Animate with scene parameters
	Add a new scene parameter
	Delete a scene parameter
	Link an object property to a scene parameter



	7 Work on a template
	7.1 Add and delete objects
	7.1.1 Add an object to a template
	7.1.2 Remove an object from a template
	7.1.3 Delete an object from the project

	7.2 Use template rules
	7.2.1 Add a template rule
	7.2.2 Delete a template rule
	7.2.3 Edit a template rule

	7.3 Change the template settings
	7.3.1 Open the template settings
	7.3.2 Edit the template settings

	7.4 Use the timeline controls
	7.4.1 Use the player control buttons
	Rewind a template
	Play a template
	Pause a template

	7.4.2 Add a keyframe
	7.4.3 Select all timeline items
	7.4.4 Copy and paste items
	Copy to the clipboard
	Paste to the timeline

	7.4.5 Delete an item from the timeline
	7.4.6 Scale the time
	7.4.7 Use the snap controls
	Enable or disable player head snap
	Set the snap distance

	7.4.8 Hide and unhide items
	Hide or unhide an object
	Hide or unhide command tracks
	Hide or unhide object properties

	7.4.9 Enable or disable the pickup
	7.4.10 Lock or unlock an object
	7.4.11 Zoom in or out of the timeline

	7.5 Preview a template
	7.6 Take a snapshot
	7.7 Rate all templates

	8 Work on transitions
	8.1 Edit the transition settings
	8.1.1 Open the transition settings
	8.1.2 Edit the transition settings

	8.2 Change the A/B objects of a transition
	8.3 Preview a transition
	8.4 Take a snapshot
	8.1 Rate all transitions
	8.2 Work on animated transitions
	8.2.1 Set the duration


	9 Work on effects
	9.1 Add an action to an effect
	9.2 Link an action to a template
	9.3 Delete an action
	9.4 Preview an effect
	9.5 Take a snapshot

	10 Work on compound elements
	10.1 Add and delete items
	10.1.1 Add an effects block
	10.1.2 Delete an effects block
	10.1.3 Add a transition to an effects block
	10.1.4 Add one or multiple effects to an effects block
	10.1.5 Add a GPO

	10.2 Copy and paste items
	10.2.1 Copy an effects block
	10.2.2 Paste an effects block

	10.3 Change the order of production elements or effects blocks
	10.4 Replace items
	10.4.1 Replace a background
	10.4.2 Replace a transition

	10.5 Edit a pause

	11 Use a keyboard shortcut
	11.1 Use a shortcut that works anywhere
	11.2 Move through and edit the Stage
	11.3 Edit the Template Timeline


