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Introducing Xbuilder
Xbuilder’s primary role in the Vertigo Suite is to quickly and accurately build multiple 
instances of template-based or pre-rendered graphics for playout. Xbuilder is also allows 
you to prepare the new graphics for playout by verifying quality, previewing playout and 
organizing the graphics into playlists.

While the remaining chapters provide instructions for how to use Xbuilder, the following 
list provides a brief overview of Xbuilder’s main functions:

• Create and populate graphics pages from a master template
Templates created in Xstudio lock down a graphics’ layout. With no need to recreate 
the graphic’s layout, Xbuilder can use templates to quickly create multiple instances of 
the graphics where the content is specific to the broadcast. These new graphics called 
pages are saved as individual assets whose layout is linked to the template. See page 13 
for more information.

• Render templates to a clip file for the purposes of previewing or playout
Xbuilder can render the playout of templates into various video clip formats, so that 
you can preview the graphics playout, or use the resulting clip file to playout the pre-
rendered graphic on a video server or Vertigo playout device. See page 25 for more 
information.

• Perform quality control and media check of pre-rendered graphics files
Xbuilder’s Make List feature (QC workflow) allows you to preview and validate (approve 
or reject) the pre-rendered graphics that the After Effects Plug-in and the Make List file 
created and ingested into the Xmedia Server.
Once the graphics are approved and published to the device(s), Xbuilder’s Air List 
feature (MC workflow) allows you to quickly preview and verify that all of the approved 
graphics have actually been published to the correct devices. See page 31 for more 
information.

• Create sequential playlists to be played out in Xplay
Xbuilder allows you to build playlists, which are ordered sequences of program clips 
and branding and promotional graphics elements (i.e. pages, scenes or clips). The 
resulting playlists can be edited and played back using the Vertigo Suite’s Xplay. See 
page 43 for more information.

• Create rundowns and segments for newsroom applications
Similar to sequential playlists, Xbuilder can create rundowns and segments, which are 
ordered lists of the pages, scenes and clips that can be brought into newsroom 
applications. See page 69 for more information.
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Getting started with Xbuilder
This chapter provides you with information about installing and licensing the Xbuilder 
software on a client workstation. Additional information and instructions are provided for 
performing a basic setup and configuration of the Xbuilder software.

Once you have completed the installation and quick setup, Xbuilder will be properly 
configured to create and save pages, render graphics to clips and create playlists.

This chapter is organized into the following topics:
• Installation and licensing information, on page 4
• Starting Xbuilder and connecting to the Xmedia Server, on page 5
• Overview of Xbuilder’s user interface, on page 6
• Configuring Xbuilder’s settings, on page 8
• Adding and configuring a Preview device, on page 9
• Configuring a device for the verification of playlist elements, on page 10
 3
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Installation and licensing information
Xbuilder is packaged with the Vertigo Suite software installation wizard. It can be installed 
as part of the full installation or as an individual (standalone) component. In both cases, you 
simply need to run the installation wizard on a workstation that is on the same network as 
the Xmedia Server.

Information regarding the Vertigo Suite’s hardware and network requirements, as well as 
instructions for installing and/or upgrading Xbuilder, are available in the Vertigo Suite’s 
Release Notes, which can be downloaded from the Support Portal web site.

To operate in its full capacities, Xbuilder requires that four (4) software application licenses 
(listed below) be installed and validated on the Xmedia Server. Therefore, once Xbuilder is 
installed, you must contact Technical Support (support@grassvalley.com) to request a 
license key. Then you must apply and validate the licenses using the XmediaServer Control 
Panel. Instructions for acquiring and validating licenses are also provided in the Vertigo 
Suite’s Release Notes.

License name Description

Xbuilder The Xbuilder license is required to open and operate the base 
features and functionality of the Xbuilder application.

XGSoftware The XG Software license is required to preview graphics using the 
VX-Preview (Software CG) application. See page 22 for more 
information.

XGEncode The XG Encode license is required to use Xbuilder’s Render to File 
feature, which renders and saves the playout of a template, page, 
and/or scene to a file in various clip formats. See page 25 for more 
information.

XGEncodeforPlayout The XG Encode for Playout license is required to render pages 
and/or scenes to playout server compatible formats (XDCAM and 
IMX compatible MXF files). See page 27 for more information.

QC The QC license is required to use Xbuilder’s Quality Control (QC) 
workflow (Open MakeList feature). The QC workflow allows you 
to preview and validate graphics before they are published to the 
target devices and taken to air. See page 31 for more information.
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Starting Xbuilder and connecting to the Xmedia Server
When you initially launch Xbuilder, a dialog box appears and asks you to configure the 
server location. As a client application, Xbuilder must be connected to the Xmedia Server, 
which is the centralized asset management server for Vertigo applications and devices.

Since you have only just installed Xbuilder, the first task that you must do is to connect 
Xbuilder to the Xmedia Server.

To start Xbuilder and connect to the Xmedia Server:
1 Click Start>Programs>VertigoXmedia>Xbuilder.
2 When the message asking you to configure the server location, click the Yes button. 

The Settings dialog box appears.
3 Click Servers in the tree view at left. This displays the settings related to the Xmedia 

Server (see page 115 for more information about Xbuilder’s Server settings).
4 In the XmediaServer IP Address field, replace <server IP> with the IP address of the 

machine hosting the Xmedia Server.
5 Unless the port number was changed when the Xmedia Server was installed, the 

default in the XmediaServer Port field will be correct. If it was changed, enter the new 
number.

6 Click OK.
Xbuilder launches. If the program does not launch, consult your system administrator. 
The problem could be due to one of the following:

• The IP address or port was entered incorrectly.
• The machine hosting the Xmedia Server is down.
• The Xmedia Server is not running on the host machine.
• The machine is not connected to the network.
5
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Overview of Xbuilder’s user interface
Xbuilder provides an interface provides you with the tools and features required for 
accomplishing various tasks like creating and populating pages, rendering graphics to a file 
or building playlists.

The following descriptions provide an overview of Xbuilder’s main interface features and 
components. Information and instructions for how to use each interface component are 
provided in within the applicable tasks in further chapters.

Fig. 2-1: Xbuilder interface

1 Main menus - Located along the top of the interface, these menu commands provide 
access to most of Xbuilder's settings and administrative functions. See Xbuilder’s 
menus & toolbars, on page 87 for more information.

2 The upper portion of the Xbuilder interface changes according to what type of project 
you are working on: playlist, segment, rundown or timeline.

• Playlist Editor - The workspace where pages, templates, scenes and clips can be 
organized into a sequential playlist. See page 44 for full details on using the Playlist 
Editor.

• Segment window - Very similar to the Playlist Editor, the Segment window allows 
you to build a portion of a sequential playlist to be used in a rundown. See page 71 
for full details on using the Segment window.

• Rundown Editor - The workspace for creating a sequential rundown playlist using 
segments, pages, clips, scenes and template assets. See page 73 for full details on 
using the Rundown Editor.

• Timeline Editor - The Timeline Editor allows you to create and edit automated 
promos by assembling and editing episodic clips, graphics, and audio elements 
within a timeline interface.

1

2

3

4

5

6
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3 Asset Browser - Located in the lower left-hand portion of the interface, the Asset 
Browser provides a tree view of the asset categories on the connected Xmedia Server. 
When you select a category or sub-category, the assets stored within the category are 
displayed in the panel to the right of the Asset Browser (Template Editor). You can 
display or hide the Asset Browser by pressing Ctrl+A, or by selecting Asset Browser 
from the View menu.

4 Template Editor - Its main function is to provide a canvas for displaying and editing the 
variable fields on a open pages, templates and scenes. Its toolbar buttons provide 
access to commands and features tat can be applied to the displayed asset.
A secondary function of this interface panel, is to display the contents of the selected 
category from the Asset Browser. The assets from a selected category can be viewed in 
proxy or list view mode.

5 Favorites Browser - Located in the lower right-hand portion of the interface, the 
Favorites Browser provides a quick drag-and-drop area where frequently used 
templates, pages, scenes and clips can be stored for easy access.

6 Status bar - Located along the bottom of the Xbuilder window, the status bar provides 
process update messages (left), server connection identification (center), and preview 
device connection status (right).
7
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Configuring Xbuilder’s settings
Although Xbuilder’s default settings are appropriate for most operating circumstances, you 
may want to customize the look and behavior of the application using Xbuilder’s settings. 
Note that modifying these settings is entirely optional.

Changes to Xbuilder settings are made within the Settings dialog box, which can be 
accessed by selecting Tools>Settings from the Xbuilder menu commands. 

This Settings dialog box contains a tree-structure of thematic settings. Each of the settings 
is defined in the following sections:

• General settings, on page 104
• Display settings, on page 105
• Template Favorites settings, on page 107
• Automation settings, on page 108
• Playlist Ingest settings, on page 109
• Place Holders settings, on page 110
• Merge List settings, on page 111
• Logging settings, on page 112
• Render To File settings, on page 113
• Timelines settings, on page 114
• Work Orders settings, on page 115
• Servers settings, on page 115
• Playlist > Basic settings, on page 116
• Playlist > Highlight settings, on page 117
8
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Adding and configuring a Preview device
To use Xbuilder’s features for previewing the playout and/or render a page/scene to file, 
you must specify which device Xbuilder will use to perform these tasks. In most cases, a 
Vertigo Software CG device is used for previewing and rendering to file in Xbuilder. 
Note:The XGSoftware license is required to fully use the preview feature.To add and 
connect Xbuilder to a Preview device:

1 Open the Device Configuration window by selecting Tools>Device Manager. 
2 In the Device Configuration window, select the Add button:
3 The Device Configuration windows expands to reveal two tabs (General and 

Advanced) with settings for identifying the device’s configuration.
4 Specify the appropriate General Device Configuration settings:

5 Click Apply.
6 In the Device Configuration dialog box, click in the cell to the right of Preview. 
7 Select the device from the table at left and then click .  

The device now appears next to the Preview box at right.
8 Click Close.

When Xbuilder successfully connects to the preview device, the LED in the lower right 
corner of the Xbuilder window is green and when disconnected, it is red.

Device name The name of the selected device. This can only be modified when 
adding a device.

Device alias An alternative name for the selected device on your network.

Description An optional field that lets you label the device to distinguish it from 
other similar devices at your facility (for example).

Device Type Identifies the type of device that these settings apply to. Select 
Preview (or other device) for Software CG devices.

Control IP The network location (IP address) or hostname of the selected 
device. The host must be available on the network.

Control Port The networking port that serves as a channel for sending commands 
to and from the device.

Publish IP The network location (IP address) or hostname of the selected 
device. The host must be available on the network.

Publish Port The networking port that serves as a channel for publishing assets. 
Typically, this value is set to 15000.
Note: This value must correspond with the port used by the 
XpublishAgent on the output device.
9
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Configuring a device for the verification of playlist elements
Xbuilder can be configured to manually or automatically verify the elements of a playlist 
have been published to specified devices. Elements that have not been published are 
identified and highlighted in the playlist so that they can be published. For this verification 
step to be accomplished, the target devices that will be checked must first be assigned in 
the Device Manager.

To specify a device for the verification of playlist elements:
1 Open the Device Manager by selecting Tools>Device Manager. 

The Device Configuration dialog box appears.
2 Verify that the intended output device is listed in the Device Configuration dialog box. 

If it is not, then you must add it to the device list.
a In the Device Configuration window, select the Add button.
b The Device Configuration windows expands to reveal two tabs (General and 

Advanced) with settings for identifying the device’s configuration.
c Specify the appropriate General Device Configuration settings:

Device name The name of the selected device. This can only be modified when adding a 
device.

Device alias An alternative name for the selected device on your network.

Description An optional field that lets you label the device to distinguish it from other 
similar devices at your facility (for example).

Device Type Identifies the type of device that these settings apply to. Choose from the 
following: VertigoXG, IntuitionXG, Preview (or other device), 
ImageStore, Intuition, FTP, LGK, DSK, HMP, or Other.

Control IP The network location (IP address) or hostname of the selected device. The 
host must be available on the network.

Control Port The networking port that serves as a channel for sending commands to and 
from the device.

Publish IP The network location (IP address) or hostname of the selected device. The 
host must be available on the network.

Publish Port The networking port that serves as a channel for publishing assets. 
Typically, this value is set to 15000.
Note: This value must correspond with the port used by the XpublishAgent 
on the output device.
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d Specify the appropriate Advanced Device Configuration settings:

e Click Apply. 
The device is added to the Device list in the Device Configuration dialog box.

Clip Template The name of the template that is used to play out clips. The clip template’s 
control-side must have a texture linked to a scene-side clip object. Use the 

 button to navigate to the Clip template. 
Note that among the Vertigo Suite’s system templates are valid clip 
templates for various scene formats. The system templates are export files 
that are stored in the following directory: Program 
Files\VertigoXmedia\Apps\Support. Once imported into the Xmedia 
Server, the templates are stored in the Templates>System Templates 
category.
The Clip Template field only appears when one of the following device types 
is selected: Vertigo XG, Intuition XG, Preview (and other devices), or Other.

Cel Template The name of the template used to play out cel animations. The cel template’s 
control-side must have a texture linked to a scene-side clip object. Use the 

 button to navigate to the Cel template.
Note that among the Vertigo Suite’s system templates are valid Cel 
templates for various scene formats. The system templates are export files 
that are usually stored in the following directory: Program 
Files\VertigoXmedia\Apps\Support. Once imported into the Xmedia 
Server, the templates are stored in the Templates>System Templates 
category.
The Cel Template field only appears if one of the following device types is 
selected: Vertigo XG, Intuition XG, Preview (and other devices), or Other.

Image 
Template

The name of the template used to play out images. The image template’s 
control-side must have a texture linked to a scene-side clip object. Use the 

 button to navigate to the Image template.
Note that among the Vertigo Suite’s system templates are valid image 
templates for various scene formats. The system templates are export files 
that are usually stored in the following directory: Program 
Files\VertigoXmedia\Apps\Support. Once imported into the Xmedia 
Server, the templates are stored in the Templates>System Templates 
category.
The Image Template field only appears if one of the following device types is 
selected: Vertigo XG, Intuition XG, Preview (and other devices), or Other.

External Keyer Allows you to associate another device with the current device. This setting 
is specifically used when the CG output is keyed over the ImageStore output. 
In this way, specific commands can be sent to the ImageStore (the External 
keyer) when specific things are done on the CG.

Publish Master Lets you select a master device.
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3 In the Device Configuration dialog box, select the text box to the right of Device1.
4 Select the device name from the table and click . 

The device appears in the box on the right side with its name in the Device1 field. 
5 Click Close on the Device Configuration dialog box.
6 Restart Xbuilder and ensure that the device was added to the Device for Verify drop-

down list in the upper-right corner of Xbuilder’s Playlist Editor toolbar.
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Creating, editing and previewing pages 
and/or scenes
In the Vertigo Suite workflow, Xstudio is used to author scenes, which display graphical 
elements (i.e. text, images, video clips, and cel animations) on air. Scenes can be standalone 
or they can be associated with a template. A template is an interface that lets operators 
control and edit parts of the scene without disturbing the scene’s layout or formatting.

The benefit of using template-based graphics is that once you have created a scene and 
template in Xstudio, rather than recreating the control and layout for similar projects, you 
can use the template and scene in Xbuilder to create multiple instances of the graphics 
(called pages) by simply changing the content (i.e. enter the new text, images, clips, and/or 
animations specific to the broadcast). Also note that no matter how many times the page is 
edited, the page retains its ties to the template that it was created from. The advantage of 
this is that changes to the template are easily propagated to all of the pages that were built 
from using that template.

There are actually two types of pages that can be created using Xbuilder: shared or 
embedded. Both types of pages provide the same playout performance in a playlist. The 
main consideration that should be taken into account is whether the page is intended to be 
included in only one or many playlists.

• Shared pages are the preferred type of page as they are created directly from an 
existing template and they are saved to the Xmedia Server as distinct assets. Shared 
pages can be used in many different playlists as a common item.

• Embedded pages are most often created from another existing page. Unlike shared 
pages, embedded pages only exist within a playlist, and it is the playlist that is saved as 
a whole to the Xmedia Server. As a result, the individual page does not exist anywhere 
else, not even in the Pages root category of the Asset Browser. Embedded page can be 
reused outside of its playlist if its playlist is inserted or appended to another playlist, or 
if the page converted into a shared page using the Save as Shared page command. See 
page 49 for instructions on creating and adding embedded pages to a playlist.

The following sections provide instructions for using Xbuilder to create and populate 
graphics pages and scenes, either individually from a template/scene or as a batch using a 
Merge List file:

• Creating an individual shared page from a template, on page 14
• Creating pages and/or scene using a Merge List, on page 15
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Creating an individual shared page from a template
Shared pages are graphics created as an instance of an existing template. They are stored 
on the Xmedia Server as an distinct assets and can be used in many different playlists as a 
common item. Like all pages, the shared page’s formatting is linked to the original template 
(changes to the template’s formatting are automatically applied to the page). The following 
instructions describe how to create an individual shared page.

To create a new shared page from a template:
1 Open Xbuilder.
2 In the Asset Browser, navigate through the Templates root directory until you see the 

desired template listed in the Template Editor.
3 Double-click the template, or right-click on the template listed in the Template Editor 

and select the Open command from the context menu.
The template opens in the Template Editor.

4 Set or edit the variable fields in the template as required (see Editing a page or scene’s 
content elements, on page 21 for assistance).

5 Select the File>Save as a Shared Page command.
The Save Page dialog box appears.

6 In the Name field enter a new name for the page.
7 In the RecallID field enter a unique a unique alpha-numeric identifier that can be used 

in Vertigo Suite applications (i.e. Xbuilder, Xplay) to quickly call up the specific page. 
(optional)

8 Enter your name in the Author field (optional).
9 Enter a short description of the page in the Description field (optional).

10 Link the page to the Pages root category or to sub-categories by selecting the check 
box for each place where you want the page to be accessible from.

11 Click OK to save the page and exit the dialog box.
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Creating pages and/or scene using a Merge List
Xbuilder’s Merge List feature (Actions>Open Merge List) allows you to create multiple 
pages and/or scenes from a single Merge List file (spreadsheet or XML file). Acting as the 
data source, the Merge List file provides Xbuilder with the information it needs to create 
new instances of pages/scenes from existing template and scene assets.

The following table describes the Merge List workflow for creating new pages and/or 
scenes:

Step Task Description

1 Configure Xbuilder’s Merge List settings
Specify the default categories in which new pages and scenes will be stored. Since 
scenes will only be moved to the default category after they have been approved, 
you must also specify a temporary category for new scenes. 

1 Open Xbuilder and select Tools>Settings>Merge List. 
2 For each of the settings, select the  button and select a destination 

category. See Merge List settings, on page 111 for more information.

2 Create the templates and scenes in Xstudio
In Xstudio, create or verify the existence of the templates and scenes that you want to 
create the new pages and scene from.

3 Create the Merge List file
Xbuilder generates the new pages and/or scenes based on the data provided in the 
Merge List file. The Merge List file can be in XML format or an Excel spreadsheet. The 
following sections provide instructions for creating an appropriate Merge List file:
• Creating Merge List file in Microsoft Excel, on page 16
• Creating an XML Merge List file, on page 18

4 Load the Merge List file in Xbuilder
When a Merge List file is loaded, Xbuilder generates the new pages and/or scenes 
based on the data provided in the Merge List file. After being processed, the new 
pages and/or scenes are added to a playlist in Xbuilder’s Playlist Editor.

1 Open Xbuilder and select Actions>Open Merge List.
2 Use the Open Merge List File window to open the Merge List file.

5 Approve or reject the new pages and/or scenes
When new pages are generated by the Merge List, they are added to the playlist as 
embedded pages until they have been “approved”. Approved pages become assets 
(shared pages) and they are saved in the specified default render path. Rejected 
pages remain in the playlist as embedded pages. 
When new scenes are generated by the Merge List, they are first placed in the 
specified temporary scenes category. Scenes are only moved to their specified render 
path location after they have been approved. Rejected scenes remain in the 
temporary scene folder. See page 20 for instructions on how to approve or reject new 
pages and scenes.

6 With the new pages/scenes, you can perform the following tasks:
• Preview the new pages/scenes on a software CG (see page 22).
• Render all or an individual page/scene to a clip file (see page 25).
• Create and save a snapshot image of a new page or scene (see page 23).
• Perform edits to the content of new pages/scenes (see page 21).
15



Creating, editing and previewing pages and/or scenes
Creating Merge List file in Microsoft Excel
Creating Merge List file in Microsoft Excel
The Merge List file can be in the form of a Microsoft Excel spreadsheet (.xls only), which 
contains specific column headers that allows Xbuilder to create new pages and/or scenes 
from existing assets (templates/scenes), apply specific attributes, and/or populate the 
asset’s fields.

Fig. 3-1: Merge List spreadsheet

Figure 3-1 provides and example of a Merge List spreadsheet and demonstrates that the 
first row in the Merge List spreadsheet contains the mandatory column headers for the data 
the Xbuilder needs to create the new pages and/or scenes. 

The following list identifies and describes the columns and information are mandatory or 
commonly used in a Merge List spreadsheet: 

• PageName: The path and asset name of the template that the new page will be created 
from or the scene from which the new scene will be based.

• OutputName: The path and asset name given to the new page or scene. The 
outputName specified can be fully qualified. If it is not fully qualified the new page will 
be saved to a default path specified in the settings. If no default path is specified will 
then save to the asset root category. 

• RecallId: An alpha-numeric identifier given to the new page or scene. (Optional) 
• ExpiryDate: The date when the new page or scene is to be deleted from the repository. 

The format is yyyy-mm-dd. (Optional) 
• PublishLifespan: The number of days that must elapse since the last time the new page 

or scene has been accessed before it is removed from the published device. This does 
not remove it from the repository. (Optional) 

• RenderProfile: The name of the render profile to use when the user wants to render the 
page to file. The name of the render profile is defined inside of the render profile xml. 

• RenderPath: The folder where the user wishes the rendered file will be saved. 
• Duration: The duration of the page in dropframe timecode. This will be the duration of 

the file generated.
• <objectName>: Column 9 (I) and beyond are the name of a target control side object. 

The target object can be a text, textbox, image, clip, or cel animation object. 
The value for the image, clip, or cel animation override can be a fully qualified asset 
name. If the asset name is not fully qualified the asset will be searched for by the 
existing object's type. The asset from the first category in which it was found will be 
used. If the asset is not fully qualified and there is no existing object in the originating 
template then the asset cannot be found.
The object type is not defined in the object name to allow the reuse of the object 
names across types. This reduces the number of columns in the spreadsheet. 

Be mindful of the following conditions and behaviors when creating or using the Merge List 
spreadsheet file:

• Do not enter blank rows between the data as blank rows are interpreted as the end of 
file. 
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• If the name and category specified for the new page or scene matches an existing 
page/scene and the Merge List is being processed, you will be prompted as to whether 
you want to replace it.

• If the specified recalI Id is already being used elsewhere, the new page or scene will 
steal the recalI Id. 

• The items specified in the Merge List will be converted into embedded pages in a 
playlist. Once approved, the embedded pages from the playlist will then be saved as 
shared pages.
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Creating an XML Merge List file
The Merge List file can be in the form of a XML file, which contains specific attributes (tags) 
allowing Xbuilder to create new pages and/or scenes from existing assets 
(templates/scenes), apply specific attributes, and/or populate the asset’s fields.

The following example and the list below identifies and describes the attributes (XML tags) 
that are mandatory or commonly used in a Merge List to create new instance of pages 
and/or scenes:

<MergeList>

<Page name="Template/scene name" outputName="New page/scene name" 
recallId="recall ID" expiryDate="yyyy-mm-dd" 
publishLifespan="#days" renderProfile="renderProfile" 
renderPath="C:\folder" duration="#seconds">

<Textbox name="Textbox name">value</Textbox>

<Image name="Image name">value</Image>

<Clip name="Clip name">value</Clip>

<CelAnimation name="Cel name">value</CelAnimation>

</Page>

</MergeList>

• Page name - The name of the template or scene to base the new page or scene on. The 
name must be fully qualified. 

• outputName - The name given to the new page or scene. The outputName specified 
can be fully qualified. If it is not fully qualified the new page will be saved to a default 
path specified in the settings. If no default path is specified will then save to the asset 
root category. 

• recallId - The recallId given to the new page or scene. This can be alpha-numeric. 
(Optional) 

• expiryDate - The date when the new page or scene is to be deleted from the 
repository. The format is yyyy-mm-dd. (Optional) 

• publishLifespan - The number of days that must elapse since the last time the new 
page or scene has been accessed before it is removed from the published device. This 
does not remove it from the repository. (Optional) 

• renderProfile - The name of the render profile to use when you want to render the 
page or scene to a file. The name of the render profile is defined inside of the render 
profile xml. 

• renderPath - The folder where you want the rendered file will be saved. 
• duration - The duration of the page or scene in dropframe timecode. This will be the 

duration of the file generated. 
• Textbox name - The name of the target textbox. Value is the text to be set on the 

textbox. 
• Image name - The name of the target image object. Value is the name of the image 

asset to set on the image object. 

Note: Each new instance of a page or scene must be specified within 
a separate Page name node.
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• Clip name - The name of the target clip object. Value is the name of the clip asset to set 
on the clip object. 

• CelAnimation name - The name of the target cel animation object. Value is the name of 
the cel animation asset to set on the cel animation object. 

Note: The image, clip or celAnimation value specified can be a fully 
qualified name. If it is not fully qualified the image, clip, celAnimation 
from the first category in which it was found will be used. 
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Approving or rejecting new pages and scenes created from a Merge List
When new pages are generated by the Merge List, they exist only in the playlist as 
embedded pages, which means that the pages are not yet assets and that they only belong 
to that particular playlist. Therefore unless you save the playlist, you delete the new 
embedded pages. To conserve the pages for future use in other playlists, you can save them 
as shared page assets by using Xbuilder’s Approve feature.

Unlike pages, when new scenes are generated by the Merge List, they immediately become 
assets and are placed in the specified temporary scenes category. The scene assets remain 
in the temporary category until they are approved. Upon approval the scene assets are 
moved to the specified render path location.

To approve or reject new pages and scenes:
1 Verify that the default category settings in Xbuilder’s Merge List settings 

(Tools>Settings>Merge List) are properly configured (page 111). 
2 If not already done, open the Merge List in Xbuilder (page 23). The new pages and/or 

scenes will be generated and displayed in a playlist in Xbuilder’s Playlist Editor.
3 There are two (2) methods for approving new pages and/or scenes:

• Approved All - To quickly approve all of the items (pages & scenes) in the playlist, 
click the Approve all items in Mergelist button  in the Playlist Editor’s toolbar. 
Xbuilder runs through each item in the playlist, moves the assets to the 
appropriate categories, and changes the item’s status in the playlist to Approved.

• Approve individual - To approve new pages and/or scenes individually, select the 
item in the playlist. The selected page/scene opens in Xbuilder’s Template Editor. 
Click the Approve and Next button  in the Template Editor’s toolbar to approve. 
Xbuilder then creates the shared page asset, moves the asset to the appropriate 
category, and changes the item’s status in the playlist to Approved. 

4 To reject the page/scene, click the Reject and Next button  in the Template Editor’s 
toolbar. When rejected, scene assets remain in the temporary category, while pages 
remain as embedded pages in the playlist. In both cases, Xbuilder changes the item in 
the playlist to red and its status to Rejected. 
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Opening an existing page or scene
There are two (2) ways to open and display an individual page or scene in Xbuilder: 

• Navigating through the Asset Browser’s Pages or Scenes root category and the 
page/scene assets are listed or previewed in the panel to the right of the Asset Browser. 
Double-click the asset’s name and the page/scene will open in the Template Editor.

Or,
• With a populated playlist open in the Playlist Editor, double-click a page or scene item 

in the playlist and it opens in the Template Editor. 

Editing a page or scene’s content elements
When you open a standalone scene in Xbuilder’s Template Editor, you can make and save 
changes to the content of editable objects within the scene (i.e. change the image, edit the 
text, choose another cel animations...etc.), but you cannot reposition or make any other 
changes to the scene’s layout. 

Unlike scenes, when you open a page or template in Xbuilder, it is not the scene-side of the 
project that is displayed in the Template Editor, but rather the control-side (template). The 
control-side contains objects that are pre-programmed to control the content and behavior 
of the objects on the scene-side. Therefore, you can make certain modifications to the 
associated scene’s variable content fields before sending them to air, including:

• setting text in text boxes by clicking within the text box and typing in text.
• selecting a listed items from drop-down boxes 
• selecting check boxes to indicate a choice or enable a setting
• replacing existing images, cel animations, or clips with another of the same type

Replacing an image, cel animation, or clip on a page
The following instructions guide you through how to replace an image on a page/scene, 
however, the procedure is identical for replacing cel animations and clips.

To change an image:
1 Open the page so that it is displayed in Xbuilder’s Template Editor.
2 Right-click on the image. 

The Select an image dialog box is displayed.
The tree view at left lists all eligible categories from which a new image can be chosen. 
By default, the category containing the image is initially displayed. The selection of a 
new image may be restricted to a specific category. In this case the tree view shows the 
contents of this category instead of the Images root category.

3 Double-click the folder that contains the required image. Click the Proxy View button 
 to display the folder’s contents as proxies, or click the List View button  display 

detailed asset information.
4 Double-click the desired image in the right window pane, or select the desired file and 

then click the Select button. The Select an image dialog box closes and the new image 
appears in the page.
21



Creating, editing and previewing pages and/or scenes
Using Work Orders to request missing images or clips
Using Work Orders to request missing images or clips
While creating or editing a page, you may realize that the Xmedia Server does not contain 
the specific image or video clip asset that you need for your page. In such a case, Xbuilder 
allows you to create a work order (see page 91), which is a set of requests directed at your 
graphics department for the creation and addition of the required asset to the Xmedia 
Server. Each request in the work order is known as a job. While creating the job request, you 
can insert a placeholder on the page. Once the asset is ingested into the Xmedia Server and 
the job is complete, the placeholder is automatically replaced by the new image/video and 
the page is ready to go to air.

Xbuilder also allows you to view all of the work orders and jobs on your system through the 
Asset Browser’s Work Orders and Jobs categories.

The Work Order Management System is a feature that must be installed and configured on 
the Xmedia Server. For a more detailed description about configuring the Work Order 
Management system, please refer to the Xmedia Server Configuration Guide.

Since creating and fulfilling work orders and jobs is the same in Xbuilder and Xnews, we ask 
that you please consult the Xnews User Guide for instructions and information about Work 
Orders.

Previewing a page or scene on the Preview device
Since only a static version of the control-side of a template or page is displayed in Xbuilder’s 
Template Editor, it may not provide you with a true representation of how it will look when 
played out on a device. Similarly, standalone scenes open as static displays, meaning that 
you are not able to view the playout of any cel animations, clips or animated properties 
associated with the scene.

Xbuilder offers the Preview Page/Scene command  in the Template Editor’s toolbar as a 
method for viewing the playout of the template, page or scene that you currently have 
open in the Template Editor. The Preview Page/Scene renders and plays out the video, 
audio, and animation elements of the page/scene on the preview device (Software CG) 
specified in Xbuilder’s Manager. 

To preview a template, page, or scene on a connected device:
1 Set up the preview device.

In most cases, the device used for previewing the playout will be a Vertigo Software CG. 
Therefore, you should verify that the software CG is specified in the SWCG Executable 
Location parameter on Xbuilder’s General setting page and that the device is also 
properly configured as the Preview device in Xbuilder’s Device Manager. 

2 Open the desired template, page, or scene so that it is displayed in Xbuilder’s Template 
Editor.

3 Select the Preview Page/Scene command  from the Template Editor’s toolbar.
A publishing status bar briefly appears in the right-corner of the Template Editor’s 
toolbar. Once the publishing is complete, the scene automatically begins to play in the 
software CG’s playout window.
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Saving a snapshot (image file) of a page or scene’s playout
The Take Snapshot of Page/Scene command  in the Template Editor’s toolbar allows 
you to render and save (as an image file) a single frame of the scene’s playout. This is 
particularly useful when the template, page or scene contains clips and/or cel animations, 
as you can specify the exact frame during playout to capture. The resulting image file can 
then be easily distributed (i.e. by email or file transfer) for feedback and/or approval.

To render and save a snapshot of a template, page or scene’s playout:
1 Verify that Xbuilder is properly configured/connected to a preview device (Software 

CG) in the Device Manager and that the software CG is specified in the SWCG 
Executable Location parameter on Xbuilder’s General settings page.

2 Verify, or edit, the Render Path location where the image file will be saved to by 
opening the Software CG’s Dashboard application and selecting the 
Advanced>General page.

3 Open the desired template, page or scene asset so that it is displayed in Xbuilder’s 
Template Editor.

4 Select the Take Snapshot of Page/Scene command  from the Template Editor’s 
toolbar.
The Take Snapshot dialog box appears.

5 Type a name for the rendered image file in the Target filename field.

6 Verify the Start Offset value, which determines the specific frame of the playout that 
will be extracted.

7 Click the Render button and a publishing status bar appears in the right-corner of the 
Template Editor’s toolbar. Once the publishing is complete, the scene appears on the 
preview device and the frame is automatically converted to an image and saved to an 
image file in the specified render folder.

8 Navigate to the directory where the image was saved (Render Path setting from 
step 3). Open the saved file and the image will display in your targa (.tga) compatible 
media viewer.

Note: The rendered image format of a snapshot is always Targa (.tga). 
As such, the Render Format property in the Take Snapshot dialog box 
cannot be changed.

Note: Since the duration of a snapshot is always one frame, the 
Duration property in the Take Snapshot dialog box cannot be 
changed. Similarly, the Quality level property is fixed at High and 
cannot be changed.
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Saving a snapshot (image file) of a page or scene’s playout
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Rendering pages and scenes to a clip file
Xbuilder’s Render to File feature allows you to render and save the playout of templates, 
pages and scenes as a video clip files. This is particularly useful when a template, page or 
scene contains clips and/or cel animations, since the resulting clip file captures and saves 
the full video, audio and animation elements of the scene’s playout.

There are three (3) workflows in which Xbuilder’s Render to File feature is intended to be 
used:

• Render to VAF for pre-rendered playout, on page 26
• Render to MXF for playout on a video server, on page 27
• Render to MPEG for preview, on page 28

Regardless of which workflow you choose, Xbuilder provides the following two (2) methods 
for rendering pages and/or scenes to a clip file:

• Manual rendering pages and/or scenes to a file, on page 29
Uses the Template Editor’s Render Page/Scene to File button  to render and save 
the playout of an individual scene to a clip file.

• Batch-rendering of pages and/or scenes to a file, on page 30
When a Merge List is used to create pages and scenes, all of the resulting pages and 
scenes can be rendered and saved as individual video clip files using the Playlist Editor’s 
Render all items in playlist button .
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Render to VAF for pre-rendered playout
Xbuilder’s Render to File feature uses the Vertigo Software CG’s rendering engine to render 
pages and scenes into .vaf (Vertigo Animation Format) files. The rendered VAFs can then be 
easily ingested (as-is) into the Xmedia Server by setting up a watch-folder using the Vertigo 
File Ingest Service for playout on Vertigo XG devices.

The advantage of pre-rendering pages and/or scenes to VAF is that it minimizes risk during 
the playout by eliminating live rendering and data insertion. 

In the Render to file (VAF) workflow, master templates are first created in Xstudio. Once the 
templates are opened in Xbuilder, pages are created by populating the templates with 
instance data (either individually or as a batch using a Merge List). When Render to File is 
executed, the new pages are rendered and saved to disk (not the Xmedia Server) as VAF clip 
files. You can then import the files into the Xmedia Server and the VAFs can be played out 
on Vertigo XG devices.

Fig. 4-1: Render to file (VAF) workflow

NOTES
• Rendering VAF files requires the XG Encode license.
• VAF is a heavily compressed format and encoding times can be very long. 

The encoder is multi-threaded and will scale to the number of available cores.
• VAF looping points cannot be set in this workflow.
• VAF clips will automatically be cropped based on the scene’s content.
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Render to MXF for playout on a video server
Xbuilder’s Render to File feature uses the Vertigo Software CG’s rendering engine to render 
pages and scenes into XDCAM and IMX compatible MXF files that are natively supported on 
virtually all modern playout servers. 

When you configure the Render to File feature, you select the output format from among 
the following render format profiles:

• MXF IMX 25 (PCM audio)
• MXF IMX 30 (PCM audio)
• MXF IMX 40 (PCM audio)
• MXF IMX 50 (PCM audio)
• MXF MPEG2 (PCM audio) HD
• MXF MPEG2 (PCM audio) SD
• MXF XDCAM HD-50 (50 Mbit 4:2:2) (PCM)

In the Render to file (MXF) workflow, master templates are first created in Xstudio. Once the 
templates are opened in Xbuilder, pages are created by populating the templates with 
instance data (either individually or as a batch using a Merge List). When Render to File is 
executed, the new pages are rendered and saved to disk (not the Xmedia Server) as MXF 
clip files. The MXF files are now ready for eventual playout on a 3rd party video server.

Fig. 4-2: Render to file (MXF) workflow

NOTES
• Supplied profiles are heavily tuned and are not intended to be modified by the end-

user.
• Render to playout server compatible formats requires the XGEncodeForPlayout 

software license. However, MPEG2 encoding only requires the XG Encode license.
• Encoding scales to the number of CPU cores on the system running Xbuilder.
• MXF files generated by Xbuilder are not intended to be re-ingested into the Xmedia 

Server.
• MXF Op1a has been deprecated on Windows 7.
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Render to MPEG for preview
Xbuilder’s Render to File feature uses the Vertigo Software CG’s rendering engine to render 
pages and scenes into MPEG clip files that can be saved to disk and then viewed on most 
media players.

Rendering pages and scenes to MPEG is mainly used in situations where you want to share 
and allow others to preview the file’s playout using a portable and common playout format.

The Render to file (MPEG) workflow starts with the creation of master templates in Xstudio. 
Once the templates are opened in Xbuilder, pages are created by populating the templates 
with instance data (either individually or as a batch using a Merge List). When Render to File 
is executed, the new pages are rendered and saved to disk (not the Xmedia Server) as MPEG 
clip files. The MPEG files can then be ingested into the Xmedia Server or distributed for 
previewing and/or approval.
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Manual rendering pages and/or scenes to a file
When an individual template, page, or scene is open in Xbuilder’s Template Editor, you can 
use the Render Page/Scene to File button  in the Template Editor’s toolbar to capture 
and save the asset’s playout to a video clip file.

To render and save a template or page as a video file:
1 Verify that Xbuilder is properly configured/connected to a preview device (i.e. Software 

CG) in the Device Manager.
2 Open the Xbuilder Settings window (Tools>Settings) and configure the SWCG 

Executable Location parameter on the General settings page.
3 Select Render To File in the Settings window and configure the default settings.
4 Open the template, page or scene so that it is displayed in Xbuilder’s Template Editor.
5 Select the Render Page/Scene to File button  from the Template Editor’s toolbar.

The Render to File dialog box appears.
6 Type a name for the rendered file in the Target filename field.
7 Select the desired video format for the rendered file from Render Format drop-down 

list. 

8 You can edit the Duration value, if you want it to be different from the value specified 
in the Default Duration field in the Render To File settings (step 3).

9 Press the Render button and a publishing status bar appears in the right-corner of the 
Template Editor’s toolbar. Once the publishing is complete, the captured video 
automatically starts to playout on the preview device and the video file is saved to the 
default render path folder.

Note: If you load an HD scene and specified an SD profile (or vice 
versa), the render fails. The profile must be consistent with the format 
of the scene.

Note: The rendered video file is saved to the specified location on your 
system and it is not saved as a Clip asset on the Xmedia Server. If at 
anytime you want to use the render clip file as an asset within the 
Vertigo Suite, you must use Xstudio or Xplorer to import/ingest the 
video file into the Xmedia Server.
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Batch-rendering of pages and/or scenes to a file 
When a Merge List is used to create pages and scenes, all of the resulting pages and scenes 
can be rendered and saved as individual video clip files using the Playlist Editor’s Render all 
items in playlist button .

To render and save all of the resulting items from a Merge List:
1 Verify that Xbuilder is properly configured/connected to a preview device (i.e. Software 

CG) in the Device Manager.
2 Open the Xbuilder Settings window (Tools>Settings) and configure the SWCG 

Executable Location parameter on the General settings page.
3 Select Render To File in the Settings window and configure the default settings.

Although the settings associated with each item in Merge List file take precedent, 
configuring these settings is prudent in case the Render Profile and Duration attributes 
are not specified in the Merge List file.

4 Create the Merge List file and load it into Xbuilder using the procedure described on 
page 23.

5 Once the new pages and/or scenes from the Merge List have been created and are 
displayed in the playlist, select the Render all items in playlist button  from the 
Playlist Editor’s toolbar.
Xbuilder automatically launches the preview device and starts to publish and render 
each of the pages and scenes from the playlist. Once an item is published, the page or 
scene’s playout in previewed on the device’s display.

6 Once the process is complete, you can navigate to the directory where the clip file was 
saved and open the saved file in an appropriate media viewer.

Note: The Default Profile Path and Default Profile settings only need to 
be set when using Xbuilder on Windows7.

Note: The profile specified must be consistent with the format of the 
scene. The render will fail if they are different.

Note: The rendered video file is saved to the specified location on your 
system and it is not saved as a Clip asset on the Xmedia Server. If at 
anytime you want to use the render clip file as an asset within the 
Vertigo Suite, you must use Xstudio or Xplorer to import/ingest the 
video file into the Xmedia Server.
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Check (MC)
The Vertigo Quality Control (QC) workflow is the process by which graphics can be 
previewed and validated before they are published to the target devices and taken to air. 
The QC workflow creates the graphics files from Adobe After Effects Project compositions 
and a Make List spreadsheet (1). The resulting graphics are then brought into Xbuilder as a 
playlist where they can be previewed on the Software CG and validated 
(approved/rejected) individually (2). The status of each asset is updated in the Make List 
and the approved graphics are moved to the Approved Category folder on the XMS, which 
can be set up to automatically publish to the playout device(s).

Once the graphics are approved and published to the device(s), you can use the Vertigo 
Media Check (MC) workflow to quickly preview and verify that all of the approved graphics 
have actually been published to the correct devices (3). Opening an Air List in Xbuilder 
generates a playlist of approved graphics. The Air List is usually the same spreadsheet as 
the Make List, but the status of all of the assets are Approved. You can preview the graphics 
and/or launch a verification in which Xbuilder verifies the actual availability of the graphics 
assets on the targeted device’s database. The asset’s status is then reported back and 
displayed in the playlist.

By using the QC and MC workflows, you can be confident that your graphics are correct and 
that they are ready to go to air. 

The following sections provide instructions and details regarding the configuration and use 
of the Vertigo QC and MC workflows:

• Setting up the QC and MC workflows, on page 32
• Creating a Make List / Air List spreadsheet, on page 36
• Using AE Plug-in and the Make List to create and ingest graphics, on page 38
• Quality Control: Previewing and validating graphics in Xbuilder, on page 39
• Media Check: Graphics publish verification, on page 41
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Setting up the QC and MC workflows
Prior to using the Vertigo QC and MC workflows, some of the Vertigo Suite components  
(i.e. destination folders, Xbuilder, device manager, licensing) must be configured to ensure 
the proper coordination of resources.

The following sections provide instructions for configuring the Vertigo Suite for the QC and 
MC workflows:

1 Create and set up the Subfolders and Approved Category folders, on page 32
2 Specify Xbuilder’s settings for the QC and MC workflows, on page 33
3 Associate channels to devices in Xbuilder’s Device Manager, on page 33
4 Verify that the system templates are installed and publish them to the SWCG, on 

page 34
5 Verify the presence of the QC license, on page 35

Create and set up the Subfolders and Approved Category folders
We recommend that you create the Subfolders and Approved Category folders in advance 
of using the QC workflow’s Make List. The Make List’s Subfolders column specifies into 
which subcategory folders on the central Xmedia Server, new assets will be ingested to. 
Meanwhile, the Approved Category column identifies the folder into which the assets will 
be moved once they have been approved. See page 36 for more information about 
creating and using the Make List file.

A compelling reason to set up the Approved Category folders in advance is that it allows 
you to assign publish rules to these folders. That way, when the assets are moved from the 
subfolders upon approval, the assets will automatically be published to the appropriate 
playout device(s).

To create and set up the Subfolders and Approved Category folders:
1 Open Xplorer.
2 Create a new subfolder within the Clips and/or CelAnimations root categories for the 

ingested asset files.
a Right-click on the Clips root category and select the New Category command.
b Specify a name for the subfolder in the New Category dialog box and click OK.
c Repeat steps a and b for the CelAnimations root category.

3 Create a new folder within the Clips and/or CelAnimations root categories for the 
Approved Category.

a Right-click on the Clips root category and select the New Category command.
b Specify a name for the Approved subfolder in the New Category dialog box and 

click OK.
c Repeat steps a and b for the CelAnimations root category.

Note: If you choose not to pre-configure the Approved Category 
folder for auto-publish, you will have to manually publish the assets 
before being able to preview them on a device or before using the MC 
workflow.
32



Xbuilder
User Manual
4 Assign publish devices to the Approved Category folders.
a Right-click on the new Approved Category folder in the Clips root category and 

select the Properties command. 
The Publish Devices dialog box appears.

b Select the device(s) that you want the assets to be automatically published to and 
then click OK.

c Repeat steps a and b for the Approved Category folder in the CelAnimations root 
category.

Specify Xbuilder’s settings for the QC and MC workflows
To accommodate the QC and MC workflows, a few of Xbuilder’s settings must be 
configured. 

To configure Xbuilder’s settings for the QC workflow:
1 Launch Xbuilder.
2 In the Device for Verify drop-down list, select Use Playlist Devices.
3 Open Xbuilder's Settings dialog box (Tools>Settings).
4 Set the Xbuilder>General>Verify playlist parameter to Manual.
5 Set the Xbuilder>General>Number of Verify Devices to the number of devices that 

you expect to use for verifying assets.
6 Click OK in the Settings dialog box to apply the new settings and close the dialog box.

Associate channels to devices in Xbuilder’s Device Manager
Xbuilder’s Device Manager associates device channel names to actual physical devices. 
Xbuilder uses this association when previewing and performing media check of the asset 
on a device. 

When performing quality control tasks (validation), only the Preview device is required to 
be assigned to the local software CG in the Device Manager. However, when performing 
media checks, the number of devices that can be associated is the Preview device plus the 
number of devices identified in the Number of Verify Devices setting. 

The channel names in the Device Manager’s Name column are what you will enter in the 
Make List / Air List file’s Target Channel column. When Xbuilder performs a media check, it 
uses the data (channel names) in the Target Channel column to determine on which 
devices to look for published assets.

To configure Xbuilder’s Device Manager for QC and MC tasks:
1 Open Xbuilder’s Device Manager (Tools>Device Manager).
2 Set the Preview device to the local Software CG defined.
3 Change the default channel names that appear in the Name column by clicking in the 

cell and typing a new name.
4 Using the Device List and the Add To Active Devices button  associate each one of 

the channels to their respective devices.
Note that the channel names are used by the playlist to identify the target device(s) for 
each asset.
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5 Click Close in the Device Configuration dialog box to apply the changes and close the 
dialog box.

Verify that the system templates are installed and publish them to the 
SWCG

The QC and MC workflows require that a series of system templates be installed on the 
central Xmedia Server and published to all Vertigo preview and playout devices, including 
the Software CG. The system templates are general purpose "asset holders" for different 
asset types and different TV formats. 

Generally, the system templates are automatically added when the Vertigo Suite software is 
installed on the Xmedia Server and Vertigo hardware devices. Since the system templates 
are vital to the proper functioning of the QC and MC workflows, we recommend that you 
verify that all of the system templates are installed on the Xmedia Server and Vertigo 
playout devices using Xplorer.

The Vertigo Software CG is used by the QC and MC workflows as the preview device. Unlike 
the hardware playout devices, the system templates are not published to the Software CG 
during the Vertigo Suite installation. Therefore, you must publish the system templates to 
the Software CG device as part of the QC workflow configuration.

To verify that the system templates are installed on the central XMS and hardware 
playout devices:

1 Open an instance of Xplorer, which is connected to the central Xmedia Server.
2 Select the Xmedia Server in the Device Viewer.
3 In the Asset Browser, select Templates>System Templates and verify that all of the 

system templates are displayed in the Asset Gallery.
If the system templates are not present, or if some are missing, please import the 
templates from the following directory location: C:\Program 
Files\VertigoXmedia\Apps\Support\SystemTemplates.rar. Decompress the files 
to a local directory and import them to the Xmedia Server using Xplorer. If the 
templates still do not appear, please contact our Technical Support Services.

4 For each of the hardware playout devices, select the hardware device and then select 
Templates>System Templates in the Asset Browser. Verify that all of the system 
templates are displayed in the Asset Gallery.
If the system templates are not present, or if some are missing, please import the 
templates from the directory location identified in step 3 or publish the templates from 
the Xmedia Server to the device.

To publish the system templates to the Software CG preview device:
1 Open an instance of Xplorer, which is connected to the central Xmedia Server.
2 Select the Xmedia Server in the Device Viewer.
3 In the Asset Browser, select Templates>System Templates.
4 Right-click on the System Templates subcategory in the Asset Browser and select the 

Publish To>CG menu command. The Publish Progress window appears as the assets 
are published to the Software CG device.

5 Once the publishing is complete, close the Publish Progress window.
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6 Select the Software CG device in Xplorer’s Device Viewer.
7 In the Asset Browser, select Templates>System Templates and verify that all of the 

system templates are displayed in the Asset Gallery.
If the system templates are not present on the Software CG device, or if some are 
missing, please contact our Technical Support Services for assistance.

Verify the presence of the QC license
The QC and MC workflows requires that a valid QC license be installed and validated on the 
central Xmedia Server. Without a valid QC license, Xbuilder’s Open MakeList and Open 
AirList menu commands are disabled.

To verify that a valid QC license is installed and validated on the Xmedia Sever:
1 Open Xbuilder.
2 Select the Actions menu.

If the Open MakeList and Open AirList menu commands are enabled, then the QC 
license is properly installed and validated on the Xmedia Server.
If the Open MakeList and Open AirList menu commands are disabled:

a Open the License Manager (Help>License). 
b Click the Show Details button in the License Manager dialog box.
c Select the Licensed Applications and Devices tab.
d Verify the QC license is present in the list. If not, please contact our Technical 

Support team to obtain a valid QC license. If the license is present, please verify 
that the Xmedia Server and its services are properly running.
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Creating a Make List / Air List spreadsheet
Both the QC and MC workflows require you to create a specially formatted Excel 
spreadsheet called a Make List (for QC) or Air List (for MC). The same spreadsheet can be 
used for both QC and MC tasks since it contains the same mandatory data for creating and 
organizing the graphics assets. The main difference between the two files is that the MC 
workflow requires that all of the assets in the Air List’s have the Status column marked as 
Approved.

The Make List is an Excel Spreadsheet (.xls) whose data is used by the Vertigo After Effects 
Plug-in to create graphics assets (clips or cel animations) based on an After Effects project. 
The resulting asset are then stored automatically on the Xmedia Server. The same Make List 
is then used to create a playlist in Xbuilder, which is used during the quality control 
(preview and validation) and the media check tasks.

The first row in the Make List contains the mandatory column headers for the data that the 
After Effects Plug-in and Xbuilder need to create the assets and playlist. The following list 
describes the columns and information that must be present in the Make List spreadsheet:

• Project Name: The path and filename of the After Effects project. This information is 
used by the After Effects plug-in to generate the asset. This information is not used by 
Xbuilder.

• Output File Name: The name of the asset that is generated by the After Effects plug-in. 
The name must include the extension, so that Xbuilder can tell what the asset type is 
(i.e. Clip versus Cel animation) even though the extension does not appear in the asset 
name in Xmedia Server.

• Format: The format of the asset, which is used by Xbuilder to launch the software CG in 
the appropriate format to get the best preview possible. Acceptable values are:

• NTSC
• PAL
• HDTV_720_60
• HDTV_720_60M
• HDTV_720_50
• HDTV_1080_30
• HDTV_1080_30M
• HDTV_1080_25
• NTSC_16_9
• PAL_16_9

• Status: The status of the asset (Approved, Rejected). The After Effects plug-in only 
generate assets for those not marked as Approved. Xbuilder writes the status into the 
Make List that was opened.

• Approved Category: The category folder into which the assets are moved when they 
have been approved. The category should be read as Subfolder 1\Subfolder 

Note: To ensure that the Make List contains all of the required 
columns, a sample Make List is available to be used as a template: 
http://support.com/portal/software/Vertigo%20Software/Makelist_s
ample.xls
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2...\Subfolder N. We recommend that you create the Approved Category folder in 
advance so that you can assign publish rules to this folder. That way, when the assets 
are moved into this folders, they will also be automatically published to the appropriate 
playout devices. See page 32 for instructions. 

• Subfolder 1, ..., Subfolder N: The category folder into which the After Effects plug-in 
puts the asset when it is generated. This is the category folder where unapproved 
assets exist and rejected assets are moved to (from the approved category). We 
recommend that you create these folders in advance. See page 32 for instructions.

• Target Channel: A comma-delimited list of names of devices to which the asset is 
published. The devices specified must be the names of the target device channels, 
which are defined in the Name column in Xbuilder’s Device Manager. When Xbuilder 
generates the playlist, one playlist element will be created for each of the asset’s 
targeted device channels.

Fig. 5-1: Multiple target channels results in one playlist element for each of the asset’s targeted 
devices

Make List / Air List

Playlist

Device Manager
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Using AE Plug-in and the Make List to create and ingest graphics
The QC workflow uses the Vertigo After Effects Plug-in’s Merge Mode to create and ingest 
the graphics files (clips and/or cel animations) into the Xmedia Server. Using the Make List 
spreadsheet as an input, Merge Mode creates the graphics files from the specified Adobe 
After Effects Project composition(s) and then ingests them to the destination categories on 
the XMS. 

To use the After Effects Plug-in and Make List to create and ingest graphics files:
1 Launch Adobe After Effects and select the File>Export> Vertigo Animation (Merge 

Mode) menu command.
A message appears warning you that the project you currently have open will be 
closed without saving. To continue, simply click OK. 
The Export Vertigo Animation dialog box appears.

2 Click the  button in the Input - Data source file name field to navigate to and select 
the Make List spreadsheet.

3 In the Output destination section, enable Export to XMS server name / IP and then 
type either the Xmedia Server’s hostname or the IP address of the XMS device where 
the output files will be ingested to.

4 Enable Overwrite existing files / assets if you wish to automatically replace an existing 
file that may already exist using the exact same name in the exact same location.

5 Select the Options button to expose advanced options, which specify how the 
graphics files will be created, including specifying the looping behavior. See the “After 
Effects Plug-in User Manual” for more information.

6 Create the graphics files by clicking OK. 
The Export Vertigo Animation dialog box closes and the Export Progress dialog box 
appears to track the graphics files’ creation.

7 Verify that the files were ingested into the Xmedia Server by opening Xbuilder and 
navigate through the Asset Browser to the expected destination category and 
subfolder.

Note: If the subfolders were not previously set to automatically 
publish the assets to the target devices, you must open Xplorer and 
manually publish the assets to the preview and verify devices before 
proceeding.
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Quality Control: Previewing and validating graphics in Xbuilder
The QC workflow allows you to preview and validate (approve or reject) the graphics that 
the After Effects Plug-in and the Make List file created and ingested into the Xmedia Server.

When you open the Make List file in Xbuilder, a playlist is created that contains an element 
for each of the assets (pages) that were created by the After Effects Plug-in’s export. 
Selecting an element in the playlist, opens the page in Xbuilder’s Template Editor. 

To preview the page’s playout, select the Preview Page button and the page plays out in 
the local Software CG’s Live window. To validate the page, simply select either the Approve 
or Reject buttons. Approved assets are automatically moved to the Approved Category 
that was specified in the Make List spreadsheet, while rejected assets are flagged as such 
for further revising.

To use Xbuilder to preview and validate graphics created by using a Make List:
1 Launch Xbuilder and select Actions>Open MakeList... menu command.

The Open Merge List File dialog box appears.

2 Select and open the Make List file.
Xbuilder creates a temporary playlist with one element per asset. The first element is 
selected by default and is displayed in Xbuilder’s Template Editor pane. If an asset has 
multiple target devices, it will appear multiple times in the playlist with different target 
devices.
If there is any issue parsing the data or finding the asset, a comment is inserted in the 
playlist. 

3 To preview the page (element) selected in the playlist, simply click the Preview Page 
button  in Xbuilder’s Template Editor toolbar.
The page is automatically published and opened in the local Software CG’s Live 
window. The Live Window displays the page’s playout in the format associated with the 
page’s template. You can preview the page multiple times.

Note: The Open MakeList command is only enabled if a valid QC 
license is found on the Xmedia Server. Please contact our Technical 
Support team to obtain a valid QC license.

Note: When previewing a page, the Software CG and its Live window 
open automatically in the format associated with the page’s template. 
Each time you preview another page whose format is different from 
the current page, the Live Window closes and reopens in the 
appropriate new format. Also note that since these instances of the 
Software CG are launched by Xbuilder, the Software CG also closes 
when Xbuilder is closed.
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4 To validate pages, Xbuilder offers three (3) buttons in the Template Editor’s toolbar. 

5 After validating the pages, you can close the playlist and/or Xbuilder. Before closing, 
you are prompted to save the playlist. You can select No, since the playlist is meant to 
be temporary and each element’s status has already been saved to the Make List file.
If you need to revisit the playlist in the future, you simply have to open the Make List in 
Xbuilder as was described in step 1.

Approve
Select the Approve button if you are satisfied with the page’s playout and it is 
deemed ready to go to air “as-is”. Once Approved, the asset is moved to the 
Approved Category that was specified in the Make List spreadsheet. The 
element’s status is updated to Approved in the playlist and the status is written to 
the opened Make List spreadsheet. The next item in the playlist is then selected 
and opened automatically.
Note that approved assets may still be previewed and rejected by reselecting the 
element in the playlist.

Reject
Select the Reject button if you are not satisfied with the page’s playout and you 
would like it to be flagged for revision.
Once rejected, the asset is moved back to the original category. The element’s 
status is updated to Rejected in the playlist and the status is written to the 
opened Make List spreadsheet. The next item in the playlist is then selected and 
opened automatically.
Note that rejected assets may still be previewed and approved by reselecting the 
element in the playlist.

Skip
Select the Skip button to move down the playlist to the next element. 
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The Vertigo Media Check (MC) workflow allows Master Control to quickly verify that all of 
the assets that were validated (approved) during the QC workflow have been published to 
the target playout devices.

A prerequisite for the MC workflow is the QC workflow’s Make List with the Status all of the 
assets marked as Accepted. The Make List also must contain a column called Target 
Channel, which lists the devices on which to verify the publish. 

When used for MC workflow purposes, the Make List file is referred to as an Air List. The Air 
List file is imported into Xbuilder, which creates a temporary playlist that contains an 
element for each of the assets (pages). If an asset has multiple target devices, the asset will 
appear multiple times in the playlist with different target channels.

You can preview any of the assets on the Software CG selecting the page (element) in the 
playlist and clicking the Preview Page button  in Xbuilder’s Template Editor toolbar.

A media check is executed by clicking the Verify Playlist button . The availability of the 
asset is verified directly in the target device’s database. A comparison is also performed 
between the published graphic file on the device and the graphic file in the central Xmedia 
Server. The results of the verification and comparison are displayed in the item’s Status in 
the playlist. Possible status messages are: 

• Ready - The asset is published and ready to be used.
• Cannot Connect to Device - Xbuilder is unable to connect to the target device’s 

database. Either the device is offline or not properly defined in the Device Manager.
• Asset on Device but Not Published - The asset exists as an asset on the device’s 

database, but is not found in the publish folder. This occurs if someone deletes the 
published file without deleting the asset from the device’s database.

• Asset Not Published Or Is Not Same Version - The asset does not appear to be in the 
device’s database. You will also get this message if an asset of the same name exists on 
the device, but is not the same as the one on the central Xmedia Server. 

• Unknown Device - The asset is targeting a device that is not defined in the Device 
Manager.

To use Xbuilder and an Air List to verify that the assets have been published to the target 
playout devices:

1 Launch Xbuilder and select Actions>Open AirList... menu command.
The Open Air List File dialog box appears.

2 Select and open the Air List file.
If there is any issue parsing the data or finding the asset, a comment is inserted in the 
playlist. 

3 To preview the page (element) selected in the playlist, simply click the Preview Page 
button  in Xbuilder’s Template Editor toolbar.

Note: The Open AirList command is only enabled if a valid QC license 
is found on the Xmedia Server. Please contact our Technical Support 
team to obtain a valid QC license.
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The page is automatically published and opened in the local Software CG’s Live 
window. 

4 To verify that the assets in the playlist have been successfully published to the target 
device(s), simply click the Verify Playlist button . 
Xbuilder reports results of the media check query in the playlist’s Status column. 

Note: When previewing a page, the Software CG and its Live window 
open automatically in the format associated with the page’s template. 
Each time you preview another page whose format is different from 
the current page, the Live Window closes and reopens in the 
appropriate new format. Also note that since these instances of the 
Software CG are launched by Xbuilder, the Software CG also closes 
when Xbuilder is closed.
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Xbuilder allows you to build manual or automatic playlists, which are ordered sequences of 
program clips and branding and promotional graphics elements (i.e. pages or scenes). 
Manual playlists are typically designed to be played back sequentially by operator control 
using Xplay, while automatic playlists are typically designed to have specific time and 
duration values that are used during playback by Xplay. 

The following sections provide instructions for how to create and edit playlists in Xbuilder:
• An overview of the Playlist Editor, on page 44
• Procedural overview for creating a sequential playlist, on page 45
• Creating a new playlist, on page 46
• Opening an existing playlist, on page 46
• Populating a playlist, on page 48
• Appending or inserting the contents of a playlist to a playlist, on page 51
• Configuring the Playlist table columns, on page 53
• Repositioning playlist items within the playlist, on page 58
• Adding segments to the playlist, on page 60
• Adding comments to the playlist, on page 61
• Deleting playlist items from the playlist, on page 62
• Editing the properties associated to the playlist items, on page 64
• Saving a playlist, on page 66
• Reloading the playlist, on page 68
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An overview of the Playlist Editor
The Playlist Editor allows you to build sequential lists of graphic pages, scenes and clips. The 
contents and positioning of the elements in the playlist determine the playout order and 
duration of the playlist. 

The following descriptions provide an overview of the Playlist Editors’ features and 
components. 

Fig. 6-1: Playlist Editor components

1 Toolbar: A series of buttons that allows you to perform actions related to creating, 
opening, saving, and populating playlists. See Playlist Editor’s toolbar, on page 94 for a 
description of each button on the toolbar.

2 Name: Displays the name of the playlist that is currently displayed in the Playlist Editor. 
An asterisk appears beside the name until the playlist, or edits to the playlist, have been 
saved.

3 Device for Verify: Allows you to target a specific device or all of the configured devices 
when a playlist verification is executed. See Configuring a device for the verification of 
playlist elements, on page 10 and Opening an existing playlist, on page 46 for more 
details.

4 Playlist: The Playlist is the area where you create a sequential playlist by adding and 
organizing pages, scenes and clips into the intended playout order. Generally, each row 
in the playlist represents a page, scene or clip to be played out. To help further organize 
playlists, rows of pages, scene and clips can be gathered into playlist segments and 
comment rows can also be added. 
The playlist’s columns display information about each page included in the playlist. You 
can determine which columns are displayed or hidden in the playlist table by using the 
Column Layout dialog box. You can also determine the order in which the columns 
appear in the table. See Configuring the Playlist table columns, on page 53 for 
descriptions of each column and instructions for how to display or hide certain Playlist 
table columns.

1

2

4

3
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Procedural overview for creating a sequential playlist
The procedure below identifies the high-level steps involved in creating playlists for playing 
out branding and promotional graphics sequences. Subsequent sections (identified by the 
links within the procedure) provide step-by-step instructions for performing each step. 

To create a sequential playlist in Xbuilder:
1 Create a new playlist, or open an existing playlist.

• Creating a new playlist, on page 46
• Opening an existing playlist, on page 46
• Verifying the contents of a playlist, on page 47

2 Populate the playlist with pages, scenes, clips, and/or the contents of other playlists.
• Creating and adding an embedded page to a playlist, on page 49
• Adding shared pages, scenes and clip assets to a playlist, on page 50
• Appending or inserting the contents of a playlist to a playlist, on page 51

3 Determine which property columns you want displayed in the playlist.
• Configuring the Playlist table columns, on page 53

4 Organize the playlist items.
• Repositioning playlist items within the playlist, on page 58 (optional)
• Adding segments to the playlist, on page 60 (optional)
• Adding comments to the playlist, on page 61 (optional)
• Deleting playlist items from the playlist, on page 62 (optional)

5 Edit the playlist items’ properties.
• Editing the properties associated to the playlist items, on page 64 

6 Save the playlist
• Saving a playlist, on page 66

Additional tasks that can be performed using the playlist are:
• Reloading the playlist, on page 68
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Creating a new playlist
To create a new playlist, you must first open a new, empty Playlist Editor. If the Playlist Editor 
area is already occupied by another project (i.e. an existing playlist, rundown editor or 
segment window), performing the Create New Playlist action (described below) 
immediately clears the Playlist Editor space and a blank Playlist Editor appears, ready for 
use.

To create a new playlist:
• Select File>New Playlist.

Or,
• Click the Create New Playlist button  in the Playlist toolbar. 

Opening an existing playlist
Existing playlists are stored on the Xmedia Server. You can open existing playlists either 
from the Asset Browser or from the File menu.

To open an existing playlist using the Asset Browser:
1 Select the Playlists root category in the Asset Browser, and navigate to the appropriate 

category where the playlist is stored.
The playlists contained in the Asset Browser category is listed/displayed in the panel to 
the right of the Asset Browser.

2 Double-click the name of the desired playlist.
Or,
Right-click on the playlist’s name and select the Open command from the context 
menu.
The playlist opens in the Playlist Editor.

To open an existing playlist from the File menu:
1 Select File>Open Playlist. 

The Open Playlist dialog box appears.
2 Navigate through the Playlist categories in the right panel until the desired playlist is 

listed in the left panel.
3 Double-click the desired playlist listed in the right panel.

Or, 
Select the playlist and then click OK.
The playlist opens in the Playlist Editor.

Note: Xbuilder’s Merge List and Make List / Air List features are 
alternative ways of creating playlists containing new pages and/or 
scenes from an Excel spreadsheet or XML file. See Creating pages 
and/or scene using a Merge List, on page 15 and Performing Quality 
Control (QC) and Media Check (MC), on page 31 for more information.
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Verifying the contents of a playlist
When a playlist is opened in Xbuilder, you can run a verification of all of the items in the 
playlist to be certain that they have been published and are available on specific or all 
devices configured in Xbuilder’s Device Manager.

When a playlist verification is executed, each element in the playlist is verified as follows: 
• Checks if the assets used by the playlist element actually exist. 
• Checks if the assets that are used by the playlist element require the completion of a 

Work Order before they can be used. 
• Checks if the assets used by the playlist element are published on a specified device. If 

not, then it initiates the publishing of the assets.

There are two (2) ways in which you can perform a playlist verification: manual or 
automatic.

1 Open Xbuilder’s General settings page (Tools>Settings>General) and choose a value 
for the Verify Playlist setting:

• Choose Automatic if you want Xbuilder to automatically run a verification each 
time a playlist is opened in Xbuilder’s Playlist Editor.

• Choose Manual if you do not want playlists to automatically be verified each time 
they are opened in Xbuilder’s Playlist Editor.

2 In the Number of Verify Devices field on the General settings page, specify the total 
number of devices that you would like to set up in the Device Manager for the 
purposes of verifying playlist contents.

3 Click OK to close the Settings dialog box.
4 Open Xbuilder’s Device Manager (Tools>Device Manager) and following the 

instructions on page 10 for adding and configuring devices for playlist verification.
5 Select from the Device for Verify drop-down list, select the device(s) that you what to 

verify when the Verify Playlist task is executed. In the case where the playlist items 
already have a device assignment associated with them, you can select the Use Playlist 
Devices option, otherwise choose a specific device.

6 If Xbuilder’s Verify Playlist setting was set to Automatic, opening an existing playlist in 
Xbuilder results in an immediately playlist verification. 
If Xbuilder’s Verify Playlist setting was set to Manual, the playlist is not verified upon 
opening. However, in either case, you can execute a playlist verification at any time by 
clicking the Verify Playlist button  in the Playlist Editor’s toolbar.
The results of the playlist verification are reported directly in the playlist by highlighting 
erroneous items in red, as well as reporting problems in the item’s Status column.

Note: Regardless of whether you choose Automatic or Manual, you 
can manually execute a playlist verification at any time using the 
Verify Playlist button  in the Playlist Editor’s toolbar.
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Populating a playlist
Playlists are a sequentially ordered list of the video clips, scenes and graphic pages of a 
show. As described on page 13, there are two (2) types of pages that can be added to a 
playlist: embedded pages and shared pages. Since shared pages exist in the Xmedia Server 
as distinct assets, they can be used in many different playlists as a common item. 
Embedded pages are unique and independent, in that they are not linked to any other 
playlists. Any and all edits to an embedded page therefore only affect the playlist that it 
belongs to.

The following sections provide instructions for adding embedded and shared pages to a 
playlist:

• Creating and adding an embedded page to a playlist, on page 49
• Adding shared pages, scenes and clip assets to a playlist, on page 50

After you have create and saved a few playlists, you might have the need to create a playlist 
whose contents is very similar to one that already exists. Rather than adding each page, 
scene and clip individually again, you may want to append or insert the contents of the 
existing playlist (pages and clips) to the new playlist. See Appending or inserting the 
contents of a playlist to a playlist, on page 51 for instructions on using this method for 
populating a playlist.

Fig. 6-2: An example of a playlist that contains graphic pages, clips, segments, and comments

Note: Templates that are stored in the Asset Browser can be dragged 
and added to playlists. In doing so, an instance of that template is 
automatically converted into an embedded page unique to that 
playlist. In other words, it becomes an embedded page based on the 
template.
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Creating and adding an embedded page to a playlist
Creating and adding a new embedded page to the playlist results in the page existing only 
in that specific playlist, not as an asset in the Asset Browser to be used in additional 
playlists. 

The following instructions describe the commonly used method of creating a new 
embedded page from a template, followed by some alternative methods.

To create a new page from a template and add it to the playlist as an embedded page:
1 Click the Insert New Page button  in from playlist’s toolbar. 

The Select a template for the new graphic dialog box appears.
2 Navigate to the appropriate template asset within the Templates root category and 

sub-categories.
3 Double-click the template asset listed.

The template opens in the Template Editor.
Or,
Select the template in the Template Editor and click OK. 
The template opens in the Template Editor.

4 Set or edit the variable fields in the template as required (see Editing a page or scene’s 
content elements, on page 21 for assistance).

5 Optional: Preview the playout of the page using the Preview Page command  in 
the Template Editor’s toolbar (see Previewing a page or scene on the Preview device, on 
page 22).

6 Select the row in the playlist where you would like the page to be inserted (the page is 
inserted below the selected row).

7 Click the Insert in Playlist and Close button  from the Template Editor’s toolbar.
The page is immediately added to the playlist below the selected playlist row and the 
template closes leaving the Template Editor empty.

Alternative ways of creating and adding an new embedded page from a template 
include:

• Navigate through the Asset Browser’s Templates categories until the desired template 
is listed in the panel to the right of the Asset Browser. Select the desired template asset 
from the Template Editor and drag and drop it into the playlist.

• With a template open in the Template Editor, drag and drop the  icon (located in the 
upper portion of the Template Editor) into the playlist.

• If you have populated the Favorites Browser with existing templates, you can drag and 
drop these templates from the Favorites Browser into the playlist.

• Open a Merge List in Xbuilder and all of the new pages that are created are added to a 
new playlist as embedded pages until they are approved (then they become shared 
pages). See Creating pages and/or scene using a Merge List, on page 15 for more 
information.
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Adding shared pages, scenes and clip assets to a playlist
Shared pages, scenes and clips are three asset types that can be added to different playlists. 
Although these assets are stored on the Xmedia Server, they are accessible to Xbuilder 
through the Asset Browser.

The following instructions describe how to add shared pages, scenes and clip asset to a 
playlist by dragging the asset from the Asset Browser to the playlist. If however, the shared 
page or scene is already open in the Template Editor, a second set of instructions describes 
how to add that page or scene to the playlist.

To add a shared page, scene or clip asset to the playlist:
1 Select the Pages, Scenes or Clips root category in the Asset Browser, and navigate to 

the appropriate category where the asset is stored.
The assets contained in the pages, scenes or clips categories are then listed/displayed 
in the panel to the right of the Asset Browser.

2 Select the desired asset and drag it into the Playlist Editor.
Notice that a highlighted horizontal line appears in the Playlist Editor as you drag the 
pointer over the various rows in the playlist. This line indicates the location of where 
the asset will be inserted in the playlist. 

3 Drop the asset into the playlist by releasing the mouse button. 

To add an opened shared page or scene to the playlist:
1 With a shared page or scene open in the Template Editor, select the playlist row where 

you want the page to be inserted (the page will be inserted below the selected row).
2 Click the Save Page, Insert in Playlist button  located in the Template Editor’s 

toolbar.
Any unsaved changes that were made to the page or scene are immediately saved and 
the page/scene is added to the playlist below the selected playlist row.

Note: Since shared pages exist in the Xmedia Server as distinct assets, 
they can be used in many different playlists as a common item. A 
noteworthy drawback of using shared pages in multiple playlists is 
that if the shared page is edited or deleted, you will (perhaps 
unintentionally) affect all of the playlists that contain that shared 
page.

Note:A fully extended Insert Line indicates that the asset will be 
added to the playlist as a primary event, while a partially extended 
line indicates that it will be added as a secondary event (see Adding a 
secondary event to a primary event in a playlist, on page 58 and 
Adding a secondary event to a primary event in a playlist, on page 58 
for more information.
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Appending or inserting the contents of a playlist to a playlist
Rather than adding pages, scenes, templates, and clips individually to a playlist, you can 
add the entire contents of an existing playlist (including segments and comments) to a 
playlist. This avoids having to recreate the contents of a playlist that already exists.

As described below, there are three (3) ways to add the contents of an existing playlist 
assets to a playlist:

• Drag and drop the playlist asset from the Asset Browser into the Playlist Editor.
• Use the Append Playlist command.
• Use the Insert Playlist command.

To add the contents of an existing playlist to a playlist by dragging and dropping the 
playlist asset:

1 Select the Playlists root category in the Asset Browser, and navigate to the appropriate 
category where the playlist asset is stored.
The assets contained in the Playlists category are then listed/displayed in the panel to 
the right of the Asset Browser.

2 Select the desired playlist asset and drag it into the Playlist Editor.
Notice that a highlighted horizontal line appears in the Playlist Editor as you drag the 
pointer over the various rows in the playlist. This line indicates the location of where 
the playlist will be inserted in the playlist.

3 Drop the playlist asset into the playlist by releasing the mouse button.
The entire contents of the playlist asset is added immediately to the playlist, including 
all pages, templates, scenes, clips, segments, and comments that were contained in the 
playlist asset.

To add the contents of an existing playlist to a playlist using the Append Playlist 
command:

1 Open in the playlist to be added in the Playlist Editor and then select the File>Append 
Playlist menu command.
The Append Playlist dialog box appears.

2 Navigate through the Append Playlist dialog box and select the playlist asset that you 
want to add (append) to the end of current playlist.

3 Click OK, or double-click the playlist’s asset name in the Append Playlist dialog box.

Note: Adding the contents of a playlist to another playlist is a 
legitimate way of copying embedded pages from one playlist to 
another.

Note: A fully extended Insert Line indicates that the playlist will be 
added as a primary event, while a partially extended line indicates 
that it will be added as a secondary event (see Repositioning primary 
playlist items (clips, scenes, pages, or comments), on page 58 and 
Adding a secondary event to a primary event in a playlist, on page 58 
for more information.
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The entire contents of the playlist asset is added immediately to the bottom portion of 
the playlist, including all pages, templates, scenes, clips, segments, and comments that 
were contained in the playlist asset.

To add the contents of an existing playlist to a playlist using the Insert Playlist command:
4 Open in the playlist to be added in the Playlist Editor and then select the playlist row 

where you want the contents of the playlist to be inserted (the contents will be inserted 
below the selected row).

5 Select the File>Insert Playlist command from the Xbuilder menus.
The Insert Playlist dialog box appears.

6 Navigate through the Insert Playlist dialog box and select the playlist asset that you 
want to add (insert in) to the end of current playlist.

7 Click OK, or double-click the playlist’s asset name in the Insert Playlist dialog box.

The entire contents of the playlist asset is added immediately below the selected playlist 
row, including all pages, templates, scenes, clips, segments, and comments that were 
contained in the playlist asset.
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Configuring the Playlist table columns
The playlist table’s columns display information about each page, template, scene, or clip 
included in the playlist/segment. Using the Column Layout dialog box, you can determine 
which columns are displayed or hidden in the playlist. You can also determine the order in 
which the columns appear in the playlist.

Column headings that are currently displayed in the playlist are listed in the Selected 
Columns text box (on the right), while hidden column headings are listed in the Available 
Columns text box (on the left). Customizing the playlist column means simply moving the 
headings from on side to the other (see the instructions below). The Column Layout dialog 
box conveniently also offers two (2) standard layouts: Basic and Full.

The following table lists and describes all of the available column categories that can be 
displayed in the Playlist Editor:

Description Displays a user provided text that describes the playlist item. 
The description text is originally created by filling in the Description 
field on the Save dialog box when the item is originally saved as an 
asset.
You can also add/edit the description text of a page, template, scene 
or clip asset by editing the Description field in the Template Editor 
when the asset is opened. See Editing the properties associated to 
the playlist items, on page 64 for more information.

Device Identifies the device to which the page, template, scene or clip will 
be sent.

Duration Identifies the length of time that the page, template, scene or clip 
stays on air during the playout of the playlist.

Mark In Displays the frame location that will be used as a starting point when 
the clip asset is played out in the playlist. As is described in Editing 
the properties associated to the playlist items, on page 64, this 
property is set using the MarkIn/Out Editor. 

Mark Out Displays the frame location that will be used as an ending point 
when the clip asset is played out in the playlist. As is described in 
Editing the properties associated to the playlist items, on page 64, 
this property is set using the MarkIn/Out Editor.

Name Displays the name of the playlist item.
See Editing the properties associated to the playlist items, on 
page 64 for information regarding editing the name of specific 
playlist items.

Offset Identifies the amount of time delay between the playout of two 
consecutive playlist elements. 

Overflow Identifies the difference between the total time of the content in a 
timeslot and the time available in the timeslot. When the total time 
of the content in a timeslot exceeds the time available, there is an 
overflow. 
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The following sections explain how to customize the playlist table’s columns. 
• Adding columns to a playlist, on page 54
• Removing columns from a playlist, on page 55
• Creating, renaming, and deleting your custom column headings, on page 55
• Reordering the columns in a playlist, on page 56
• Using the standard column layouts: Basic or Full, on page 56

Adding columns to a playlist

Complete the following steps to add one or many columns to a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select the desired column heading(s) from the Available Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Right Arrow  button.

Playout Type Indicates the method by which the playlist item (i.e page, template, 
scene, clip) be cued to air:
• Sequential : The playlist element is played when the previous 

element has completed (possibly with an offset).
• Hard Start : The playlist element is played at the specified time of day. 

If required, the currently playing element will be preempted. When a hard 
start element is played the playlist is synchronized with the system clock. 
The time of day is specified by entering it into the Offset column.

• Manual : The playlist element is played when a Resume command is 
sent to the playlist. If this command arrives earlier than expected, the 
currently playing element is preempted. If the command arrives later than 
expected, the playlist waits before resuming playout. The Resume 
command can be sent from the Play button in Xplay, or from logic in the 
Panel.

Recall ID Displays the Recall ID for the page, template, scene or clip, which is 
used by other Vertigo Suite applications as a shortcut identifier for 
calling up pages and templates.
The Recall ID is originally created by filling in the Recall ID field on 
the Save dialog box when the page or template is originally saved as 
an asset.

Status When the Verify playlist setting is enabled, each element in the 
playlist is verified when the playlist is loaded to ensure that it is 
available and ready for use. The results of the verification are 
displayed in the Status column for each element. See Adding and 
configuring a Preview device, on page 9 for more information. The 
playlist item’s on-air or cued status is also displayed in this column.

Note: For instructions on modifying column information for playlist 
items, refer to Editing the properties associated to the playlist items, 
on page 64.
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The selected column headings immediately move to the Selected Columns text box.
4 Click Apply to implement the changes immediately to the playlist, while keeping the 

Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Removing columns from a playlist

Complete the following steps to remove one or many columns from a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select the desired column heading(s) from the Selected Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Left Arrow  button.
The selected column headings immediately move to the Available Columns text box.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Creating, renaming, and deleting your custom column headings
To better reflect the particular contents of your playlist, the Column Layout dialog box 
allows you to create your own (user defined) column headings. Once it has been created, 
you can also rename the column heading or delete it from the Column Layout dialog box 
by right-clicking on the name and selecting either the Rename or Delete command from 
the context menu.

To create a custom playlist column heading:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears.
2 Click the Add button.

The Add Column dialog box appears.

Note: Only custom column headings can be renamed and deleted 
from the Column Layout dialog box.
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3 Type the name of the new column in the text box and click OK.
The new column heading’s name immediately appears in the Selected Columns text 
box on the Column Layout dialog box.

4 Click Apply to immediately add the new column to the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to immediately add the new column to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Reordering the columns in a playlist
The order in which the column appear in the Playlist Editor is determined by the column 
heading’s position in the 

Complete the following steps to reorder one or many columns in a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in order 
the Selected Columns text box.

2 Select the column heading(s) that you want to move to another position from the 
Selected Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Up Arrow  button once for each position that you want to move the 
column to the left in the playlist.
Or, 
Click the Down Arrow  button once for each position that you want to move the 
column to the right in the playlist.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Using the standard column layouts: Basic or Full
The Column Layout dialog box offers two (2) preset standard layouts:

• Basic - Includes only the Name, Device and Status columns.
• Full - Includes all columns.

These standard layouts are convenient ways of populating or removing columns from the 
Playlist Editor.
56



Xbuilder
User Manual
To select a standard layout playlist format:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select either Basic or Full from the Standard Layout drop-down list.
3 Click the Select button.

The Selected Columns and Available Columns text boxes are immediately 
appropriately populated.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.
57



Creating and using playlists
Repositioning playlist items within the playlist
Repositioning playlist items within the playlist
Pages, scenes and clips are added to the playlist as primary scheduled events. Once added 
to the playlist, you can reposition the items within the playlist by dragging and dropping 
them to the desired row location. 

When a clip is a primary event in the playlist, you can reposition pages and scenes within 
the playlist to become secondary events to the clip. Making a page or scene a secondary 
event to a clip allows you to set the page or scene’s offset and duration with respect to the 
clip (primary event), rather than to the beginning of the playlist.

The following sections provide instructions for repositioning items within the playlist:
• Repositioning primary playlist items (clips, scenes, pages, or comments), on page 58
• Adding a secondary event to a primary event in a playlist, on page 58

Repositioning primary playlist items (clips, scenes, pages, or comments)

To reposition a playlist item:
1 Select the playlist item that you want to move to a new location.
2 Click and drag the selected playlist item into the desired playlist row. 

As you drag, a insert line (red line by default) extends across the table, which indicates 
where the item will be placed. 

3 Release the mouse button to drop the item in its new location.

Fig. 6-3: Drag and drop the playlist item to the desired row location

Adding a secondary event to a primary event in a playlist
Making a page or scene a secondary event to a clip allows you to set the page or scene’s 
offset and duration with respect to the clip (primary event), rather than to the beginning of 
the playlist. 

To add a secondary event to a primary event:
1 Add a clip to the playlist as a primary event by dragging the clip asset from the Asset 

Browser and dropping it into the desired location in the playlist.
2 Add a page or scene to the playlist as a secondary event to the clip by dragging the 

asset from the Asset Browser to the row below the clip’s name in the playlist. 

Note: Also see Adding segments to the playlist, on page 60 for 
instructions for how to move playlist items into, or out of, playlist 
segments.
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Before you drop it, take note of the following:
• Whether or not the primary event heading changes color. If the primary event 

heading changes color, the page/scene will become a secondary event. If it does 
not, then the item will be placed below the primary event as an additional primary 
event.

• The length of the insert line (red by default). If the insert line runs the entire width 
of the playlist, then the page/scene is being moved outside the primary event. If 
the line shortens, it means that the page will become a secondary event 
(see below).

• Blue box: Once page/scene has been added to the primary event, it is bordered at 
left by a blue box (see below).

3 Drop the page/scene into the playlist by releasing the mouse button.

A fully extended insert line adds the page/scene as a primary object

A partially extended insert line adds the page/scene as a secondary object to the primary object

Note: To make a page or scene that already exists as a primary event 
in the playlist a secondary event of a clip in that same playlist, simply 
drag the page/scene from its current location to the row under the 
clip in the same way that is described in step 2 and 3 above.
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Adding segments to the playlist
You can insert segments into your playlists to group together related playlist items under 
common headings. This allows you to:

• See at a glance how items in a playlist have been organized thematically 
(e.g. Headlines, Sports, Business, Entertainment).

• Move the contents of a segment at once. This is useful if, for example, at the last minute 
you decide that the pages organized under Business should be placed before the 
Sports segment.

To add a segment to the playlist:
1 Select the playlist row where you want the segment to be inserted (the segment 

heading will be inserted above the selected row).
2 Right-click on the row and select the Add Segment command from the context menu 

that appears. 
The segment heading is added above the selected row with the name open for editing.

3 Enter a name for the segment and press ENTER. 
At this point the segment is empty, even if pages, scenes, clips or templates appear to 
be beneath it. You now need to add items to the segment.

4 Click and drag the selected playlist item into the desired segment. As you drag, a red 
line indicates where the item will be placed. Before you drop it, take note of the 
following:

• Whether or not the segment heading changes color. If the segment heading does 
change color, the item will become part of the segment. If it does not, then the 
item will be placed outside of the segment.

• The length of the insert line (red by default). If the insert line runs the entire width 
of the playlist, then the item is being moved outside the segment. If the line 
shortens, it means that the item is being moved into the segment (see below).

• Blue box: Once items have been added to a segment, they are bordered at left by a 
blue box (see below).

Note: Playlist segments are different from the segment assets that are listed 
in the Asset Browser’s Segments root category. Segment assets are stored 
on the Xmedia Server and made available in the Asset Browser for creating 
rundowns, while playlist segments are only available to the playlist in which 
they are a part of.
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Adding comments to the playlist
Annotating your playlist by adding comments often benefits the person operating the 
playlist. Your comments should be concise, yet identify the purpose or behavior of 
elements in your playlist.

To add comments to the playlist:
1 Select the playlist row where you want the comment to be inserted (the comment will 

be inserted above the selected row).
2 Right-click on the row and select the Add Comment command from the context menu 

that appears. 
The comment row is added above the selected row with the text ready for editing.

3 Type the text for the comment and press ENTER. 

To edit the text of a comment row that is already inserted into the playlist:
1 Select the comment row who’s text is to be edited.
2 Right-click on the row and select the Edit Cell command from the context menu that 

appears. The comment row text becomes ready for editing.
3 Type the new text for the comment and press ENTER.
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Deleting playlist items from the playlist
While building or using the playlist, you may want to remove an item that was previous 
added to the playlist (i.e. a page, scene, template, clip, playlist segment, or comment). 

The following instructions describe how to delete items from the playlist, as well as how to 
delete all playlist items in one action.

To delete an individual item from the playlist:
1 Select the item that you would like to delete from the playlist.
2 Right-click on the item’s row and select the Delete command from the context menu.

Or,
Press the Delete key on your keyboard.

3 If Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) is 
enabled, the Confirm Delete dialog box appears. Select Yes and the item is 
immediately deleted from the playlist, or select No to cancel the delete action.
If however Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) 
is disabled, then the item is immediately deleted from the playlist.

To delete multiple items from the playlist:
1 Select the first item that you would like to delete from the playlist.
2 While holding down the Ctrl key, select the various items that you would like to delete 

from the playlist.
3 Right-click on one of the selected items and select the Delete command from the 

context menu.
Or,
Press the Delete key on your keyboard.

To delete a consecutive grouping of items from the playlist:
1 Select the first item that you would like to delete from the playlist.
2 While holding down the Shift key, select the last item that you would like to delete 

from the playlist.
The first, last, and all items between these two become selected forming the group of 
items to be deleted from the playlist.

3 Right-click within the grouping and select the Delete command from the context 
menu.
Or,
Press the Delete key on your keyboard.

4 If Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) is 
enabled, the Confirm Delete dialog box appears. Select Yes and the items are 
immediately deleted from the playlist, or select No to cancel the delete action.

Note: If the page, template, scene or clip that is to be deleted is a saved 
asset, deleting the item from the playlist does not remove the asset 
from the system, only from the playlist. However, embedded pages, 
playlist segments, and comments that were added to the playlist, but 
are not assets, will be completed deleted from the system.
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If however Xbuilder’s Confirm page deletion property is disabled, then the items are 
immediately deleted from the playlist.

To delete the entire contents of the playlist in one action:
1 Select the Actions>Clear Playlist command from Xbuilder’s menu commands.

Or,
Press F8.

2 If Xbuilder’s Confirm playlist clear property (Tools>Settings>Automation) is enabled, 
the Clear Playlist dialog box appears. Select Yes and the items in the playlist are 
immediately deleted and the playlist is left empty. Or, select No to cancel the clear 
playlist action.
If however Xbuilder’s Confirm page deletion property is disabled, then the playlist 
items are immediately removed from the playlist, leaving an empty playlist.
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Editing the properties associated to the playlist items
Each item that is added to the playlist is arranged as a row in the Playlist Editor. Some of the 
properties that are associated with the item are identified in the column cells that run along 
the playlist row. You can change certain playlist item properties from within the playlist. The 
following table explains how to edit each playlist column. 

Note: See Configuring the Playlist table columns, on page 53 for a 
description the available playlist column categories, as well as how to 
display/hide the column categories.

Description You cannot change a page, template or scene description from 
within the Playlist Editor since it’s a fundamental property of the 
asset.
However, if you still would like to add/edit the description text, 
double-click the item’s row in the playlist. The item opens in the 
Template Editor. Type the text in the Description field in the upper 
portion of the Template Editor. If the item was a page, click the Save 
Page, and Close button  in the Template Editor. If the item was a 
template, click the Commit and Close button  in the Template 
Editor. The playlist’s Description column now displays the 
added/edited text.

Device The name of the output device to which the playlist item will be sent 
when it is played out in Xplay.

Duration The duration of time a playlist item stays on air can be modified by 
selecting the row and then clicking once in the Duration column cell. 
Type in the amount of time that you would like the item to stay on air 
for (i.e. 00:00:01 is one second). Then press Enter.
See Playlist > Basic settings, on page 116 for a description of the 
Show hours in duration column setting, which determines the 
format of the Duration value in the playlist column.

Mark In To edit the value in the Mark In column for clip items in the playlist, 
select the clip row in the playlist. Right-click on the Mark In column 
cell and select the Visual MarkIn/MarkOut command from the 
context menu. The MarkIn/Out Editor window appears. Use the left 
handle on the slider to adjust the Mark In value and then click Apply.

Mark Out To edit the value in the Mark Out column for clip items in the playlist, 
select the clip row in the playlist. Right-click on the Mark Out column 
cell and select the Visual MarkIn/MarkOut command from the 
context menu. The MarkIn/Out Editor window appears. Use the right 
handle on the slider to adjust the Mark Out value and then click 
Apply.
64



Xbuilder
User Manual
Name You cannot rename a page, template, scene or clip from within the 
Playlist Editor since it’s a fundamental property of the asset.
However, if you still would like to edit the name of the item in the 
playlist, double-click the row in the playlist. The item opens in the 
Template Editor. Type the new name in the Name field in the upper 
portion of the Template Editor. Click the Commit and Close button 

 in the Template Editor. The playlist’s Name column now displays 
the edited name.
To edit the name of a playlist segment, right-click the segment 
headings row and select the Edit Cell command from the context 
menu. Type the new text and press Enter.
See Adding comments to the playlist, on page 61 for instructions on 
how to edit the text in a comment row.

Offset The offset time, which represents the amount of time delay between 
the playout of two consecutive playlist elements, can be modified by 
selecting the row and then clicking once in the Offset column cell. 
Type in the amount of time that you would like to be between the 
playout of the playlist items (i.e. 00:00:01 is one second). Then, press 
Enter. 
See Display settings, on page 105 for a description of the Offset 
display format setting, which determines the format of the Offset 
value in the playlist column.

Overflow Currently, you cannot edit the overflow column’s value in Xbuilder’s 
Playlist Editor.

Playout Type The Playout Type column’s setting, as indicated by an icon, can be 
changed by right-clicking on the playout type’s column’s cell, and 
then selecting the Playout Type command from the context menu. 
Select one of the following playout types styles: Sequential, Hard 
Start, or Manual. See page 54 for more information about the three 
(3) playout types.

Recall ID The Recall ID column’s value cannot be changed from within the 
Playlist Editor since it’s a fundamental property of the page or 
template.
However, if you still would like to add/edit the Recall ID for a 
particular page, double-click the page’s row in the playlist. The page 
opens in the Contents Editor. Type the text in the Recall ID field in the 
upper portion of the Template Editor. Click the Save Page, and 
Close button  in the Template Editor. The playlist’s Recall ID 
column now displays the added/edited text.

Status Displays the results of a verification routine when the playlist is 
loaded, as well as the item’s on-air or cued status.
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Saving a playlist
For a playlist to be available for future use, or accessible to other Vertigo Suite applications 
(i.e. Xplay), the playlist must be saved to the Xmedia Server. Newly created playlists are 
given a generic name (i.e. Playlist1) until they are saved and you specify a unique name.

As well, any edits that are performed to existing playlist are not permanent until the playlist 
has been saved. A playlist with unsaved edits is indicated by an asterisks beside the 
playlist’s name in the Playlist Editor. 

When a playlist is saved to the system, it becomes a playlist asset. Playlist assets are stored 
and accessed from within the Playlists root category (and sub-categories) in the Asset 
Browser and listed in the Template Editor.

To save a newly-created playlist:
1 Select the File>Save Playlist command from Xbuilder’s menu commands. 

Or,
Press Ctrl+s.
Or,
Click the Save Current Playlist  button in the Playlist Editor’s toolbar.
The Save Playlist dialog box appears.

2 In the Name field enter a new name for the playlist.
3 Enter your name in the Author field (optional).
4 Enter a short description for the playlist in the Description field (optional).
5 Link the playlist to the Playlists root category or to sub-categories by selecting the 

check box for each place where you want the playlist to be accessible from.
6 Click OK to save the playlist and exit the dialog box.

Or,
Click Cancel to discard all entered information and return to the unsaved playlist.

To save the changes to an existing playlist:
• Select the File>Save Playlist command from Xbuilder’s menu commands. 

Or,
• Press Ctrl+s.

Or,
• Click the Save Current Playlist  button in the Playlist Editor’s toolbar.

To save an existing playlist under a different name or into another category:
1 Select the File>Save Playlist As command from Xbuilder’s menu commands. 

Or,
Click the Save Current Playlist As  button in the Playlist Editor’s toolbar.
The Save Playlist dialog box appears.

2 In the Name field enter a new name for the playlist.
3 Enter your name in the Author field (optional).
4 Enter a short description for the playlist in the Description field (optional).
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5 Link the playlist to the Playlists root category or to sub-categories by selecting the 
check box for each place where you want the playlist to be accessible from.

6 Click OK to save the playlist and exit the dialog box.
Or,
Click Cancel to discard all entered information and return to the unsaved playlist.

Note: If you only want to move an existing playlist to another 
category, you don’t necessarily have to perform a Save As. Simply drag 
and drop the playlist from the Template Editor from its current 
category to another within the Asset Browser.
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Reloading the playlist
If you’ve had a playlist open for a while you may need to reload it to ensure that it’s still up-
to-date. For example, additional items may have been appended to the playlist by a user at 
another workstation while the playlist was also open at your workstation.

To reload the playlist:
• Select the Actions>Reload Playlist command from Xbuilder’s menu commands.

Or,
• Press F5.

Or,
• Click the Reload Playlist button  in the Playlist Editor’s toolbar.
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Xbuilder allows you to create rundowns, which are ordered lists of the thematic rundown 
segments that make up a program. In turn, the rundown segments are lists of the graphic 
pages (shared and embedded), scenes, and/or clips. The order in which the items are listed 
in the rundown determines their playout order as well.

There are two types of rundown segments: shared segments and embedded segments.
• Shared segments are segment lists that are created and saved as assets on the Xmedia 

Server. These segments are accessed through the Asset Browser’s Segments root 
category and they can be added to any rundown.

• Embedded segments are similarly created, but rather than being saved as 
independent assets, they are saved as part of the rundown. Embedded segments 
therefore, can only be used by the rundown that it belongs to.

The following sections provide descriptions and instructions for how to create and edit 
rundowns and segments in Xbuilder:

• An overview of the Rundown Editor, on page 70
• An overview of the Segment Editor & Segment Window, on page 71
• Creating a new rundown, on page 74
• Opening an existing rundown, on page 74
• Creating and using rundown segments, on page 75
• Opening an existing rundown segment, on page 81
• Adding segments to a rundown, on page 82
• Repositioning segments within the rundown, on page 84
• Removing segments from a rundown, on page 84
• Saving a rundown under a different name or category, on page 85
• Deleting a rundown from the system, on page 85

Note: Although rundown segments appear very similar to playlists, be 
aware that there are differences between the two and that you should 
make assumptions that their functionality is the same. For example, 
you cannot add the contents of a playlist to a rundown segment if the 
playlist’s pages are organized within playlist segments.
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An overview of the Rundown Editor
The Rundown Editor lists the content and playback order for a program. A rundown is 
populated and organized using rundown segments that are built and edited in the 
Segment Editor or the Segment window. The Segment Editor appears to the right of the 
Rundown Editor and is used mainly to view and edit the segments belonging to the 
rundown.

Fig. 7-1: Rundown Editor components

The following table identifies and describes the components of the Rundown Editor:

Rundown name New rundowns are given a temporary default name of Rundown#, 
which appears in the first row of the Rundown list. Once you save the 
rundown, the default name is replaced with its new name. 
Rundowns are saved on the Xmedia Server as assets and are 
available to Xbuilder through the Asset Browser’s Rundowns root 
category.

Rundown segments Each row in the Rundown Editor represents an individual rundown 
segment. Rundown segments are built and viewed in the Segment 
Editor/Window and can consist of a single page or a series of pages. 
When you select a segment in the Rundown Editor, the row’s 
background changes color. When the segment is open the Segment 
Editor, the segment’s name is highlighted in the Rundown Editor. 
These color settings can be changed using Xbuilder’s segment color 
settings.

Rundown Editor’s 
menu commands

The Rundown Editor also features a context menu that allows you to 
save, rename or delete the segment that is selected in the Rundown 
Editor.

Rundown name

Rundown segments

Segment open in
Segment Editor

Rundown Editor’s
menu commands
(right-click)
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An overview of the Segment Editor & Segment Window
Xbuilder offers two interfaces for creating and editing rundown segments: the Segment 
Editor and the Segment window. 

The Segment Editor is joined to the Rundown Editor and it allows you to:
• Create and populate new rundown segments with pages and playlists.
• Add the segments to the rundown that is open in the Rundown Editor.
• Save the segment as shared segment (using the Save As button) or as an embedded 

segment (using the Save button).
• View, add, edit, or remove pages, scene or clips belonging to the segment highlighted 

in the Rundown window. 

Fig. 7-2: The Rundown Window and the Segment Editor

The Segment window is a standalone interface (meaning that it is not associated with a 
specific rundown) that allows you to create and populate new shared rundown segments 
with pages, scenes, clips and playlists.

Fig. 7-3: The Segment window is a stand-alone interface for creating and editing shared segments

The following list identify and describe the main interface components
1 Toolbar: A series of buttons that allows you to perform actions related to creating, 

saving, and populating segments. See Segment Editor toolbar, on page 101 for a 
description of each button on the toolbar.

2 Segment: A list of the pages, scenes and clips that make up the content of the segment. 
Each page, scene, or clip has a dedicated row in the Segment Editor/window, which 
determines their intended playout order. See Adding pages to a rundown segment, on 
page 76 and Repositioning pages within the rundown segment, on page 79 for more 
information.
Like playlists, the columns display information about each item included in the 
rundown segment. Xbuilder allows you to determine which columns are displayed or 
hidden in the Segment Editor/window by using the Column Layout dialog box. See 
Configuring the Playlist table columns, on page 53 for instructions on how to display or 
hide certain columns.
You can annotate the segment by adding comment rows. Comment rows are often 
used to insert instructions or identification annotations so that operators are better 

1

4

2
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informed. See Adding a comment row to the rundown segment, on page 79 for more 
information.

3 Menu commands: Right-clicking on a segment row exposes menu commands that 
allows you to set the playout type or delete the selected segment row. When these 
commands are opened on a clip row, the Visual Mark In/Mark Out command can be 
used to edit the clip’s starting and ending times. The two other commands allow you to 
insert a segment or comment above the currently selected segment.

4 Name: Displays the name of the rundown segment that is currently displayed in the 
Segment window. An asterisk appears beside the name until the segment, or the edits 
to the segment, have been saved. See Saving a rundown segment, on page 80 for more 
information.

5 Device for Verify: In the same way that Xbuilder allows you to verify the presence and 
publishing of playlist items on configured devices, Xbuilder can also manually verify 
the contents of a segment on specified devices using the Verify Segment button .
This particular interface component allows you to target a specific device or all of the 
configured devices when a segment verification is executed. 
See Configuring a device for the verification of playlist elements, on page 10 and 
Verifying the contents of a playlist, on page 47 for more details.

Note: Xbuilder’s Action menu contains commands for clearing and 
reloading segments in the Segment Editor/Window. See Actions 
menu, on page 91 for more information. 
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Procedural overview for creating rundowns
The procedure below identifies the high-level steps involved in building rundowns for 
playing out branding and promotional graphics sequences. Subsequent sections 
(identified by the links within the procedure) provide step-by-step instructions for 
performing each step. 

To create a rundown in Xbuilder:
1 Create a new rundown, or open an existing rundown.

• Creating a new rundown, on page 74
• Opening an existing rundown, on page 74

2 Create new rundown segments for the rundown.
• Creating a new rundown segment, on page 75
• Adding pages to a rundown segment, on page 76
• Adding scene assets to a rundown segment, on page 78
• Adding clip assets to a rundown segment, on page 78
• optional - Adding a comment row to the rundown segment, on page 79
• optional - Repositioning pages within the rundown segment, on page 79
• optional - Deleting or removing items from a rundown segment, on page 79
• Saving a rundown segment, on page 80

3 Add rundown segments to the rundown and edit the rundown.
• Adding segments to a rundown, on page 82
• optional - Repositioning segments within the rundown, on page 84
• optional - Removing segments from a rundown, on page 84

4 Save the rundown.
• Saving a rundown under a different name or category, on page 85

Note: As a preliminary step, verify that the Segments category is 
displayed in Xbuilder’s Asset Browser (without it you will not be able 
to populate the rundown). If the Segments category is not displayed, 
then open the xbuilder.ini file (C:\Program 
Files\VertigoXmedia\Apps) and set the DisplaySegments setting to 
True.
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Creating a new rundown
To create a new rundown, you must execute the Create New Rundown action (described 
below), which immediately replaces whatever is currently in the upper portion of the 
Xbuilder window with a new, empty Rundown/Segment Editor.

To create a new rundown:
1 Select File>New Rundown or press Ctrl+R. 

The Save Rundown dialog box appears.
2 In the Name field enter a new name for the rundown.
3 Enter your name in the Author field (optional).
4 Enter a short description of the rundown in the Description field (optional).
5 Link the rundown to the Rundowns root category or to sub-categories by selecting the 

check box for each place where you want the rundown to be accessible from.
6 Click OK to save the rundown and exit the dialog box.

The Rundown Editor and Segment Editor appear and are ready to be populated.

Opening an existing rundown
Existing rundowns are stored on the Xmedia Server. You can open existing playlists either 
from the Asset Browser and Template Editor, or from the File menu.

To open an existing rundown using the Asset Browser and Template Editor:
1 Select the Rundowns root category in the Asset Browser, and navigate to the 

appropriate category where the rundown is stored.
The rundowns contained in the Asset Browser category are listed in the Template 
Editor.

2 Double-click the desired rundown in the Template Editor.
Or,
Right-click on the rundown in the Template Editor and select the Open command from 
the context menu.
The rundown opens in the Rundown Editor and the first segment listed in the rundown 
list is displayed in the Segment Editor.

To open an existing playlist from the File menu:
1 Select File>Open Rundown. 

The Open Rundown dialog box appears.
2 Navigate through the Rundown categories in the right panel until the desired rundown 

is listed in the left panel.
3 Double-click the desired rundown listed in the right panel.

Or, 
Select the rundown and then click OK.
The rundown opens in the Rundown Editor and the first segment listed in the rundown 
list is displayed in the Segment Editor.
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Creating and using rundown segments
Typically, rundown segments are lists of graphic pages (shared and embedded pages), 
scenes, clips and shared playlists that make up a section of a program. The order in which 
these items are listed in the rundown segment determines their playout order as well.

The following sections provide instructions for creating new rundown segments and 
opening existing rundown segments:

• Creating a new rundown segment, on page 75
• Configuring the segment table columns, on page 76
• Adding pages to a rundown segment, on page 76
• Adding scene assets to a rundown segment, on page 78
• Adding clip assets to a rundown segment, on page 78
• Adding a comment row to the rundown segment, on page 79
• Repositioning pages within the rundown segment, on page 79
• Deleting or removing items from a rundown segment, on page 79
• Saving a rundown segment, on page 80

Creating a new rundown segment
Rundown segments can either be shared or embedded. While shared segments can be 
created and edited in both the Segment Editor and the Segment window, embedded 
segments can only be created in the Segment Editor.

The following instructions guide you through the process of creating new rundown 
segments from either interface.

To create a new shared segment in the Segment window:
1 Select the File>New Segment command from the Xbuilder toolbar.

The upper portion of the Xbuilder window becomes an empty Segment window.
2 Populate the segment with shared pages and/or embedded pages (templates) from 

the Asset Browser and Template Editor.
3 Click the Save button  in the Segment window’s toolbar.

Or,
Select the File>Save Segment or the File>Save Segment As command from the 
Xbuilder menu commands.
The Save Segment dialog box appears.

4 In the Name field enter a new name for the segment.
5 Enter your name in the Author field (optional).
6 Enter a short description of the segment in the Description field (optional).
7 Link the segment to the Segments root category or to sub-categories by selecting the 

check box for each place where you want the segment to be accessible from.
8 Click OK to save the segment and exit the dialog box.
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To create a new segment (shared or embedded) in the Segment Editor:
1 With a rundown open in the Rundown window, click the New Segment button  in 

the Segment Editor’s toolbar.
A new segment is added to the rundown window below the initial segment listed and 
the Segment Editor becomes empty and is ready to be populated.

Configuring the segment table columns
The segment table’s columns display information about each page included in the 
rundown segment. Using the Tools>Configure Playlist Columns command, you can 
determine which columns are displayed or hidden in the segment table. You can also 
determine the order in which the columns appear in the table. 

Since the instructions for configuring the segment table’s columns are identical to those for 
the playlist columns, please refer to Configuring the Playlist table columns, on page 53.

Adding pages to a rundown segment
The method that you will use to add a page to a rundown segment will depend upon 
whether you want the page to be embedded or shared. 

The following sections provide instructions for adding embedded pages, shared pages, and 
the pages of a playlist to a rundown segment:

• Adding an embedded page to a rundown segment, on page 76
• Repositioning segments within the rundown, on page 84
• Adding the pages of a playlist to a rundown segment, on page 78

Adding an embedded page to a rundown segment
The following instructions describe the two (2) ways that you can add an embedded page 
to a rundown segment.

To add an embedded page to a rundown segment using the Insert New Page button:
1 With the segment open in either the Segment Editor or the Segment Window, select 

the Insert New Page button  in the Segment’s toolbar.
The Select a template for the new graphic dialog box appears.

2 Navigate and select the template that you would like to the new page to be based 
upon, then click OK.
The template opens in Xbuilder’s Template Editor.

3 Make the appropriate edits to the template’s variable fields, then click the Insert in 
Playlist and Close button  in the Template Editor’s toolbar.

Note: Do not use the File>Insert Segment or File>Append Segment 
commands to add the pages contained in one segment to another 
segment, as this creates a playlist segment in the receiving segment. 
The obstacle is that rundown segments that contain playlist segments 
cannot be added to rundowns.
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The template is added to the segment editor/window as an embedded page.

To add an embedded page to a rundown segment using templates from the Asset 
Browser:

1 Open the rundown segment in either the Segment Editor or the Segment Window.
2 Navigate and select a template from the Asset Browser/Template Editor.
3 Perform one of the following:
• Drag the template from the Template Editor and drop it into the segment. Then 

double-click the page’s name in the Segment table. The page opens in the Template 
Editor. Make the appropriate edits to the template’s variable fields, then click the 
Commit and Close button  in the Template Editor’s toolbar (or drag the X-logo icon 
into the segment).
Or,

• Double-click the template in the Template Editor. The page opens in the Template 
Editor. Make the appropriate edits to the template’s variable fields, then click the Insert 
in Playlist and Start a New Page button  in the Template Editor’s toolbar (or drag 
the X-logo icon into the segment).

Adding a shared page to a rundown segment

To add a shared page to a rundown segment using pages from the Asset Browser:
1 Open the rundown segment in either the Segment Editor or the Segment Window.
2 Navigate and select a page from the Asset Browser/Template Editor.
3 Perform one of the following:

• Drag the page from the Template Editor and drop it into the segment. Then 
double-click the page’s name in the Segment table. The page opens in the 
Template Editor. Make the appropriate edits to the page’s variable fields, then click 
the Save Page and Close button  in the Template Editor’s toolbar (or drag the 
X-logo icon into the segment).

Or,
• Double-click the page in the Template Editor. The page opens in the Template 

Editor. Make the appropriate edits to the page’s variable fields, then click the Save 
Page, Insert in Playlist button  in the Template Editor’s toolbar (or drag the X-
logo icon into the segment).

Note: To save the new embedded page as a shared page, select the 
page in the Segment Editor/window and click either the Save Current 
Segment As button  or the File>Save Segment As command (see 
Saving a rundown segment, on page 80).

Note: To save the new embedded page as a shared page, select the 
page in the Segment Editor/window and click either the Save Current 
Segment As button  or the File>Save Segment As command (see 
Saving a rundown segment, on page 80).
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Adding the pages of a playlist to a rundown segment
If the series of pages that you want to add to the rundown segment already exist within a 
playlist, you can add the playlist to the rundown segment and the pages will automatically 
become a part of the segment.

To add the pages of a playlist to a rundown segment:
1 Open the rundown segment in either the Segment Editor or the Segment Window.
2 Navigate and select a playlist from the Asset Browser/Template Editor.
3 Drag the playlist from the Asset Browser/Template Editor and drop it into the Segment.

The pages that were contained in the playlist are automatically listed in the rundown 
segment.

Adding scene assets to a rundown segment
To add a scene asset to a rundown segment:

1 Open the rundown segment in either the Segment Editor or the Segment Window.
2 Navigate and select a scene asset from the Asset Browser/Template Editor.
3 Perform one of the following:

• Drag the asset from the Template Editor and drop it into the segment. 
Or,

• Open the scene in the Template Editor. Make the appropriate edits to the scene’s 
variable fields, then click the Save Scene, Insert in Playlist button  in the 
Template Editor’s toolbar (or drag the X-logo icon into the segment).

Adding clip assets to a rundown segment
To add a clip asset to a rundown segment:

1 Open the rundown segment in either the Segment Editor or the Segment Window.
2 Navigate and select a clip asset from the Asset Browser/Template Editor.
3 Drag the asset from the Template Editor and drop it into the segment. 

Clip assets are added to segments as primary events and highlighted in green (below).

Note: The playlist that is to be added to the rundown segment must 
only contain pages. The playlist will be rejected if it contains playlist 
segments or clips.
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Adding a comment row to the rundown segment
Annotating your segment by adding comments often benefits the person operating the 
rundown. Your comments should be concise, yet identify the purpose or behavior of 
elements in your segment.

To add comments to the segment:
1 Select the segment row where you want the comment to be inserted (the comment 

will be inserted above the selected row).
2 Right-click on the row and select the Add Comment command from the context menu 

that appears. 
The comment row is added above the selected row with the text ready for editing.

3 Type the text for the comment and press ENTER. 

To edit the text of a comment row that is already inserted into the segment:
1 Select the comment row who’s text is to be edited.
2 Right-click on the row and select the Edit Cell command from the context menu that 

appears. The comment row text becomes ready for editing.
3 Type the new text for the comment and press ENTER.

Repositioning pages within the rundown segment
The order in which pages are listed in the segment determines their playout order as well. 
As such, after adding the pages to the segment, you may need to reposition pages within 
the segment to reflect the desired playout order.

To reposition a page within a segment:
1 Select the page that you want to move to a new location.
2 Click and drag the selected page into the desired segment row. 

As you drag, a insert line (red line by default) extends across the table, which indicates 
where the item will be placed. 

3 Release the mouse button to drop the item in its new location.

Deleting or removing items from a rundown segment
The following instructions describe how to remove individual pages, scenes, clip and 
comments from the rundown segment, as well as how to remove all of the segment’s 
contents in one action.

To delete an individual item (page, scene, clip or comment) from the segment:
1 Select the item that you would like to delete from the segment.
2 Right-click on the item’s row and select the Delete command from the context menu.

Note: If the page that is to be deleted is a saved, shared asset, deleting 
the page from the segment does not remove the asset from the 
system, only from the segment. However, embedded pages and 
comments that were added to the segment will be completely 
deleted from the system.
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Or,
Press the Delete key on your keyboard.

3 If Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) is 
enabled, the Confirm Delete dialog box appears. Select Yes and the item is 
immediately deleted from the segment, or select No to cancel the delete action.
If however Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) 
is disabled, then the item is immediately deleted from the segment.

To delete a consecutive grouping of items from the playlist:
1 Select the first item that you would like to delete from the segment.
2 While holding down the Shift key, select the last item that you would like to delete 

from the segment.
The first, last, and all items between these two become selected forming the group of 
items to be deleted from the segment.

3 Right-click within the grouping and select the Delete command from the context 
menu.
Or,
Press the Delete key on your keyboard.

4 If Xbuilder’s Confirm page deletion property (Tools>Settings>Automation) is 
enabled, the Confirm Delete dialog box appears. Select Yes and the items are 
immediately deleted from the segment, or select No to cancel the delete action.
If however Xbuilder’s Confirm page deletion property is disabled, then the items are 
immediately deleted from the segment.

To delete the entire contents of the segment in one action:
1 Select the Actions>Clear Playlist command from Xbuilder’s menu commands.

Or,
Press F8.

2 If Xbuilder’s Confirm playlist clear property (Tools>Settings>Automation) is enabled, 
the Clear Segment dialog box appears. Select Yes and the items in the segment are 
immediately deleted and the segment is left empty. Or, select No to cancel the clear 
segment action.
If however Xbuilder’s Confirm Playlist Clear property is disabled, then the segment 
items are immediately removed from the segment, leaving an empty segment.

Saving a rundown segment
After building or editing the rundown segment, you must save the segment to retain its 
current pages and settings. Saving the segment not only makes edits permanent, but it also 
offers you an opportunity to save embedded segments as shared segments.

Note: An asterisks next to the segment’s name indicates that edits 
have been made to the segment, but have not yet been saved.Use 
the Save Current Segment button  to save the rundown in its current 
form. In other words, an embedded segment is saved as an embedded 
segment, and a shared segment is saved as a shared segment. 
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Use the Save Current Segment As button  to open the Save Segment dialog box, 
which allows you to save an embedded segment as a shared segment, or to save a shared 
segment under a different name or in a different category.

Opening an existing rundown segment
There are three (3) ways to open an existing rundown segment:

• Opening a shared segment from the Asset Browser. Double-click the segment’s name 
in the Template Editor opens the segment in the Segment Window.

• With the Segment Window already open, select the File>Open Segment command. 
The Open Segment dialog box appears and allows you to select the shared segment to 
be opened. Click OK and the segment automatically appears in the Segment Window.

• With a rundown open in the Rundown Editor, double-click a segment in the rundown 
list and the segment opens in the Segment Editor.

Regardless of which way you choose to open the segment, once the rundown segment is 
displayed in the Segment Editor/Window, you can:

• edit the segment by opening, adding, removing, or repositioning the pages, scenes 
and clips that belong to the segment

• add comments to the segment
• open and edit the pages, scenes and clips belonging to the segment
• save any changes to the segment, or save it under a different name or category

Note: When the rundown segment is open in the Segment window, 
the File>Save Segment and File>Save Segment As commands 
perform the equivalent actions as the buttons described above.
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Adding segments to a rundown
The Rundown Editor contains the list of segments that make up the content and playout 
order of the program. Populating the Rundown Editor involves adding segments to the 
rundown list. Selecting a segment listed in the rundown list displays the contents of the 
segments in the Segment Editor (next to the Rundown Editor).

The following sections provide instructions for adding segments to a rundown:
• Adding the first segment to a new rundown, on page 82
• Adding additional segments to a rundown, on page 82

Adding the first segment to a new rundown
When a new rundown is created, the Segment Editor’s status reads No segment loaded, 
which means that the current rundown does not yet contain any segments.

To add a first segment to a rundown:
1 Click the Create New Segment button  in the Segment Editor’s toolbar.

A new segment is added to the Rundown Editor’s list with New Segment as its default 
name.

2 The segments default name is highlighted (white) and can be edited immediately by 
typing the new name. If the default name is no longer highlighted, right-click on the 
default name and use the Rename command to provide a new name for the segment.
The segment’s name is displayed in the Segment Editor’s status line and you can now 
populate the segment with pages.

Adding additional segments to a rundown
When an existing rundown is opened, the Rundown Editor lists the segments in the order 
in which they will be played out. Meanwhile, the Segment Editor (next to the Rundown 
Editor) displays the pages that belong to the segment that is currently selected in the 
rundown list.

To add additional segments to a rundown:
1 Select the segment in the Rundown Editor where the new segment will be placed (the 

new segment is placed above the selected segment).
2 Perform one of the following:

Note: The File>New Segment command does not add a new segment 
to a rundown, rather it creates a new shared segment using the 
Segment Window. See Creating a new rundown segment, on page 75 
for more information.

Note: When a new rundown is created, the Create New Segment 
button does not appear in the Segment Editor’s toolbar if the Asset 
Browser contains the Segments root category. To display or hide the 
Segments root category, edit the root category’s display setting  
(i.e. DisplaySegments=False) in the xbuilder.ini file.
82



Xbuilder
User Manual
• Click the Create New Segment button  in the Segment Editor’s toolbar. 
A new segment is added to the Rundown Editor’s list with New Segment as its 
default name.

Or,
• Drag an existing shared segment from the Asset Browser/Template Editor and drop 

it into the desired location in the Rundown Editor’s segment list.
Or,

• Drag an existing shared page or template (creates an embedded page) from the 
Asset Browser/Template Editor and drop it into the desired location in the 
Rundown Editor’s segment list. The segment that is created contains the shared or 
embedded page as the first item in the segment.

The segment’s name is displayed in the Segment Editor’s status line and you can now 
populate the segment with pages.

Note: When a new rundown is created, the Create New Segment 
button does not appear in the Segment Editor’s toolbar if the Asset 
Browser contains the Segments root category. To display or hide the 
Segments root category, edit the root category’s display setting (i.e. 
DisplaySegments=False) in the xbuilder.ini file.
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Repositioning segments within the rundown
The order in which segments are listed in the Rundown Editor determines the playout order 
as well. As such, after adding the segments to the rundown, you may need to reposition 
segment within the rundown to reflect the desired playout order.

To reposition a segment within a rundown:
1 Select the segment that you want to move to a new location.
2 Drag the selected segment into the desired rundown row. 

As you drag, a insert line (red line by default) extends across the list, which indicates 
where the segment will be placed. 

3 Release the mouse button to drop the item in its new location.

Removing segments from a rundown
The Rundown Editor contains the list of segments that make up the content and playout 
order of the program. If the rundown list contains a segment that is no longer needed, you 
can remove it from the rundown using the Delete command.

To remove a segment from a rundown:
1 Right-click on the segment in the Rundown Editor and select the Delete command 

from the context menu.
Or, 
Select the segment in the Rundown Editor and press the Delete key on your keyboard.

2 If Xbuilder’s Confirm page Deletion property (Tools>Settings>Automation) is 
enabled, the Confirm Delete dialog box appears. Select Yes and the segment is 
immediately deleted from the Rundown Editor. Or, select No to cancel the delete 
segment action.
If however Xbuilder’s Confirm page deletion property is disabled, then the segment is 
immediately removed from the Rundown Editor.

Note: Repositioning the segments in a rundown automatically saves 
the new order immediately, so that if the rundown is playing, then the 
changes are immediately implemented.

Note: If the segment is an embedded segment, then it is deleted from 
the system permanently. If, however, the segment is saved as a shared 
segment, then it will only be removed from the rundown, not the 
system. See Saving a rundown segment, on page 80 for more 
information about embedded and shared segments.
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Saving a rundown under a different name or category
Although the rundown was saved to the Xmedia Server when it was created, you can use 
the Template Editor Rundown As command to save the currently open rundown under a 
different name or category.

Selecting the File>Save Rundown As command, opens the Save Rundown dialog box, 
which allows you to specify a new name for the currently open rundown and/or save the 
rundown within a sub-category of the Rundowns root category in the Asset Browser.

Deleting a rundown from the system
All saved rundowns are stored on the Xmedia Server and are accessed from within the 
Rundowns root category in the Asset Browser. When the Rundowns category (and 
subcategories) are selected in the Asset Browser, the individual rundowns are listed in the 
Template Editor.

If a rundown is no longer needed, you can permanently remove it from the system by:
1 Right-click on the rundown listed in the Template Editor and select the Delete 

command from the context menu.
Or,
Select the rundown listed in the Template Editor and press the Delete key on your 
keyboard.

2 The Delete dialog box appears and asks you to confirm whether you want to delete the 
rundown. Click Yes to delete the rundown and the rundown is immediately deleted 
from the system. Click No to cancel the delete action.
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Xbuilder’s menus & toolbars
The following sections provide a quick reference to the menu commands, toolbars, and 
properties associated with various parts of Xbuilder’s user interface:

• Xbuilder’s menu commands, on page 88
• Playlist Editor’s toolbar, on page 94
• Template Editor’s toolbar & properties, on page 96
• Segment Editor toolbar, on page 101

Xbuilder’s 
menu commands

Playlist Editor

Template Editor

Note: See Overview of Xbuilder’s user interface, on page 6 for a quick 
orientation to the entire Xbuilder user interface. All user interface 
features and components are described in full detail throughout this 
document in their applicable tasks and instructions.
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Xbuilder’s menu commands
Many of Xbuilder’s key features are thematically organized within the menu bar command 
structure at the top of the main interface window.

The following sections provide functional definitions of the Xbuilder menu commands:
• File menu, on page 88
• View menu, on page 90
• Actions menu, on page 91
• Tools menu, on page 92
• Timeline menu, on page 92
• Help menu, on page 93

File menu
The File menu contains commands that are related to opening, inserting, appending, and 
saving playlists, segments, and rundowns. 

Note that the name displayed for the following commands, Open, Append, Insert, Save, 
and Save As, depends upon whether a playlist, rundown, segment window is active. 

Each of the File menu commands are described in the following table:

New Playlist Opens a new, empty playlist.
Alternative access:
• Keyboard shortcut: Ctrl+N
•  New Playlist button in the Playlist Editor 

New Rundown Opens a new, empty rundown.
Alternative access:
• Keyboard shortcut: Ctrl+R

New Segment Opens a new, empty segment.
Alternative access:
• Keyboard shortcut: Ctrl+T
•  Create New Segment button in the Segment window 

When the Playlist Editor is active When the Segment window is active
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New Timeline Opens a new, empty timeline.
This command is disabled unless a seed file is specified in Xbuilder’s 
General setting’s Timeline Seed field in.
Alternative access:
•  New Timeline button in the Timeline window 

Open
[Open Playlist]
[Open Segment]
[Open Rundown]

Depending the active window in Xbuilder, this command displays a 
dialog box that lets you select an existing playlist, segment, or 
rundown to open.
Alternative access:
• Keyboard shortcut: Ctrl+O
•  Open Existing Playlist button in the Playlist Editor 

Append
[Append Playlist]
[Append Segment]

Depending what is already open in Xbuilder, this command displays 
a dialog box that lets you select a playlist or segment to add to the 
end of the current playlist.
Alternative access:
• Keyboard shortcut: Ctrl+P

Insert
[Insert Playlist]
[Insert Segment]

Displays a dialog box that lets you select a playlist or segment to 
insert above the currently selected row in the current 
playlist/segment.
Alternative access:
• Keyboard shortcut: Ctrl+I

Save
[Save Playlist]
[Save Segment]

Saves the currently opened playlist, segment, or rundown. If the item 
is new and has not yet been saved, a dialog box displays that lets you 
set specific data related to the asset (i.e. name, author, 
description...etc.).
Alternative access:
• Keyboard shortcut: Ctrl+S
•  Save Current Playlist button in the Playlist Editor
•  Save Current Segment button in the Segment window 

Save As
[Save Playlist As] 
[Save Segment As]
[Save Rundown As]

Opens a dialog box that allows you to save the playlist, segment, or 
rundown using a new name.
Alternative access:
• Keyboard shortcut: Ctrl+S
•  Save Current Playlist As button in the Playlist Editor
•  Save Current Segment As button in the Segment window 

Save as Shared Page Saves the open page or template as a page asset on the Xmedia 
Server, so that it is available to be used in other playlists. See 
Creating an individual shared page from a template, on page 14 for 
more information.
Alternative access:
• Keyboard shortcut: Ctrl+H 

Exit Closes Xbuilder.
Alternative access:
• Keyboard shortcut: Ctrl+Q
•  Close button in the top-right corner of the Xbuilder window 
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View menu
The View menu contains commands that are related to displaying or hiding browsers and 
tools that are used by, or within, the Xbuilder interface. The following table describes the 
functionality of the View menu’s commands.

Open Message Log When selected, this command displays the message log dialog box, 
which records the processes and errors that occur during your 
Xbuilder session. When cleared, this command hides the log.
Alternative access:
• Keyboard shortcut: Ctrl+M

Asset Browser Displays or hides the Asset Browser. The Asset Browser is a 
collapsible panel on the lower-left side of the Xbuilder interface that 
allows you to view and access assets according to their type.
Alternative access:
• Keyboard shortcut: Ctrl+A
• Click the handle along the lower-left portion of the Xbuilder interface.

Open Log File When selected, this command opens the current log file in Notepad 
from: C:\ProgramData\VertigoXmedia\Logs. The log file stores 
the processes and errors that occurred during your Xbuilder session 
and is useful when debugging.

Show/Hide Panel Displays or hides the lower portion of the Template Editor, which 
displays the control objects of an open control panel.
Alternative access:
• Keyboard shortcut: Ctrl+L

Favorites Browser Displays or hides the Favorites Browser, which is a collapsible panel 
on the lower-right side of the Xbuilder interface that allows you to 
view and storage frequently used templates and pages. 
Alternative access:
• Keyboard shortcut: Ctrl+U
• Click the handle along the lower-right portion of the Xbuilder interface.

Proxy View Determines the format by which the Template Editor displays assets 
from the Asset Browser. The two available formats are: thumbnail 
(proxy) images, or as detailed lists.
Alternative access:
• Keyboard shortcut: Ctrl+W

Display Frames Only available when a timeline is active.
Allows you to set the timeline’s top ruler’s units as frames or time 
code units.
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Actions menu
The Actions menu contains commands that allow you to control or perform tasks related to 
your playlists, segments, or devices. Many of these commands are also available within the 
appropriate windows as buttons, or as key command shortcuts.

Clear
[Clear Playlist]
[Clear Segment]

Deletes all items in the playlist or segment.
Alternative access:
• Keyboard shortcut: F8

Reload
[Reload Playlist]
[Reload Segment]

Reloads the last saved version of the playlist or segment.
Alternative access:
• Keyboard shortcut: F5
•  Reload Playlist button in the Playlist Editor
•  Reload Segment button in the Segment window 

Ingest Playlist Opens the Import Playlist Log File dialog box, which allows you to 
import playlist log files (.log) into Xbuilder.
Alternative access:
• Keyboard shortcut: F10

Create Work Order Opens the Work Order dialog box, which allows you to create a new 
work order. The work order system requires users to login using a 
user name and password. User names and passwords are registered 
and stored on the Xmedia Server using the Xmedia Server’s 
properties panel.
Alternative access:
• Keyboard shortcut: F11

Clear Device Sends a clear command to the device connected to Xbuilder causing 
the device’s display to immediately stop displaying its contents.

Open Merge List The Open Merge List command allows you to create multiple 
pages and/or scenes from a single Merge List file (spreadsheet or 
XML file). Acting as the data source, the Merge List file provides 
Xbuilder with the information it needs to create new instances of 
pages/scenes from existing template and scene assets.

Open MakeList As the gateway to the Vertigo Quality Control (QC) workflow, the 
Open MakeList command allows you to open a Make List file, 
which creates a playlist element for each of the assets (pages) that 
were created by the After Effects Plug-in’s export. You can then 
preview, approve or reject the new graphics. See Quality Control: 
Previewing and validating graphics in Xbuilder, on page 39 for more 
information.

Open AirList As the gateway to the Vertigo Media Check (MC) workflow, the 
Open AirList command allows Master Control to quickly verify that 
all of the assets that were validated (approved) during the QC 
workflow have been published to the target playout devices. See 
Media Check: Graphics publish verification, on page 41 for more 
information.
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The Tools menu contains commands that allow you to specify some of settings that affect 
the aesthetic and behavioral properties of Xbuilder. It also allows you to configure Xbuilder 
to interact with other devices and applications. The following table describes the 
functionality of the Tools menu commands.

Timeline menu
The Timeline menu only appears when the Timeline Editor is open in the Xbuilder window.

Settings Displays the Settings dialog box, which is used to establish the aesthetic 
and behavior of many of the Xbuilder features. See Configuring Xbuilder’s 
settings, on page 8 for more information.

Configure 
Playlist Columns

Displays the Column Layout dialog box. This allows you to determine 
what kind of information will be displayed in the Playlist and Segment 
windows for each item. See Configuring the Playlist table columns, on 
page 53 and Configuring the segment table columns, on page 76 for more 
information.

Plugins Opens the Plugin Manager, which is used for registering or de-
registering plugins that support or enhance Xbuilder. 

Device Manager Displays the Device Configuration dialog box, which allows you to 
define and add new output devices to the Device Manager. Once devices 
are added to the Device Manager, you can connect a device to Xbuilder to 
be used for previewing and/or verify if each playlist element has been 
published on the device. See Adding and configuring a Preview device, on 
page 9 for more information.

Timeline seeds Displays the Timeline Seed dialog box, which allows you to add/remove 
and specify the seed files that are used as the basis for building auto 
promo timelines in the Timeline Editor.

Fade This command is only enabled when the timeline’s seed file contains 
a Fader channel. Selecting this command displays the Timeline Fade 
dialog box, which allows you set the duration of the automatic fade-
in and fade-out of the timeline. See for more information.

Render to File This command allows you to render and save a copy of the entire 
auto promo on either the VertigoXG or the Software CG devices. 

Batch Render to File Not yet documented.

Snapshot This command allows you to extract a single frame of an auto promo 
timeline and save it to a file as an image file (.tga).
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Help menu
The Help menu contains commands that provide Xbuilder product information, like 
licensing and software version identification, as well as access to the License Manager for 
installing the required applications license. The following table describes the commands 
available within Xbuilder’s Help menu.

About Displays the product information regarding what the version of Xbuilder and 
Xmedia Suite you are using.

License Opens the License Manager dialog box, which allows you to install and view 
the required application licenses for Xbuilder. See the Vertigo Suite Release 
Notes for specific instructions on how to acquire and install licenses for 
Xbuilder.
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Playlist Editor’s toolbar
The toolbar along the top-left side of the Playlist Editor contains a series of buttons that 
allow you to populate the playlist and perform other basic actions on the existing playlist. 
See An overview of the Playlist Editor, on page 44 for more information.

The following table provides a functional description of each button on the playlist toolbar:

 
Create New Playlist
Create and displays a new, empty playlist.
Alternative access:
• Menu command: File>New Playlist
• Keyboard shortcut: Ctrl+N

 
Open Existing Playlist
Displays a dialog box for selecting and opening an existing playlist asset.
Alternative access:
• Menu command: File>Open Playlist
• Keyboard shortcut: Ctrl+O

 
Save Current Playlist
Saves the current playlist. If the playlist is new and has not yet been saved, a 
dialog box appears and lets you set specific data related to the playlist.
Alternative access:
• Menu command: File>Save Playlist
• Keyboard shortcut: Ctrl+S

 
Save Current Playlist As
Saves the current playlist under a different name.
Alternative access:
• Menu command: File>Save Playlist As

 
Reload
Reloads the most recently saved version of the playlist.
Alternative access:
• Menu command: Actions>Reload Playlist
• Keyboard shortcut: F5

 
Insert New Page
Opens the Select a template for the new graphic dialog box, which allows you 
to insert a new page into the playlist.

 
Verify Playlist
Executes a manual playlist verification to see if the items in the playlist have been 
properly published to the devices selected in the Device for Verify drop-down list. 
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Approve all items in Mergelist
This button only appears when the playlist open in the Playlist Editor was created 
from a Merge List.
Approves all of the items (pages & scenes) in the playlist, moves the assets to the 
appropriate categories, and changes the item’s status in the playlist to Approved. 
See Approving or rejecting new pages and scenes created from a Merge List, on 
page 20 for more information.

 
Render all items in playlist
This button only appears when the playlist open in the Playlist Editor was created 
from a Merge List.
When a Merge List is used to create pages and scenes, all of the resulting pages 
and scenes can be rendered and saved as individual video clip files using the 
Playlist Editor’s Render all items in playlist button. See Batch-rendering of 
pages and/or scenes to a file, on page 30 for more information.
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Template Editor’s toolbar & properties
Xbuilder’s Template Editor is located in the bottom portion of the Xbuilder interface and is 
used to display and edit pages, templates, and/or scene assets. When a template or page 
asset is opened in Xbuilder, the control-side of the project (Template+Scene) is displayed in 
the Template Editor allowing you to make edits to the content and create new pages. 
Logically, opening a standalone scene asset displays the actual scene allowing you to also 
make changes to its content. 

The Template Editor’s toolbar items and properties change slightly depending on the type 
of asset that it is currently open in the Template Editor. The following sections identify and 
describe each of the possible toolbar buttons, properties, icons and fields that may appear 
in the Template Editor.

• Template Editor’s toolbar buttons, on page 96
• Template Editor’s properties, on page 99
• X-icon, on page 99
• Asset name (Template or Scene), on page 99
• Shared Page, Embedded Page and Scene icons, on page 100

Template Editor’s toolbar buttons
Depending upon the type of asset and how it was opened, the Template Editor’s toolbar 
contains the following buttons:

Template Editor’s
canvas

Template Editor’s
toolbar

Template Editor’s
properties

X-icon, asset name
and page/scene icons

 
Save Page or Save Scene
This button is only available if the current page (shared page) or scene asset was 
opened from the Asset Browser.
Saves any edits that have been made to the current page (shared page) or 
scene.

 
Save Page, and Close
This button is only available if the current page (shared page) or scene asset was 
opened from within the playlist.
Saves any edits that have been made to the current page or scene and closes 
the page/scene so that it is no longer displayed in the Template Editor.
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Save Page As or Save Scene As
This button is only available if the current page (shared page) or scene asset was 
opened from the Asset Browser.
Saves any edits that have been made to the current page or scene under a 
different name and allows you to store it within other Pages or Scenes 
categories in the Asset Browser.

 
Insert in Playlist and Start New Page
This button is only available if the current page (embedded page) was opened 
from within the playlist.
Saves any edits that have been made to the current shared page and adds it to 
the playlist currently opened in the Playlist Editor. Where within the playlist the 
page is added depends on whether the Enable Insert Page after Selected 
button is enabled or disabled.

 
Commit and Close
This button is only available if the current page (embedded page) was opened 
from within the playlist.
Updates the page in the playlist with any edits that have been made and closes 
the page so that it is no longer displayed in the Template Editor.

 
New Page
This button is only available if the current page (shared page) was opened from 
the Asset Browser.
Creates a new page by resetting the variable fields back to their original 
template defaults. Note that the new page is not actually created until you save 
it as a shared page, or add it to the playlist as an embedded page.

 
Save Page, Insert in Playlist or Save Scene, Insert in Playlist
This button is only available if the current page (shared page) or scene was 
opened from the Asset Browser.
Saves any edits that have been made to the current shared page and adds it to 
the playlist currently opened in the Playlist Editor. Where within the playlist the 
page is added depends on whether the Enable Insert Page after Selected 
button is enabled or disabled.

 
Enable Insert Page after Selected or Enable Insert Scene after Selected 
This button is only available if the current page (shared page or embedded) or 
scene was opened from the Asset Browser.
When enabled (orange rather than blue), and the Save Page, Insert in Playlist 
button is used, the page will be inserted into the playlist below the currently 
selected row. When disabled, the page will be added to the last row in the 
playlist.

 
Create New WorkOrder
This button is available if the current page (shared page or embedded) was 
opened from either the Asset Browser or from within the playlist. However, it is 
not available when a scene asset is open.
Opens the Work Order dialog box, which allows you to create a new work 
order for the page. The work order system requires users to login using a user 
name and password. User names and passwords are registered and stored on 
the Xmedia Server using the Xmedia Server’s properties panel. See page 22 for 
more information.
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Approve and Next
This button is available if the current page or scene was opened from the 
playlist created by the Merge List or Make List file.
As part of the Merge List and QC workflow, you can perform a quality control 
verification of the pages and scene created from the Merge List / Make List. See 
page 20 and page 38 for more information.

 
Reject and Next
This button is available if the current page or scene was opened from the 
playlist created by the Merge List or Make List file.
As part of the Merge List and QC workflow, you can perform a quality control 
verification of the pages and scene created from the Merge List / Make List. See 
page 20 and page 38 for more information. 

 
Next Merge List item
This button is available if the current page or scene was opened from the 
playlist created by the Merge List or Make List file.
This button allows you to move to the next item (skip) in a playlist created by 
the Merge List / Make List without changing its Status.

 
Preview Page or Preview Scene
This button is available to all pages, templates and scenes opened in the 
Template Editor.
Allows you to view the playout of the resulting template, page, or scene on the 
configured preview device (Software CG), including the playout of its video, 
audio, and animation elements. 

 
Render Page to File or Render Scene To File
This button is available to all pages, templates and scenes opened in the 
Template Editor.
If a template, page or scene contains clips, audio files, and/or cel animations, 
then the Render to File command in the Template Editor’s toolbar allows you 
to render and save the template/page as a video file. 

 
Take Snapshot of Page or Take Snapshot of Scene
This button is available to all pages, templates and scenes opened in the 
Template Editor.
The Take Snapshot of Page/Scene command  in the Template Editor’s 
toolbar allows you to render and save (as an image file) a single frame of the 
scene’s playout. This is particularly useful when the template, page or scene that 
is open in Xbuilder’s Template Editor contains clips and/or cel animations, as 
you can specify the exact frame during playout to capture. 
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The following page properties can be set from within the Template Editor:

X-icon
The X-icon  appears in the upper portion of the Template Editor when a template, page 
or scene was opened from the Asset Browser. Once any edits have been saved, dragging 
the icon from the Template Editor to the playlist allows you to add the page or scene to a 
playlist that is open in the Playlist Editor.

Asset name (Template or Scene)
The name of the template or scene that the shared page or scene is based upon is displayed 
in the upper-right portion of the Template Editor. This is information is practical if you want 
to make changes to the page/scene that goes beyond editing the variable fields, such as 
changing the layout or formatting. These types of changes require editing the template in 
Xstudio.

Even though shared pages are assets saved in the Xmedia Server, all pages are built from 
templates and therefore inherit the properties and formatting settings of the template. As 
such, only the variable fields from the template can be changed on the page in Xbuilder. 
The implication of being based on a template is that any saved changes to the template in 
Xstudio will automatically be transmitted to all of the pages that were created from that 
template.

Recall ID This property is only available to pages (shared pages) and scene assets 
opened in the Template Editor.
Allows you to specify a unique identifier for the page or scene. The Recall 
ID can later be used to instantly call up the page asset in the Vertigo Suite’s 
playout application, Xplay.

Name This property is only available to templates (embedded pages) opened in 
the Template Editor.
The default name of the embedded page will be identical to the name of 
the template until you type a new name in this field and press either the 
Insert in Playlist and Start New Page button or the Commit and Close 
button in the Template Editor toolbar.

Description Allows you to provide a short textual description of the page or scene for 
helping to identify the purpose or contents of the page.

Specify Offset Allows you to specify the time delay between the playout between the 
open page/scene and the next consecutive page/scene in the playlist.

Duration Allows you to specify the amount of time the page or scene will remain on 
air. 

Note: The name of the embedded page will be identical to the 
template name until you change the name in the page’s Name 
property field. 
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Shared Page, Embedded Page and Scene icons
Since there is no way distinguishing which pages in the Playlist Editor are embedded pages 
or shared pages; opening a page in the Template Editor and verifying the icon in the upper-
right corner is the only way of identifying the page type.

The Shared Page icon  indicates that the page that is open in the Template Editor is a 
shared page. Meanwhile, the Embedded Page icon  indicates that the page that is open 
in the Template Editor is an embedded page.

Similarly, if the asset open in the Template Editor is a scene asset, the Scene icon  is 
displayed in the upper-right corner of the Template Editor.
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Segment Editor toolbar
The toolbar along the top-left side of the Segment window contains a series of buttons that 
allow you to perform actions related to populating the rundown segment and performing 
basic actions on the existing segment.

The following table provides a functional description of each button on the Segment 
window’s toolbar:

 
Create New Segment
When selected in the standalone Segment window, a new (empty) rundown 
segment is created, which can be populated and saved as a shared segment.
When selected in the Segment window associated with the Rundown Editor, a 
new (empty) rundown segment is created and added to the rundown. The 
default name of the segment, New Segment, can immediately be changed by 
typing a new name in the Rundown Editor. You can then populate the segment 
with pages and save it as an embedded segment in the rundown, or use the Save 
Current Segment As button to save it as a shared segment (see Saving a 
rundown segment, on page 80). 
Alternative access:
• Menu command: File>New Segment
• Keyboard shortcut: Ctrl+T

 
Save Current Segment
Saves the current rundown segment in its current form (i.e. an embedded 
segment is saved as an embedded segment, and a shared segment is saved as a 
shared segment). Use the Save Current Segment As button to save an 
embedded segment as a shared segment (see Saving a rundown segment, on 
page 80). 
An asterisks next to the segment’s name indicates that edits have been made to 
the segment, but have not yet been saved.
Alternative access:
• Menu command: File>Save Playlist
• Keyboard shortcut: Ctrl+S

 
Save Current Segment As
Opens the Save Segment dialog box, which allows you to:
• Save the currently open shared segment under a different name.
• Save the currently open embedded segment as a shared segment to be stored in the 

Asset Browser’s Segments root category.
Alternative access:
• Menu command (standalone only): File>Save Segment As
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Reload
Reloads, or refreshes, the most recently saved version of the segment.
Reloading the segment is useful for:

• insuring that you have the most recent version of a segment. For 
example, if somebody else accesses and makes changes to the segment 
while you are have it open.

• quickly returning to the state that the segment was in when it was last 
saved after making unsaved and unwanted edits. 

Alternative access:
• Menu command: Actions>Reload Segment
• Keyboard shortcut: F5

 
Insert New Page
Opens the Select a template for the new graphic dialog box, which allows you 
to open and edit a page in the Template Editor. Once you have made the 
appropriate edits to the page, click the Insert in Playlist and Close button  
in the Template Editor’s toolbar to insert the new page into the segment.

 
Verify Segment
Executes a manual segment verification to see if the items in the segment have 
been properly published to the devices selected in the Device for Verify drop-
down list. 
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Although Xbuilder’s default settings are appropriate for most operating circumstances, you 
may want to customize the look and behavior of the application using Xbuilder’s settings. 
Note that modifying these settings is entirely optional.

The following sections provide a quick reference description of all of Xbuilder’s settings:
• General settings, on page 104
• Display settings, on page 105
• Template Favorites settings, on page 107
• Automation settings, on page 108
• Playlist Ingest settings, on page 109
• Place Holders settings, on page 110
• Merge List settings, on page 111
• Logging settings, on page 112
• Render To File settings, on page 113
• Timelines settings, on page 114
• Work Orders settings, on page 115
• Servers settings, on page 115
• Playlist > Basic settings, on page 116
• Playlist > Highlight settings, on page 117
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General settings
• Startup panel - Specifies the panel that is loaded when Xbuilder is launched.
• Page life span - All pages have an expiry date. Once reached, expired pages are deleted 

from the system in order to keep the server from becoming clogged with pages that 
are no longer relevant. Use this field to enter the number of days before a page expires. 
If left at 0, the page never expires. If a page that already existed is edited, its expiry is 
reset to the number of days specified in this field. 

• Remove deleted pages on open - If a playlist includes deleted pages, selecting this 
option ensures that they will be deleted automatically the next time the playlist is 
loaded. Otherwise, the expired pages will be highlighted in red.

• Append date to page names - When selected, this setting adds the date to the asset 
name of the page that is being created/saved.

• Verify playlist - When set to Automatic, each element of the playlist is verified when 
they are loaded. When set to Manual, each element in the open playlist is verified when 
the Verify Playlist button  is clicked in the Playlist Editor’s toolbar. In both cases, the 
result of the verification is displayed in the Status column of the playlist element. See 
Verifying the contents of a playlist, on page 47 for more information.

• Number of Verify Devices - Determines the number of device rows that will be 
dedicated as Verify devices in Xbuilder’s Device Manager. See Configuring a device for 
the verification of playlist elements, on page 10 for more information.

• Spell check on - When selected, the application helps you to avoid any typing error or 
spelling mistakes by underlining any potentially misspelled words that you have 
entered.

• Spell check color - Specifies the RGB color that the spell check on setting uses for the 
line color to identify potentially misspelled words.

• Use default offset after zero duration - This setting affects the offset applied to playlist 
elements after edits. When the playlist is edited, the offsets of affected elements are 
adjusted to avoid any gaps in the playlist. The rule applied when setting the offset of a 
playlist element that follows a page element is to make the offset equal to the duration 
of the preceding page element. In cases where the duration of the preceding page 
element is zero then the Use default offset after zero duration setting is consulted. If it 
is true, then an offset of 10 seconds is used, otherwise, an offset of 0 is used.

• SWCG Executable Location - The full path to the Software CG executable used to 
preview and/or render to the asset to an image or video file. Usually, the installer places 
the VertigoCG2L.exe file in the following directory:  
C:\Program Files\VertigoXmedia\Apps\VertigoCG2

• TV Format - When using a MergeList in Xbuilder to create a series of pages, the TV 
Format parameter ensures that the values that appear in the playlist’s Duration column 
are displayed using a consistent resolution format. For example, if the duration in the 
MergeList is 45 seconds for a 25 fps template, then the duration in the playlist will be 
00:45.0 when TV Format is set to PAL and 00:37.15 when set to NTSC.
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Display settings
Although the Display setting page has various settings, the bulk of the settings deal with 
the overflow and underflow properties, which are set on this page and reported in the 
Overflow column in the Playlist Editor.

At the center of the overflow/underflow discussion are timeslots. A timeslot is a set of 
playlist items between two hard-starts (a hard-start is a playout type for bringing playlist to 
air at a specific time). The total time available in the timeslot is determined by the difference 
of the two hard-start times. Ideally, the timeslot should be filled with enough content to 
exactly fill this time. 

Overflow (or underflow) refers to the difference between the total time of the content in a 
timeslot and the time available in the timeslot. When the total time of the content in a 
timeslot exceeds the time available, there is an overflow. Similarly, when the total time of 
the content in a timeslot is less than the time available, there is an underflow.

The overflow column in the playlist indicates if a timeslot has an overflow or an underflow. 
The time difference is displayed as a positive value for overflows and a negative value for 
underflows. Furthermore, it is possible to specify thresholds for overflow and underflow. 
When the overflow or underflow in a timeslot exceeds the threshold, the overflow column 
is colored to draw attention to the problem. 

• Tile size for proxies - The size (in pixels) of proxies used in to display the assets in a 
category. 

• Overflow/underflow error color 1 - Specifies the color used to in the playlist’s 
Overflow column to indicate that a timeslot contains an overflow or underflow that 
exceeds acceptable thresholds. 

• Overflow/underflow error color 2 - Specifies a second color used to indicate that a 
timeslot contains an overflow or underflow that exceeds acceptable thresholds. The 
need for a second/alternating color is to distinguish between successive timeslots that 
contain an error. 

• Normal status color 1 - Specifies a color used to in the playlist’s Overflow column to 
indicate that a timeslot does not contain an overflow or underflow that exceeds 
acceptable thresholds. 

• Normal status color 2 - Specifies a second color used to indicate that a timeslot does 
not contain an overflow or underflow that exceeds acceptable thresholds. The need for 
a second/alternating color is to distinguish between successive timeslots that do not 
contain an error. 

• Overflow tolerance - Specifies the threshold (in milliseconds) above which an overflow 
in a timeslot is considered an error. 

• Underflow tolerance - Specifies the threshold (in milliseconds) above which an 
underflow in a timeslot is considered an error. 

• Offset display format - Specifies how the Offset column of the playlist is formatted. The 
following settings are available: 

• Standard: When hard-starts are used, items display the time of day at which they 
will play. If there are no hard-starts, items display the time relative to the start of the 
playlist at which they will play. Secondary items display the time at which they will 
play, relative to the start of the primary item that contains them. 
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• Raw: Displays the offset between the start of the playlist item and the preceding 
item. If the preceding item is a clip, the offset is with respect to the end of the clip 
(usually this value is zero). If the preceding item is a page, the offset is with respect 
to the start of the page, that is, when the page was taken. Normally, this value is 
equal to the duration of the preceding page. 
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Rather than searching through the Asset Browser for a template, the Template Favorites 
settings allow you to assign a particular template to a control key sequence. This provides a 
convenient shortcut for opening frequently needed and used templates. The Template 
Favorites settings allows you to assign shortcut for up to (10) templates. 

To assign a specific template to a control key sequence:
1 Open the Settings dialog box: Tools>Settings
2 Select Template Favorites from the tree menu in the left panel.
3 Click in the text box of one of the Control key sequence (i.e. Ctrl+1) rows that you want 

to assign the template to.
4 Press the  button next to the text box. 

The Select Template dialog box appears.
5 In the Select Template dialog box, navigate to the desired template. Select the 

template and click OK.
Now when you are working in Xbuilder and you press the Control key sequence, the 
template assigned to that shortcut will open in the Xbuilder content panel.
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Automation settings
Xbuilder automation settings allow you to determine whether or not you would like 
messages to display while working in Xbuilder. While these messages may become 
redundant, they often serve as an important confirmation step. Therefore, in most cases, we 
recommend that you leave these settings selected.

• Confirm page deletion - When selected, Xbuilder displays a confirmation message 
whenever you attempt to delete a page. When cleared, the message will not be 
displayed and the deletion process will execute immediately.

• Confirm playlist clear - When selected, Xbuilder displays a confirmation message 
whenever you attempt to clear a playlist. When this setting’s check box is cleared, the 
message will not be displayed and the playlist will be immediately cleared.

• Prompt for save on new playlist - When selected, Xbuilder displays a confirmation 
message requesting that you save any changes to the current playlist before closing it. 
When this setting’s check box is cleared, the message will not be displayed and the 
playlist will close without saving the most recent changes.
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Playlist Ingest settings
Xbuilder is able to generate playlists from a traffic file. The following settings are used to 
influence how this generation takes place. 

• Default category for Clips - Specifies the category in which all clips used in the 
ingested playlist reside. When a clip name is encountered in the traffic file, a search is 
made for the clip in this category. This category is also used to hold place-holder clips 
when they need to be created. During the ingest process, the traffic file may refer to 
clips that are not present. When this occurs a place-holder clip is created in the 
specified category and an associated WorkOrder Job is created. 

• Default category for Pages - Specifies the category in which all pages used in the 
ingested playlist reside. When an Action is encountered in the traffic file, a search is 
made for a page with the same name in this category. 

• Default category for Templates - Specifies the category in which all templates used in 
the ingested playlist reside. When a Live Event is encountered, a search is made for a 
template with the same name in this category. When an Action is encountered in the 
traffic file, a search is first made for a page with the same name. If that search fails, then 
a second search is made for a template with the same name in this category. 

• Default Secondary Event Template - Specifies the default template to use for an 
Action when no page or template could be found.

• Path for error log - Specifies the directory in which the ingest log file is written. The 
ingest log file contains a record of what happened during the playlist ingest. It can be 
consulted to see if any errors occurred. 

• Tolerance for too long clips - Specifies a time value (in milliseconds). The maximum 
value by which the actual duration of a clip can differ from its reported duration in the 
traffic file. If the difference between the actual clip duration and the reported clip 
duration exceeds this tolerance, (either too short or too long), then the clip is 
considered invalid. Xbuilder will display a message box upon completion of the ingest 
if any invalid clips are encountered. 
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Place Holders settings
Within a WorkOrder Job, a place holder can be created for an image or clip. A place holder is 
an empty asset that serves as a place holder for an image or clip that will be obtained later 
by completing the associated WorkOrder Job.

• Images place holder default category - Specifies the category in which new image 
place holders are saved. If unspecified, image place holders are saved to in the same 
category as the image from which the place holder is created. 

• Clips place holder default category - Specifies the category in which new clip place 
holders are saved. If unspecified, clip place holders are saved to the same category as 
the clip from which the place holder is created. 
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The properties on the Merge List settings page determine the default categories in which 
new pages and scenes are placed when they are created using a Merge List. Note that new 
scene are first placed in a temporarily category until they are approved, then they are 
moved to the scene category. New pages do not go to a temporary category, rather they go 
directly to the default category specified in the Merge List settings. See Creating pages 
and/or scene using a Merge List, on page 15 for full details and instructions.

• Merge List default page category - Select the  button to open the Select a Category 
window. Then select a destination category or sub-category where all new pages will 
be stored once created using the Merge List file.

• Merge List default scene category - Select the  button to open the Select a 
Category window. Then select a destination category or sub-category where the 
approved scenes will be stored.

• Merge List temporary scene category - Select the  button to open the Select a 
Category window. Then select a destination category or sub-category where the new 
scenes will be stored temporarily until they are approved, in which case they will be 
moved to the category specified in the Merge List default scene category setting. 
Rejected scenes will remain in this temporary category.
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Logging settings
Xbuilder offers several logging options that you can use for observing Xbuilder’s behavior 
and/or troubleshooting unexpected problems. The Xbuilder log files are saved in the 
following directory: C:\ProgramData\VertigoXmedia\Logs

• Rollover count - The rollover count determines the number of Xbuilder*.log files 
kept in the logging folder. Choose a large enough number so that enough relevant log 
files are stored. This helps to identify of repetitive behaviors and facilitates 
troubleshooting.

• Log file size (bytes) - The maximum size of a log file before starting over from the 
beginning.

• Log level - Xbuilder can be set to provide the following levels of logging events:
• Error – A major failure that impacts the end-user.
• Warn – An important but non-fatal error.
• Info – A useful notification message to help users troubleshoot/track issues.

• Enable Debug Logging - Select the  button to open the Verbose Logging window, 
which is used for selecting which categories of information, processes and errors to 
record in the log files. 
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Render To File settings
Xbuilder offers a variety of rendering profiles which allow you to render templates, pages or 
scenes to files that can be stored on your system. Full details and instruction for rendering 
to file are available on page 25. 

• Default Profile Path - (To be used in Windows7 only) Identifies the path to the folder 
where the Pipeline profile files can be found. Normally, the Vertigo Suite installer stores 
these files in the following directory:  
C:\Program Files(X86)\Technologies\Vertigo Render To File.  
Once you specify the path, you must click OK and restart Xbuilder for the profiles to 
populate the Default Profile settings drop-box.

• Default Profile - (To be used in Windows7 only) If you do not explicitly choose one in 
the Render To File window, the default profile selected in this setting will be used to 
render the asset to a file. The drop-box is populated based on the files located in the 
folder defined by the Default Profile Path setting. Current profiles include:

• MPEG2 (mp2 audio) HD
• MPEG2 (mp2 audio) SD
• MXF IMX 25 (PCM audio) 
• MXF IMX 30 (PCM audio) 
• MXF IMX 40 (PCM audio) 
• MXF IMX 50 (PCM audio)
• MXF MPEG2 (PCM audio) HD
• MXF MPEG2 (PCM audio) SD
• MXF XDCAM HD-50 (50 Mbit 4:2:2) (PCM audio)
• VAF HD
• VAF SD

• Default Render Path - Allows you to specify the default folder on your system where 
the file will be rendered to.

• Default Duration - The default duration of the file to be generated. If the duration is 0, 
the clip will be rendered for 1 second.
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Timelines settings
Xbuilder’s Timelines settings support the creation and definition of auto promo timelines.

• Show full timeline name - Determines if the fully qualified name of the timeline, 
including its category, or the short name of the timeline, without its category, is 
displayed above the timeline editing area.

• Default Fade In Duration (sec) - Specifies the default fade in duration used in newly 
created timelines. 

• Default Fade Out Duration (sec) - Specifies the default fade out duration used in newly 
created timelines. 

Note: The durations are specified in seconds, since timelines may use 
a variety of video formats, with different frame rates. 
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Xbuilder’s WorkOrders settings support the behavior and management of work orders and 
jobs.

• Rows in WO job list - This setting determines the number of rows are always visible in 
the job list portion of the Work Order window. Since most work orders contain a small 
number of jobs, the default value of 3 is reasonable. If there are more than three jobs in 
the work order, you can always scroll down through the list to view the additional jobs. 
If you routinely add numerous jobs to a work order, this setting can be set to a larger 
number so that you can see all the jobs without having to scroll. Note that the 
minimum permitted value is 3 and the maximum permitted value is 10.

• Highlight OverDue WO - Highlights work orders that are past their due date in red.
• WO due date tolerance (days:hours) - Sets the tolerance for whether a work order is 

identified as being overdue and consequently highlighted in red if the Highlight 
OverDue WO setting is enabled. The format of the this setting value is Days:Hours. For 
example, a tolerance value of 1:18 translates to one day and eighteen hours can go by 
before the work order is flagged as being overdue.

Servers settings
The Servers settings specify the locations of the Xmedia Server and the Data Server. The 
XmediaServer contains all assets, i.e. all building blocks used in the creation of broadcast 
graphics. This is where playlists, templates, images, etc., are stored. The Data Server is an 
application that manages all data coming in from sources specified in templates. The Data 
Server distributes the data and provides live updates of data values when requested.

• XmediaServer IP Address - Specifies the IP address of the machine running the 
XmediaServer. 

• XmediaServer Port - Specifies the port on which the XmediaServer is listening.
• Backup XMedia Server IP Address - Specifies the backup server’s IP address used in 

case of failure of the primary Xmedia Server.
• Backup XMedia Server Port - Specifies the backup server’s port used in case of failure 

of the primary Xmedia Server.
• Data Server IP Address - Specifies the IP address of the Data Server.
• Data Server Port - Specifies the port on which the Data Server is listening.
• Backup Data Server IP Address - Specifies the backup data server’s IP address used in 

case of failure of the primary data server.
• Backup Data Server Port - Specifies the backup data server’s port used in case of failure 

of the primary data server.

Note: To access the Xmedia Server and Data Server interfaces, select 
Start>Settings>Control Panel. Then select the VertigoXmedia Data 
Server or VertigoXmedia Xmedia Server icons.
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Playlist > Basic settings
Playlist basic settings determine colors for everything in your playlist -- pages, actions, 
segments, comments and titles. Click the  button to the right of each color field to display 
a color selection dialog box. You can also choose a font for the playlist.

• Title Color - Specifies the background color of the playlist header row.
• Title Text Color - Specifies the text color of the playlist header row.
• Page Color - Specifies the background color of a page in the playlist.
• Page Text Color - Specifies the text color of a page in the playlist.
• Action Color - Specifies the background color of an action in the playlist.
• Action Text Color - Specifies the text color of an action in the playlist.
• Segment Color - Specifies the background color of a playlist segment.
• Segment Text Color - Specifies the text color of a playlist segment.
• Comment Color - Specifies the background color of a playlist comment.
• Comment Text Color - Specifies the text color of a playlist comment.
• Main Font - Specifies the font to be used throughout the playlist.
• Show hours in duration column - Determines how the duration values are displayed 

(i.e. hours, minutes, seconds, frames). When selected, the duration values are displayed 
using the following format: MM:SS.FF. However, if the duration exceeds one hour, the 
duration value is shown in an HH:MM:SS.FF format. For example 01:12.23. If this setting 
is not selected, durations values are always shown in HH:MM:SS.FF format. For example 
00:01:12.23.
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Playlist highlight settings determine colors for playlist items that are currently in the 
process of being edited. Click the  button to the right of each color field to display a color 
selection dialog box.

• Insert Line Color - When an item is being dragged to a new position in the playlist, the 
insert line indicates where the item will be placed once the mouse key is released, and 
whether or not it is being placed within a segment (refer to the note below). An insert 
line that runs the entire width of the playlist indicates that the item is being moved 
outside of a segment. If the line does not run the entire width, the item is being moved 
within a segment.

• Select Color - Specifies the background color of a selected playlist item.
• Select Text Color - Specifies the text color of a selected playlist item.
• Segment Selected Text Color - Specifies the color used to draw the segment name in a 

segment that is selected. We recommend choosing a color that contrasts with the 
Segment Selected Color so the text will be visible. 

• Segment Drag Over Color - Specifies the background color of the segment heading 
when an item is being dragged into it.

• Edit Color - Specifies the background color of a playlist cell when its contents are being 
edited.

• Edit Text Color - Specifies the text color of a playlist cell when its contents are being 
edited.
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Contact Us
Grass Valley Technical Support
For technical assistance, contact our international support center, at 
1-800-547-8949 (US and Canada) or +1 530 478 4148.

To obtain a local phone number for the support center nearest you, please consult the 
Contact Us section of Grass Valley’s Web site (www.grassvalley.com).

An online form for e-mail contact is also available from the Web site.

Corporate Head Office
Grass Valley
3499 Douglas-B.-Floreani
St-Laurent, Quebec  H4S 2C6
Canada
Telephone: +1 514 333 1772
Fax: +1 514 333 9828
www.grassvalley.com


	Introducing Xbuilder
	Getting started with Xbuilder
	Installation and licensing information
	Starting Xbuilder and connecting to the Xmedia Server
	Overview of Xbuilder’s user interface
	Configuring Xbuilder’s settings
	Adding and configuring a Preview device
	Configuring a device for the verification of playlist elements

	Creating, editing and previewing pages and/or scenes
	Creating an individual shared page from a template
	Creating pages and/or scene using a Merge List
	Creating Merge List file in Microsoft Excel
	Creating an XML Merge List file
	Approving or rejecting new pages and scenes created from a Merge List

	Opening an existing page or scene
	Editing a page or scene’s content elements
	Replacing an image, cel animation, or clip on a page
	Using Work Orders to request missing images or clips

	Previewing a page or scene on the Preview device
	Saving a snapshot (image file) of a page or scene’s playout

	Rendering pages and scenes to a clip file
	Render to VAF for pre-rendered playout
	Render to MXF for playout on a video server
	Render to MPEG for preview
	Manual rendering pages and/or scenes to a file
	Batch-rendering of pages and/or scenes to a file

	Performing Quality Control (QC) and Media Check (MC)
	Setting up the QC and MC workflows
	Create and set up the Subfolders and Approved Category folders
	Specify Xbuilder’s settings for the QC and MC workflows
	Associate channels to devices in Xbuilder’s Device Manager
	Verify that the system templates are installed and publish them to the SWCG
	Verify the presence of the QC license

	Creating a Make List / Air List spreadsheet
	Using AE Plug-in and the Make List to create and ingest graphics
	Quality Control: Previewing and validating graphics in Xbuilder
	Media Check: Graphics publish verification

	Creating and using playlists
	An overview of the Playlist Editor
	Procedural overview for creating a sequential playlist
	Creating a new playlist
	Opening an existing playlist
	Verifying the contents of a playlist
	Populating a playlist
	Creating and adding an embedded page to a playlist
	Adding shared pages, scenes and clip assets to a playlist
	Appending or inserting the contents of a playlist to a playlist

	Configuring the Playlist table columns
	Adding columns to a playlist
	Removing columns from a playlist
	Creating, renaming, and deleting your custom column headings
	Reordering the columns in a playlist
	Using the standard column layouts: Basic or Full

	Repositioning playlist items within the playlist
	Repositioning primary playlist items (clips, scenes, pages, or comments)
	Adding a secondary event to a primary event in a playlist

	Adding segments to the playlist
	Adding comments to the playlist
	Deleting playlist items from the playlist
	Editing the properties associated to the playlist items
	Saving a playlist
	Reloading the playlist

	Creating and using rundowns and segments
	An overview of the Rundown Editor
	An overview of the Segment Editor & Segment Window
	Procedural overview for creating rundowns
	Creating a new rundown
	Opening an existing rundown
	Creating and using rundown segments
	Creating a new rundown segment
	Configuring the segment table columns
	Adding pages to a rundown segment
	Adding an embedded page to a rundown segment
	Adding a shared page to a rundown segment
	Adding the pages of a playlist to a rundown segment

	Adding scene assets to a rundown segment
	Adding clip assets to a rundown segment
	Adding a comment row to the rundown segment
	Repositioning pages within the rundown segment
	Deleting or removing items from a rundown segment
	Saving a rundown segment

	Opening an existing rundown segment
	Adding segments to a rundown
	Adding the first segment to a new rundown
	Adding additional segments to a rundown

	Repositioning segments within the rundown
	Removing segments from a rundown
	Saving a rundown under a different name or category
	Deleting a rundown from the system

	Xbuilder’s menus & toolbars
	Xbuilder’s menu commands
	File menu
	View menu
	Actions menu
	Tools menu
	Timeline menu
	Help menu

	Playlist Editor’s toolbar
	Template Editor’s toolbar & properties
	Template Editor’s toolbar buttons
	Template Editor’s properties
	X-icon
	Asset name (Template or Scene)
	Shared Page, Embedded Page and Scene icons

	Segment Editor toolbar

	Xbuilder’s settings
	General settings
	Display settings
	Template Favorites settings
	Automation settings
	Playlist Ingest settings
	Place Holders settings
	Merge List settings
	Logging settings
	Render To File settings
	Timelines settings
	Work Orders settings
	Servers settings
	Playlist > Basic settings
	Playlist > Highlight settings

	Contact Us

