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Introducing Xpanel
Xpanel is the Vertigo Suite’s application that allows you to create and operate “soft” control 
panels for controlling the playout of graphics on external channel branding devices. 
Specifically, Xpanel can be used to control the following channel branding devices: 
Imagestore 750, Densite LGK-3901, Densite DSK-3901, Intuition, Intuition XG, Vertigo XG 
and HMP devices.

Xpanel’s Design mode provides an environment for creating custom control panels that 
meet your specific functional needs. Building a control panel in Xpanel basically involves 
adding and configuring Xpanel’s control objects (widgets), which provides operators with 
manual and automated controls for selecting and playing out branding graphics, as well as 
video and/or audio media on a single-channel or multiple channels. For example, panels 
may include controls for performing the following tasks:

• Cutting or fading up and down graphics on specific device keyers
• Viewing what media is currently keyed up on a specific device keyer
• Adjusting the gain, transparency and/or positioning media on device keyers
• Adjusting the levels and playing out voice-over audio, while ducking program audio
• Performing A/B mixing of incoming video sources using traditional cut and fade 

transitions
• Monitoring the health and alarms of connected devices

If your control needs extend beyond the abilities of Xpanel’s objects, Xpanel also allows you 
to add primitive objects, which can be configured to perform actions based on 
playout/operator events or changes in tallies from the devices.

Xpanel also provides a station configuration, where channels and their associated devices 
are defined. This simplifies panel creation by abstracting away device specifics and allows 
for channel selection and ganged operation.

Once panels have been created and saved, they can be opened in Xpanel’s Production 
mode and used by operators to control the on-air playout of graphics on the specified 
channel branding devices.
 1
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Getting started with Xpanel
To help get you started using Xpanel, this chapter provides you with information about 
installing and licensing the Xpanel software. Once installed, you must configure Xpanel to 
recognize and actively connect with a local or remote server (Xmedia Server). 

Information and instructions to help you set-up and familiarize yourself with Xpanel are 
provided in the following sections:

• Installation and licensing information, on page 4
• Starting Xpanel and connecting to the Xmedia Server, on page 5
• Overview of Xpanel’s user interface, on page 7

Note: For users who are unfamiliar with the Xmedia Server, it is the 
centralized asset management server and license manager for Vertigo 
applications and devices. The Xmedia Server can run locally as a 
service on the Xpanel workstation, or it can be a remote/central 
Xmedia Server device on the same network as the workstation 
running Xpanel. In both cases, the Xmedia Server contains the assets 
and the database that Xpanel uses to play out graphics and voice-
over audio on branding devices. See Connecting Xpanel to an Xmedia 
Server, on page 5 for more information.
 3
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Installation and licensing information
Installation and licensing information
Xpanel is packaged with the Vertigo Suite software installation wizard. It can be installed as 
part of the full installation or as an individual (standalone) component. In both cases, you 
simply need to run the installation wizard on a workstation that is on the same network as 
the Xmedia Server.

Information regarding the Vertigo Suite’s hardware and network requirements, as well as 
instructions for installing and/or upgrading Xpanel, are available in the Vertigo Suite’s 
Release Notes, which can be downloaded from the Documentation Library on the Grass 
Valley website (www.grassvalley.com).

Xpanel requires that a software application license be installed and validated on the 
Xmedia Server that it is connected to (local or remote). Therefore, once Xpanel is installed, 
you must contact Technical Support (support@grassvalley.com) to request a license key for 
Xpanel. Then you must apply and validate the license using the Vertigo Suite’s License 
Manager, which stores the license on the Xmedia Server. Instructions for acquiring and 
validating Xpanel’s application license are also provided in the Vertigo Suite’s Release 
Notes. 

Note: Xpanel will not operate properly unless its connection to the 
Xmedia Server is active and a valid license is present. See page 6 for 
more information about resolving connection and license errors.
4
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Starting Xpanel and connecting to the Xmedia Server
Open Xpanel by clicking VertigoXmedia>Xpanel from the Windows Start menu.

Each time Xpanel is opened, it verifies the connection to the server and the availability of 
the Xpanel license. If both conditions are successful, then Xpanel opens and is ready to be 
used. However, if either of these conditions is unsuccessful, an error message appears and 
prompts you to resolve the situation.

The following sections describe how to resolve situations in which Xpanel cannot connect 
to the Xmedia Server or find a valid license on startup.

• Connecting Xpanel to an Xmedia Server, on page 5
• Resolving a license error on startup, on page 6

Connecting Xpanel to an Xmedia Server
As a client application, Xpanel must always be connected to the Xmedia Server, which is the 
centralized asset management server and license manager for Vertigo applications and 
devices. The Xmedia Server can run locally as a service on the Xpanel workstation 
(automatically installed as part of the Vertigo Suite installation) or it can be a 
remote/central Xmedia Server device on the same network as the workstation running 
Xpanel. In both cases, the Xmedia Server contains the assets and the database that Xpanel 
uses to play out graphics and voice-over audio on branding devices.

While using Xpanel, the connection to the Xmedia Server must always be maintained 
(active), otherwise you will be prevented from performing tasks that involve browsing or 
saving to the Xmedia Server. Therefore, if for any reason the connection to the Xmedia 
Server fails (disconnected), you must re-establish the connection before continuing to use 
Xpanel. 

Resolving an Xmedia Server connection failure when opening Xpanel:
1 Open Xpanel by clicking VertigoXmedia>Xpanel from the Windows Start menu.

If Xpanel cannot successfully connect to the Xmedia Server, an error message appears.
2 Click Yes and Xpanel’s Options window opens and displays the Setup page.
3 Verify Xpanel’s server connection configuration.

• If the Use Remote XMS check box is unchecked, Xpanel is configured to connect to 
the local Xmedia Server, which was installed as part of the Vertigo Suite’s 
installation package. Since Xpanel was unable to connect to the local Xmedia 

Note: If Xpanel’s Startup options are configured to open in Production 
mode, a station configuration must be loaded from the Xmedia Server 
before Xpanel can actually open. See page 21 for more information.

Note: Common reasons for losing the connection are that the Xmedia 
Server or the machine hosting Xpanel has lost its network connection 
(network is down, IP address has changed or network cable 
disconnected), the Xmedia Server service has been stopped, or the 
Xmedia Server machine has been shutdown or has crashed.
5
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Resolving a license error on startup
Server on start up, you should verify that the Xmedia Server Service is actively 
running (MS Control Panel>VertigoXmedia XmediaServer>Service Control).

• If the Use Remote XMS check box is checked, Xpanel is configured to connect to a 
remote Xmedia Server (i.e. central Xmedia Server) that is on the same network as 
the Xpanel client workstation. 

Since Xpanel was unable to connect to the remote Xmedia Server on start up, verify the 
accuracy of Server name / IP setting and the Server Port setting (14050). If these 
settings are incorrect, make the appropriate edits.
If these settings are correct, verify that the machine hosting the Xmedia Server is 
operating, that it is actively connected to the network, and its Xmedia Server Service is 
actively running.

4 Click OK.
If you made any changes to the server settings, a message box appears and informs 
you that you must restart Xpanel for the new server to take effect.
Xpanel should now open. If Xpanel still does not open, contact your system 
administrator to help troubleshoot any possible network problems.

Resolving a license error on startup
Resolving a license failure when opening Xpanel:

1 Open Xpanel by clicking VertigoXmedia>Xpanel from the Windows Start menu.
If Xpanel cannot successfully locate a valid Xpanel2 license on the Xmedia Server, an 
error message appears.

2 Evaluate and act according to the following:
• Click Enter License if you suspect that the cause of the license error is that the 

Xpanel2 license has not yet been installed and validated on the Xmedia Server. The 
License Manager opens and you can follow the instructions in the Release Notes 
for acquiring and installing a software license.

• Click Change Server if you suspect that the cause of the license error is that Xpanel 
is connected to the wrong Xmedia Server (the license resides on another Xmedia 
Server). Xpanel’s Options window opens and displays the Setup page. Follow steps 
3 and 4 on page 5 that describes how to resolve an Xmedia Server connection 
failure.
6
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Overview of Xpanel’s user interface
Xpanel has two work modes: Design and Production. Since each mode is used for different 
purposes, Xpanel’s user interface provides unique interface features in each mode. 

The Production Mode button located in the upper-right corner of the menu bar provides an 
easy way to identify which mode Xpanel is currently in.

To switch between Design and Production mode:
• Select the View>Production Mode menu command.

Or,
• Press CTRL+P

Or,
• Click the Production Mode button located in the upper-right corner of the menu bar. 

The following sections provide a quick overview of the various user interface features, while 
the remaining chapters provide more detailed descriptions within procedural contexts:

• Design mode interface components, on page 8
• Production mode interface components, on page 10

The following sections provide instructions for managing and using Xpanel’s interface, like 
opening/closing and docking/floating Xpanel’s Views, as well as how to zoom in/out or pan 
across Xpanel’s canvas.

• Opening and positioning Xpanel’s Views, on page 12
• Zooming in/out of the canvas, on page 14
• Panning across the canvas, on page 14

Note: Which mode Xpanel opens in depends upon the Start in 
Production mode setting in Xpanel’s Startup options (see page 8). 

Note: In order to switch from Design mode to Production mode, a 
Station Configuration must be loaded in Xpanel. See Loading a station 
configuration, on page 21 for more information. 
Also note that you may be prompted to enter a password when trying 
to switch from Production mode to Design mode. See page 95 for 
more information.

= currently in Design Mode

= currently in Production Mode
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Design mode interface components
Design mode is Xpanel’s authoring environment that allows you to create and edit panels. 
This section provides a brief functional description of the main interface components in 
Design mode.

Fig. 2-1: An example of a panel open in Xpanel’s Design mode

1 Menus - These menu commands provide access to the settings and administrative 
functions that are relevant to Xpanel’s Design mode. See Xpanel’s menus & toolbars, on 
page 107 for a description of each menu command.

2 Objects toolbar - Panels are created by adding control objects to the panel’s canvas 
and setting their properties. The objects toolbar consists of six (6) thematic tabs that 
contain object buttons that can be dragged onto the panel. The objects become the 
mechanism by which operators control broadcast graphics. See Adding objects and 
primitives to a panel, on page 26 for a description of each object.

3 Production mode button - Xpanel has two work modes: Design and Production. 
Besides being a toggle button to switch from one mode to the other, the Production 
mode button also identifies Xpanel’s currently mode. 

4 Panel Canvas toolbar - When creating or editing a panel, the buttons in this toolbar 
provide quick access to many of the administrative, editing and formatting functions 
that are applied to the panel and its objects. See page 107 for a functional description 
of each button in the toolbar.

5 Panel tabs and canvas - Each panel is created upon a canvas (workspace) where 
objects are added and formatted into a functional control panel. Multiple panels can be 
opened simultaneously, in which case a tab for each panel appears on top of the 
canvas area. These panels can be stacked (default) or docked to the outer sides (side-
by-side or up-down) by holding down the left-mouse button on a panel’s tab and using 
the docking options. The panel’s canvas also has properties that determine its 

1

2

5

6

3
4

7

= currently in Design Mode

= currently in Production Mode
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appearance and behavior. The following sections provide information and instructions 
on using the panel’s canvas:

• Opening panels or projects, on page 23
• Configuring the panel’s properties, on page 24
• Zooming in/out of the canvas, on page 14
• Panning across the canvas, on page 14

6 Views - Xpanel provides several different views, which are mainly software tools used in 
the creation and support of panels. As described on page 12, the views can be docked 
panels or floating windows, which can be displayed or hidden.
The following views are available in Xpanel:

• Properties: Panels are created by adding objects to the panel’s canvas and setting 
their properties. When an object, or the canvas itself, is selected, its current 
properties settings are displayed in the Properties view. See page 24 and page 26 
for more information.

• Object List: A list of the objects that are currently on the panel. Right-clicking the 
object allows you to select the Set as a drag & drop default and Reset the drag & 
drop default commands. 

• Asset Browser: The Asset Browser allows you to browse and preview the Panels, 
Images, Data schemas that are stored on the Xmedia Server. Panels can be opened 
directly from the Asset Browser, images can be dragged onto the canvas and new 
data schemas can be created and linked to objects.

• Action Editor: All of the objects in Xpanel, except for primitives, are defined with a 
specific purpose or function. For example, the DSK object is a toggle button for 
keying up or down a graphic. The Action Editor allows you to add to the 
functionality of standard Xpanel objects or define the functionality of primitive 
objects by configuring and associating the objects with a set of actions to occur on 
an event. See Adding events and actions to primitives and objects, on page 69 for 
more information.

• Script Editor: The Script Editor allows you to create or edit custom VB scripts to 
provide more complex functionality to actions associated with Xpanel objects. 

• Station Manager - Xpanel’s Station Manager allows you to define the devices on 
the network and then create a station configuration, which groups the devices into 
channels. See Creating and loading a station configuration, on page 15 for more 
information.

• RCP List - The RCP List allows you to configure the RCP-BR devices on your 
network. 

7 Status bar - The Status bar displays the name of the panel/project that is currently 
open in Xpanel. It also displays the status of a task that was just performed in Xpanel, 
like successful completion saving a panel or exporting assets.
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Production mode interface components
Production mode is Xpanel’s playout environment that allows you to load and use panels to 
control playout devices.

This section provides a brief functional description of the main interface components in 
Production mode.

1 Menus - Located along the top of the interface, these menu commands provide access 
to Xpanel’s setting and administrative functions that are relevant to Production mode. 
See Xpanel’s menus & toolbars, on page 107 for a description of each menu command.

2 Panels & Tabs - In Production Mode, opened panels are displayed on the main area of 
the user interface. Multiple panels can be displayed at the same time, in which case a 
tab appears on top of each panel. When multiple panels are open, they can be stacked 
(default) or docked to the outer sides (side-by-side or up-down) by holding down the 
left-mouse button on a panel’s tab and using the docking options. 
In Production mode, operators can interact with the panel’s objects (i.e. click buttons, 
set text, select media... etc.), but they cannot edit the panel or its objects.
When the Show Alarm tab in production mode setting is enabled (see page 103), the 
Alarms panel is loaded and displays the status of the device alarms and health meters 
for the connected devices.

3 Status bar - The Status bar displays the name of the panel/project that is currently 
open in Xpanel. It also displays the connection status of the devices associated with the 
panel. You can click on the status bar to open the Connections Monitor view.

4 Production mode button - Xpanel has two work modes: Design and Production. 
Besides being a toggle button to switch from one mode to the other, the Production 
mode button also identifies Xpanel’s currently mode. 

Note: Production mode makes the panels live. Therefore, if your intent 
is to explore the interface or test the panel’s behavior, ensure that the 
selected devices are not live on air.

1

2

4

5

3
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When Xpanel is intended to be used in Production mode only, it can be configured to 
open in Production mode and the ability to switch to Design mode can be restricted 
using a password protection. See page 95 for more information.

5 Connection Monitor - The Connection Monitor displays the connection status and 
properties for the channels and devices that are assigned to the objects on the panel(s) 
that are currently open in Xpanel. See Monitoring device connectivity, on page 102 for 
more information.

= currently in Design Mode

= currently in Production Mode
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Opening and positioning Xpanel’s Views
As described on page 8 and page 10, Xpanel provides you with several views, which are 
browsers and tools for building, configuring and monitoring the exact appearance and 
behavior of the panel and its objects. 

To avoid cluttering Xpanel’s interface and allow you to personalize the layout of your 
workspace, the views are hidden by default. The following sections describe how once the 
views are opened, they can be in the following states: floating, docked, hidden, pinned, or 
tabbed.

For users, who are unfamiliar with the behaviors of docked and floating UI panels, the 
following topics describe the basic tasks for controlling the layout of Xpanel views:

• Opening and closing views, on page 12
• Floating versus docked views, on page 12
• Positioning docked views, on page 13
• Auto-hidden and pinned views, on page 13

Opening and closing views
By default, the views are hidden from Xpanel’s main interface since they are used during 
various stages panel building and usage. 

• To open a view in either Design or Production mode, simply select the View menu and 
then choose one of the views. Alternatively if the view has one, you can use the view’s 
keyboard shortcut.

• To close a view, either click the X button in the top-right corner of the view, or select 
View menu and the view’s name once again or use the view’s keyboard shortcut.

Floating versus docked views
Views can be docked to the outer sides of the Xpanel interface or float as independent 
windows. When a view is opened, it will appear in the state and position that it was last 
closed in. Double-click the view’s title bar to toggle between docked and floating states. 

Note: Views and their layouts persist after being switched between 
Xpanel’s two modes, as well as across Xpanel sessions.

Design mode

Production mode
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Positioning docked views
Views can be docked along the outer sides of the Xpanel interface. When you hold down 
the mouse’s left button over a view’s title bar, docking guides appear to indicate where the 
view can be docked. To dock the view, simply drag the view’s title bar onto the dock guide.

Fig. 2-2: Docking views to the outer sides of the Xpanel interface

Two or more docked elements can be docked in the same location by combining them into 
a single panel with multiple tabs, or by stacking them. 

When you drag a view by its title bar (or tab) on top of another view, a multi-position 
docking tab appears. If you drag and drop the view onto one of the four outer guides, the 
new view will be stacked on top, below, or beside the current view in that location. If you 
drop the view onto the center guide or onto the docked view’s title bar, the two views 
combine into a multi-tab view.

Fig. 2-3: Views sharing the same location (multi-tab or stacked)

Auto-hidden and pinned views
By default, docked views are pinned to their location, meaning that appear when opened 
and stay displayed until they are closed. Clicking the Auto-Hide button  in the view’s title 
bar changes the view’s state from pinned to auto-hidden, which automatically hides the 
view on the side leaving only a tab. The view is not closed, just hidden. To make the view re-
appear, simply hover the mouse pointer over the view’s tab and click within the view. Each 
time you click outside of the view however, the view automatically hides. 

To change the view from auto-hidden to pinned, simply click Auto-Hide button  again.

Stacked 

single panel with multiple tabs

(side-by-side)
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Zooming in/out of the canvas
Whether Xpanel is in Design mode or Production mode, you may want to see a panel’s 
objects in greater detail by zooming in on the canvas. Similarly, you can get an expanded or 
distanced view of the canvas by zooming out of the canvas.

There are several methods for zooming in or out of the canvas:

Mouse wheel
• Click anywhere on the canvas and roll the mouse wheel forward to zoom in or roll the 

mouse wheel backward to zoom out.

Alt key sequence
• Hold down the ALT key and the right mouse button, then drag a rectangle around the 

specific area that you want to zoom in on.

Home key / Spacebar
• Press the Home key or spacebar on your keyboard to completely fit the canvas within 

the Xpanel’s current workspace’s frame.

Panning across the canvas
When you zoom in on a portion of the canvas, you may not see certain areas of the canvas. 
Rather than zooming out and sacrificing the current zoomed view, you can maintain the 
zoom scale by panning across the canvas to the area that was otherwise outside of the 
window’s display. 

To pan across the canvas:

Holding down the ALT key and press the arrow keys on your keyboard to move the canvas 
toward the desired location.
14



Creating and loading a station 
configuration
Before using Xpanel to create panels and control devices, you must ensure that the devices 
that the panels will control are listed in Xpanel’s Station Manager, which means that they 
are associated with the Xmedia Server. If a device is not listed, you must add the device’s 
configuration profile to the Xmedia Server.

Once the devices are listed in the Station Manager, you must create a station configuration, 
which is a set of channel definitions that group the devices. The station configuration is 
then saved to the Xmedia Server and loaded in Xpanel so that you can set panel objects to 
control specific channels or devices. 

The following sections provide instructions for how to create and load station 
configurations:

• Adding a device to the Station Manager, on page 16
• Creating and saving a new station configuration, on page 17
• Adding a channel to the station configuration, on page 18
• Loading a station configuration, on page 21

Fig. 3-1: Xpanel’s Station Manager displays a station configuration that contains channels
 15
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Adding a device to the Station Manager
Xpanel’s Station Manager identifies the output devices that are associated with the Xmedia 
Server and therefore can be controlled by the panels created in Xpanel. If a device is not 
listed in the Station Manager, you can add the device to the Xmedia Server by creating a 
profile that defines the device’s connection and communication properties.

The following device types are supported and can be added to Xpanel’s Station Manager.
• Imagestore
• LGK
• DSK
• Intuition
• Intuition XG (Remote/Central Xmedia Server only)
• Vertigo XG (Remote/Central Xmedia Server only)
• HMP
• Xftp
• Xpublish Agent

To add a new device configuration to the Xmedia Server using the Station Manager:
1 Launch Xpanel’s Station Manager by selecting the View>Station Manager menu 

command.
2 Click the New Device button  and select the type of device from the drop-down 

list.
The Device Properties window appears.

3 Complete the following fields on the Device Properties’ General tab:
• Name: The name of the device.
• Alias: An optional field that provides an alternative name for the device on your 

network.
• Description: An optional field that lets you identify the device using a meaningful 

label. This is helpful for distinguishing similar devices at your facility.
• Control IP: The network location (IP address) or hostname of the selected device. 

The host must be available on the network.

Note: Since several applications in the Vertigo Suite are capable of 
defining devices on the Xmedia Server using the Device Manager, it is 
possible that the device configuration profiles of some of the devices 
on your network are already present in the Station Manager. As such, 
when you open Xpanel and it is connected to the Xmedia Server, the 
devices that already exist in the Xmedia Server will appear in Xpanel’s 
Station Manager.

Note: Intuition XG and Vertigo XG devices are only listed if Xpanel is 
configured to connect to a remote/central Xmedia Server. See 
Starting Xpanel and connecting to the Xmedia Server, on page 5 for 
more information.
16



Xpanel
User Manual
• Control Port: The networking port that serves as a channel for sending commands 
to and from the device.

4 Select the Publishing tab and complete the following fields:
• Publish IP: The network location (IP address) or hostname of the of the machine to 

which assets are published when publishing to the selected device. This is usually 
set to the same address as the Control IP. Note that the host must be available on 
the network.

• Publish Port: The networking port that serves as a channel for publishing assets. 
Typically, this value is set to 5001.

5 Click Save.
The device is added to the device list in the Station Manager.

Creating and saving a new station configuration
The station configuration determines which channels and devices are available to be 
controlled by the panels created in Xpanel.

The following procedures describes how to create a station configuration by assigning 
devices from the Station Manager’s Device List to the channels and then saving the station 
configuration to the Xmedia Server.

To create and save new station configuration:
1 Launch Xpanel’s Station Manager by selecting the View>Station Manager menu 

command.
2 Click the New Station button  from the Station Manager’s toolbar.

The channel configurator section of the Station Manager is empty.
3 Add a channel to the channel configurator section of the Station Manager and assign 

devices to the channel. See Adding a channel to the station configuration, on page 18.

Note: Notice that the image on the New Device button has changed 
and now displays the icon representing the device type of the last 
device added (e.g.  for Imagestore devices). This provides a 
shortcut to add a new device of that same type. If you want to add a 
new device that is a different type, click the drop-down list arrow 
portion of the New Device button and select the new device type. 
 
Another method for quickly adding a new device is to select an 
existing device and use the Copy Device  and Paste Device buttons 

 in the Device List’s toolbar to create a copy of the device. Select the 
copy of the device and click the Device Properties button . Edit the 
device’s properties in the Device Properties window and click Save.

Note: Although station configurations are saved to the Xmedia Server, 
they can only be used on instances of Xpanel that are connected to 
that server. The station configuration cannot be copied or exported to 
another server.
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Adding a channel to the station configuration
4 Save the station configuration by clicking the Save Station button  in the Station 
Manager’s toolbar.
The Save Station Configuration window appears.

5 In the Name field, specify a name for the Station Configuration.
6 The Author field is automatically filled in with the current login user’s name, but it can 

be edited.
7 The Description field is optional and lets you identify the station using a meaningful 

label.
8 Click Save.

Since the station is open, its name now appears in the Station Manager’s toolbar.

Adding a channel to the station configuration
The station configuration defines a set of channels, which identify the devices that make up 
the transmission path of a playout channel. A channel can consist of a single device or 
multiple devices that work together (i.e. an Imagestore device as the down-stream keyer for 
an Intuition XG device).

Each station configuration must contain at least one channel. The following procedure 
explains how to add a channel to the station configuration, as well as how to associate 
devices with the channel.

Fig. 3-2: A typical channel setup in a station configuration

To create a new channel in Xpanel’s Station Manager:
1 Launch Xpanel’s Station Manager by selecting the View>Station Manager menu 

command.
2 Create a new station configuration or click the Open Station button  in the Station 

Manager’s toolbar to open an existing station configuration.
3 Right-click in the channel configurator section of the Station Manager and select the 

Add Channel command.
A new channel row is immediately added to the channel configurator. 

Note: An alternative to using the Save Station button is to click the 
Save and Load Station button  in the Station Manager’s toolbar. 
See Loading a station configuration, on page 21 for more information.
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The following table defines a channel’s default columns:

4 Add an additional device column for each device in the channel. 
Right-click on the channel and select the Add device column command, as well as the 
appropriate device type.

Column name Description

ID An ID number associated with the channel that determines its order 
in the Station Manager’s channel configurator. You can edit the ID 
number by selecting the cell and typing a new number. When you 
click away or press Enter, the channel is automatically sorted in the 
Station Manager according to the ID number. Note that each 
channel’s ID number must be unique.

Channel The channel’s name. You can rename the channel by clicking in the 
Channel cell and typing a new name, or by right-clicking on the 
channel and selecting the Rename channel command.

Automation ID The Automation ID was once used for schedule-based publishing, but 
it has since been deprecated.

Group If all of the channels are left as Default, then they will all be shown in 
one view on the Channel Selector. This works well if there are only a 
few channels, but if you want to show the channels in groups, then 
entering a Group name will separate the channels in the Channel 
Selector into their appropriate groups.

IS1 By default, new channels contain a device column called IS1, which 
represents an Imagestore device in the channel. If the channel that 
you want to define does not contain an Imagestore device, remove 
this device column by right-clicking on the column’s heading and 
selecting the Remove device column command.
If however the channel will contain an Imagestore device, drag the 
appropriate Imagestore device from the Station Manager’s Device List 
and drop it onto the channel’s IS1 cell. Another way to assign a device 
to a channel’s device column is to right-click within the recipient cell 
and select the Add device command, which expands to display all of 
the available devices from the Device List of that device type. Select a 
device from the list.

Note: The scope of this user manual is limited to explaining the 
definition of channels on the Control View tab. Please contact our 
Technical Support for questions regarding the Station Manager’s 
Roles View tab.
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5 Add devices to the device columns by dragging the appropriate devices from the 
Station Manager’s Device List and dropping them onto the channel’s device columns.

6 Save the channel to the station configuration by clicking the Save Station button  in 
the Station Manager’s toolbar.

Removing a device assignment from a channel
A device can only be assigned to one channel, so if that device is required by another 
channel, you must first remove it from its present channel.

To remove a device assignment from a channel:
1 Right-click on the channel cell that contains the device and select the Remove device 

command.
2 Click the Save Station button  in the Station Manager’s toolbar.

Removing a channel from a station configuration
To remove a channel from a Station Configuration:

1 Right-click anywhere within the channel and select the Remove channel command.
2 Click Yes when prompted to confirm that you want to remove the channel. 

The channel is immediately removed from the station configuration. 
3 Click the Save Station button  in the Station Manager’s toolbar. 

Note: A device can only be assigned to one channel. When a device is 
added to a channel, the device becomes disabled (grey) in the Station 
Manager’s Device List to indicate that it is already dedicated to a 
channel. If that device is required by another channel, you must first 
remove it from its present channel. See Removing a device 
assignment from a channel, on page 20.
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Loading a station configuration
When creating or editing panels in Xpanel’s Design mode, a station configuration must be 
loaded so that you can set panel objects to control specific channels or devices. 

Also note that a station configuration must be loaded in Xpanel in order to access Xpanel’s 
Production mode. Whether switching from Design mode to Production mode or if Xpanel’s 
Startup options are configured to open in Production mode, Xpanel will not open 
Production mode until a station configuration is loaded first. Select Yes to open Xpanel’s 
Options window and following the instructions below for loading a station configuration.

The two methods for loading a station configuration are described below.

Loading a station configuration using Xpanel’s Options:
1 Select the Tools>Options menu command.

The Options window appears.
2 Select the Setup tab and click the Load button in the Station configuration section.

The Open Station Configuration window appears.
3 Select the station configuration that you want to load and click Open.

The station configuration’s name now appears in the Station name field in the Options 
window.

4 Click OK.

Loading a station configuration using Xpanel’s Station Manager:
1 Create a new station configuration or click the Open Station button  in the Station 

Manager’s toolbar to open an existing station configuration. 
2 Click the Save and Load Station button  in the Station Manager’s toolbar. 
3 Click OK when prompted to confirm that you want to set Xpanel to use the open 

configuration.

Xpanel saves the open station configuration and loads it as Xpanel’s current station in 
Xpanel’s Options settings (Setup tab > Station name).
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Building and editing panels
Xpanel’s Design mode provides the workspace and tools for building control panels that 
allow operators to interact with and control the preview and/or on air playout of graphics. 

The following sections provide a generic workflow and introduces you to the control 
objects that are used to create control panels in Xpanel:

• Opening panels or projects, on page 23
• Configuring the panel’s properties, on page 24
• Adding objects and primitives to a panel, on page 26
• Configuring an object’s properties, on page 27
• Creating a Channel Selector, on page 53
• Positioning and formatting objects on the canvas, on page 55
• Saving a panel, on page 64
• Adding panels to a project, on page 65
• Exporting and importing a panel or project, on page 66
• Closing panels, on page 67

Opening panels or projects
Xpanel’s Design mode allows you to build new panels and/or edit panels that already exist 
on your system. 

Xpanel allows you to save multiple panels into one grouped file called a project, which has 
the extension .xpp and is not saved on the Xmedia Server, but locally instead. Each 
individual panel must already have been saved to the Xmedia Server before becoming part 
of a project. When the project is opened, all of the panels belonging to the project load in 
Xpanel. 

The following sections provide instructions for opening a new or existing panels and 
projects in Xpanel:

• Opening a new panel, on page 23
• Opening an existing panel or project, on page 24

Opening a new panel
When Xpanel’s Startup options are not configured to auto-load a panel or project (see 
page 98), each time Xpanel is opened a new panel with a default name of Panel1 is 
automatically created. You can use this empty panel to build a new panel.

If you are already working within Xpanel and you would like to create a new panel, perform 
one of the following to open a new panel:

• Select the File>New menu command.
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Or,
• Press CTRL+N

Or,
• Click the New button  located in the Xpanel canvas’ toolbar. 

The new panel opens with an empty canvas and a tab that displays a default panel name 
(i.e. Panel1).

Opening an existing panel or project
When Xpanel’s Startup options are configured to auto-load a panel or project, each time 
Xpanel is opened, the panel or project specified will automatically be loaded and displayed 
in Xpanel.

You can also access and open existing panels and projects using the following methods:

To open an existing panel:
• Select the File>Open menu command or press Ctrl+O. The Open Panel window 

appears. Navigate to and select the panel. Click Open.
Or,

• Click the Open button  in the Design mode toolbar. The Open Panel window 
appears. Navigate to and select the panel. Click Open.
Or,

• Open the Asset Browser (Ctrl+A) and select the Panels tab. Navigate to the panel and 
then double-click its name.

To open an existing project:
• Select the File>Project>Open menu command. The Open Project window appears. 

Navigate to and select the Xpanel project file (*.xpp). Click Open.

Configuring the panel’s properties
Xpanel’s Design mode allows you to view and edit properties that determine the 
appearance and behavior of the panel and its components (i.e. canvas, home area, guides... 
etc.).

To display the panel’s properties:
• If Xpanel’s Properties view is not open, right-click anywhere on the panel (i.e. the 

canvas or home area, not on an object) and select the Properties command. The 
Properties view opens and displays the panel’s current properties settings. 

Or,

Note: Panels and projects created on another Vertigo Suite system can 
be imported into the system and then opened using the above 
methods. 
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• If Xpanel’s Properties view is already open, select anywhere on the panel (the canvas or 
home area, not on an object) and the panel’s current properties settings are displayed.

Property category Properties and description

• Name: The panel’s current name. This is a read-only field. See Renaming a 
panel, on page 4 for instructions on how to rename a panel.

• Recall ID: Allows you to set an ID that can be entered into the Recall ID 
field in Production mode to instantly call up the panel.

• Tab Can be Active: Set to False if the panel should never become the 
current active panel.

Appearance The Appearance properties allow you to change the color of the 
panel’s canvas or display an image as canvas’ background.
• Font: Sets the default font properties (style, size...etc.) for Text objects 

added to the panel’s canvas. 
• Back Color: Determines the solid color of the panel canvas’ background.
• Background Name: Allows you to select an image asset as the canvas’ 

background rather than a solid background color and displays the image 
asset’s name.

• Background Location: Allows you to select an image asset as the 
canvas’ background rather than a solid background color and displays the 
image asset’s location.

Guides Guides are virtual lines that are superimposed over the panel’s canvas 
in Design mode. You can use the guides as a reference when 
arranging or aligning objects. While the guides are activated using 
the Format>Add Guides menu command, the Guides properties 
can be used to set the visibility, color and whether or not the guides 
are locked to a specific position.
• Guides Active: Determines whether or not the guides will have snap-to 

functionality.
• Guides Color: Determines the color of the guides.
• Guides Lock: Determines whether or not the guides will be locked in 

place or available for repositioning.
• Guides Visible: Determines whether or not the guides are visible.

Home Area The Home Area is the area surrounding the panel’s canvas. The Home 
Area properties allow you to set the size, color and visibility of the 
home area.
• Home Area Width: Determines the width of the home area.
• Home Area Height: Determine the height of the home.
• Home Area Color: Determines the color of the home area.
• Home Area Lock: Determines whether or not the home area can be 

resized by dragging from its edges and corners.
• Home Area Visible: Determines whether or not the home area will be 

visible.

Production • Auto Load Scene: Determines whether or not to automatically load the 
scene.

• Auto Take: Determines whether or not to automatically take the panel to 
air.

• Available Takes: Sets the number of takes that can be taken to air with 
the panel.
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Adding objects and primitives to a panel
Panels are built by adding objects to the panel’s canvas. Most of the objects are graphical 
controls or displays that have a specific purpose or logic associated to them. As such, once 
the object is added to the panel’s canvas, you simply have to set the object’s properties.

Unlike the other objects, primitives are raw graphical controls or displays that have limited 
or no logic associated to them. Besides having to set a primitives properties, you must also 
program its logic by associating specific actions to events using the Action Editor (see 
Adding events and actions to primitives and objects, on page 69).

The objects and primitives that can be used to build a panel are organized thematically in 
the Objects toolbar in Xpanel’s Design mode. 

The following sections provide a brief introduction to each object and primitive:
• Primitive objects and their properties, on page 28
• Drawing objects and their properties, on page 33
• DSK objects and their properties, on page 35
• Video objects and their properties, on page 40
• Audio objects and their properties, on page 43
• Other objects and their properties, on page 48

To add an object or primitive to the panel’s canvas:
1 Open a panel in Xpanel’s Design mode.
2 Select a tab from the Objects toolbar.
3 Perform one of the following:

• Select the object’s or primitive’s icon and then drag and drop it onto the canvas.

Or,
• Hold down the left mouse button and drag to set the desired size. The 

object/primitive is added to the panel when you release the mouse button.

Note: If an existing panel contains objects that would like to include 
on a new panel, you can avoid starting from new by copying objects 
from one panel and pasting them onto the new panel. Note that all of 
the objects’ property settings are also brought over.
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Configuring an object’s properties
Once an object or primitive has been added to the panel’s canvas, you must configure its 
properties to determine its appearance and specific behavior. 

To display an object’s properties:
• If Xpanel’s Properties view is already open, select the object on the canvas and the 

object’s current properties settings are displayed.
• If Xpanel’s Properties view is not already open, perform one of the following:

• Right-click on the object and select the Properties command. The Properties view 
opens and displays the object’s current properties settings. 

Or,
• Select the object and then open the Properties view by selecting the 

View>Properties menu command or by pressing Ctrl+R. The Properties view 
opens and displays the object’s current properties settings.

When a property is selected in the Properties View, a brief definition appears in the lower 
panel of the Properties view. To supplement these definitions, the following sections 
provide a brief introduction to each of the objects and primitives, as well as advice for how 
to set some of their main properties:

• Primitive objects and their properties, on page 28
• Drawing objects and their properties, on page 33
• DSK objects and their properties, on page 35
• Video objects and their properties, on page 40
• Audio objects and their properties, on page 43
• Other objects and their properties, on page 48
• Configuring an object’s Control properties, on page 50

Note: Selecting multiple objects displays their common properties in 
the Properties view, which allows you to set these common properties 
once for all of the selected objects rather than individually. 

In this example, the Channel Selector’s
current properties settings are displayed
in the Properties view.
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Primitive objects and their properties
Unlike other objects, primitives are raw graphical controls or displays that have limited or 
no logic associated to them. As such, you must set the primitive’s properties and/or 
program its logic by associating specific actions and tallies to events using the Action Editor 
(see Adding events and actions to primitives and objects, on page 69).

Fig. 4-1: Xpanel’s Primitive objects

Text Box primitive
Adding a Text Box primitive allows you to type and display text inside a recessed box. 
Information can be entered manually or fed in from a data source (see Adding a data source 
to an object, on page 83).

When associated with the On Update event, a change to the text box’s content can trigger 
actions that affect the playout’s content and/or behavior (see page 70).

The text box object’s properties can be edited to modify its appearance and behavior. For 
example, the following properties can be used to limit and/or determine the text’s format:

• Word Wrap: When set to False (default), the text is displayed on one line until the end 
of the bounding box and the surplus is cut off. Setting this property to True allows text 
to wrap to the next line once it reaches the end of the bounding box.

• Limit Width: When set to False (default), unlimited amount of text can be entered in 
the text box. Setting this property to True, limits the amount of text entered to the 
width of the text box. 

• Max Length: Specifies the maximum number of characters that can be entered in the 
text box in Production mode. (Default = 256)

• Format: Modifies the text displayed in the object to a specific format, which creates 
uniformity. Some of the available formats are: Upper case, lower case, long date, and 
time AM/PM.

Button primitive
Adding a Button primitive creates a button object, which is most often associated with the 
On Click event. When an operator clicks the button, actions are executed that affect the 
playout’s content and/or behavior.

By default, Button primitives are configured to one state since the Change State on Click 
property is set to False (regardless of the value of the Number of States property). 
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Note: Keep as False if you are using tallies.

If you want the button to toggle between multiple states, set the Change State on Click 
property to True and set the Number of States property to the number of states desired 
(e.g. 3 states = ready, on, off ).

The State property can be used to set and report the current state of the button. Accepted 
values range from 0 to the number of states specified in the Number of States property.

Text, colors and/or images can be applied to the button to help operators identify the 
purpose and/or state of the button.

• Use the Text, Image Name, Image Location and/or Back Color properties to edit and 
specify a main label, background image or background color for the button (regardless 
of the button’s state). Another method for setting the button’s background image is to 
drag an image asset from the Asset Browser and drop it directly on the button object.

• Use the Image States property to specify the background image/color and text to be 
used for each button state. Select property and click the  button, which displays the 
controls for setting the image from an internal or XMS source, the background color 
and/or the text for each state of the button.

Radio Button primitive
Adding Radio Button primitives allows you to assign actions that trigger commands when 
selected/deselected by the operator either prior or during playout. Radio button objects 
are often associated with actions that are executed on the On Selected and On Unselected 
events.

Check Box primitive
Adding Check Box primitives allows you to assign actions that trigger commands when 
checked/unchecked by the operator either prior or during playout. Check box objects are 
most often associated with actions that are executed on the On Checked and On 
Unchecked events.
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Drop-down List primitive
A Drop-down List primitive is often used to provide operators with a quick and limited list 
of options that can be selected. 

The Drop-down list can be populated manually in Design mode by double-clicking the 
object and typing in each option separated by a carriage return (Enter). The drop-down list 
can also be populated with data fed in from a data source (see Linking data entities to a 
panel object, on page 93).

When associated with the On Update event, a change to the drop-down list’s selection can 
trigger actions that affect the playout’s content and/or behavior.

Slider primitive
A Slider primitive allow operators choose a value along a continuous range set between a 
minimum and maximum value. The slider’s value can be selected in Production mode by 
either dragging the slider’s handle to a precise value, or by double-clicking the slider’s 
handle, typing a value and clicking off the object.

When associated with the On Update event, a change to the slider’s value can trigger 
actions that affect the playout’s content and/or behavior.

Use the following properties to format and establish the range of values for the slider 
primitive:

• Orientation: Determine whether the slider appears horizontally or vertically. 
• Text Position: Determine if and where the slider’s current value can is displayed (off, 

above, on the slider, or below). 
• Value: The current value of that the slider’s position represents.
• Minimum: The minimum value that the slider will accept and display.
• Maximum: The maximum value that the slider will accept and display.
• Precision: Determines the number of decimal places of the value for the slider’s values.
• Increment: Determines the interval value by which the slider position will 

increase/decrease the current value.

LED primitive
A LED primitive is often used to provide operators with a visual cue based on the LED’s state 
(color). A practical use of an LED object is to program other objects to change the LED’s 
State property to alert operators of a operational state (i.e. a keyer is currently on/off ). 

The LED’s State property can be set to the following:
• Off (Black)
• On (White)
• Intermediate (Green)
• Error (Red)

LED objects can be is associated with the On Update event, so that a change in their State 
can execute other actions.
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The LED object’s Text property displays a text string next to the LED. This text is often used 
to identify the LED object and/or provide instructions to the operator. How the LED object 
is added to the panel affects whether or not the text is immediately visible.

Timer primitive
Adding a Timer primitive allows you to create and display a timer object that can be set up 
to count up or down to/from specific times. 

When associated with the On Timer event, an update to the timer object can trigger 
actions that affect the playout’s content and/or behavior.

Use the following properties to set the timer’s start, stop and interval values, as well as the 
format in which the timer will be displayed:

• Start Time: Sets the initial time at which the timer will start.
• End Time: Sets the time at which the timer will stop.
• Interval: Sets the interval at which the timer ticks. The smallest interval supported is 

0.05 seconds.
• Infinite: Sets whether the timer is infinite or not.
• Auto Start: Sets whether or not the timer will automatically start upon entering 

Production mode.
• Format: Determines the time format in which the timer will be displayed (e.g. 

HH:MM:SS or MM:SS).

ActiveX primitive
Adding an ActiveX primitive allows you to integrate a third party or custom component 
into the panel. 

In the Class Name property, type the registered classname of the ActiveX object. For 
example, if adding the Microsoft Media Player, you would enter 
MediaPlayer.MediaPlayer.1

Alternatively, you can select the Class Name property and click the  button to open the 
ActiveX Browser window. Select an application from the list and click OK. The application is 
added to the ActiveX object. If applicable, additional properties are added to the ActiveX 
Properties category within the Properties view, which allow you to edit the application’s 
user properties.

Up Down primitive
An Up Down primitive is provide operators with text box that displays a current value. In 
Production mode, the up and down arrow buttons next to the text box are used for 
incrementing or decrementing a value between set minimum and maximum values. 
Operators can also type a valid value directly within the text box.

When the Up Down primitive is associated with the On Update event, a change to the value 
can trigger actions that affect the playout’s content and/or behavior.

Drag & drop from the toolbar

Select from the toolbar & click

sets the Text property with
a default value.

the canvas. The Text property
is empty.
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Use the following properties to establish the range of values for the Up Down primitive:
• Value: The current value of the Up Down box.
• Minimum: The minimum value that the Up Down box will accept and display.
• Maximum: The maximum value that the Up Down box will accept and display.
• Precision: Determines the number of decimal places of the value for the Up Down box’s 

values.
• Increment: Determines the interval value by which the Up Down box will 

increase/decrease the current value.
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Drawing objects and their properties
Unlike most objects that provide a control mechanism, the main purpose of the objects 
within the Drawing tab are to provide visual or organizational aids, which make the panels 
more user-friendly for operators.

Fig. 4-2: Xpanel’s Drawing objects

Text object
Adding a Text object to the panel allows you to display a text string, which is often used to 
label other objects on the panel or for providing instructions to the operator.

When you require the text object to be confined to a limit space on the panel, we 
recommend setting the object’s Word Wrap property to True, which allows the text to wrap 
to the next line once it reaches the end of the bounding box.

A text object’s Allow Edits property determines if the text displayed in a text object can be 
edited in Production mode. By default, this property is set to False, since Text objects are 
mainly used as static labels/headings on the panel. However, setting this property to True 
allows operators to edit the text. This opens the object to other possibilities too in that its 
behavior can then be similar to that of the Text Box primitive. Text can be manually entered 
into the object or configured to receive data from a data source.

Image object
Adding an Image object to the panel creates a placeholder upon which you can add a static 
representation of an image asset. 

To add an image asset to an image object (in Design mode):
• Either double-click the image object or right-click on the image object and select the 

Edit command. The Open Image window appears. Select the image asset and click 
Open.

Or,
• Open the Asset Browser and select the Images tab. Drag an image asset from the Asset 

Browser and drop it onto the image object.

Note: A quick method for adding an image object to the panel is to drag and 
drop an image asset from the Asset Browser directly onto the panel. Using 
this method eliminates the need to create the image object first.

Text

Image

Bevel
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If the desired image is not already stored within the system (i.e. Xmedia Server), you can use 
the File>Ingest menu command to add it to the system as a Vertigo Image asset.

When the Image object’s Allow Edits property is set to True (default), operators can change 
the image asset associated with the object in Production mode. By associating the editable 
Image object with an On Update event, it can be used to trigger actions that can affect the 
playout’s content or behavior.

Image objects can also be configured to act like a one state button, which allows them to 
be associated with the On Click event to trigger actions that can also affect the playout’s 
content or behavior.

Bevel object
Adding a Bevel object provides you with a box shape that is useful for identifying groupings 
or subdivisions on the panel. The Bevel object’s background can be a solid color or 
transparent (leaving just outline frame), and/or you can display a label for the Bevel using 
its Text property.

The Bevel object creates a
box or background upon which
other objects can be placed.
The Bevel provides the visual
effect of a grouping or
sub-dividing the panel.
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DSK objects and their properties
DSK (Downstream Keyer) objects are panel controls that allow operators to select, edit, 
view and control media content or fill & key signals that are played out on the keyer(s) of 
specified playout devices.

Fig. 4-3: Xpanel’s DSK objects

Fade DSK Button object
The Fade DSK button object is a toggle control for cutting up or down the media content 
that is currently loaded onto the keyers. Which channels, devices and the exact keyer that 
are associated with the button is determined by setting the button’s Control properties 
(Devices, Channels, Keyer). The speed at which the keyer is brought up/down is 
determined by the Fade Rate, which is specified in fields from 0 to 100).

In Production mode, the DSK Fade Button appears grey when the keyer is cut down and red 
when it is cut up.

The Fade DSK button can also be configured to be in an armed state, which means that the 
content is pre-loaded and ready to go to air when a Take command is triggered (i.e. Take 
Button object is clicked).

When you set the Fade DSK button’s Armable property to True, two LEDs (Cut & Fade) 
appear with the DSK button, which allows you to determine the transition style for cutting 
up/down the keyer (see page 100).

Media Selector object
In Production mode, selecting the Media Selector object opens the Browse Media Window, 
which allows you to browse and load Images, Animations, Scenes and Generic assets that 

Note: Each DSK object that is added to the panel must be configured 
to control specific channel(s), device(s) and a keyer using the object’s 
Control properties (see Configuring an object’s Control properties, on 
page 50).
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reside on the specified playout devices or select a Load Live to select an external fill and 
key for the selected keyer.

Once selected, the media is loaded onto the specified keyer. If the keyer is up, then the 
media is immediately taken to air. If the keyer is down, you must use another object, like the 
Fade DSK button, or actions triggered by the On Load event to take it to air.

When adding a Media Selector object, we suggest that you also add a Keyer Image 
Thumbnail object to display a proxy image of the asset that is loaded by the Media 
Selector when in Production mode.

When browsing devices that have a lot of media, enter a string in the Search Filter and only 
media containing that string is displayed. 

Quick Media Selector object
In Production mode, selecting the Quick Media Selector’s Browse button opens the Browse 
Media Window, which allows you to browse and load Images, Animations, Scenes and 
Generic assets that reside on the specified playout devices or select a Load Live to select an 
external fill and key for the selected keyer.

Unlike the Media Selector object, the Quick Media Selector provides an area for displaying 
the currently selected asset. Note that the object’s LED is dark, which indicates that the 
asset has not yet been loaded to the device(s). To load the asset, click the proxy image area 
of the object. The LED changes color and the asset is loaded. If the keyer is up, then the 
media is immediately taken to air. If the keyer is down, you must use another object, like the 
Fade DSK button, or actions triggered by the On Load event to take it to air.

When browsing devices that have a lot of media, enter a string in the Search Filter and only 
media containing that string is displayed. 

RCP Media Selector object
The RCP Media Selector object provides a control interface that provides a look and 
functionality similar to the RCP. 

The RCP Media Selector allows you to browse and load media that is stored on the specified 
device. In Production mode, you can use the last button to display the assets of the Images, 
Animations, Scenes, or Audio categories, as well as view the live inputs available for Load 
Live.
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When browsing a category, the RCP Media Selector displays only some of the assets at a 
time, so use the Up and Down buttons to scroll through the assets.

The Search button launches a search engine, which you can use to locate assets based 
portions or the complete file name.

Keyer Image Thumbnail object
The Keyer Image Thumbnail object displays a proxy image of the asset that is currently 
loaded to the specified keyer. This allows operators see on the panel exactly which asset is 
currently loaded. This Keyer Image Thumbnail object is often used in conjunction with 
other objects that load media onto keyers, like Fade DSK Button, Media Selector, Load Live 
Button or RCP Media Selector. 

Load Live Button object
The Load Live Button object allows you to load a specific Fill and Key video input signal 
(associated with the Imagestore, LGK and DSK devices) to the specified keyer.

In Production mode, when the Load Live Button is clicked the signal specified in the 
object’s Input property is loaded onto the specified keyer. Once selected, the media is 
loaded onto the specified keyer. If the keyer is up, then the video feed is immediately taken 
to air. If the keyer is down, you must use another object, like the Fade DSK button, or 
actions triggered by the On Load event to take the video feed to air.

When adding a Load Live Button object, we suggest that you also add a Keyer Image 
Thumbnail object to display a proxy image input video source that is loaded by the Load 
Live Button when in Production mode.

DSK Clip Gain Transparency object
The DSK Clip Gain Transparency object produces a slider or an Up Down box that allows 
operators to set either the clip, gain or transparency value for the keyed signal. 

The DSK Clip Gain Transparency object’s Slider Appearance property determines if the 
control is a slider (True) or an Up Down box (False). The object’s Orientation property 
determines whether the slider is horizontal or vertical.

The Keyer Thumbnail object
displays the asset that was selected
and loaded to the keyer by the Media
Selector button.
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You must instantiate the control by selecting one of the following in the object’s CGT type 
property:

• Clip: The level under which the key signal is forced to black (64 - 940).
• Gain: Amplifies the signal forcing grey levels to approach white (64-940).
• Transparency: Affects the luminance of the key and therefore the amount of 

background allowed in the output (0 - 512).

Image Position object
The Image Position object produces a slider or an Up Down box that allows operators to 
set or reposition the horizontal and/or vertical center of the media content loaded on the 
keyer.

• Slider Appearance: Determines if the control is a slider (True) or an Up Down box 
(False).

• Orientation: If the Slider appearance property is set to True, this property determines 
whether the slider is horizontal or vertical. 

• Positioning Type: Determines if the Image Position object will control the image’s 
X position or Y position.

• Positioning Mode: Determines the precision by which the Image Position object will 
control the movement of the image. Choose from either Coarse or Fine.

The following example demonstrates a Keyer Viewer object and two Image Position 
objects that allow us to view and control the positioning of the image that is loaded on the 
keyer.

Image Crop object
The Image Crop object produces a slider or an Up Down box that allows operators to crop 
visible portions of the image on the keyer without affecting the asset itself.

The Image Crop object’s Slider Appearance property determines if the control is a slider 
(True) or an Up Down box (False). If the Slider Appearance property is set to True, the 
Orientation property determines whether the slider is horizontal or vertical.

The Crop Type property determines if the left, right, top or bottom portion of the image is 
cropped. 

Note: In Production mode, clicking a precise point in the Keyer Viewer 
moves the image to that position and the Image Position object’s values are 
immediately updated.
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The following example demonstrates a Keyer Viewer object and four Image Crop objects that 
allow us to view and control the cropping of the image that is loaded on the keyer. The cropping 
area is displayed with a diagonal hatching and the colour of the image is inverted.

Keyer Viewer object
The Keyer Viewer object previews on the panel, the currently loaded media content or 
video input as it will appear on the keyer when taken to air. The Keyer Viewer object is often 
used in conjunction with other objects that allow you to load, position and format the 
media onto keyers, like Media Selector, Image Position and Image Crop objects. 

Note: In Production mode, clicking a precise point in the Keyer Viewer 
moves the image to that position and the Image Position object’s values 
are immediately updated.
39



Building and editing panels
Video objects and their properties
Video objects and their properties
Video objects are panel controls that allow operators to control the program video and/or 
audio that is played out on the specified playout devices. Specifically, these objects can be 
used to fade to down the output program video and/or audio by applying A/B mixing of 
the incoming video sources using cut, V-fade, U-fade or arbitrary asymmetric V-fade 
transitions.

Fig. 4-4: Xpanel’s Video objects

Fade To Black/Silence object
Adding a Fade To Black/Silence object to a panel creates a toggle button that allows 
operators to fade down the keyers to black output and/or fade the voice-over audio to 
silence. 

In Production mode, the area under the Fade label turns red when the keyer is faded to 
black.

Since this object produces a button, you must define the behavior and fade rate using the 
object’s Fade to Black (True/False), Fade to Silence (True/False) and Fade Rate (1 and 999 
fields, 0 indicates a cut transition) properties. 

Note: Each Video object that is added to the panel must be assigned 
to control specific channel(s) and device(s) using the object’s Control 
properties (see Configuring an object’s Control properties, on 
page 50).

Note: Fading to black/silence is considered to be an emergency measure 
since it immediately fades the keyer to and from black, and the voice-overs 
to and from silence.
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Transition Type object
Adding a Transition Type object to a panel allows operators to choose the transition style that 
is used when the device’s A/B mixer moves the program output between two SDI video input 
streams.

Which channels and devices are associated with the Transition Type object is determined 
by setting its Devices and Channels properties.

The Transition Type object can also be configured to be in an armed state, which means 
that the transition type can be pre-loaded and ready to go to air when a Take command is 
triggered (i.e. Take Button object is clicked).

When the Transition Type object’s Armable property is to True, the wipe transitions are 
removed and only the Fade transitions can be selected.

Transition Rate object
The Transition Rate object produces a slider or an Up Down box that allows operators to 
set the fade/wipe transition rate from 1 and 200 fields, or 0 to indicate a cut transition. 

Which channels and devices are associated with the Transition Rate object is determined by 
setting its Devices and Channels properties. 

The Slider Appearance property determines if the control is a slider (True) or an Up Down 
box (False). If the Slider Appearance property is set to True, the object’s Orientation 
property determines whether the slider is horizontal or vertical.

Virtual GPI object
The Virtual GPI object allows operators to control up to 18 GPI triggers that are configured 
for the specified device(s). 

Which channels and devices are associated with the Virtual GPI object is determined by 
setting the object’s Devices and Channels properties.

Map the Virtual GPI buttons to the device’s GPIs using the drop-down in the GPI List 
property.

The Virtual GPI object can also be configured to be armed using the Armable property (see 
page 100 for more information). 

Note: The rate at switch the transition occurs is not a property of the 
Transition Type object. Operators set the transition rate using a Transition 
Rate object on the panel.
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AB Mixer Button object
The AB Mixer object produces a toggle button that allows operators to transition the SDI 
video source that is being played out on the specified channel(s) and device(s) from one 
video input source to another (Input A to Input B, and vice versa).

Which channels and devices are associated with the AB Mixer Button object is determined 
by setting the object’s Devices and Channels properties.

When adding an AB Mixer object to a panel, we recommend also adding a Transition Type 
object, which allows operators to select the transition style for the A/B mix. If the Transition 
Type object is not selected, then the AB Mixer uses the last transition type used or the 
device’s default transition type.

The rate at which the transition from one video source to the other occurs is determined by 
the AB Mixer object’s Transition Rate property, whose value can be set from 1 and 200 
fields, or 0 to indicate a cut transition.

Take Button object
Adding a Take Button object to a panel allows operators to manually trigger a Take 
command to all of the objects associated with the same channel(s) and device(s), which is 
determined by setting the Take Button object’s Devices and Channels properties

When the Take button is selected in Production mode, armed objects and objects (i.e. 
primitives or the panel) that contain actions associated with the On Take event are 
immediately executed. This means that multiple events can be triggered simultaneously. 
See page 100 for more information.
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Audio objects are panel controls that allow operators to select and control the audio files or 
external audio source that are played out as voice overs with the program audio on the 
specified playout device(s). Voice-overs adjust the combined levels of the background 
audio and incoming voice-over.

Fig. 4-5: Xpanel’s Audio objects

Voice Over Button object
The Voice Over Button object is a toggle switch that allows operators to cut up or down the 
loaded audio file or external audio on the specified device(s). Which channels, devices and 
the exact voice-over layer that are associated with the button is determined by setting the 
button’s Control settings (Devices, Channels, Voice Over). 

In Production mode, the Voice Over Button appears red when the voice over is active (i.e. 
playing) and grey when it is not.

The Voice Over button can also be configured to be in an armed state, which means that 
the audio is pre-loaded and immediately ready to be taken to air when a Take command is 
triggered (i.e. Take Button object is clicked). When you set the Armable property to True, 
the Arm LED appears with the Voice Over button. Clicking the Voice Over button arms or 
disarms the Voice Over as indicated by the LED’s state (see page 100).

Voice Over Level and Voice Over Graph
The Voice Over Level object produces a slider or an Up Down box that allows operators to 
set either the preset value for the voice over and duck level for the background (program) 
audio.
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Note: Each Audio object that is added to the panel must be assigned 
to control specific channels, devices, and a voice-over or Easyplay 
layer using the object’s Control properties (see Configuring an 
object’s Control properties, on page 50).
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Voice overs adjust the combined levels of the background audio and incoming voice-over 
so the audio level does not exceed the original background volume. The diagram shows 
how the duck and voice over presets adjust the actual audio levels.

You must instantiate the Voice Over Level object by selecting either Duck Level or Preset 
Level from the object’s Level type property. The duck value is the amount by which the 
background audio level is attenuated when the voice over is fully on. The voice over preset 
value is the level of the voice over audio when the voice-over is fully on. Both values are 
given in decibels from -99.5 dB to +28.0 dB.

The Voice Over Level object’s Slider Appearance property determines if the control is a 
slider (True) or an Up Down box (False). If the Slider Appearance property is set to True, the 
Orientation property determines whether the slider is horizontal or vertical.

Adding a Voice Over Graph object to the panel provides operators with a visual 
representation of the preset and duck levels. Since the Voice Over Graph is a read-only 
control, it must be used with Voice Over Level objects.

Voice Over Media Selector object
In Production mode, selecting the Voice Over Media Selector object opens the Browse 
Media Window, which allows you to browse the audio asset files that reside on the specified 
playout device(s) and then load them on the specified Easyplay layer.

Once selected, the audio file is loaded onto the specified Easyplay layer, but it is not yet 
played out on air. You must use another object, like the Voice Over button or actions 
triggered by the On Load event to actually take the audio to air on the playout devices.

Background Audio

Voice Over Audio

Preset Level

Duck Level
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Quick Voice Over Media Selector object
In Production mode, selecting the Quick Voice Over Media Selector object’s Browse button 
opens the Browse Media Window, which allows you to browse the audio asset files that 
reside on the specified playout device(s) and then load them on the specified Easyplay 
layer.

Unlike the Voice Over Media Selector object, the Quick Voice Over Media Selector displays 
the name of the currently selected audio asset. Note however, that the object the asset has 
not yet been loaded to the device(s). To load the asset, click the object’s button area. 

Note that although the audio file is loaded, it is not yet played out on air. You must use 
another object, like the Voice Over button or actions triggered by the On Load event to 
actually take the audio to air.

Voice Over Rate object
The Voice Over Rate object produces a slider or an Up Down box that allows operators to 
set a rate at which the audio file ducks down the program audio and plays out the voice 
over (audio file or external audio source).

The Slider Appearance property determines if the object is a slider (True) or an Up Down 
box (False). If the Slider Appearance property is set to True, the object’s Orientation 
property determines whether the slider is horizontal or vertical.

Audio Meters object
Adding an Audio Meter object allows operators to monitor the current audio levels on the 
preview and program outputs.

There are several properties associated with Audio Meter objects that allow you to 
configure the look and behavior of the Audio Meter object. For example, the Meter Style 
property allows you to set the format in which the Audio Meter appears, either as Bars or an 
Analogue display. The Number of Pairs property allows a value of up to 24 to display up to 
48 channels in the Audio Meter object (Meter Style = Bars).
45



Building and editing panels
Audio objects and their properties
Audio Output Level object
The Audio Output Level object produces a slider or an Up Down box that allows operators 
to set the program output audio level to a value between -99.5 dB to +28.0 dB.

The Audio Output Level object’s Slider Appearance property determines if the control is a 
slider (True) or an Up Down box (False). If the Slider Appearance property is set to True, the 
Orientation property determines whether the slider is horizontal or vertical.

Audio Input Level object
The Audio Input Level object produces an Up Down box or slider control that allows 
operators to set the program input audio level to a value between -99.5 dB to +28.0 dB.

The Audio Input Level object’s Appearance property determines if the control is an Up 
Down box or a Slider. If the Appearance property is set to Slider, the Orientation property 
determines whether the slider is horizontal or vertical. 

The Input and Input Channel properties specify the input source (Input A or Input B) and 
audio channel to use.

Audio Input Phase object
The Audio Input Phase object is a toggle button that allows operators to invert the input 
signal’s phase.

Use the object’s Input and Input Channel properties to specify the input source (Input A or 
Input B) and the audio channel.

Audio Input Mute object
The Audio Input Mute object is a toggle button that allows operators to mute the 
incoming program audio. 

Use the object’s Input and Input Channel properties to specify the input source (Input A or 
Input B) and the audio channel.

Audio Shuffles object
The Audio Shuffles object provides audio mixer blocks that allow operators to control the 
audio input or voice over with audio shuffle presets that were defined on the playout 
device. 

In the Shuffle size property drop-down list, select either 16x16 (default) or 4x4 to 
determine the number of audio mixer blocks in the object. 
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In the Shuffle type property, specify which audio input the Audio Shuffles object is meant 
to control. The options in this drop-down list are dependent upon which Shuffle size value 
is selected.

Shuffle size Shuffle Type values

16x16 • Feed 1
• Feed 2
• Feed 3
• Feed 4
• Voice Over 1
• Voice Over 2
• Voice Over 3
• Voice Over 4
• Voice Over 5
• Voice Over 6
• Voice Over 7
• Voice Over 8
• Output PGM
• Output PVW
• Output CLN
• Output MON

4x4 • Input A
• Input B
• Input Vo
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Other objects and their properties
The Other tab contains only four objects types: Channel Selector, Alarm Display, Health 
Meter and Hard Panel Brightness. The following table provides functional descriptions of 
each of these objects.

Fig. 4-6: Xpanel’s Other objects

Channel Selector object
Normally, each object on a panel is configured to control specific channels and devices 
using the object’s Channels and Devices properties. As such, you cannot control a different 
channel in Production mode without returning to Design mode and manually editing the 
objects’ properties.

The Channel Selector object solves this issue by defining Channel buttons which represent 
a channel profile. In Production mode, operators can select a Channel button from the 
Channel Selector to determine which channel the panel’s operations will apply to. The 
following sections provide instructions for how to configure and use a Channel Selector:

• Configuring an object’s Control properties, on page 50
• Creating a Channel Selector, on page 53
• Selecting channels using a Channel Selector, on page 99

Alarm Display object
Adding an Alarm Display object to a panel allows operators to monitor the status of 
device(s) that have been configured to be alarmed. The type of information displayed on 
the Alarm Display is the device’s name, IP address, connection status, and device type and 
software version.

If multiple devices are associated with the object, use the left and right arrows to move 
from one device’s status to another.

Health

Alarm

Meter

Display

Channel

Hard Panel

Selector

Brightness
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Health Meter object
Playout devices can be configured to continually monitor and set off alarms to identify error 
conditions that may affect the performance or health of the device. 
Adding Health Meter objects to a panel allows operators to monitor the current readings of a 
device and be alerted if an alarm occurs. If the reading for the particular device condition falls 
outside of the expected range, an alarm is triggered and the Health Meter’s LED turns red to 
alert the operator of the potential problem. An alarm can be turned on or off by toggling the On 
button.

Health Meter objects can only monitor one type alarm at a time. Therefore, you must 
choose one of the following alarm types from the object’s Health Value property:

Hard Panel Brightness object
The Hard Panel Brightness object adds an Up Down box or slider to the panel so that 
operators can adjust the brightness of the RCP-BR device’s touchscreen, where 1 is the 
dimmest and 8 the brightest.

The Hard Panel Brightness object’s Appearance property determines if the control is an Up 
Down box or a Slider. The object’s Orientation property determines whether the slider is 
horizontal or vertical. 
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Configuring an object’s Control properties
When an object is selected, its properties are displayed in the Properties view. The Control 
category contains properties that determine to which devices, channels and keyer/audio 
layer the object’s actions are applied. 

The following sections provide information and advice for how to set an object’s control 
properties:

• Channels: Dedicated versus interactive channel control, on page 50
• Devices: Selecting which devices to control, on page 51
• Keyer, Voice Over and Easyplay Layers, on page 52

Channels: Dedicated versus interactive channel control
The Channels property is used to determine to which channel the object’s actions will be 
applied. The following sections describe two ways of configuring an object’s Channels 
property, depending upon whether you want the object’s channel control to be dedicated 
or interactive.

Dedicated channel control

If the object is meant to always control specific channels and devices, we recommend 
dedicating the object to control specific channels by setting the object’s Control properties 
(Devices and Channels) to the specific channels and devices to be controlled. When the 
panel is brought into Production mode, the object’s actions only apply to the channels 
specified in the object’s Channels property. You cannot change the object’s Channels 
properties, without returning to Design mode and manually making edits to these 
properties.

You can configure an object to control a single or multiple channels by selecting from 
among the channels listed in the Channels property’s drop-down control. Note that the 
channel list is automatically populated with the channels from the currently loaded station 
configuration.

Fig. 4-7: Configuring an object to be dedicated to specific channels

When you select two or more channels, the Master Channel field is automatically filled in 
with the first channel that was selected. You can set any of the selected channels as the 
Master Channel. The importance of the master channel is that the Xpanel only displays the 
status of this channel. Indication such as which media is loaded into a channel or which 
keyers are cut up is based on tallies coming back from this device. The object’s other 
selected channels are known as ‘slave’ channels so any action carried out on the panel will 
be carried out on these channels, but the status of these channels will not be reflected in 
Xpanel.
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Interactive channel control using a Channel Selector object

If you want the ability in Production mode to choose the channel(s) that an object’s actions 
will be applied to, then we recommend that you add a Channel Selector object to the panel 
and then associate the object’s Channels property to the Channel Selector object, rather 
than to specific channels. 

Fig. 4-8: Setting an object to be controlled by a channel selector

As explained in Creating a Channel Selector, on page 53, a Channel Selector object maps 
individual channels from the Station Configuration to buttons in the Channel Selector. In 
Production mode, operators can then choose which channel the objects’ action will be 
carried out on. If the Channel Selector is configured with a Hold button, the operator can 
gang channels, which means selecting two or more channels so that operations carried out 
on the panel are sent simultaneously to all of the ganged channels (multiple channels). See 
Selecting channels using a Channel Selector, on page 99 for information and instructions 
on using a Channel Selector.

Devices: Selecting which devices to control
An object’s Devices property is used to determine to which devices the object’s actions will 
be applied. You need not specify the specific devices, rather you select the device columns 
in which the devices were placed for each channel. 

Note that the device list in the Devices property pull-down is automatically populated with 
the device columns from the currently loaded station configuration. Therefore, you may 
want to have the Station Manager view open to see exactly which devices are assigned to 
each channel’s device columns. 

Fig. 4-9: Setting an object’s Devices property
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Keyer, Voice Over and Easyplay Layers
Many objects require you to specify which device layer the object’s actions will apply. The 
following table describes that depending upon the type of object, the property for 
specifying the device layer may be either Keyer, Voice Over or Easyplay Layer.

Keyer All DSK related objects, as well as the Fade to Black/Silence object 
have a Keyer property. You must specify a numerical value (1 to 4) to 
identify the device’s keyer layer that the object’s actions will be 
applied.

Voice Over The VO Button, VO Level, VO Rate and VO Graph objects have a 
Voice Over property. You must specify a numerical value (1 to 16) to 
identify the device’s voice-over layer onto which the object’s actions 
will be applied.

Easyplay Layer The Voice Over Media Selector and Quick Voice Over Media 
Selector objects both have an Easyplay Layer property. The 
Easyplay layer property specifies onto which of the device’s Easyplay 
layers the Media Selector object will load the audio file.
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Creating a Channel Selector
When the panel is brought into Production mode, a Channel Selector object allows 
operators to choose the channel that an object’s actions will be applied to. Operators can 
switch easily between individual channels and thereby use the same objects to control 
multiple channels.

The Channel Selector can also be used to gang the channels, which means selecting two or 
more channels so that operations carried out on the panel are sent simultaneously to all of 
the ganged channels (multiple channels).

After you have created and configured a Channel Selector object, see Selecting channels 
using a Channel Selector, on page 99 for information and instructions on using a Channel 
Selector in Production mode.

Adding and configuring a channel selector:
1 Ensure that a Station Configuration is currently loaded in Xpanel.
2 Add a Channel Selector object to the panel.

The Channel Selector first appears as an empty text object that displays No Channels.

3 Display the channel selector’s properties by opening the Properties view (Ctrl+R) and 
selecting the channel selector object.

4 Set the Number of Rows, Channels per Row and Groups per Row properties, which 
determines the number of channel buttons (usually one per channel) and the number 
of rows in which they will be displayed. 

5 Select the Channel List property and click the  button, which opens the Select 
channels window.

6 Assign the Station Configuration’s channel to the Channel Selector’s buttons by moving 
them from the Available channels list to the Selected channel list and then click OK.  
The order in which they appear in the Selected channels list determines which button 
they are assigned to. For example, first in the list is assigned to the first button, second 
in list is assigned to second button...

Fig. 4-10: Assigning channels to the Channel Selector’s buttons

7 Optional - Select the Default List property and specify which channel(s) the Channel 
Selector will have selected by default.
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8 Optional - If you would like the ability to gang channels, then set the Display Hold 
Button property to True. This produces a Hold button within the Channel Selector so 
that you can select multiple channels in Production mode.

9 In the View Type property, select one of the following settings to determine the format 
of the channel selector:

10 Be sure to return to the other objects on the panel and set their Channels property’s 
Channel Selector field (see page 51).

Note: As an alternative to adding and using the Hold button, 
operators can right-click on the Channel Selector’s channel buttons in 
Production mode to select multiple channels.

Standard (Default) - The Standard view shows the channels as defined in 
the Channel List property. The channel groups as defined in the 
station configuration are ignored.

Grouped The Grouped view shows all the channels defined in the current 
station configuration and groups them according to the groups 
in the station configuration. A User section can also be used to 
define a channel group during operation. The Channel List 
property is ignored in this mode.

Working The Working view shows a list of most recently used channels 
from another channel selector. The Master Channel Selector 
property must be set to the main channel selector. The Channel 
List property is ignored in this view.

Note: Once the panel is built and the objects are appropriately 
associated with the Channel Selector, see Selecting channels using a 
Channel Selector, on page 99 for instructions on how to use the 
Channel Selector in Production mode.
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Positioning and formatting objects on the canvas
Once objects and/or primitives have been added to the panel’s canvas, you will want to 
position and format them so that the panel’s layout is functional and user-friendly.

The following sections provide information and instructions for positioning and formatting 
panel objects:

• Selecting, grouping, and/or layering objects on the canvas, on page 55
• Grouping and ungrouping objects on the canvas, on page 56
• Layering objects on the canvas, on page 57
• Resizing objects, on page 58
• Moving and positioning objects on the canvas, on page 60
• Cutting, copying and pasting objects to/from the canvas, on page 63

Selecting, grouping, and/or layering objects on the canvas
To edit and position the objects properly on the canvas, you will have to select the 
individual objects. For edits or positioning that affects several objects, it may be quicker to 
group the objects before performing the edits.

The following sections provide instructions for selecting and/or grouping objects on the 
canvas:

• Selecting a single object on the canvas, on page 55
• Selecting multiple objects on the canvas, on page 56
• Grouping and ungrouping objects on the canvas, on page 56
• Layering objects on the canvas, on page 57

Selecting a single object on the canvas
The most common way to select an object that has been added to the canvas is by simply 
clicking once directly on the object. Once you have clicked the object, a blue grid (object 
zones) appears on top of the object indicating that it has been selected and that it is now 
the primary object on the canvas (see Resizing objects using object zones, on page 58 for 
more information on object zones).

Fig. 4-11: An object zone grid on top of the object indicates that the object has been selected

An alternative technique for selecting individual objects is to hold down the left mouse 
button and drag the pointer completely around the object and then release. If the entire 
object was inside the dragged box, then the blue object zone grid appears on the object 
indicating that the object has been selected.

Selected object
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Selecting multiple objects on the canvas
There are situations when it is more effective to select multiple objects on the canvas. For 
example, you may want to use the Media Selector, Keyer Image Thumbnail and the Fade 
DSK Button objects together to make a control used for keying graphics up and down. If 
you wanted to move these objects to another location on the canvas, you would want to 
select them all, possibly group them, and then move them as one object, rather than as 
individual objects.

Fig. 4-12: Red object zone grids appear when multiple objects are selected on the canvas

To select multiple objects on the canvas:
• Hold down the Ctrl or Shift key on your keyboard, then click directly on each of the 

objects.
When the first object is selected, a blue grid (object zones) appears on top of the object 
indicating that it has been selected and that it is now the primary object on the canvas. 
However, when you select the next object, the first object’s grid changes to red, 
indicating that it is still selected but no longer the primary object. Meanwhile the 
second object that was selected now appears with a blue object zone grid indicating 
that it was the last, and now primary, object selected. 

Or,
• Hold down the left mouse button and drag the pointer completely around all of the 

objects to be selected and then release.
If all of the objects were inside the dragged box, the blue and red object zone grids 
appear on the objects indicating that these objects are selected.

Grouping and ungrouping objects on the canvas
Grouping objects basically means taking several separate objects that are selected 
together and makes them into a single object. Grouping objects is very useful when you 
want to keep several elements together, or when you want to apply the same operation to 
them all (i.e. move to a new location, set common properties or copy/cut & paste). At a later 
time, you can ungroup the object and return the object to being individual objects.

Fig. 4-13: Objects can be grouped so that they can be edited as one object

Ungrouped objects Grouped object
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To group objects:
1 Select the objects to be grouped.
2 Select the Format>Group menu command, or click the Group  button Xpanel’s 

toolbar.
A blue border surrounds the grouped objects to indicate that the group is selected.

To ungroup objects:
1 Select the group. 

A blue grid appears over the object.
2 Select the Format>Ungroup menu command, or click the Ungroup  button on 

Xpanel’s toolbar.
The blue border disappears and each object is bordered in red and/or blue.

Layering objects on the canvas
Xpanel’s layering commands allow you to move objects to the top layer for display or 
editing, as well as sending the object behind others, like in the case of a bevel primitive or a 
background image.

To bring an object one step closer to the front:
1 Select the object.

A blue grid appears over the object.
2 Click the Bring Forward button  on Xpanel’s toolbar, or select the 

Format>Layering>Bring Forward menu command.
The object moves one layer closer to the front.

To send an object one step toward the back:
1 Select the object.

A blue grid appears over the object.
2 Click the Send Backward button  on Xpanel’s toolbar, or select the 

Format>Layering>Send Backward menu command.
The object moves one layer to the back.

To bring an object to the front:
1 Select the object.

A blue grid appears over the object.
2 Click the Bring to Front button  on Xpanel’s toolbar, or select the Format>Bring to 

Front>Layering menu command.
The object moves to the first (top) layer.

To send an object to the back:
1 Select the object.

A blue grid appears over the object.

Note: When objects are grouped, the group has a set of properties 
that can be edited to determine the group’s positioning and/or which 
devices and channel it will control.
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2 Click the Send to Back button  on Xpanel’s toolbar, or select the 
Format>Layering>Send to Back menu command.
The object moves back to the furthest layer.

Resizing objects
Regardless of the size of the object or primitive when it is added to the canvas, you will 
probably need to edit the object/primitive’s size to make it larger, smaller, wider, thinner..., 
so that it fits within the panel’s layout and/or the object’s content fits.

The following sections provide information and instructions regarding the different ways 
that you can resize objects on the canvas:

• Resizing objects using object zones, on page 58
• Resizing objects using Xpanel’s Size commands, on page 59
• Resizing objects using the Width and Height properties, on page 59

Resizing objects using object zones
When you select an object that has been placed on the canvas, a grid appears on top of the 
object, dividing it into multiple zones. The blue grid indicates that this is the primary object, 
which is the last or only object selected. When multiple objects are selected at the same 
time, the primary object displays a blue grid, while the others will have a red grid. 
Identifying the primary object is extremely helpful in formatting situations like aligning 
objects. If you were aligning objects all other selected objects (overlaid with a red grid to 
indicate that they are not the primary object) would align with the primary object.

Fig. 4-14: An object’s zones, indicated by a blue/red grid, can be used to resize or move the object

When you hover the pointer over the object zones, the pointer transforms into a two-
headed directional arrow. Clicking and dragging the object zones of objects, and some 
types of primitives, allows you to resize (stretch and shrink) the object in a free-form fashion 
in the direction that it is being dragged. To maintain the scaling of the object while resizing, 
simply hold down the Shift button on your keyboard, while dragging the outer zones of the 
object. As well, dragging from the central zone allows you to move the object around the 
canvas.
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Note: Pressing ESC before releasing the mouse button aborts the 
move, copy or resize operation.
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Resizing objects using Xpanel’s Size commands
When you have multiple objects on the panel, you can use Xpanel’s Size commands to 
resize one or many objects relative to another object. 

Fig. 4-15: Xpanel’s Size commands allows you to size objects relative to other objects

To size objects based on the size of another object:
1 Select a group of objects, making sure that you select the primary object last. 

The primary object is the one that you would like all others sized relative to. The 
primary object’s selection lines appear in blue, whereas those of others appear in red. 
You can change the primary object by clicking a selected object.

2 Select one of the following Format>Size menu commands:

Resizing objects using the Width and Height properties
When you select a single object and the Properties view is open (View>Properties), the 
object’s dimensions are displayed in the Width and Height properties. Editing the settings 
of these properties immediately changes the object’s size.

Similarly, if you select multiple objects or a group of objects, you can collectively resize all of 
the objects belonging to that selection by setting the Width and Height properties. This 

Same Width Resizes all selected objects to the same width as the 
primary object.

Same Height Resizes all selected objects to the same height as the 
primary object.

Same Width & Height Resizes all selected objects to the same width and 
height as the primary object.

Match Biggest Resizes all selected objects to the same size using the 
largest width and height values from amongst all of the 
selected objects (the values do not have to be from the 
same object).

Match Smallest Resizes all selected objects to the same size using the 
smallest width and height values from amongst all of 
the selected objects (the values do not have to be from 
the same object).

Reset to Natural Size Applies to image objects only. Resets the size of the 
image object to the actual size of the image’s original 
size.
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results in all of the objects being exactly the same size. Note however, that you may need to 
reposition the object afterwards.

Moving and positioning objects on the canvas
Once you have added objects to the canvas you will want to create an attractive and 
functional layout by positioning and aligning the objects on the panel’s canvas:

• Moving objects on the canvas, on page 60
• Positioning objects using the Align commands, on page 61
• Positioning objects using Spacing commands, on page 62
• Positioning objects using guides, on page 63

Moving objects on the canvas
There are several ways to move and position objects around the canvas. Which method you 
choose to use depends on the precision of placement that you desire. 

The most common and convenient way of moving objects on the canvas is to click the 
center zone of the object and drag the object to the new location. This method is 
convenient, but it is lacks the precision that is sometimes necessary. Meanwhile, an ortho 
move provides the convenience of dragging the object, but strictly in a vertical or 
horizontal direction from its current position (right angles only).

If you require more precision than the dragging or ortho methods provide, you can nudge 
the object to the exact desired position. Nudging uses the arrow keys on your keyboard to 
move the object using predetermined increments. Coarse nudging moves the object by 
approximately 6 points with each keystroke, while fine nudging moves it only 1.4 points 
with each keystroke.

To perform an ortho move:
• Hold down the SHIFT key while dragging the object from its central zone.

To coarsely nudge an object:
• With the object selected, hold down the SHIFT key while pressing one of the arrow 

keys.

To finely nudge an object:
• With the object selected, press one of the arrow keys.
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Positioning objects using the Align commands
Use the Align commands to place objects on the canvas so that they are vertically, 
horizontally, or center-aligned in relation to other objects on the canvas. 

Fig. 4-16: Xpanel’s Align menu commands and toolbar buttons

To align objects using the Align commands:
1 Select a group of objects, making sure that you select the primary object last. 

The primary object is the one that you would like all others aligned with, and its 
selection lines appear in blue, whereas those of others appear in red. You can change 
the primary object by clicking a selected object.

2 Select one of the following commands from the Format>Align menu, or select one of 
the icons from the Align toolbar on the Xstudio interface.

Menu item Icon What it does

Align Lefts Aligns all selected objects with the left edge of the primary 
object.

Center 
Horizontally

Aligns all selected objects with the horizontal centre (y-axis) 
of the primary object.

Align Rights Aligns all selected objects with the right edge of the primary 
object.

Align Tops Aligns all selected objects with the top edge of the primary 
object.

Center 
Vertically

Aligns all selected objects with the vertical centre (x-axis) of 
the primary object.

Align Bottoms Aligns all selected objects with the bottom edge of the 
primary object.

Centers Menu 
comman
d only

Aligns all selected objects with both the horizontal and 
vertical centers of the primary object.
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Positioning objects using Spacing commands
Use the Horizontal Spacing and/or Vertical Spacing commands to quickly make the 
spacing equal between objects, as well as to increase, decrease or remove the spacing all 
together. 

To adjust the spacing between objects using the Horizontal Spacing and Vertical 
Spacing commands:

1 Select the group of objects that you want to adjust the relative spacing of. 
2 Select one of the following commands from the Format>Horizontal Spacing or 

Format>Vertical Spacing menu.

Menu commands What it does

Make Equal Horizontal: Makes equal space between the selected objects using 
the outermost objects as endpoints. 
Vertical: Makes equal space between the selected objects using 
the top and bottom objects as the end points.

Increase Increases the horizontal or vertical spacing by one grid unit based 
on the primary object.

Decrease Decreases the horizontal or vertical spacing by one grid unit based 
on the primary object.

Remove Horizontal: Removes the horizontal space so that the objects are 
aligned with their edges touching, based on the primary object. 
Vertical: Removes the vertical spacing so that the object's borders 
are touching, based on the primary object.

Note: If using the Vertical/Horizontal Spacing command does not 
produce the results you want, try to manually rearrange some of the 
objects and repeat the command.
62



Xpanel
User Manual
Positioning objects using guides
Guides are virtual lines that are superimposed over the panel’s canvas in Design mode. 
Adding guides to the canvas allows you to align objects along common vertical or 
horizontal reference lines. Once the objects are added to the canvas, you can superimpose 
guides to the canvas and when an object is dragged near a guide, it automatically snaps to 
it. You can add one or many guides to the canvas.

While the guides are activated using the Format>Add Guides menu command, the canvas’ 
Guides properties can be used to set the visibility, color and whether or not the guides are 
locked to a specific position. See Configuring the panel’s properties, on page 24 for more 
information.

To add a guide to the canvas:
1 Select Format>Add Guide and then either Horizontal or Vertical.
2 Add the guide to the canvas:

• If you selected Horizontal, drag the guide from the top or bottom of the outer 
border of the canvas.

• If you selected Vertical, drag the guide from the left or right side of the outer 
border of the canvas.

3 Adjust the placement of the guide by dragging the guide up or down on the canvas.

To delete a guide:
1 Move the mouse over the guide until the cursor becomes a double-headed arrow.
2 Select the guide and drag it out of the window.

Cutting, copying and pasting objects to/from the canvas
You can move, duplicate, and/or replace objects on the canvas by using the cut and copy 
commands to place an object on the system’s clipboard and then place the object on the 
same canvas or another panel’s canvas using the Paste command. 

Note that when you use the Cut or Copy commands, the cut or copied object remains on 
the clipboard until you choose Cut or Copy again. 

To cut, copy and paste objects:
1 Select the object(s).
2 Select one of the following from the Edit menu:

Objects added to the canvas by drag-and-drop The objects snap to the multiple guides,
which helps organize and align the objects
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• The Cut command (CTRL + X) to remove the object and move a copy onto the 
clipboard.

Or, 
• The Copy command (CTRL + C) to keep the original object where it is and move a 

copy to the clipboard.

To paste a copy of the object, select the Paste (CTRL + V) command from the Edit menu.

To move a copy of the object out from the original:
• Hold down the CTRL key while moving the copy out from the original. If you release the 

CTRL key before the mouse button, the object will not be copied -- only moved.

To move a copy of the object out from the original at right angles only:
• Hold down the CTRL and SHIFT keys while moving the copy out from the original. If you 

release the CTRL key before the mouse button, the object will not be copied -- only 
moved. 

Saving a panel
In the Vertigo workflow, all assets and panels are centrally stored in the Xmedia Server 
(either a central or local Xmedia Server). Therefore, once you have created a new panel, or 
made changes to an existing panel, you must save it to the Xmedia Server. 

When changes have been made to a new or existing panel in Xpanel, an asterisks appears 
next to the panel’s name on panel’s tab. The asterisks indicates that the changes have not 
yet been saved to the Xmedia Server. Note that if you attempt to close a panel that has 
unsaved changes, Xpanel will display a message prompting you to save the panel.

Fig. 4-17: The asterisks indicates that the panel contains unsaved changes

To save a panel:
1 If multiple panels are open, select the panel to be saved to make it the active panel in 

Xpanel.
2 Save the panel using one of the following methods:

• Select the File>Save (Ctrl+S) menu command.
Or,

Note: Cut, Copy and Paste are also available in Xpanel’s Design mode 
toolbar .
64



Xpanel
User Manual
• Click the Save button  in Xpanel’s toolbar.
Or,

• Right-click the panel’s tab and select the Save command.
If you are saving the asset for the first time, the Save window appears and allows you to 
determine the storage location (i.e. folder), specify the name of the panel, the name of 
the person who authored the panel and a short description of the panel. Click Save to 
commit the changes and save the panel to the Xmedia Server.
If saving changes to an existing assets, Xpanel simply saves the panel using the current 
name without opening the Save window. 
If you want to save the currently selected panel using another name and/or location, 
select the File>Save As menu command. This essentially allows you to create a copy of 
the panel using a different name.

Adding panels to a project
Xpanel allows you to save multiple panels into one grouped file called a project, which has 
the extension .xpp and is not saved on the Xmedia Server, but locally instead. Each 
individual panel must already have been saved to the Xmedia Server before becoming part 
of a project. Later when the project is opened, all of the panels belonging to the project 
load in Xpanel. 

Saving panels as a part of a project, is a convenient way to organize/group panels that are 
commonly used together, for transporting panels (exporting and then importing), and 
projects could even be used as another method to switch between channels. Note that 
projects also include panel layout information. Therefore if panels have been docked and 
arranged in a certain way, then the project will store and recall that information.

To save a panel as part of a new project:
1 Open each panel that will be a part of the project.
2 Select the File>Project>Save menu command.

The Save Project window appears and allows you to determine the local storage 
location and specify the name of the project. 

3 Click Save to complete. 

To save a panel as part of an existing project:
1 Open the project.
2 Create a new panel or open an existing panel.
3 Save the new panel to the Xmedia Server and/or save any changes made to the existing 

panels.
4 Select the File>Project>Save menu command.

Note: You can save an existing project under a different name or in a 
different location by using the File>Project>Save As menu command.
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Exporting and importing a panel or project
To transfer panels and projects between two separate Vertigo Suite installations, you can 
export the panels or project from one and import them into the other. Exporting wraps the 
panel’s or project’s components into a portable VxM Export file folder, which can then be 
transferred to and imported into a separate Vertigo Suite installation. 

To export a panel or project:
1 With the panel or project open in Xpanel, select File>Export and then select either the 

Export panel or Export project command.
If the panel or project contains unsaved changes, you will be prompted to save before 
proceeding.
The Save As window appears and automatically assigns the VxM_Export_* file name 
and type.

2 Select the destination directory for the export file and click Save.
The Export folder can now be transferred to the new system.

To import a panel or project:
1 After transferring the VxM Export folder to the new system and launch Xpanel.
2 Select File>Import and then select either the Import panel or Import project 

command.
The Import panel with assets window appears.

3 Navigate to the directory where the VxM Export folder is located.
4 Open the Vxm Export folder and double-click the VxM_Export_*.exp file.
5 The Import window appears and identifies all of the assets that will be imported from 

the export file to the target XMS. An icon in front of the asset’s name indicates whether 
the asset is being added  or is being updated . 
The assets are displayed in a tree-structure that represents the assets’ destination 
among the target server’s categories. Newly created categories are indicated by the  
icon.
The Import window can also contain a list of error or warning messages to alert users of 
problems that may occur if the import is performed. For example, some categories may 
have to be renamed and some assets will not be able to be categorized because of 
name conflicts. Clicking on an asset that shows either an error or warning icon 
highlights the associated messages. Similarly, clicking on a message will select the 
corresponding asset or category in the tree. 

Note: Since station configuration is not exported with the 
panels/project, once the panels are imported into the new system, 
you must re-assign the channels and devices to each object on the 
panel and/or channel selector.

Note: You can only export a single panel at a time when using the 
Export panel command. To export multiple panels in batches, 
consider grouping the panels into a project and then exporting the 
project.
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6 After inspecting the import contents, select the Import button to proceed with the 
import or select Cancel to abort the import. 

• If importing a panel, the panel is automatically added to the media server using the 
same category structure and placement as the original category assignment.

• If importing a project, the panels belonging to the project are automatically added 
to the media server using the same category structure and placement as the 
original category assignment. The panels are loaded and the following window 
appears, asking you to save the loaded panels as a project.

The Import window remains open after Import is clicked so that it can be referenced 
when looking for newly imported assets. Select the Close button to close the Import 
window.

7 Optional: Verify that the asset was properly imported by opening the Asset Browser 
and navigating to the category where you expected the asset to be stored.

Closing panels
Xpanel offers several ways to close a panel. Regardless of which method is used, if the are 
unsaved changes on the panel, you will be prompted to save the panel before closing it.

To close an panel that is currently open in Xpanel:
• Click the Close button  located in the upper-right corner of the panel.

Or,
• Select the File>Close menu command.

Or,
• Right-click on the panel’s tab and select the Close command.

Note: Right-clicking the panel’s tab exposes the Close All But this 
command, which allows you to immediately close all open panels, 
except for the currently selected one.
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Adding events and actions to primitives 
and objects
Xpanel’s Action Editor allows you to configure the panel, primitives or control objects to 
perform actions in response to events or changes in tallies from the devices. A simple 
example to illustrate this concept is that a button primitive (the object) on a control panel 
can be set in the Action Editor so that when it is clicked (the event) during playout, a 
specific audio file starts to play (the action). 

To configure the panel, primitives and/or objects to perform actions based on events or 
changes in tallies:

1 In Xpanel’s Design mode, open the Action Editor (Ctrl+E).
2 Select the primitive, object or panel.
3 Select a standard event from the Action Editor (applies only to: panels, primitives, 

channel selectors, text objects, image objects and bevel objects).
Or,
Add a user event or tally event to the Action Editor.

4 With the event selected, do one of the following:
• Add an If condition and define the condition using the Expression Builder. 

Add actions to the condition and set the actions’ parameters.
Or,

• Add an If condition and define the condition using the Expression Builder. 
Add action(s) to the event’s conditions and set the action’s parameters. 
Add an Else statement and add actions to the Else statement and set the action’s 
parameters.

Or,
• Add actions directly to the event and set the actions’ parameters.

The following sections provide functional descriptions and instructions for using the Action 
Editor to add actions and events to primitive objects:

• Selecting a standard event, on page 70
• Adding a user event, on page 72
• Adding a tally event, on page 74
• Adding actions to an event, on page 78
• Duplicating, moving and ordering actions, on page 80
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Selecting a standard event
Selecting a primitive, drawing category objects, a channel selector or the panel’s canvas 
displays standard events in the Action Editor that can be associated with actions. Not all 
standard events are available to every type of object though. The object type and its 
functionality determines the applicable standard events. For example, when a Check Box 
primitive is the selected object, the standard events that can trigger actions are limited to: 
On Load, On Unload, On Checked, On Unchecked and On Get Data.

The following table lists and describes each of the standard events that may appear in the 
Action Editor. 

Note: If you have a special requirement that is not covered by existing 
standard events, you can create custom events (User Defined events) 
that can be triggered in response to another event, or have actions 
executed whenever certain database variables change (Data Arrival 
events). See Adding a user event, on page 72 for more details and 
instructions.

On Alarm State 
Changed

The On Alarm State Changed event is only available to Alarm 
Display objects. This event is triggered when the state of a device’s 
alarm changes. 

On Channel Changed The On Channel Changed event is only available to Channel 
Selector objects. This event triggers actions when a new channel is 
selected from the Channel Selector in Production mode.

On Checked The On Checked event is available to check box objects. This event 
is triggered when the check box is selected (check mark).

On Clear The On Clear event is triggered by a graphic being cleared from the 
output device.
This event is available to text, text box, drop-down list, image and 
timer objects, as well as the panel.

On Click The On Click event is available when an image object to be used like 
a button. In other words, when the operator clicks the image actions 
are triggered.

On Click (State #) The On Click (State #) event is only available to button objects. The 
button’s Number of States property determines the number of 
these events that appear in the Action Editor. This event is triggered 
when the button enters the specified state.

On Cue The On Cue event is triggered by a graphic being cued as next to be 
sent to the output device.
This event is available to text, text box, drop-down list, image and 
timer objects.

Standard Events
for a Check Box
primitive
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On Get Data The On Get Data event is triggered when the user sends a 
command requesting that data be retrieved from its source. For 
example, a page could have been programmed to get data every 
time it is refreshed by the user.
This event is available to text, text box, radio button, check box, drop 
down list, timer objects, as well as the panel.

On Load The On Load event is triggered by a graphic entering Production 
mode or being opened while in Production mode.
This event is available to all objects, as well as the panel.

On Selected The On Selected event is only available to radio button objects. This 
event is triggered when the radio box is selected (filled in).

On Tab Activated The On Tab Activated event is only available when the panel’s 
canvas is selected. This event is triggered when the panel’s tab is 
selected in Production mode.

On Take The On Take event is triggered by a graphic being sent to the output 
device.
This event is available to text, text box, drop down list, image, timer 
and ActiveX objects, as well as the panel.

On Timer The On Timer event is triggered when the timer is updated, which is 
determined by the Timer object’s Interval property.

On Unchecked The On Unchecked event is only available to check box objects. This 
event is triggered when the check box is deselected (cleared).

On Unload The On Unload event is triggered by a graphic leaving Production 
mode.
This event is available to all objects, as well as the panel.

On Unselected The On Unselected event is only available to radio button objects. 
This event is triggered when the radio box is deselected (cleared).

On Update The On Update event is triggered by changes to an image, drop 
down list, slider, LED, Up Down box, text or text box object, followed 
by the user clicking off the object. The event is signalled not during 
the change, but after it has been completed and the object is no 
longer selected. For example, if a text box’s contents are being 
edited, the On Update is triggered only after the edits have been 
made, not during.
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Adding a user event
User events are used when you have a requirement that cannot be met by any of the 
standard events. Since they cannot be triggered by the system, they are usually triggered 
by calling a Send Event action in response to another event.

A common use for a user event is triggering actions required by more than one object. For 
example, if you had several buttons on a panel that used a common set of actions, you 
could create a User event on one of the objects to contain the common actions. Next, you 
would use the Send Event action for every object requiring these actions in order to send 
the User event to the object with the common actions. The result is akin to a function call or 
a subroutine, and it reduces the margin of error when modifications to the common action 
set are required, since changes only need to be made once. 

To create a user event:
1 Select the panel or the object for which you would like the event available. 

If the event is for the panel itself, click anywhere where there are no objects.
2 In the Action Editor, click the Add User Event  button. 

The Add new user event window appears.
3 Enter a name for your event in the field provided.
4 Click OK. 

You can now add actions to the event as required. 

Example: Parametrized User events 
User events can include parameters to supply more information to be used within the 
action. Since parametrized User events are only likely to be used in very specific cases, what 
follows is a generic example of a control panel that allows the operator to set the text of 
one text box, and at the click of the button the text changes slightly and also appears in 
another text box.

To create a panel using parametrized User events:
1 Create a new control panel with three (3) text boxes and a button.

2 Select Textbox2 and then display the Action Editor (CTRL + E).
You will create a new event for Textbox2.

3 Click the Add User Event  button.
4 In the Add new user event window, type a name for the event followed immediately by 

in parentheses into which you will enter a parameter name. For example, 
MyEvents(text). Then click OK and the custom event is added immediately to the 
Events List.

5 You will now assign a Send Event action to the button object. This will send the new 
event to Textbox2.
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a Select the button object on the panel.
b Select On Click (State 0) from the Event list.
c Click the Add Action  button.
d Select the Send Event action from the <Define Actions> drop-down list. 

The Send Event is immediately added to the Action Table.
6 In the Action Parameters, enter the name of your event in the Event Name field 

followed by a parentheses into which you will enter Control:Textbox1. For example, 
MyEvent(Control:Textbox1). 
This means that whatever text is entered in Textbox1 becomes the parameter for the 
User event.

7 In the Target field, enter Control:Textbox2. 
This means that when the button is clicked, it sends the custom event to Textbox2 
(which is expecting it) with the contents of Textbox1 as the parameter.

8 Select Textbox2 on the panel and then select your custom event from the Event list. 
9 Click the Add Action  button and select the Set Text action from the <Define 

Actions> drop-down list. 
The Set Text action is immediately added to the Action Table.

10 In the Source field of the Action Parameters, type Event: and then the event 
parameter. For example, if your User event is MyEvent(text), you would enter 
Event:text. 

• You can also format the Source parameter. For example, to make the parameter 
text appear uppercase you would put Event:text in parentheses and precede it 
with ucase. 

• You could also append text by using & and then text in quotation marks. For 
example, your entry could look like this: ucase(Event:text & “ is coming up 
next”). 

11 In the Target field, type Control:Textbox3. 
This indicates that Textbox3 will be receiving the text specified by the User Defined 
event parameter. In this case, the text is coming from Textbox1, and will be formatted 
and extended by the time it reaches Textbox3.

12 Switch to Production mode (CTRL + P).
Type text in Textbox1, click the button, and then watch the text appear in Textbox3.
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Adding a tally event
When devices, like the Imagestore 750, have tallies turned on, the device sends callbacks 
when the state of a keyer or its properties change. Xpanel’s objects can be programmed to 
report the status of a device or execute actions in response to a tally coming back from the 
device.

To add a tally event to the panel’s Action Editor:
1 Select the object that the tally event will be added to. 
2 In the Action Editor, click the Add tally event  button. 

The Add New Tally Event window appears.
3 Select the channel (or the channel selector) and the device(s) that will return tally 

callbacks to Xpanel.

4 Select a tally event from the following expandable categories of tallies: 
• Tallies: Standard tally callbacks that represent changes to the state of the device.
• Command armed tallies: Tally callbacks that represent changes when armable 

objects are set to an armed state.
• Command disarmed tallies: Tally callbacks that represent changes when armable 

objects are set to a disarmed state.

5 Configure the selected tally’s parameters in the Tally variables section.
The Filter Value column allows you to define conditions that must be true when the 
tally is received in order to carry out the action(s). The example below demonstrates 
that the actions associated with the DSK State tally will only be carried out when the 
tally is received and the Tally Keyer value is 1 and the Tally State is 0.

6 Click OK.
The Add New Tally Event window closes and the tally event is added to the Action 
Editor as On Tally (<name_of_tally>). You can now add conditions and/or actions to 
the tally event as you would for any other event type (see page 78).

Example: Adding tally events to display the state of a DSK
The following procedure demonstrates how to configure a button primitive on a panel to 
display the current state of a device’s DSK using a DSK State tally event. More precisely, 
when keyer 1 on the device is up and Xpanel receives a DSK State tally, the button will turn 

Note: Unlike standard and user events, tally events can only be added 
to objects, not to the panel.

Note: If you select two or more devices, Xpanel executes actions 
associated with the tally event if any one of the devices returns an 
appropriate tally callback.

Note: When a tally is selected, a brief description of the tally is 
provided in the Tally description section of the Add New Tally Event 
window.
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red and display “ON”; when Xpanel receives a DSK State tally indicating that keyer 1 is 
down, the button will turn blue and display “OFF”.

1 Add a button primitive to a panel.
2 Open the Action Editor (Ctrl+E) and select the button primitive.
3 Add and configure a DSK State tally event to execute actions when Xpanel receives a 

tally from the device that keyer 1 is cut up.
a Click the Add tally event  button. 
b In the Add New Tally Event window, select the channel (or the channel selector) 

and the device.
c In the Tally section, expand the Tallies category and select DSK State.
d In the Tally variables section, set the Keyer filter to 1 and State filter to 1.
e Click OK.

The On Tally (DSK State-Filtered) tally event is added to the Action Editor.

Fig. 5-1: Add a DSK State Tally event to the Button primitive

4 Select the On Tally (DSK State-Filtered) tally event and add the Set Back Color action to 
turn the button’s background color to red when the tally reports keyer 1 is cut up.

a Click the Add action  button to add an action.
b Select Set Back Color from the drop-down list of actions.
c Specify the Set Back Color’s Action Parameters to:

• Target: Control:Button1
• Color: 255,0,0

5 Select the On Tally (DSK State-Filtered) tally event and add Set Text action to change 
the button’s text to “ON” when the tally reports keyer 1 is cut up.

a Click the Add action  button to add an action.
b Select Set Text from the drop-down list of actions.
c Specify the Set Text’s Action Parameters to:

• Target: Control:Button1
• Source: ON

6 Select the On Tally (DSK State-Filtered) tally event and add the Set Property action to 
change the button’s state to match the tally’s state.

When DSK State Tally = 1 When DSK State Tally = 0
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a Click the Add action  button to add an action.
b Select Set Property from the drop-down list of actions.
c Specify the Set Property’s Action Parameters to:

• Target: Control:Button1
• Property: State
• Value: Tally:State

7 Add and configure another DSK State tally event to execute actions when Xpanel 
receives a tally from the device that keyer 1 is cut down.

a Click the Add tally event  button. 
b In the Add New Tally Event window, select the channel (or the channel selector) 

and the device.
c In the Tally section, expand the Tallies category and select DSK State.
d In the Tally variables section, set the Keyer filter value to 1 and State filter value to 

0.
e Click OK.

The On Tally (DSK State-Filtered) tally event is added to the Action Editor.
8 Since we want this second tally event to contain actions that are similar to those in the 

first DSK State tally event, we’ll copy and paste the actions and then edit the necessary 
action parameters.

a Select the first On Tally (DSK State - Filtered) tally event that you created. 
b While holding down the Shift key, click the Copy  button from the Action 

Editor’s toolbar.
c Select the second On Tally (DSK State - Filtered) tally event that you created and 

click the Paste  button.
The second DSK State tally event now contains the exact same actions as the first DSK 
State tally event.

9 Edit the action parameters for the Set Back Color and Set Text actions (do not edit the 
Set Property action):

a Select the Set Back Color action and edit its parameters to:
• Target: Control:Button1
• Color: 0,128,255

b Select the Set Text action and edit its parameters to:
• Target: Control:Button1
• Source: OFF
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10 Add a Fade DSK button object to the panel, which will be used to test the behavior of 
the button object in Production mode by manually control the cutting up/down of the 
keyer.

a Add a Fade DSK button object to the panel by dragging the Fade DSK Button from 
the objects toolbar and dropping it onto the panel’s canvas.

b Open Xpanel’s Properties view (Ctrl+R) and select the Fade DSK button.
c Set the Devices and Channels properties to match the ones specified in the tally 

events (i.e. IS1 and 1 Channel).
d Verify that the Keyer property is set to 1.

11 Save the panel and switch to Production mode.
The two buttons may appear generic (grey), until Xpanel receives its first DSK State 
tally. Once the tally is received, the button reacts according to the programmed 
behavior (red = on, blue = off ).

Fig. 5-2: The button’s expected behavior in Production mode when a DSK State tally is received

12 Click the Fade DSK button to change the state of the DSK and test the behavior of the 
button. 

When DSK State Tally = 1When DSK State Tally = 0Initial display when entering
Production mode
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Adding actions to an event
To add functionality to primitive objects and/or the panel, you must specify the actions that 
are to be executed in response to an event (standard, user or tally). The following sections 
describe the two methods for adding actions to an event: 

• Add actions to an event so that they will be executed every time the event is 
encountered. This involves adding default or custom actions directly to the event and 
setting the actions’ parameters. See Adding actions directly to the event, on page 78 
for more information and instructions.

Or,
• Add a condition (If or If/Else) which evaluates the user-defined criteria and then 

determines whether or not to execute the actions defined within the condition 
statements. See Adding conditions to an event’s action list, on page 78 for more 
information and instructions.

Adding actions directly to the event
If you want actions to be executed every time the primitive or panel encounters the event, 
then you must add the actions directly to the event and define the action’s parameters.

1 With the event selected in the Action Editor, click the Add Action  button.
The <Define action> drop-down list appears in the Action Editor.

2 Select one of the standard actions from the drop-down list.

3 Set the action’s parameters which appear in the right-hand section of the Action Editor. 
Note that when a parameter is selected, a brief description of the parameter appears 
below the parameter list.

4 Optional: Click on the Action’s Comment column and type a user-friendly description 
of the purpose or behavior of the action.

Adding conditions to an event’s action list
Adding a condition (If or If/Else) allows more sophisticated logic to be applied by evaluating 
and then determining which actions are executed based on user-defined criteria. 

When an If condition is added to an event, the specified actions will only be executed when 
the If condition is true. If the condition is not satisfied/true, then no action is executed. For 
example, when the button primitive is clicked (On Click event), if the state on DSK keyer 1 is 
up (If condition), then display the text “DSK 1 On” in a text box primitive (Set Text action). 

Adding an Else statement below an If condition allows you to execute specified actions that 
will be executed when the If condition is false. Building on the example above, if the DSK 
keyer 1 is up (If condition), then display the text “DSK 1 On” in a text box primitive (Set Text 

Note: If the Action Editor’s standard actions do not perform the 
specific functions that you require, you can select the Custom action, 
which allows you to use scripts to define the desired logic and 
behavior. See Using scripts to define a custom action, on page 80 for 
more information.
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action), otherwise display the text “DSK 1 Off” in a text box primitive (Else statement & Set 
Text action).

To add and define an If condition:
1 With the event selected in the Action Editor, click the Add Condition  button.
2 Click the  button in the Define condition row.

The Expression Builder window appears, which allows you to build the condition that 
will be evaluated and must be true for the action(s) to be executed. 

3 Using the Expression Builder, create the condition’s logic and then click OK.
When building condition statements and setting some properties or parameters 
(step 5), Xpanel uses prefixes to specify the origins of objects and data. See Prefixes 
(Control:, Data:, L:, G:), on page 94 for more information on the prefixes that Xpanel uses 
to identify objects and data.

4 Click <Define action> and select an action from the drop-down list.

5 Set the action’s parameters which appear in the right-hand section of the Action Editor. 
Note that when a parameter is selected, a brief description of the parameter appears 
below the parameter list.

6 Optional: Click on the Action’s Comment column and type a user-friendly description 
of the purpose or behavior of the action.

To add and define an Else statement:
1 With the event selected in the Action Editor and an If condition defined in the Action 

Editor, click the Add Else  button.
2 Click <Define action> and select an action from the drop-down list.

3 Set the action’s parameters which appear in the right-hand section of the Action Editor. 
Note that when a parameter is selected, a brief description of the parameter appears 
below the parameter list.
When setting some properties or parameters, Xpanel uses prefixes to specify the 
origins of objects and data. See Prefixes (Control:, Data:, L:, G:), on page 94 for more 
information on the prefixes that Xpanel uses to identify objects and data.

4 Optional: Click on the Action’s Comment column and type a user-friendly description 
of the purpose or behavior of the action.

Note: If the Action Editor’s standard actions do not perform the 
specific functions that you require, you can select the Custom action, 
which allows you to use scripts to define the desired logic and 
behavior. See Using scripts to define a custom action, on page 80 for 
more information.

Note: If the Action Editor’s standard actions do not perform the 
specific functions that you require, you can select the Custom action, 
which allows you to use scripts to define the desired logic and 
behavior. See Using scripts to define a custom action, on page 80 for 
more information.
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Using scripts to define a custom action
If the Action Editor’s default actions do not perform the specific functions that you require, 
you can create custom actions that allow you to use scripts to define the desired logic and 
behavior.

To create a custom action:
1 Select Custom from the Action drop-down list.

The Action Parameters section at right is replaced by the Custom Actions list, which will 
contain any previous custom actions you or another user may have created.

2 Select an existing custom action.
Or,
Edit an existing custom action by right-clicking on the action and then selecting Edit 
from the popup menu. The Script Editor opens allowing you to edit and save the 
action’s script.
Or,
Create a new one by right-clicking on a custom action and then selecting New from the 
popup menu. The Script Editor opens allowing you to create and save a script for the 
new custom action. Contact our technical support department for more information 
regarding the “Producer API”.

Duplicating, moving and ordering actions
Rather than creating and configuring a whole new action, you can make a duplicate copy 
an existing action by copying and pasting it into the same or a different event/tally. 
Similarly, you can remove an action from one event/tally by cutting it and then pasting it 
into another (see page 76). You can also delete any unwanted actions by selecting the 
action and clicking the Delete button or pressing the Delete key.

Since the action list’s order determines the execution sequence, you may need to use the 
Action Editor’s Move Up and Move Down buttons to re-arrange the order in which the 
actions appear in the list. The Move item up and Move item down buttons can also be 
used to move actions in or out of conditions

 Cut Cuts the currently selected action. Navigate to the event/tally where 
you want to move the action(s) to and click the Paste button.
Holding down the Shift key while clicking the Cut button cuts all 
actions from the currently selected event or tally. 
Holding down the Ctrl key while selecting actions allows you to select 
multiple actions. Once selected, click the Cut button to cut the selected 
actions.

 Copy Makes a copy of the currently selected action. Navigate to the 
event/tally that you want to add the action(s) to and click the Paste 
button.
Holding down the Shift key while clicking the Copy button copies all 
actions from the currently selected event or tally. 
Holding down the Ctrl key while selecting actions allows you to select 
multiple actions. Once selected, click the Copy button to make copies 
of the selected actions.
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 Paste Pastes the last cut or copied action(s) into the currently selected action 
row.

 Delete Deletes the currently selected action(s) from the event or tally.
Holding down the Shift key while clicking the Delete button deletes 
all actions for the currently selected event or tally.

 Move item up Moves the currently selected action up one place in the event/tally’s 
action list.
Holding down the Shift key while clicking the Move item up button 
moves the currently selected action to the top of the list, making it the 
first action to be triggered by the event/tally.

 Move item 
down

Moves the currently selected action down one place in the event/tally’s 
action list.
Holding down the Shift key while clicking the Move item down 
button moves the currently selected action to the bottom of the list, 
making it the last action to be triggered by the event/tally.
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Adding a data source to an object
Xpanel and the Data Server allow you to configure Text Box, Text and Drop-down List 
objects to receive content from data sources, like databases, Excel spreadsheet files, 
delimited text files or RSS feeds. 

When associated with a data source, the object is automatically populated with the most 
recent content belonging to the data source. For example, a text box object can be 
configured to display “live” information fed to it from an RSS feed. Similarly, the options 
within a drop-down list can automatically be updated if it is linked to a spreadsheet, 
delimited text file or database that has been edited.

Linking a data source to an object also provides the opportunity for actions to be executed 
when the object triggers an event (i.e. On Update). For example, when the RSS feed 
updates the text belonging to a text box, a device command can be executed to display the 
text on a device.

The following procedure provides high-level instructions and link to information for 
defining a data source and linking it to a panel object.

To define data sources that can be linked to objects:
1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Add a new schema. 

A schema is a holding space for one or more data sources. To link data to an object, 
Xpanel must first be told where the data is coming from. This is done by setting up one 
or more data sources within a container called a schema. Once Xpanel recognizes the 
data source’s existence within the schema, the source can be used over and over again. 
See page 85 for more information about creating and using schemas.

3 From your new schema, create a data entity. 
A data entity combines specific data from a data source with instructions for displaying 
them. There are three types of data entities:

• Creating a snapshot
• Creating a ticker
• Creating a multi-ticker

4 Link items from a data entity to the panel’s object. See Linking data entities to a panel 
object, on page 93.

5 Optional: Add and configure actions to be executed when the object is updated. See 
Adding actions to an event, on page 78.
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Connecting Xpanel to the Data Server
The Data Server is a service that is responsible for managing data coming from various 
feeds by providing live updates of data values when requested, and distributing the data to 
the appropriate recipients. The Data Server can run locally on the Xpanel workstation 
(automatically installed as part of the Vertigo Suite installation) or it can be run on a 
remote/central Xmedia Server device on the same network as the workstation running 
Xpanel.

The connection to the Data Server is optional, in that Xpanel will run even if the connection 
to the Data Server is down. However, data sources and variables will not work unless the 
connection is active. Common reasons for losing the connection are that the Xmedia Server 
or the machine hosting Xpanel has lost its network connection (network is down, IP 
address has changed or network cable disconnected), the Data Server service has been 
stopped, or the Xmedia Server machine has been shutdown.

Fig. 6-1: Data cannot be retrieved unless Xpanel is actively connected to the Data Server 

Setting Xpanel’s connection to the Data Server:
1 With Xpanel open, select the Tools>Options window to open and displays the Setup 

page.
2 Verify Xpanel’s Data Server connection configuration.

• If you want to connect to the Data Server that is running locally, the Use Remote 
Data Server check box should be unchecked.

If Xpanel is unable to connect to the local Data Server, you should verify that the Data 
Server Service is actively running (MS Control Panel>VertigoXmedia 
DataServer>Service Control).

• If you want to connect to the Data Server that is running on a remote Xmedia 
Server (i.e. central Xmedia Server) that is on the same network as the Xpanel client 
workstation, the Use Remote XMS check box should be checked. 

If Xpanel is unable to connect to the remote Xmedia Server on start up, verify the 
accuracy of Server name / IP setting and the Server Port setting (14060). If these 
settings are incorrect, make the appropriate edits.
If these settings are correct, verify that the machine hosting the Data Server is 
operating, that it is actively connected to the network, and its Xmedia Server Service is 
actively running.

3 Click OK.
If you made any changes to the server settings, a message box appears and informs 
you that you must restart Xpanel for the new server to take effect.
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Creating and configuring data schemas
For data links to work, Xpanel must first recognize where the data is coming from. This is 
done by setting up one or more data sources within a schema. Once the data source exists, 
it can be used over and over again to create data entities (i.e. snapshots, tickers and multi-
tickers). When you create a schema, you specify at least one data source and its identifying 
information (e.g. location, whether it is a database, Excel file, text file... etc.).

The following topics provide more information and instructions for creating and working 
with schemas:

• Creating a new data schema, on page 85
• Editing schemas, on page 87
• Renaming or saving a copy of a schema with a new name, on page 87
• Deleting schemas, on page 87

Creating a new data schema
To create a new data schema:

1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Right-click anywhere within the Asset Browser and select the New Schema command.

The Data Schema Settings window appears.
3 In the Name field, enter the name you would like to assign to the schema.
4 Click the New drop-down list and select one of the following data sources: 

• Database
• Excel Spreadsheet
• Delimited Text File
• RSS

Depending on your choice, different fields will display in the Data source settings.

5 If you chose Database from the Data Source Type drop-down list:
a Make a selection from the Database type drop-down list:

• Data Source Name (DSN)
• Microsoft Access (*.mdb)
• Microsoft SQL Server
• Oracle Server

b If you chose Data Source Name, select either the User/System DSN or the File DSN 
radio button. If opting for User/System DSN, make a selection from the drop-down 

Database Excel Spreadsheet Delimited Text File RSS
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list; if opting for File DSN, enter the file name in the field provided or click  to 
browse. If required, enter the user name and password.

c If you chose Microsoft Access, specify the file name in the Access database field 
(click  to browse).

d If you chose Microsoft SQL Server or Oracle Server, specify the name of the 
computer hosting the server in the Server name field, the name of the database in 
the Database field, and the Username and Password to connect to the server in 
the appropriate fields.

e Click the Test Connection button to ensure the connection to the database works 
(unless you opted for Microsoft Access, in which case it is not necessary). If 
successful, the database’s tables will automatically display.

f If desired, you can skip testing the connection and simply click the Get Tables 
button to display the various tables within the database.

g Select one or more tables from the Select related tables from the following list 
section to make them available in the data source (hold down the Shift or Ctrl key 
for multiple selections).

h Specify the Database connection pool size. This specifies the number of database 
connections that are permitted to be reused.

i Specify the Connect timeout, which is a timeout in seconds.
6 If you chose Excel Spreadsheet from the Data Source Type drop-down list, provide the 

required information in the File Name or URL field (click  to browse).

7 If you chose Delimited Text File from the Data Source Type drop-down list:
a Provide the required information in the File Name or URL field (click  to browse). 
b Specify the characters that will act as the column and row delimiters in the text file. 

By default, the Column delimiter is set to a comma character and the Row 
delimiter is set to \r\n (carriage return and line feed).

c Set the URL Timeout property in milliseconds (default = 5000).
d If the Column delimiter is set to comma and your text file data contains a text string 

with an intentional comma (i.e. Smith, Daniel, Jones, Mary), you can avoid the 
unintentional breaking on commas by putting the text between double quotations 
(i.e. “Smith, Daniel”, “Jones, Mary”) and enabling the Double quotes escape 
column delimiter parameter.

8 If you chose RSS from the Data Source Type drop-down list, enter the URL.
RSS commonly-used XML format distributes news headlines, links and abstracts 
collected from the Web. There are many sites available that conform to this format. For 
a sampling, refer to http://www.newsisfree.com/. From there you can create an 
account and then start browsing the free news feeds.

Note: Only .xls files are supported. Excel’s .xlsx files are not 
supported.

Note: Make sure the web site you are entering is correct and up-to 
date.
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9 Click the Save button to save the new data source. It displays at left under Data 
Sources.

10 Repeat steps 3 to 10 until all data sources for the schema have been created, then click 
OK. This closes the Data Schema Settings window.

Editing schemas
When editing a schema, you are editing data source details.

To edit a schema:
1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Right-click on the schema that is to be edited and select the Edit command.

The Data Schema Settings window appears.
3 Select a data source from the list at left.
4 Click the Edit button. The Data source settings fields are displayed. 

For a description of each data source setting, please refer to page 85.
Or,
Click the Delete button to delete the data source from the schema.

5 When done making changes, click the Save button and then click OK to exit the Data 
Schema Settings window.

Renaming or saving a copy of a schema with a new name
You can rename a schema right-clicking on a schema and then selecting one of the 
following commands:

• Edit - This option opens the Data Schema Setting window, where you can edit the 
schema’s name in the Name field.

• Rename - This option should only be used if you have just created your schema and 
would like to rename it.

• Save As - This option creates a copy of the schema while keeping the old one. Any links 
to panels, for example, are preserved as long as the original schema exists. However, if 
you delete the old version all data links will break.

Deleting schemas
To delete a schema:

1 Right-click on the schema that is to be deleted and select the Delete command.
2 The Delete Data Schema window appears and warns you that by deleting the schema, 

all associated data entities (i.e. snapshots and tickers) will also be deleted.
Click Yes to confirm that you want to delete the schema.

Note: If you have already used your schema to create tickers, 
snapshots etc., it is not recommended that you use the Rename 
option, since the data entities will be affected by the name change, 
and data links to objects will be broken.
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Creating and configuring data entities
Snapshots, tickers and multi-tickers are all data entities -- combinations of specific data 
from a data source (more than one data source in the case of multi-tickers), and instructions 
on how to display the data once it has been linked to an object (e.g. in ticker format, as a 
snapshot value).

The following sections describe how to create and edit data entities:
• Creating a snapshot, on page 88
• Creating a ticker, on page 90
• Creating a multi-ticker, on page 92
• Editing and deleting data entities, on page 92
• Renaming or saving a copy of a data entity with a new name, on page 92

Creating a snapshot
A snapshot is a table of data values that is periodically refreshed. Use a snapshot to display 
a single data value, in contrast to a ticker which cycles through a set of values.

To create a snapshot:
1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Right-click on the schema that you want to add the snapshot to and select the New 

Snapshot command.
The Data Snapshot Settings window appears.

3 In the Snapshot Name field enter a name for your snapshot.
4 In the Data source drop-down list, select one of the data sources that is already defined 

in the schema.
The Data Setting fields that are displayed depend on the type of data source selected.
If the Data source is an Excel Spreadsheet:

• Verify the Excel file path (read-only) and specify the sheet name in the Sheet name 
field.

If the Data source is a text file:
• Verify the Text file path (read-only).

If the Data source is an RSS:
• Verify the URL path (read-only). 

If the Data source is a database:
a Select one or more tables from the Select table(s) section (hold down the SHIFT or 

CTRL key for multiple selections)
b Select the columns to be returned from the query in the Select Return Column(s). 

To change the titles of selected columns, click the Edit Column Names button. 
When the Column Headers dialog box displays, click in a column name to make 
the text editable.

c To have only specific records returned, use the Set Key area. To use stock 
information as an example, you could display only stocks that have gone up or 
down by $1.00 or more. 
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d Each line in the Set Key area represents a filter on the available data and is 
expressed as a condition on the value of a column. Select a column name and 
operator from the drop-down list in their respective columns. The value can either 
be entered as a constant or can be set to the value of another column by choosing 
a column name from the drop down list in the Value column. Alternatively, it is 
possible to set a DYNAMIC VALUE by choosing <DYNAMIC> from the drop-down 
list. 

e To sort returned records, use the Set Sorting Order table. Click in the Name 
column to display a drop-down list that contains all column names of the selected 
tables in the data source. Once the column has been selected, click in the Order 
row to display the drop-down list that contains your two choices: Ascending and 
Descending.

5 In the Refresh Rate field, enter the time interval in seconds that will separate data 
refreshes, or select the Never Refresh check box to deactivate the Refresh Rate field.

6 In the Garbage Collect field, enter the time interval at which the system will purge 
outdated instances of data variables.

7 In the Max Rows field, enter the maximum number of rows to be returned by the query. 
This will ensure that the system’s performance will not be hampered by the retrieval of 
unnecessarily large tables. If you would prefer that there be no limit on the number of 
rows returned by the query, enter 0.

8 The value of the Stale Interval field represents the frequency at which the system 
checks to see if the data has been updated. If the data has not been updated with the 
specified time, a warning is sent to the Xpanel log file. Note that the Stale Interval value 
must either be left blank (default) or be a value greater than the Refresh Rate value.

9 Click OK.
This closes the Data Snapshot Settings window. 
To view the new snapshot, expand the schema in the Asset Browser. 

Fig. 6-2: New snapshot is listed under the schema
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Creating a ticker
Use a ticker when you want to scroll through a data set, displaying one or more items at 
preset intervals. The item or items will be replaced with new content from a selected 
source.

To create a ticker:
1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Right-click on the schema that you want to add the snapshot to and select the New 

Ticker command.
The Data Ticker Settings window appears.

3 In the Ticker Name field enter a name for your ticker.
4 Specify the Ticker Settings:

a In the Interval (sec) field, select the number of seconds you would like to elapse 
before displaying the next data item.

b In the Items field, select the number of data rows that are available for display. 
c In the Increment field, select the number of rows you would like to increment. The 

number of items must always be equal to or less than the increment number to 
avoid data items being skipped.

d In the Burst field, select the number of data items you would like initially sent from 
the Data Server to the output device. If no burst is required, leave the count at 0.

e Select the Refresh only at end check box to refresh ticker data only after it has 
gone through the entire table.

f Select the Start By Default check box to have the ticker start running as soon as its 
host control panel or page is activated. This is the only way to start it without 
setting up an action.

g Select the Wrap around check box to have the ticker wrap. This feature is useful if 
your ticker is showing, say, three data items at a time and you want to ensure that if 
you reach the end of your table and there are only two items left, that you don’t 
end up with a blank item. In this case, if Wrap around were selected the first item 
from the table would go to air as the last item.

h Select the Loop check box to have the ticker start at the beginning of the table and 
play again after it has reached the end.

i Enable the Individualised property when you want to allow each client to control 
the state of the ticker independently.

5 In the Data source drop-down list, select one of the data sources that is already defined 
in the schema.
The Data Setting fields that are displayed depend on the type of data source selected.

Note: The Burst setting is used with crawling or rolling tickers, and 
ensures that the first data item will not repeat itself if subsequent data 
items are not sent to the device in time. If using the Burst setting, it 
must be reset every time you go to Production mode using two Ticker 
Command actions (Reset and Start) associated with the panel’s On 
Load event.
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If the Data source is an Excel Spreadsheet:
• Verify the Excel file path (read-only) and specify the sheet name in the Sheet name 

field.
If the Data source is a text file:

• Verify the Text file path (read-only).
If the Data source is an RSS:

• Verify the URL path (read-only). 
If the Data source is a database:

a Select one or more tables from the Select table(s) section (hold down the SHIFT or 
CTRL key for multiple selections).

b Select the columns to be returned from the query in the Select Return Column(s). 
To change the titles of selected columns, click the Edit Column Names button. 
When the Column Headers dialog box displays, click in a column name to make 
the text editable.

c To have only specific records returned, use the Set Key area. To use stock 
information as an example, you could display only stocks that have gone up or 
down by $1.00 or more. 

d Each line in the Set Key area represents a filter on the available data and is 
expressed as a condition on the value of a column. Select a column name and 
operator from the drop-down list in their respective columns. The value can either 
be entered as a constant or can be set to the value of another column by choosing 
a column name from the drop down list in the Value column. Alternatively, it is 
possible to set a DYNAMIC VALUE by choosing <DYNAMIC> from the drop-down 
list. 

e To sort returned records, use the Set Sorting Order table. Click in the Name 
column to display a drop-down list that contains all column names of the selected 
tables in the data source. Once the column has been selected, click in the Order 
row to display the drop-down list that contains your two choices: Ascending and 
Descending.

6 In the Refresh Rate field, enter the time interval in seconds that will separate data 
refreshes, or select the Never Refresh check box to deactivate the Refresh Rate field.

7 In the Garbage Collect field, enter the time interval at which the system will purge 
outdated instances of data variables.

8 In the Max Rows field, enter the maximum number of rows to be returned by the query. 
This will ensure that the system’s performance will not be hampered by the retrieval of 
unnecessarily large tables. If you would prefer that there be no limit on the number of 
rows returned by the query, enter 0.

9 The value of the Stale Interval field represents the frequency at which the system 
checks to see if the data has been updated. If the data has not been updated with the 
specified time, a warning is sent to the Xpanel log file. Note that the Stale Interval value 
must either be left blank (default) or be a value greater than the Refresh Rate value.

10 Click OK.
This closes the Data Ticker Settings window. 
To view the new ticker, expand the schema in the Asset Browser. 
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Creating a multi-ticker
A multi-ticker looks and acts exactly like a ticker, except that it takes its data from more than 
one data source within a single schema. This allows you to run through all data from one 
and then immediately move on to the next one.

To create a multi-ticker:
1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Right-click on the schema that you want to add the snapshot to and select the New 

Multi-ticker command.
The Data Multi-ticker Settings window appears.

3 In the Multi-ticker Name field enter a name for your ticker.
4 Specify the Ticker Settings by following the instructions in step 4 on page 90.
5 Under Sub-Tickers click the New button. This enables the fields under Individual Sub-

Ticker Settings. The sub-tickers are individual tickers that make up the multi-ticker.
6 Within Sub-ticker Settings, enter a name for the sub-ticker in the Sub-Ticker Name 

field.
7 Follow steps 5 to 9 on page 90 to complete the rest of the sub-ticker information.
8 Click the Save button to save the new sub-ticker. It is immediately added to the Sub-

tickers section.
9 Repeat steps 5 to 8 from this procedure until all data sources for the multi-ticker have 

been created, then click OK. This closes the Data Multi-ticker Settings window. 
To view the new multi-ticker, expand the schema in the Asset Browser.

Editing and deleting data entities
To edit or delete data entities:

1 Open Xpanel’s Asset Browser (Ctrl+A) and select the Data tab.
2 Expand the schema that contains the data entity.
3 Right-click the data entity that is to be edited or deleted:

• Select the Edit command. The data entities Settings window appears. Make the 
appropriate edits and click OK.

Or,
• Select the Delete command. When the Delete data ticker window appears, click 

Yes to confirm that you want to delete the data entity.

Renaming or saving a copy of a data entity with a new name
The same issues surrounding the Rename versus the Save As functions for schemas also 
applies to snapshots, tickers and multi-tickers (see Renaming or saving a copy of a schema 
with a new name, on page 87). Basically, renaming is risky unless you have just created the 
data entity. Any links you have made with it on a panel will be broken.

Saving a data entity as something else creates a copy of it while keeping the original and 
any links created with it.
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Linking data entities to a panel object
Data linking is the process of connecting data to objects, so that the object’s content is 
always fed the most recent information from the data source. For example, to display 
headlines from a newswire feed you must link the data source to the object displaying the 
data (e.g. a text box).

To create a data link:
1 Ensure that both the Properties view (Ctrl+R) and the Asset Browser (Ctrl+A) are open.
2 Select the Data tab in the Asset Browser and navigate to the schema and data entity 

that will populate the panel object.
3 Expand the data entity to display its contents.
4 Add or select the object (Text box, Text or drop-down list) that will receive data from 

the data entity. The object’s properties now appear in the Properties view.
5 Create the data link by dragging a data item or data column heading from the data 

entity directly onto the object on the panel. 

The object’s Data Source property is automatically filled in with the data source’s path 
(i.e. Data:<schema>:<dataEntity>(<column#>,<Row#>). Note the prefix that Xpanel 
uses to specify the origins of the data. See Prefixes (Control:, Data:, L:, G:), on page 94 for 
more information on the prefixes that Xpanel uses to identify objects and data.

Note: When creating data links, bear in mind that only one data item 
can be assigned to an object. Therefore, if your data source has 
multiple columns and you would like to display data from more than 
one, you’ll need to set up several text boxes. Furthermore, you’ll need 
to ensure that the data item for each text box comes from the same 
row, otherwise your data will be out of sync.
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Prefixes (Control:, Data:, L:, G:)
When setting some properties or parameters, Xpanel uses prefixes to specify the origins of 
objects and data. While you can type these in along with the object name or data source, 
Xpanel’s drag and drop functionality makes it unnecessary for the most part by 
automatically filling all required information.

The following table identifies the most common prefixes used:

Lookup table properties
Objects that have a Data Source property, most likely also have a Lookup Table and 
Lookup Table Location properties. 

Lookup tables are created in Xstudio, the Vertigo Suite’s template authoring application, 
and they provide a way of defining replacement values for incoming data. For example, an 
object that is being fed the full city names from a live data source, cross references the city 
name against a lookup table and then displays the city’s abbreviation. Refer to the Xstudio 
User Manual for instructions on how to create and use Lookup tables.

In the context of using lookup table in Xpanel, if lookup tables are saved on the same 
Xmedia Server that Xpanel is connected to, you can use these lookup tables to replace the 
values coming into an object linked to a data source. How you apply a lookup table 
depends on where the data is coming from:

• If data is being fed in from a data source, you would use the Lookup Table and Lookup 
Table Location properties in the Properties view to select the lookup table and identify 
its location on the Xmedia Server.

• If the lookup table is replacing text coming from somewhere other than a data source, 
e.g. the contents of a text box being set into another text box, you would use the Action 
Editor’s Expression Builder to create a LOOKUP expression (see page 69).

Prefix Signifies

Control: A control object, e.g. Control:MyControlObject.
This prefix is commonly used in the Action Editor to identify the control object 
that the action’s parameters apply to (e.g. Target or Source). See Adding actions 
to an event, on page 78.

Data: A data item from the Data Server, e.g. Data:Schools:SchoolsClosed(1,1).
This prefix is commonly used in the Data Source property to identify the data 
item that is linked to an object. See Linking data entities to a panel object, on 
page 93.

L:
G:

• A local data server variable, e.g. L:SelectedStock.
• A global data server variable, e.g. G:StationID.
Local and global database variables are created on the fly whenever a reference 
to one is made in a property value or action parameter. It is also possible for 
controls to set the value of these variables such that other controls may read 
them. Local database variables can only be used within the control panel that 
created them and are destroyed when the panel exits Production mode. Global 
database variables, on the other hand, are shared amongst all control panels and 
remain in the database even after exiting Production mode.
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Operating panels in Production mode
Xpanel’s Production mode allows operators to open panels that were built in Xpanel’s 
Design mode and use them to control the playout of graphics on external channel 
branding devices. Production mode also allows operators to monitor the Xpanel’s 
connection to the devices associated with the loaded panels, as well as monitor the health 
and alarms of connected devices.

For the most part, the mechanics of operating panels in Production mode are the same as 
most Windows-based user interface controls (e.g. clicking buttons or setting values using a 
slider or up/down box). Well designed panels should be user-friendly and intuitive so that 
operators can easily identify and use the controls. Operators who would like to learn more 
about the purpose and functionality the individual objects are encouraged to consult 
Adding objects and primitives to a panel, on page 26.

The following sections provide information and instructions for opening panels in 
Production mode and using some of the less intuitive controls, like channel selectors and 
how to arm and take certain objects. Information is also provided to explain how operators 
can use Xpanel’s monitoring and logging features to oversee the status and details of 
Xpanel’s operations.

• Opening panels and projects in Production mode, on page 96
• Xpanel startup for operator control workstations, on page 97
• Selecting channels using a Channel Selector, on page 99
• Using armed states (Arm & Take), on page 100
• Monitoring device connectivity, on page 102
• Monitoring device alarms, on page 103
• Configuring and viewing Xpanel’s log files, on page 104
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Opening panels and projects in Production mode
Once you have created a panel in Xpanel’s Design mode, you will want to test its 
functionality and usability by switching to Xpanel’s Production mode.

To switch from Design mode to Production mode:
• Select the View>Production Mode menu command.

Or,
• Press CTRL+P

Or,
• Click the Production Mode button  located in the upper-right corner of 

the menu bar. 

When in Production mode, perform one of the following to open another panel or project:

To open an existing panel:
a Select the File>Open menu command or press Ctrl+O.

The Open Panel window appears. 
b Navigate and select the desired panel. 
c Click Open.

To open an existing project:
a Select the File>Project>Open menu command.

The Open Project window appears. 
b Navigate and select the desired project. 
c Click Open.

Note: In order to open in Production mode, a valid station 
configuration must be loaded in Xpanel. If a station configuration is 
not already loaded, you will be prompted to load a station 
configuration before Production mode is opened. See Loading a 
station configuration, on page 21 for more information. 
 
Opening a panel in Production mode makes the panel live and 
enables the On Load event, which may trigger actions. Therefore, if 
your intent is to explore the interface or test the panel’s behavior, 
ensure that the selected devices are not live on air.

Note: If Xpanel is in full screen Production mode and you want to 
open a new panel or project, press the F11 key to leave full screen 
mode and then use the procedures above to open the panel(s). Press 
F11 again to return to full screen mode.
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Xpanel startup for operator control workstations
Operators do not need to have access to Xpanel’s Design mode when Xpanel is used for 
playout control on an operator control workstation. In such operational situations, we 
recommend configuring Xpanel’s Startup options to automatically open in full screen 
Production mode, as well as automatically load a specific panel or project. You can also 
restrict operators from accessing Xpanel’s Design mode by enabling a password 
requirement in order to switch from Production mode to Design mode.

To set up Xpanel for an operator control workstation:
1 Launch Xpanel.
2 Open the Options window by selecting the Tools>Options menu command.
3 Select the Startup tab.
4 Optional - Enable the Start in full screen mode setting to ensure that Xpanel’s user 

interface is full screen each time the application is opened. 
When Production mode is in Full Screen, the Xpanel title bar and menus are hidden and 
the remaining portions of the user interface expand to cover the full screen. Use the 
F11 keyboard button to toggle between Full Screen and regular view. 

5 Enable the Start in production mode setting to have Xpanel automatically start up in 
Production mode each time it is opened.
In order to open in Production mode, a valid station configuration must be loaded in 
Xpanel. Therefore, if the Start in production mode setting is enable and a station 
configuration is not already loaded, you will be prompted to load a station 
configuration before Xpanel can open in Production mode. See Loading a station 
configuration, on page 21 for more information.

6 Optional - The Optional password for Edit mode field becomes available when the 
Start in Production mode setting is enabled. This field allows you to restrict the ability 
to switch from Production mode to the Design mode by requiring a password.
To implement the password protection, simply type the password in the field. Later 
when you click OK (further in this procedure), you are prompted to confirm the 
password by retyping the password.
Once the password protection is configured, when an operator attempts to enter 
Design mode from Production mode, they are asked to provide a password. Only by 
providing a correct password will they be able to change modes.

Full Screen modeRegular view (Full Screen disabled)
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7 Optional - If you configure Xpanel to start in full screen Production mode, we 
recommend that you also set either the Auto-load panel or Auto-load project options, 
which will automatically load the specified panel or project each time Xpanel is started.
Use the Browse button to navigate to and select the desired panel or project.

8 Click OK to commit the Start-up options settings.
The new Start-up options’ setting will be applied next time Xpanel is launched.

Note: Loading a panel in Production mode makes the panel live and 
enables the On Load event, which may trigger actions. Therefore, if 
your intent is to explore the interface or test the panel’s behavior, 
ensure that the selected devices are not live on air.
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Selecting channels using a Channel Selector
In Production mode, a Channel Selector object allows you to choose the channel(s) that an 
object’s operations will be applied to. You can select and execute on one channel at a time 
or gang the channels (select two or more channels) so that operations carried out on the 
panel are sent simultaneously to all of the ganged channels.

While the appearance and style of the Channel Selector may be different depending upon 
the object’s properties settings, the basic operation of the Channel Selector is very similar 
in most cases. Regardless of the View Type setting, the main operational features are the 
channel buttons, which are mapped to specific channels and devices. See Creating a 
Channel Selector, on page 53 for more information about configuring a Channel Selector 
object in Design mode.

Fig. 7-1: Click the channel buttons in the Channel Selector to activate a channel assignment

To select a channel operators simply have to click a channel button. Once selected, 
operations carried out by objects associated with the Channel Selector will be executed on 
that channel. In Production mode, the color of the Channel Selector’s channel buttons 
change depending upon its current state. 

Fig. 7-2: States of the channel buttons

Note: When the panel is loaded, one or several channel buttons may 
already be selected if the Channel Selector’s Default List property was 
set.

View Type = Standard

View Type = Grouped

Grey = Not selected/active

Red = Selected/active

Red with alert symbol = Selected, but a device is disconnected

Ganged channels = Red is the master channel, 
while white are the slave channels
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There are two methods for ganging channels in a Channel Selector:
• If the Display Hold Button property was set to True, a Hold button will appear within 

the Channel Selector. Select the Hold button, then click the channels that you would 
like to gang together. The first channel selected appears in red and is designated as the 
Master Channel, while the others appear in white and are the slave channels. 

Or,
• If the Channel Selector does not have a Hold button (Display Hold Button property 

was set to False), you can right-click on the Channel Selector’s channel buttons in 
Production mode to select multiple channels.

Using armed states (Arm & Take)
Using a technique called Arm & Take, operators can ready multiple objects on the panel in 
Production mode and then execute their operations simultaneously by clicking the Take 
button. 

When an object’s Armable property is set to True, operators can put objects into a ready 
state by clicking the object so that the button or LED changes color. The object’s operations 
are prepared and remain in an armed state until a Take command is triggered (clicking the 
Take button). Once the Take command is triggered, the operations associated with all of 
the armed objects on the panel are carried out. 

For example, if keyer 1 is currently down (grey), but it is armed to cut up when the Take 
button is clicked. Keyer 2 is currently on air (red), but it is armed to fade down when the 
Take button is clicked. Keyer 3 is also currently on air (red), but since it is not armed (neither 
of the LEDs are active), its state will remain unchanged when the Take button is clicked.

Fig. 7-3: Arm & Take example

The sections below provides descriptions of the specific behavior of the four (4) Xpanel 
objects that can be configured to be armable.

Fade DSK button objects
The Fade DSK button object is a toggle control for cutting up or down the media content 
that is currently loaded onto the keyers. 
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In Production mode, the DSK Fade Button appears grey when the keyer is cut down and red 
when it is cut up.

When the Fade DSK button’s Armable property is set to True, two LEDs (Cut & Fade) appear 
with the DSK button (see page 35). Clicking the DSK button toggles the button between its 
armed states (armed-cut, armed-fade, disarmed).

Refer to the example above for a short description of the Fade DSK button’s arm & take 
behavior.

Transition Type objects
The Transition Type object allows you to choose the transition style that is used when the 
device’s A/B mixer moves the program output between two SDI video input streams.

When the Transition Type object’s Armable property is set to True, you can choose the 
transition type that will be used when a Take command is triggered (i.e. <Active>Take 
Button object is clicked). In addition to the Transition Type, the transition rate at the time 
the object is armed is also locked in and used when a Take command is triggered.

Note: Wipe transitions are removed when the Transition Type object is armed.

Virtual GPI objects
The Virtual GPI object allows you to control up to 18 GPI triggers that are configured for the 
specified device(s).

When the Virtual GPI’s Armable property is set to True, you can arm one or several of the 
Virtual GPI buttons by simply clicking the individual buttons, which turns them from grey 
(disarmed) to red (armed). They will remain it this state until the Take button is clicked, at 
which time the operations associated with the armed GPI buttons will be carried out.

Voice Over button objects
The Voice Over Button object is a toggle switch that allows you to cut up or down the 
loaded audio file or external audio on the specified device(s). 

In Production mode, the Voice Over Button appears red when the voice over is active (i.e. 
playing) and grey when it is not.

When the Voice Over button’s Armable property is set to True, an Arm LED appears next to 
the Voice Over button (see page 43). Clicking the Voice Over button toggles the button 
between its armed state (Arm LED active) and disarmed state (Arm LED inactive).

The example below demonstrates that VO 1 is currently up (red), but it is armed to be cut 
down when the Take button is clicked. VO 2 is not currently on air (grey), but it is armed to 
cut up when the Take button is clicked. VO 3 is also currently off air (grey), but since it is not 
armed (the LED is inactive), its state will remain unchanged when the Take button is clicked.
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Monitoring device connectivity
In Production mode, it is crucial that operators be aware of and have control over the 
connections between Xpanel and the devices. As such, when Xpanel is in Production mode, 
operators can monitor the connection status displayed in the lower-left status bar. The 
status bar’s messages (below) allow operators to casually monitor the connection status.

As the status bar messages state, more details are available by clicking the status bar, which 
opens Xpanel’s Connections Monitor view. 

Fig. 7-4: Xpanel’s Connection Monitor view

The Connections Monitor allows operators to monitor and manage the connections by 
displaying the devices’ connection status and details. The devices are organized by channel 
and display the device’s connection state, IP address, and port. If the connection is good, 
the channel and device details are green. However, if the connection is down, the channel 
and device details are red.

Devices may be in the following states:
• Good connection: The network connection and the communication port between 

Xpanel and the device are open and active. These conditions allow for proper 
communication between Xpanel and the device.

• Not connected: While the network connection is good, the operator has disconnected 
Xpanel (closed the communication port) by using the Force disconnect of 
<device_name> command.

• Lost connection: The network connection was good, but something has caused that 
connection to fail (e.g. network goes down or network cable disconnected). Xpanel 
automatically tries to re-establish the network connection. If the connection is re-
established, then the status changes to Good Connection. However, if the connection 
cannot be re-established, then the status changes to Bad Connection.

Note: Another way to open the Connection Monitor is to select the 
View>Connections Monitor menu command.
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• Bad connection: Xpanel cannot connect to the specified device through the network 
connection. This may indicate that the network is down, the wrong IP address is 
specified for the device, or the network cable is disconnected. Once the problem is 
resolved, use the Reconnect all used devices command to reconnect Xpanel to the 
device.

Operators can connect and disconnect devices listed in the Connection Monitor by right-
clicking on a device’s heading and selecting the following commands:

• Reconnect all used devices: Attempts to reconnect all listed devices whose state reads 
Not connected.

• Force disconnect of <device_name>: Allows the operator to disconnect a device from 
Xpanel, which closes the communication but not the physical connection between 
Xpanel and the device. The device’s state changes from Good connection to Not 
connected when this command is used. Use the Reconnect all used devices command 
to reconnect the device.

Monitoring device alarms
Enabling the Show alarm tab in Production mode setting (Tools>Options>Diagnostics) 
opens the Alarm panel, which shows the status of the device alarms for devices associated 
with the current channels. The device alarms must have been configured on the device 
itself in order to be displayed on the Alarms panel.

Fig. 7-5: Device alarms are displayed on the Alarms panel in Xpanel’s Production mode

Clicking the arrow buttons  on the Alarm panel allows you to scroll through the 
available devices, in which case the device information and alarms are updated and 
represent the selected device.

Note: The device must be actively connected to Xpanel for the alarms 
to be displayed on the Alarms panel. See Monitoring device 
connectivity, on page 102 for more information.
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If any of the device readings fall outside the expected range, the Alarm panel’s tab turns red 
and the LED on the specific alarm’s health meter will also turn red to highlight the potential 
problem. You can turn alarms on or off by toggling the On button within the appropriate 
alarm’s health meter box.

Configuring and viewing Xpanel’s log files
As Xpanel operates, events are recorded to a log text file, which is stored under the 
Windows system directory for application specific data.

Since the log files thoroughly track and record Xpanel’s events during operation, they are a 
great tool to use for diagnosing error conditions or unexpected behaviors. 

Xpanel’s Logging options allow you to specify the categories of events that you want to be 
recorded in the Xpanel log files, as well as the maximum number and size of Xpanel log files 
that will be archived. As well, the Enable verbose logging setting on the Diagnostics tab 
can be used to supplement the basic logging information.

Fig. 7-6: Xpanel’s log file settings are present on the Diagnostics and Logging options tabs

Although the default values are sufficient for most operating conditions, the following 
settings can be configured on the Logging tab in Xpanel’s Options window 
(Tools>Options).

• Log Level - This sets the default log level used by all logging categories except those 
that have been checked in the Debug Categories list. The choices are:

• Error - Only log errors and essential operations.
• Warn - Log unsuccessful operations that may indicate a problem (in addition to all 

messages logged at the Error level).
• Info - (Default) Log important events that occur during normal conditions (in 

addition to all messages logged at the Warn level).
It is recommended to set the Log Level to Info in order to provide enough information 
in the logs to diagnose common problems without affecting performance.

• File Size - Sets the maximum memory size for each log file created per run. The default 
value is 6 MB.

• File Count - Specifies the maximum number of Xpanel*.log files that will be 
stored. A large enough number should be chosen to store over a day's worth of 
logs. This way if a problem happens the relevant log files will be available. Once the 

Note: You can add and configure your own device alarms directly to 
the panel using Xpanel’s Health Meter objects. See Health Meter 
object, on page 49 for more information.
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maximum number of files is reached, the oldest log file will be replaced by a new 
one. The default value is 5.

• Debug Category List - Select the types of debug logging (categories) that you would 
like to record in the Xpanel log file:

• General - General logging that does not fit under any other category.
• VxmsApi - Logs client-side calls to the Xmedia Server.
• VxmsTcp - Logs client-side socket communication with the Xmedia Server using 

the principal Xmedia Server connection.
• VxmsCache - Logs client-side activity in the Xmedia Server cache.
• VxmsTcpLayer - Logs client-side socket communication with the Xmedia Server 

used by the cache and publishing.

To view Xpanel’s current log file:
• Select the View>View Log File menu command.

The current log file opens in Notepad. 
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Xpanel’s menus & toolbars
Xpanel’s commands are thematically organized within the menus at the top of the main 
interface window. Note that the menus in Design mode and Production mode differ slightly 
since the purpose and required functionality are different in each mode.

When Xpanel is in Design mode, the toolbar provides you with easy access to some of the 
most frequently used commands.

Fig. A-1: The toolbar in Xpanel’s Design mode provides quick access to frequently used commands

The following sections provide functional definitions of the Xpanel’s menu commands and 
toolbar buttons:

• File menu commands, on page 108
• Edit menu commands, on page 109
• View menu commands, on page 109
• Format menu commands, on page 111
• Tools menu commands, on page 113
• Help menu commands, on page 113

New

Open

Save

Export

Import

Cut

Copy Undo

Paste Redo

Align commands

Layering commands

Group

Ungroup
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File menu commands
The File menu contains commands that are related to opening, saving, importing or 
exporting panels or projects.

Each of the File menu commands is described in the following table:

New Design mode only.
Opens a new, empty panel in Xpanel.
See Opening panels or projects, on page 23 for more information.

Open Opens the Open Panel window, which lets you select an existing 
panel to open.
See Opening panels or projects, on page 23 for more information.

Save Design mode only.
Saves changes made to the currently selected panel, as well as any 
specified metadata.
If saving the panel for the first time, it opens the Save Panel window 
(otherwise it simply saves using the current panel name). 
See Saving a panel, on page 64 for more information.

Save As Design mode only.
Opens the Save Panel window, which allows you to save the 
currently selected panel using a new name and/or directory 
location.

Close Closes the currently selected panel. If the panel contains unsaved 
changes, the Close Panel window appears and offer you the 
opportunity to save the changes before closing the panel.

Project A project consists of multiple panels that are saved within one 
project file (*.xpp). Each panel is an individual asset on the system, 
but instead of opening each panel independently, opening the 
project file opens all associated panels automatically.
• Open: Opens the Open Project window, which lets you select an 

existing Xpanel project to open.
• Save: Saves changes made to the currently open project and its panels. If 

saving the project for the first time, it opens the Save Project window 
(otherwise it simply saves using the current project name).

• Save As: Opens the Save Project window, which allows you to save the 
currently selected project using a new name and/or directory location.

Export • Export panel: Opens the Save As window, which allows you to export 
the selected panel by sending a copy of the panel out of Xpanel and into a 
VxM Export folder which can be saved anywhere on your system.

• Export project: Opens the Save As window, which allows you to export 
the open project by sending a copy of the project (and its panels) out of 
Xpanel and into a VxM Export folder which can be saved anywhere on your 
system.

Import • Import panel: Opens the Import panel with assets window, which 
allows you to navigate to and then import panels that were created in 
Xpanel and exported from a separate system/network. 

• Import project: Opens the Import panel with assets window, which 
allows you to navigate to and then import a project that was created in 
Xpanel and exported from a separate system/network.
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Edit menu commands
The Edit menu is only available in Design mode since it contains commands that are related 
to editing content on the panels during panel building tasks.

View menu commands
The View menu contains commands that are related to displaying or hiding windows and 
tools that are used to create and/or operate panels.

Each of the View menu commands is described in the following table:

Ingest Opens the Ingest window, which allows you to ingest image files 
into the system so that they can be added to the panel. See page 33 
for more information.
Note that the image files are ingested into the content server, but 
they are not published to the devices (unless auto-publishing is 
setup on the Xmedia Server). We recommend that you use the 
Vertigo Suite’s Xplorer or Xstudio applications to ingest media to be 
used on the devices (i.e. images, cel animations, video and audio 
clips...etc.).

Exit Allows you to quit Xpanel, prompting you first to save if any edits 
have not yet been saved.

Undo Allows you to undo an edit on the currently selected panel.

Redo Allows you to redo (repeat) an edit on the currently selected panel.

Cut Cuts the selected object(s) on the currently selected panel to the 
clipboard.

Copy Copies the selected object(s) on the currently selected panel to the 
clipboard.

Paste Pastes the clipboard contents onto the currently selected panel.
Alternative access:

Delete Deletes the selected object(s).

Select All Selects all objects on the currently selected panel.

Production Mode Switches between Xpanel’s two modes: Design mode and 
Production mode.

Connection Monitor Production mode only.
Opens the Connections view, which displays the connection status 
of all the channels and devices that are assigned to objects on the 
panel. See Monitoring device connectivity, on page 102 for more 
information.

Properties Design mode only.
Opens the Properties view, which displays the current properties 
and settings belonging to the selected object(s) or the panel’s 
canvas. 
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Object List Design mode only.
Opens the Objects view, which displays a list of the objects that are 
currently on the panel. Selecting an object in the Objects view 
selects the object on the panel. 
Right-clicking the object allows you to select the Set as a drag & drop 
default and Reset the drag & drop default commands.

Asset Browser Design mode only.
Opens the Asset Browser view, which allows you to browse and 
preview the Panels, Images, Data schemas that are stored on the 
system. Panels can be opened directly from the Asset Browser, 
images can be dragged onto the canvas and new data schemas can 
be created and linked to objects.

Action Editor Design mode only.
Opens the Action Editor view, which allows you to add to the 
functionality of standard Xpanel objects or define the functionality 
of primitive objects by configuring and associating the objects with 
a set of actions to occur on an event. See Adding events and actions 
to primitives and objects, on page 69 for more information.

Script Editor Design mode only.
Opens the Script Editor view, which allows you to create or edit 
custom VB scripts to provide more complex functionality to actions 
associated with Xpanel objects. 

Station Manager Design mode only.
Opens the Station Manager view, which allows you to define the 
devices on the network and then create a station configuration, 
which groups the devices into channels. See Creating and loading a 
station configuration, on page 15 for more information.

RCP List Design mode only.
Opens the RCPs view, which allows you to define and configure the 
RCP-BR devices on your network. 

Full Screen Changes Xpanel to Full Screen mode, in which case the Xpanel title 
bar and menus are hidden and the remaining portions of the user 
interface expand to cover the full screen. This mode is most often 
used when Xpanel is used on an operator controlled workstation. 
Use the F11 keyboard button to toggle between Full Screen and 
regular view.
Xpanel can also be configured to open in full screen mode by 
enabling the Start in full screen mode setting in Xpanel’s Startup 
options (see page 97).

View Log File When selected, this command opens the current log file in Notepad. 
The log file stores the processes and errors that occurred during your 
Xpanel session and is useful when debugging. 
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Format menu commands
The Format menu is only available in Design mode since it contains commands that use 
when building and editing panels, like positioning and sizing the objects placed on the 
panel.

Each of the Format menu commands is described in the following table:

Group Takes several separate objects selected together on the currently 
selected panel and groups them into a single grouped object. 
See Grouping and ungrouping objects on the canvas, on page 56 for 
more information.

Ungroup Ungroups a single grouped object on the currently selected panel 
back into separate objects. 
See Grouping and ungrouping objects on the canvas, on page 56 for 
more information.

Align The Align commands allow you to place objects on the canvas so 
that they are vertically, horizontally, or center-aligned in relation to 
other objects on the canvas.
See Positioning objects using the Align commands, on page 61 for a 
description of each of the Align commands.
Alternative access: Toolbar buttons

Layering The layering commands allow you to move objects to the top layer 
for display or editing, as well as sending the object behind others. 
See Layering objects on the canvas, on page 57 for a description of 
each of the Layering commands.
Alternative access: Toolbar buttons

Size Allows you to resize one or many objects relative to another object 
using the following commands:
• Same Width
• Same Height
• Same Width & Height
• Match Biggest
• Match Smallest
• Reset to Natural Size

Align Align Center
vertically

Center
horizontally

Align
top

Align
bottom

rightleft

Bring to
front

forwards
Bring

Bring
backwards

back
Send to
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Horizontal Spacing
Vertical Spacing

The Horizontal Spacing and/or Vertical Spacing commands allow 
you to quickly make the spacing equal between objects, as well as to 
increase, decrease or remove the spacing all together.
Choose from the following commands:
• Make Equal
• Increase
• Decrease
• Remove
See Positioning objects using Spacing commands, on page 62 for a 
description of each of the Spacing commands.

Add Guide Allows you to display virtual lines on the canvas that you can use as a 
reference when arranging or aligning objects. See Positioning 
objects using guides, on page 63 for more information.
• Horizontal:  

Makes a horizontal guide available for dragging into the canvas from the 
top of the window.

• Vertical:  
Makes a vertical guide available for dragging into the canvas from the left 
side of the window.
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The Tools>Options menu command launches the Options window that contains all of the 
settings for configuring Xpanel’s Setup, Startup, Diagnostics and Logging options. Refer to 
the following sections for more information:

• Connecting Xpanel to an Xmedia Server, on page 5
• Xpanel startup for operator control workstations, on page 97
• Monitoring device alarms, on page 103
• Configuring and viewing Xpanel’s log files, on page 104

The Tools>License Manager menu command launches the Vertigo Suite’s License Manager 
window, which lists the Vertigo licenses currently installed on the system, as well as 
allowing you to add and validate new licenses. 

Help menu commands
The Help>About menu command displays the product information splash screen that 
identifies the version of the Vertigo Suite you are currently using. Click the splash screen to 
close it.
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Contact Us
Grass Valley Technical Support
For technical assistance, contact our international support center, at 
1-800-547-8949 (US and Canada) or +1 530 478 4148.

To obtain a local phone number for the support center nearest you, please consult the 
Contact Us section of Grass Valley’s website (www.grassvalley.com).

An online form for e-mail contact is also available from the website.

Corporate Head Office
Grass Valley
3499 Douglas-B.-Floreani
St-Laurent, Quebec  H4S 2C6
Canada
Telephone: +1 514 333 1772
Fax: +1 514 333 9828
www.grassvalley.com
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