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Introducing Xplay
Xplay is the Vertigo Suite’s application for controlling and previewing the playout of media 
and graphics. The management and playout of the playlist can be either operator-
controlled using the Xplay user interface or through a external automation system. Xplay’s 
versatility also allows you to control playout on multiple devices, multiple channels, and/or 
multiple layers on a channel all from a single interface.

In situations where operator-control over the playlist is appropriate, Xplay allows you to:
• Create new playlists that contain pages, clips and/or templates
• Create new pages and add them to a playlist
• Edit existing playlists and pages either prior to playout, or on the fly during the 

broadcast
• Send completed playlists to air on one or more playout devices in real-time using 

manual control techniques, or with the assistance of customizable run-time control 
panels

In newsroom environments, Xplay is the media event sequencer which controls the playout 
of rundowns in a similar way that it controls the playout of traditional playlists. Using the 
MOS protocol, the newsroom computer system (NRCS) sends the rundown information to 
Xplay, which previews and plays out on Vertigo playout devices.

Fig. 1-1: Xplay also acts as the media event sequencer in newsroom environments

Upon receipt of the rundown, Xplay recalls the graphics pages from the Xmedia Server and 
then plays out the dynamic news sequences with live data mapped to the appropriate 
graphic template fields. Customized control panels at the top of the Xplay interface can be 
used for manual operation. Since Xplay’s device views show a preview of the device’s 
playout, you can also make last minute changes to the graphics. The Xnews User Manual 
provides more information about the Vertigo news graphics workflow.

Xplay can also be used to allow third-party automation systems, like Pharos, Pebble Beach, 
Harris (ADC), and Florical, to control Vertigo playout devices (i.e. Vertigo XG and Intuition 
XG). Automation commands are sent using standard automation controls protocols for 
graphics playback either through a serial or TCP/IP connection. Xplay receives these 

NRCS & Xnews plugin

Asset management

Xplay

Playout device
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Introducing Xplay
commands from automation to control the device and the device sends back status 
messages. See Controlling Xplay devices using automation protocols, on page 73 for more 
information.

Fig. 1-2: Xplay allows third-party automation systems to control Vertigo playout devices

Station automation

Automation
protocol

Xplay

(Serial or TCP/IP)
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Getting started with Xplay
Xplay can be used to preview and control the playout of media and graphics on a single or 
multiple devices and this can be done either manually or through automation. As such, the 
procedures for installing and configuring Xplay are depend upon its intended use.

The following sections provide information and instructions for how to install, configure 
and become familiar with Xplay’s user interface:

• Installation and licensing information, on page 4
• Starting Xplay and connecting to the Xmedia Server, on page 4
• Overview of the Xplay interface, on page 5
• Configuring Xplay’s settings, on page 8
• Adding and connecting Xplay to playout devices, on page 9
 3



Getting started with Xplay
Installation and licensing information
Installation and licensing information
When playout is to be controlled manually by an operator, Xplay is typically installed and 
configured on a client computer that is connected via a local-area network to the playout 
devices. However, when the playout is to be controlled by an external automation system, 
Xplay is installed and configured directly on the Vertigo playout device (i.e. Vertigo XG or 
Intuition XG).

Regardless of where it is installed, Xplay is packaged with the Vertigo Suite software 
installation wizard. It can be installed as part of the full installation or as an individual 
(standalone) component. In both cases, you simply need to run the installation wizard on a 
workstation that is on the same network as the Xmedia Server.

Information regarding the Vertigo Suite’s hardware and network requirements, as well as 
instructions for installing and/or upgrading Xplay, are available in the Vertigo Suite’s 
Release Notes, which can be downloaded from the Support Portal web site.

Starting Xplay and connecting to the Xmedia Server
When you initially launch Xplay, a dialog box appears and asks you to configure the server 
location. As a client application, Xplay must be connected to the Xmedia Server, which is 
the centralized asset management server for Vertigo applications and devices.

Since you have only just installed Xplay, the first task that you must do is to connect Xplay 
to the Xmedia Server.

To start Xplay and connect to the Xmedia Server:
1 Click Start>Programs>VertigoXmedia>Xplay.
2 When the message asking you to configure the server location, click the Yes button. 

The Settings dialog box appears.
3 Click Servers in the tree view at left. This displays the settings related to the Xmedia 

Server (see page 115 for more information about Xplay’s Server settings).
4 In the XmediaServer IP Address field, replace <server IP> with the IP address of the 

machine hosting the Xmedia Server.
5 Unless the port number was changed when the Xmedia Server was installed, the 

default in the XmediaServer Port field will be correct. If it was changed, enter the new 
number.

6 Click OK.
Xplay launches. If the program does not launch, consult your system administrator. The 
problem could be due to one of the following:

• The IP address or port was entered incorrectly.
• The machine hosting the Xmedia Server is down.
• The Xmedia Server is not running on the host machine.
• The machine is not connected to the network.

Note: Unlike most other Vertigo Suite applications, Xplay does not 
require a software application license.
4
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Overview of the Xplay interface
While some of the Xplay interface components remain constant, others are customizable 
using Xplay’s settings. The following descriptions identify the Xplay’s main interface 
components and provide a brief functional description of each.

Fig. 2-1: Xplay set to Manual playout mode and On-Air Preview layout mode

1 Main menus: Located along the top of the interface, these menu commands provide 
access to most of Xplay’s settings and administrative functions. See Xplay’s menu 
commands, on page 88 for more information.

2 Asset Browser: The Asset Browser, which is located within a collapsible panel, provides 
a tree view of assets stored on the Xmedia Server. You can use the Asset Browser to 
locate and load a rundown into Xplay, as well as to add pages, clips, templates and/or 
scenes to an open playlist. 

3 Playlist Editor: The Playlist Editor is the workspace where an opened playlist is 
displayed. Playlist elements (segment headings, pages, clips, comments...etc.) are 
organized in a sequential list. 

• The buttons along the top of the window are used for loading and managing 
playlists. These buttons allow you to open a new playlist, as well as save, reload, 
loop... the playlist and its elements. 

• The Quick Recall field, which can be hidden/exposed using the View>Quick Recall 
command, allows you to quickly locate and insert a page, clip, template and/or 
scene into the playlist using the asset’s Recall ID property.

• The Playlist Editor’s global Cue and Take buttons allow you to control the timing of 
when the playlist elements appear on air. 

4 Message Log: Xplay’s Message Log window alerts you to possible errors or operational 
events that may impede or adversely affect your playout. For example, the Message 
Log will alert you if Xplay’s connection to the Xmedia Server (XMS) or to an output 
device is disconnected or re-connected.

1
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The Message Log window is conveniently displayed as a floating window upon start up 
and each time a new message is added to the Message Log. 
You can hide the Message Log window by clicking the window’s Close button . To 
reopen the Message Log window at anytime, select the View>Open Message Log 
command or press Ctrl + M.
Rather than a floating window, the Message Log window can be set as an embedded 
window in the Xplay interface. To embed the Message Log window, set the 
Tools>Settings>Layout>Show embedded message window setting. 

Fig. 2-2: Xplay’s Message Log window can be floating or embedded

5 EAS Status bar: When Xplay is configured to support the Emergency Alert System 
(EAS), the EAS Status bar provides operators with a quick visual of the EAS receiver’s 
status and any current event messages. See Emergency Alert System (EAS) Support, on 
page 129 for more information.

6 Xplay’s Status bar: Xplay’s status bar identifies the name and status of the currently 
loaded playlist, as well as Xplay’s connection status to the Xmedia Server.
The following table describes the possible status information that is displayed in each 
of the categories:

The X logo indicates that a basic Vertigo Suite playlist is 
loaded in the Playlist Editor. The logo is followed by the 
playlist’s name.

The asterisks beside the playlist’s name indicates that 
unsaved edits have been made to the playlist.

Xplay’s Filter pages by device setting is enabled and 
some playlist elements were removed because they were 
not assigned to a device.

The MOS logo indicates a rundown (playlist) is currently 
loaded in Xplay. Rundowns are a type of playlist normally 
used for MOS news broadcasts.

Xplay is properly connected to the Xmedia Server whose 
name or IP address is indicated.
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7 Toolbar Panel: Any panel opened for use with the playlist will be displayed in a panel 
directly under Xplay’s menu bar. When a panel is open, you can display or hide the 
entire control panel area by selecting or deselecting View>Toolbar panel. The panel 
area can be resized by dragging from its bottom borders downwards. You can also 
zoom in/out of the panel by using the mouse wheel. See Using a panel to control an 
additional keyer level on a device, on page 69 for more information.

8 Device Views: Xplay’s General settings (Tools>Settings) allow you to set the Layout 
setting to either Multi-Device or OnAir-Preview, which affects the appearance of 
Xplay’s Device Views. The Device Views allow you to see a visual representation of the 
playlist element that is either being cued or currently being played out on a device.

• Multi-Device: When Xplay is configured to playout to multiple devices or on 
different keyers of the same device, a display pane appears according to the 
number of devices specified in the Number of devices setting. Each device’s 
display view has indicators that informs of the device’s connection status, as well as 
override buttons for controlling the playout of the playlist elements on that device 
(e.g. Cue, Take Clear). The override buttons allow you to take selected playlist 
elements to air on the channel of your choice. The layout of the device’s display 
views can also be customized using the Layout>MultiDevice Layout setting, which 
can be set to OnAir, Preview, or PreviewOnAir. See Configuring Xplay for multi-
device playout, on page 14 for more information.

• OnAir-Preview: This mode is used when Xplay is connected to only a single 
playout device (1 keyer channel) and an optional preview device (i.e. Software CG). 
One display pane shows the playlist element that is currently on air, while the pane 
previews the element that has been cued as next-to-air. See Configuring Xplay for 
single device playout (OnAir-Preview), on page 12 for more information.

When this section of the Status bar turns red, Xplay is has 
lost its connection to the Xmedia Server whose name or IP 
address is indicated.

Alerts or warns you that the Xplay.ini file, which is 
located in C:\Program Files\VertigoXmedia\Apps, is 
currently in an unwritable state. This means that Xplay is 
currently not able to save any of the Xplay settings upon 
shutdown.
7
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Configuring Xplay’s settings
While Xplay’s default settings are appropriate for most operating circumstances, you may 
want to customize the look and behavior of the application using Xplay’s settings. Note that 
modifying these settings is entirely optional.

Changes to Xplay’s settings are made within the Settings dialog box, which can be 
accessed by selecting the Tools>Settings menu command. 

This Settings dialog box contains a tree-structure of thematic settings. Each of the settings 
is defined in the following sections:

• General settings, on page 99
• Layout settings, on page 101
• Playout settings, on page 102
• AFD settings, on page 104
• Display settings, on page 105
• Template Favorites settings, on page 107
• Panel Events settings, on page 108
• Automation settings, on page 109
• As Run Logging settings, on page 111
• Logging settings, on page 113
• Plugins settings, on page 114
• Servers settings, on page 115
• Playlist > Basic settings, on page 116
• Playlist > Status settings, on page 117
• Playlist > Highlight settings, on page 118

Note: Some settings will require you to restart Xplay for the changes 
to be applied.
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Adding and connecting Xplay to playout devices
Xplay allows you to preview and control the playout of media and graphics on various 
types of rendering and playout devices (e.g. Software CG, Vertigo XG or Intuition XG).  Xplay 
can be configured to preview and control playout on a single device, or to managed the 
playout on multiple devices, multiple channels, and/or multiple layers on a channel all from 
a single interface.

Fig. 2-3: Xplay’s Device Views allow you to control the playout on specific devices, channels and/or 
keyers

The following sections describe how to configure Xplay’s Device Manager and Device Views 
to connect to your output device(s):

1 Adding output devices to Xplay’s Device Manager, on page 9
2 Configuring Xplay for single or multi-device playout control, on page 12
3 Connecting output devices to Xplay, on page 16

Adding output devices to Xplay’s Device Manager
Before Xplay can connect and playout media and graphics content to an output device, 
each instance of the output device must be defined in Xplay’s Device Manager.

The Device Manager maintains a list of output device profiles that have been configured to 
work with Xplay. You can add several devices to the Device Manager, as well as add a 
separate device for each channel of the same device (i.e. XG1 for channel A and XG2 for 
channel B of a dual-channel Vertigo XG device).

Note that adding a device to the Device Manager does not automatically associate the 
device with an Xplay Device View (keyer) nor does it automatically connect the device to 
Xplay (these tasks are performed in a separate step described on page 11 and page 16. 
Adding devices to the Device Manager simply means that these devices are already 
configured and available to Xplay whenever they may be needed.

Note: Xplay supports playout on several different device types, 
including the Software CG, Vertigo XG, Intuition XG, as well as other 
Grass Valley and 3rd party devices. Please refer to the latest Vertigo 
Suite Release Notes for the complete list of supported devices.

Xplay’s Device Views
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Adding output devices to Xplay’s Device Manager
To add an output device to Xplay’s Device Manager:
1 Open the Device Configuration window by selecting Tools>Device Manager. 
2 In the Device Configuration window, select the Add button.
3 The Device Configuration windows expands to reveal two tabs (General and 

Advanced) with settings for identifying the device’s configuration.
4 Specify the appropriate General Device Configuration settings:

Device name The name of the selected device. This can only be modified when adding a 
device.

Device alias An alternative name for the selected device on your network.

Description An optional field that lets you label the device to distinguish it from other 
similar devices at your facility (for example).

Device Type Identifies the type of device that these settings apply to. 
Choose from:
• VertigoXG
• IntuitionXG
• Preview (or other device)
• ImageStore
• Intuition
• FTP
• LGK
• DSK
• HMP
• Other
Note: Always select Preview (or other device) for Software CG devices.

Control IP The network location (IP address) or hostname of the selected device. The 
host must be available on the network.
Note: The Control IP setting is not displayed when HMP is selected as the 
device type.

Control Port The networking port that serves as a channel for sending commands to and 
from the device.
Note: The Control Port setting is not displayed when HMP is selected as the 
device type.

Publish IP The network location (IP address) or hostname of the selected device. The 
host must be available on the network.
Note: The Publish IP setting is not displayed when Vertigo XG, Intuition XG 
or Intuition are selected as the device type.

Publish Port The networking port that serves as a channel for publishing assets. Typically, 
this value is set to 15000.
Notes: 
• The Control Port setting is only displayed when Preview, FTP, HMP or Other are 

selected as the device type.
• This value must correspond with the port used by the XpublishAgent on the output 

device.

Publish as 
Export

The Publish as Export setting is only displayed if FTP is the selected device 
type.
This setting publishes the asset in the Vertigo Export (.vex) zip file format. 
The VEX format is used by the File Ingest Service to import assets into the 
Xmedia Server and/or device.
10
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5 Specify the appropriate Advanced Device Configuration settings:

6 Click Apply.

Clip Template When a “stand-alone” clip asset played out (either from the playlist or from 
an automation command), Xplay will use this system template to determine 
the clip’s playout format, position and behavior. 
Click the  button to navigate to and select a Clip template. 
Valid clip templates for various scene formats are included with the Vertigo 
Suite’s system templates. Once imported into the Xmedia Server, the 
templates are stored in the Templates>System Templates category.
If you choose to create your own clip template, remember that the clip 
template’s control-side must have a texture linked to a scene-side clip 
object.

Cel Template
&
Image 
Template

The name of the template that is used to play “stand-alone” cel animations 
or images when they are taken to air using an automation command. 
Click the  button to navigate to and select a cel template or image 
template. 
Valid templates for various scene formats are included with the Vertigo 
Suite’s system templates. Once imported into the Xmedia Server, the 
templates are stored in the Templates>System Templates category.
If you choose to create your own template, remember that the template’s 
control-side must have a texture linked to a scene-side cel animation or 
image object.

External Keyer Allows you to associate another device with the current device. This setting 
is specifically used when the Software CG output is keyed over the 
ImageStore output. In this way, specific commands can be sent to the 
ImageStore (the External keyer) when specific things are done on the 
Software CG.
Note: The External Keyer setting is not displayed when FTP and HMP are 
selected as the device type.

Publish Master Lets you select a master device.
Note: The Publish Master setting is only displayed when Preview and 
Other are selected as the device type.

Note: After a device has been added to the Device Manager, you can 
edit a device’s configuration settings (except for the Device Name) or 
delete the device from the Device Manager. However, the device must 
not be actively assigned to a Device View in Xplay.
11
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Configuring Xplay for single or multi-device playout control
The Device Views along the right-side of the Xplay interface allow you to view and control 
the playlist items that are either being cued or currently being played out on a device. 

Taking into consideration your intended use and output device configurations, you must 
set Xplay’s Layout setting (Tools>Settings>General>Layout) to either OnAir-Preview or 
Multi-Device, which determines the appearance of Xplay’s device views. You must also 
associate Xplay’s Device Views with the device channels and keyers that the playlist items 
will be played out on. Both of these tasks are explained in the following sections:

• Configuring Xplay for single device playout (OnAir-Preview), on page 12
• Configuring Xplay for multi-device playout, on page 14

Configuring Xplay for single device playout (OnAir-Preview) 
When Xplay is to be connected to only a single playout device, we recommend that you set 
Xplay’s Layout setting to OnAir-Preview. The OnAir-Preview layout provides you with two 
Device View windows (On Air and Preview) and the Toolbar Panel. See page 54 for a 
detailed description of the OnAir-Preview layout.

Fig. 2-4: On Air - Preview layout’s device views and Toolbar Panel

Once a playout device and a preview device (optional) have been added to Xplay’s Device 
Manager and the layout is set to OnAir-Preview, you can assign a device (channel and/or 
keyer) to each of the On Air and Preview Device Views using the Active Device table in the 
Device Manager.

To configure Xplay for single device playout using the OnAir-Preview layout:
1 Select Tools>Settings>General and set the Layout setting to OnAir-Preview and click 

OK.
2 Restart Xplay.
3 Open Xplay’s Device Manager by selecting Tools>Device Manager.

The Device Configuration window appears with the available output devices already 
listed in the device table. If the desired device is not listed, refer to page 9 for 
instructions on how to add a device to the Device Manager.

4 To associate the On Air Device View with a playout device and keyer.
a In the Active Device table, click On Air to select the row.
b In the Device Configuration table, select the device that you want to playout on.

Toolbar Panel

On Air

Preview
Device View

Device View
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c Click the right-arrow button  to establish the association. 
The device is immediately added to the Active Device table. It is also added to the 
On Air Device View on the Xplay interface.

d Click the device’s Keyer column and assign a keyer value.  
The keyer value tells Xplay on which layer of the output device to playout the 
playlist element (0 is the bottom-most level).

Fig. 2-5: Connecting Xplay to an output device

5 Optional - If you want to preview and/or edit playlist items before they are taken to air, 
you can associate the Preview row in the Active Device table with an output device.

a In the Active Device table, click Preview to select the row.
b In the Device Configuration table, select the device that you want to preview the 

playout on.
c Click the right-arrow button  to establish the association. 

The device is immediately added to the Active Device table. It is also added to the 
Preview Device View on the Xplay interface.

d Click the device’s Keyer column and assign a keyer value.  
0 is the bottom-most level.

6 Optional: To configure Xplay to use a control panel asset to control and playout 
graphics on a different device or on a different keyer on the On Air device:

a In the Active Device table, click Panel to select the row.
b In the Device Configuration table, select the device that you want to control the 

playout on.
c Click the right-arrow button  to establish the association. 

The device is immediately added to the Active Device table.
d Click the device’s Keyer column and assign a keyer value.  

0 is the bottom-most level.

Step B Steps A & D

Step C
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Configuring Xplay for multi-device playout
When you want to use Xplay to control the playout on more than one output device or 
control more than one keyer on the same device, we recommend that you set Xplay’s 
Layout setting to Multi-Device. 

Fig. 2-6: Multi-Device layout’s device views and Toolbar Panel

The Multi-Device layout allows you to specify the number of playout devices or keyers to be 
controlled and then produces one Device View window in Xplay for each device channel or 
keyer. For example, if I intend for Xplay to control and playout on one dual-channel Vertigo 
XG with both channels having two keyer levels; I would set the Number of devices setting 
to 4. Consequently, this produces 4 device view windows in Xplay, which would be 
assigned to these device channels/keyers. See page 58 for more information about the 
Multi-Device layout.

Once playout devices have been added to Xplay’s Device Manager and the layout is set to 
Multi-Device, you can assign a device (channel and/or keyer) to each of the On Air and 
Preview Device Views using the Active Device table in the Device Manager.

To configure Xplay to control and playout on multiple devices and/or keyers:
1 Select Tools>Settings>General and set the Layout setting to Multi-Device.
2 On the same page, specify the number of devices and/or keyers to be controlled in the 

Number of devices setting.
3 Select Tools>Settings>Layout and set the Multi-Device Layout setting to Preview, 

OnAir or PreviewOnAir.
4 Click OK and then restart Xplay.

When Xplay reopens it displays multiple Device View windows along the right-side in 
the format specified by the Multi-Device Layout setting.

5 Open Xplay’s Device Manager by selecting Tools>Device Manager.
The Device Configuration window appears with the available output devices already 
listed in the device table. If the desired device is not listed, refer to page 9 for 
instructions on how to add a device to the Device Manager.

6 To assign an output device with a Device View:

Toolbar Panel

Device Views
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a In the Active Device table, click the <Device#> in the Name column to select the 
row.

b In the Device Configuration table, select the device that you want to assign to the 
Device View selected in the Active Device table.

c Click the right-arrow button  to establish the association. 
The device is immediately added to the Active Device table. It is also added to the 
Device View on the Xplay interface.

d Repeat the above steps for each of the device views in the Active Device table.

Fig. 2-7: Associating a device with one of Xplay’s Device Views

7 Once a device is added to the Active Device table, you can complete the remaining 
properties associated with each of the Device Views:

• Keyer: The keyer value tells Xplay on which layer of the output device to playout 
the playlist element (0 is the bottom-most level).

• Preview: (Optional) Assigns a device from the Device Configuration table to be a 
preview device. This allows you to preview the playout of a playlist item when it is 
cued and then playout on the assigned device when it is taken to air. Like an output 
device, the preview device’s name and connection status LED are displayed in the 
Device View’s toolbar.

• Show View: Determines whether or not the Device View window is appears (True) 
or is hidden (False) in the Xplay interface. When an abundance of devices are 
active, hiding certain devices from view provides more space on the Xplay 
interface for those devices that are of greater interest.

• Number of Additional Keyers: You can associate a number of additional keyers 
with a particular device. This is useful if Xplay is configured with many devices, for 

Note: By default, the device views in Multi-Device layout are named 
Device1, Device2, Device3...etc. You are not obligated to keep these 
default names. To personalize the device views by assigning them a 
new name, right-click on the Keyer State button (the device’s name in 
the Device View’s toolbar) and select the Rename command. The 
Keyer State button will now display the new name, as does the Active 
Device table in the Device Manager.

Step B

Step A

Step C
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example 20 devices with 16 keyers on each device. Xplay is not capable of 
displaying this many views simultaneously. So, you can decide to show only the 
keyer specified in the Keyer column of each device for control/interaction 
purposes and the rest will remain hidden, but be controllable by automation. Note 
that the additional keyers are accessible to all External Control functions and they 
can be referred to by name using the following format: 

<BaseKeyerName>#1 

<BaseKeyerName>#2 

... 

<BaseKeyerName>#n

8 Click the Close button on the Device Configuration window.

Connecting output devices to Xplay
Although the output devices may be properly configure and associated to the Device Views 
in Xplay’s Device Manager, you must also ensure that the Device View is actively connected 
to the output device. An active connection means that the output device is up and running 
and that Xplay is able to communicate with it.

The device’s connection status is reported using an LED on the Device View’s toolbar. 

Fig. 2-8: Whether or not a device is actively connected to a Device View is indicated by the LED

To reconnect Xplay to a device:

If Xplay is not connected or disconnects from an output device, the LED next to the device 
name turns red. You can reconnect Xplay to the output device without having to access the 
Device Manager; simply double-click the red LED. The LED turns green if a connection to 
the device is established. If the LED remains red, it means one of the following:

• The information describing the device has been entered incorrectly.
• The desired device is down.
• The network connection has been lost.

To disconnect Xplay from a device:

If desired, you can disconnect from a device and run your playlist in Xplay to ensure that all 
page information is correct. You can temporarily disconnect a device from Xplay, without 

Output Device
Name

Device View
Name

Connection LED
Green = Connected
Red = Disconnected
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removing the device from the Device Manager; simply right-click on the device’s LED and 
select the Disconnect command (the green LED turns red). 

Note: You can change the default name of the Device View (i.e. 
Device1) to something more descriptive by right-clicking on the 
Device View’s name in the toolbar and selecting the Rename 
command. When the name becomes editable, type the new name 
and press Enter. The name change will also be automatically be 
applied to the Device Manager’s Active Device table.
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Creating and editing playlists in Xplay
Xplay’s Playlist Editor allows you to build and edit playlists by adding playlist elements (i.e. 
pages, templates and clips) to the tabular list and organizing them into the order in which 
they are intended to be taken to air. Playlists built in Xplay are typically designed to be 
manually played back sequentially by operator control using Xplay.

Fig. 3-1: Xplay’s Playlist Editor in Standard playlist view

Each row in playlist represents a single playlist element, while the columns display 
properties associated with the playlist item (some of which can be edited directly in the 
Playlist Editor). Since some playlists can get quite long, you can also organize playlist 
elements into thematic segments, as well as insert comment rows to provide information or 
instructions to the operator controlling the playout of the playlist.

The following sections provide information and instructions for how to create and edit 
playlists in Xplay:

• Setting the Playlist Editor’s Playlist View, on page 20
• Creating a new playlist, on page 22
• Loading an existing playlist, on page 23
• Navigating and selecting elements within the playlist, on page 25
• Adding playlist elements to a playlist, on page 26
• Grouping elements into playlist segments, on page 34
• Adding comment rows to the playlist, on page 40
• Repositioning playlist elements within the playlist, on page 41
• Repositioning playlist elements within the playlist, on page 41
• Deleting playlist elements, on page 50
• Reloading the playlist, on page 50
• Saving the playlist, on page 51
 19
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Setting the Playlist Editor’s Playlist View
The appearance and functionality of Xplay’s Playlist Editor differs depending upon the 
Playlist View setting (Tools>Settings>Layout>Playlist view). As such, before create a new 
playlist or load an existing playlist in the Playlist Editor, we recommend that you first select 
an appropriate playlist view.

• None
• Standard
• ByDevice

None
When Xplay’s Playlist view setting is set to None, the Playlist Editor is not displayed in the 
Xplay window and playlists cannot be manually loaded or displayed. This setting is used 
primarily when Xplay is controlled through automation. See page 73 for more information 
about controlling Xplay using automation protocols.

Standard
When Xplay’s Playlist view setting is set to Standard, the loaded playlist is displayed in the 
Playlist Editor as a single list, showing all of its elements in the order in which they were 
saved, positioned, or are intended to be sequentially played out. 

The Playlist Editor’s global Cue and Take buttons are available in Standard view and let you 
to manually control the timing of when the playlist elements appear on air. 

Unlike the ByDevice view, Standard view can be used to control the playout on a single 
device, or on multiple devices. See page 53 for information and instructions on using 
operator controlled playout techniques.

Fig. 3-2: The Playlist Editor in Standard playlist view

Playlist elements are
ordered sequentially

Playout controls
20



Xplay
User Manual
ByDevice
Xplay’s ByDevice playlist view allows the Playlist Editor to display a playlist’s elements by 
device groupings rather than one sequential playlist. This makes it easier to identify and 
control the playlist elements that will be played out on specific devices.

Fig. 3-3: ByDevice playlist view groups playlist elements into device playlists

When a single playlist is loaded into the Playlist Editor in ByDevice playlist view, the 
sequential playlist is broken down into multiple playlists, one for each of the devices 
associated with Xplay. The playlist elements are then sorted into the device playlists 
according to the element’s Target Device property, which is set in Xstudio when the asset’s 
template is created. If the template’s Target Device property was not specified (empty), 
then the asset is appended to the first device’s playlist. You can then reposition it within its 
device view, however, you cannot move it to another device’s playlist (see page 41).

As demonstrated by how playlist elements are sorted into device playlists, the Playlist 
Editor behaves differently in ByDevice view than in Standard view. Rather than list the 
differences here, they are described in context throughout this user manual within the 
context of procedural descriptions. 

Note: In ByDevice view, the device’s playlist is shown opposite the 
Device View for the corresponding device. Each list only shows those 
elements that target the associated device. When a device is 
deactivated from the Device Manager’s Active Device table (see 
page 17), both the device’s view and playlist will be removed from the 
Xplay window.

Playlist for Device 1

Playlist for Device 2

Playlist for Device 3

Playlist for Device 4
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Creating a new playlist
To create a new playlist, you must first open a new, empty playlist. If the Playlist Editor area 
is already occupied by another playlist, performing the Create New Playlist action 
(described below) immediately clears the Playlist Editor and a blank playlist appears, ready 
for use. 

To create a new playlist:
• Select File>New Playlist.

Or,
• Press the Create New Playlist button  in the Playlist toolbar. 

Or,
• Press the Ctrl+N keyboard shortcut

Fig. 3-4: A newly created playlist in ByDevice playlist view

Note: The Playlist Editor’s layout depends upon Xplay’s Playlist View 
setting, which can be set to None, Standard, or ByDevice. If the Playlist 
Editor does not appear or it opens in an unwanted layout, see page 25 
for information regarding changing the Playlist View setting.

New, empty playlist
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Loading an existing playlist
When Xplay is in the Standard playlist view and a playlist is loaded into the Playlist Editor, 
the playlist appears as one sequential list of playlist elements. However, when Xplay is in 
the ByDevice playlist view and a playlist is loaded, the playlist splits up its elements into 
sub-playlists that contain elements that target each of the devices configured in Xplay. 
Note that in order to effectively split the playlist into device playlists, Xplay is forced to 
impose some restrictions, which are described below.

Fig. 3-5: Playlists that are loaded in ByDevice playlist view are organized differently than in Standard 
view

There are two (2) methods for loading an existing playlist into the Playlist Editor:
• Select the Playlists root category in the Asset Browser, and navigate to the appropriate 

category where the playlist is stored.
• Double-click the desired playlist in the Asset Browser.

Or,
• Right-click on the playlist ‘s name in the Asset Browser and select the Open 

command from the context menu.
The playlist opens in the Playlist Editor.

• Select File>Open Playlist, or the Ctrl+O keyboard shortcut. 
The Open Playlist dialog box appears.

• Navigate through the Playlist categories in the right panel until the desired playlist 
is listed in the left panel.

• Double-click the desired playlist listed in the right panel.
Or, 

• Select the playlist and then click OK.
The playlist opens in the Playlist Editor.

The following behaviors pertain to how existing playlists are treated when they are loaded 
into the Playlist Editor when it is set to ByDevice playlist view:

Playlist elements organized by target device
ByDevice playlist view

Playlist elements organized into one sequential list
Standard playlist view
23



Creating and editing playlists in Xplay
Loading an existing playlist
• Only the elements that target the device are displayed in the playlist for each device. 
Elements whose target device does not match any device name will be played in the 
playlist for the first device.

• Secondary elements in clips are removed from the playlist when the playlist is loaded in 
the ByDevice layout. The following message in the Message Log window confirms that 
the secondary elements were removed.

“The playlist contained secondary elements in clips that were 
removed on...”

• All empty segments and/or a comment rows are removed from the playlist when the 
playlist is loaded.

• When a playlist segment contains elements which target more than one device, the 
segment and its elements are displayed in each of the relevant devices.

• Use the Device Manager to show/hide views and their associated playlist. 

Fig. 3-6: Playlist elements are organized per assigned device in ByDevice playlist view

Segment’s elements
split per device

Device1 elements and
all unassigned elements

Device2 elements only

Device3 elements only

Device4 elements only
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Playlist element verification
When the Verify Playlist setting is enabled, each element in the playlist is verified when the 
playlist is loaded into the Playlist Editor to ensure that it is available and ready for use. 

Each element in the playlist is verified as follows:
• Checks if the asset used by the playlist element actually exists.
• Checks if the assets that are used by the playlist element require the completion of a 

Work Order before they can be used.
• Checks if the assets used by the playlist element are published on a specified device. If 

not, then it initiates the publishing of the assets.

The results of the verification are displayed in the Status column for each element in the 
playlist. 

Fig. 3-7: When the Verify Playlist setting is enabled, each element’s status is verified upon loading

Navigating and selecting elements within the playlist
When Xplay is in Standard playlist view, a loaded playlist appears in the Playlist Editor as 
one sequential list of playlist elements, and you can navigate and select freely within the 
playlist. 

When Xplay is in the ByDevice playlist view, the playlist splits up its elements into sub-
playlists that contain elements that target each of the devices configured in Xplay. As such, 
you are only permitted to select within one of the device’s playlists at a time. In other words, 
if elements are selected in the playlist for device1 and then you click on an element in 
device2, the selection is cleared in the playlist for device1.

Navigating within a playlist
While the most common way to select an element and navigate within a playlist is to 
perform a left-mouse click on the element, you can also use the following keyboard 
functions to navigate within the playlist:

• Up/Down arrow keys: Selects the element above or below the currently selected 
element within the playlist.

• Page Up/Down keys: When in Standard view, they select the first or the last element in 
the entire playlist. When in ByDevice view, they select the first or the last element in the 
selected device’s playlist.

• Home/End keys: When in Standard view, they select the first or the last element in the 
entire playlist. When in ByDevice view, they select the first or the last element in the 
selected device’s playlist.

Note: Information and instructions regarding repositioning playlist 
elements within the playlist are provided on page 41.
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Grouping a selection of playlist elements
You may want to group a selection of playlist item as to drag & drop the grouped elements 
to a different location or to delete a grouping of items all at once.

Selecting consecutive playlist elements: 

Select the first element that you want to be included in the grouping. While holding down 
the SHIFT key, select the last element from the playlist. The first, last, and all elements 
between these two become selected forming the group of elements.

Selecting non-consecutive playlist elements:

Select the first element that you want to be included in the grouping. While holding the 
CTRL key, click on each individual element that you want to be included in the grouping.

Adding playlist elements to a playlist
Xplay allows you to create and populate playlists by adding individual graphic pages, 
templates and clip assets to a playlist loaded in the Playlist Editor. Xplay also allows you to 
append or insert the entire contents of an existing playlist or segment to a loaded playlist.

The following sections provide instructions for the various ways in which you can populate 
a playlist in Xplay:

• Using the Asset Browser to add pages, templates and clips to a playlist, on page 27
• Using Quick Recall to add templates, clips and pages to a playlist, on page 28
• Using Search XMS to find and add pages, template or clips to a playlist, on page 30
• Inserting or appending a playlist to a loaded playlist, on page 31
• Adding shared segment assets to a playlist, on page 33

Selecting non-consecutive playlist elementsSelecting consecutive playlist elements

Note: Additional instructions for creating and adding embedded and 
shared pages to a playlist are provided in Creating and editing pages 
in Xplay, on page 119.
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The Pages, Templates, and Clips root categories in Xplay’s Asset Browser provide access to 
all of the shared pages, templates, and clips that are stored on the Xmedia Server. As such, 
the Asset Browser is a practical tool for finding and adding these assets to the playlist. 

To add a shared page, template or clip asset to a playlist using the Asset Browser:

The most common way to add shared pages, templates, or clips to a playlist using the Asset 
Browser is to drag the asset from the Asset Browser and drop it into the playlist.

Regardless of whether Xplay is in the Standard or ByDevice playlist view, when you drag an 
asset from the Asset Browser into the playlist, the Insert Line identifies exactly where the 
asset will be placed within the playlist. A fully extended Insert Line indicates that the 
playlist will be added as a primary event, while a partially extended line indicates that it will 
be added as a secondary event.

Normally when Xplay is in ByDevice playlist view, it is the asset’s Target Device that 
determines in which device playlist the asset will be placed. However, when you drag and 
drop an asset into a device’s playlist, the asset’s original Target Device setting is overridden 
and it assumes the new device as its target device. 

Also note that once the page is dropped into the device’s playlist, you cannot move it to 
another device’s playlist.

Additional ways to add shared pages to a playlist using the Asset Browser:

There are two (2) additional ways in which shared pages assets can be added to a playlist 
using the Asset Browser:

• Double-click the page’s heading in the Asset Browser category.

Or, 
• Right-click on the page’s heading in the Asset Browser category and select the Open 

command.

Fig. 3-8: There are three ways to add a shared page to a playlist from the Asset Browser

When Xplay is in the Standard playlist view and you add a shared page by double-clicking 
or using the Open command, the page is appended to the end of the playlist loaded in the 
Playlist Editor. You can then reposition it within the playlist by following the instructions on 
page 42.

1. Double-click
Or,

2. Open command
Or,

3. Drag & Drop
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When Xplay is in the ByDevice playlist view and you add a shared page by double-clicking 
or using the Open command, the new shared page is immediately appended to the device 
playlist as assigned by the template’s Target Device property, which is set in Xstudio when 
the template is created. If the template’s Target Device property was not specified (empty), 
then the page is appended to the first device’s playlist. You can then reposition it within its 
device view, however, you cannot move it to another device’s playlist. 

Using Quick Recall to add templates, clips and pages to a playlist
Templates, clips and shared pages contain a property called a Recall ID, which is a unique 
alpha-numeric value that is assigned by users to identify the specific asset. The Recall ID 
property can be set either when the asset is saved for the first time or by accessing and 
editing its properties in Xstudio, Xbuilder, or Xplorer. 

The purpose of assigning a Recall ID to a template, clip or shared page asset is to be able to 
quickly add the asset to a playlist in Xplay by simply using its Recall ID value, rather than 
manually searching and adding it yourself. Additionally, the Recall ID also allows you to 
quickly cue and/or take the asset to a device using Xplay.

To use Xplay’s Quick Recall functionality, you must first enable Quick Recall by selecting the 
View>Quick Recall command. Then Xplay must either be set to ByDevice playlist view or 
Standard playlist view with Manual playout mode enabled, for the Quick Recall field to 
appear in the lower portion of the Xplay interface. 

The following sections describe how you can quickly added a template, clip or shared page 
asset to a playlist using Xplay’s Quick Recall field: 

• Adding a page/template/clip to a playlist in Standard playlist view, on page 28
• Adding a page/template/clip to a playlist in ByDevice playlist view, on page 29
• Adding a page/template/clip to a playlist and cueing it to a device, on page 29

Adding a page/template/clip to a playlist in Standard playlist view

To add a template, clip or shared page asset to the playlist when Xplay is set to Standard 
playlist view:

1 Determine where you want to place the asset within the playlist by selecting the 
playlist element above the location where you want to insert the asset.

2 Type the asset’s Recall ID in the Quick Recall text box and press the + (plus) keyboard 
key. 
The asset is immediately added below the playlist element that was selected. If no 
playlist element was selected in the playlist, the asset is appended to the end of the 
playlist.
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Adding a page/template/clip to a playlist in ByDevice playlist view
When Xplay is set to ByDevice playlist view, the asset’s Target Device property primarily 
determines in which device’s playlist the asset will be added. If no Target Device is 
associated with the asset, then the asset is added to the first device’s playlist.

Meanwhile, where within the device’s playlist the asset is added depends upon if a playlist 
element is selected, and whether the selection is inside or outside of the Target Device’s 
playlist.

To add a template, clip or shared page asset to the playlist when in ByDevice playlist 
view:

1 Determine where you want to place the asset within the target device’s playlist by 
selecting the playlist element above the location where you want to insert the asset.
Note: Since you cannot set the target device on a clip asset, a clip will always default to 
the first playlist.

2 Type the asset’s Recall ID in the Quick Recall text box and then press the + (plus) 
keyboard key.
The asset is immediately added below the playlist element that was selected in the 
target device’s playlist. If no playlist element was selected, the asset is appended to the 
end of the target device’s playlist. If the selection was outside of the target device 
playlist or the asset does not have an assigned target device, the asset is appended to 
the first device’s playlist.

Adding a page/template/clip to a playlist and cueing it to a device
Xplay’s Quick Recall feature not only offers the ability to add a template, clip or shared page 
asset to the playlist loaded in the Playlist Editor, but also to then immediately cues the asset 
on a device.

Note that the asset’s Target Device property primarily determines which device view the 
asset will be cued on, as well as which device’s playlist the asset will be added to when 
Xplay is set to ByDevice playlist view. Meanwhile, where within the playlist the asset is 
added depends upon whether or not the target device already has a playlist element cued 
on it.

To add a template, clip or shared page asset to a playlist and cue it on a device:
• Type the asset’s Recall ID in the Quick Recall text box and then press Enter.

One of the following occurs:
• If nothing was already cued on the playlist corresponding to the target device, then 

the asset is inserted after the last aired element and then cued on the device.
• If an element was already cued on the playlist corresponding to its target device, 

then the asset is be inserted before the cued element and cued in its place. 
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Using Search XMS to find and add pages, template or clips to a playlist
Xplay’s Search XMS allows you to quickly find and add shared pages, templates, or clips to a 
playlist that is currently loaded in Xplay’s Playlist Editor. 

Selecting the View > Search menu opens the Search XMS window, which allows you to 
quickly search for assets stored on the Xmedia Server. Once a search is launched, assets that 
match the name, type, description, author, keywords and/or Recall ID are displayed as 
thumbnails in Proxy View or listed in a table in Detail View.

To search for assets stored on the Xmedia Server:
1 Select View > Search to open Search XMS window.
2 Type a search query in the Search XMS text box. 
3 Optional: Limit Search XMS results to specific asset types. 

By default, all asset types are evaluated by the search query as indicated by the Type 
drop-down box set to All Types. 

• To limit the search results to one asset type, select an asset type from the Type 
drop-down list. 

• To limit the search results to multiple asset types, click the Browse  button to 
open the Select Types To Search dialog. Select the asset types that you want 
included in the search and uncheck the asset types that you want excluded from 
the search results.

4 Click the  button to launch the search.
Assets that satisfy the search query are displayed in the results pane of the Search XMS 
window. 

5 Browse the results and select an asset of interest. 
• Right-clicking on an asset exposes menu commands that allow you to rename or 

delete the asset.
or,

• Add a Template, Page or Clip by dragging an asset from the search results onto a 
playlist open in Xplay.

Note: The Search XMS window uses Solr, which a web-based solution 
by the Apache group that performs fast searches across large 
amounts of data. The Xmedia Server must maintain a connection to 
Solr so that it can create an index of the database. See the Xmedia 
Server Configuration Guide for more information.

Note: If an expected asset is not returned in the search results, it may 
be because user rights management is enabled on the Xmedia Server 
and the current user does not have permission to view the asset. See 
“User Rights Management” in the Xmedia Server Configuration Guide 
for more information.
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Inserting or appending a playlist to a loaded playlist
When Xplay is set to Standard playlist view, you can add the entire contents of an existing 
playlist (i.e. pages, templates, clips, segments, and comments) to a playlist. This avoids 
having to recreate the contents of a playlist that already exists.

As described below, there are four (4) ways to add the contents of an existing playlist assets 
to a playlist:

• Drag and drop the playlist asset from the Asset Browser into the Playlist Editor.
• Use the Append Playlist command.
• Use the Insert Playlist command.
• Use the Search Tool to locate the playlist asset and then drag it into the loaded playlist.

To add the contents of an existing playlist to a playlist by dragging and dropping the 
playlist asset:

1 Be sure that Xplay is set to Standard playlist view.
2 Select the Playlists root category in the Asset Browser, and navigate to the appropriate 

category where the playlist asset is stored.
3 Select the desired playlist asset and drag it into the Playlist Editor.

Notice that a highlighted Insert line appears in the Playlist Editor as you drag the 
pointer over the various rows in the playlist. This line indicates the location of where 
the playlist will be inserted in the playlist.

4 Drop the playlist asset into the playlist by releasing the mouse button.
The entire contents of the playlist asset is added immediately to the playlist, including 
all pages, templates, clips, segments, and comments that were contained in the playlist 
asset.

To add the contents of an existing playlist to a playlist using the Append Playlist 
command:

1 Be sure that Xplay is set to Standard playlist view.
2 With the playlist that you want to add to open in the Playlist Editor, select the 

File>Append Playlist menu command.
The Append Playlist dialog box appears.

3 Navigate through the Append Playlist dialog box and select the playlist asset that you 
want to add (append) to the end of current playlist.

4 Click OK, or double-click the playlist’s asset name in the Append Playlist dialog box.

Note: The ability to insert and append playlists is only available when 
Xplay is set to Standard playlist view. When Xplay is set to ByDevice 
playlist view, both the Append playlist and Insert playlist commands 
are disabled and you cannot drag and drop a playlist asset into the 
playlist.

Note: A fully extended Insert Line indicates that the playlist will be 
added as a primary event, while a partially extended line indicates 
that it will be added as a secondary event.
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The entire contents of the playlist asset is added immediately to the bottom portion of 
the playlist, including all pages, templates, clips, segments, and comments that were 
contained in the playlist asset.

To add the contents of an existing playlist to a playlist using the Insert Playlist 
command:

1 Be sure that Xplay is set to Standard playlist view.
2 With the playlist that you want to add to open in the Playlist Editor, select the playlist 

row where you want the contents of the playlist to be inserted (the contents will be 
inserted below the selected row).

3 Select the File>Insert Playlist menu command.
The Insert Playlist dialog box appears.

4 Navigate through the Insert Playlist dialog box and select the playlist asset that you 
want to add (insert in) to the end of current playlist.

5 Click OK, or double-click the playlist’s asset name in the Insert Playlist dialog box.

The entire contents of the playlist asset is added immediately below the selected playlist 
row, including all pages, templates, clips, segments, and comments that were contained in 
the playlist asset.

To add the contents of an existing playlist to a playlist using the Search Tool:
1 With the playlist loaded in the Playlist Editor, open Xplay’s Search Tool by selecting the 

View>Search menu command. The Search window appears.
2 Select Playlist from the Type drop-down list.
3 Create a search profile by setting as many or as few of the search properties.
4 Click the Search button.

The playlist assets that meet the search profile are listed/displayed in the Search 
Window’s results area.

5 Select the desired asset from the results area and drag it over to the Playlist Editor.
Note that as you drag the mouse’s pointer over the playlist, an Insert Line appears 
within the playlist rows to indicate the location of where the asset will be inserted.
Once you have placed the Insert Line is the desired location, release the left mouse 
button to drop the asset into the playlist.
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Adding shared segment assets to a playlist
Adding a shared segment to a playlist in Xplay is a convenient way of adding an existing 
grouping of embedded pages, shared pages and/or clips to a playlist.

Shared segments are stored on the Xmedia Server and are accessible to Xplay through the 
Asset Browser’s Segments root category. Despite being created in Xbuilder and intended to 
be used in Rundowns, shared segments are essentially a thematic grouping of embedded 
pages, shared pages and/or clips. As such, shared segments can be added to a playlist in 
Xplay. 

Fig. 3-9: Segments are groupings of pages and clips

To add a shared segment to a playlist:
1 Be sure that Xplay is set to Standard playlist view.
2 Select the Segments root category in the Asset Browser, and navigate to the 

appropriate category where the segment asset is stored.
3 Select the desired segment asset and drag it into the Playlist Editor.

Notice that a highlighted Insert line appears in the Playlist Editor as you drag the 
pointer over the various rows in the playlist. This line indicates the location of where 
the segment will be inserted in the playlist.

4 Drop the segment asset into the playlist by releasing the mouse button.
The entire contents of the segment asset is added immediately to the playlist, including 
all pages, clips and comments that were contained in the segment asset.

Note: Shared segments are only permitted to be added to a playlist 
when Xplay’s Playlist view setting is Standard. Xplay will not allow you 
to add shared segment asset to a playlist when Xplay’s Playlist view 
setting is ByDevice.
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Grouping elements into playlist segments
When Xplay is in Standard playlist view, you can add playlist segments (sometimes called 
embedded segments) into your playlists to group together related playlist elements under 
common headings. This allows you to:

• See at a glance how items in a playlist have been organized thematically 
(e.g. Headlines, Sports, Business, Entertainment).

• Move the contents of a segment all at once. This is useful if, for example, at the last 
minute you decide that the pages organized under Business should be placed before 
the Sports segment.

Fig. 3-10: Playlist segments allow you to put pages, templates and clips into thematic groupings

When Xplay is in ByDevice playlist view, you are not permitted to add new playlist 
segments to a device’s playlist (the Add Segment commands are disabled). However, if a 
playlist is loaded into the Playlist Editor that contains playlist segments, the following 
behaviors occur:

• If the playlist segment contains elements that all target the same device, the segment 
and its elements are all displayed within the device’s playlist.

• If the playlist segment contains elements which target more than one device, the 
segment and its elements are split up and displayed in each of the relevant devices.

• All empty playlist segments are removed from the playlist when the playlist is loaded.
• You can only reposition a playlist segment and its elements within its own target device 

playlist.

The following sections provide instructions for adding and managing playlist segments:
• Adding and populating playlist segments, on page 35
• Repositioning playlist segments and their elements, on page 37
• Deleting playlist segments from a playlist, on page 38

Note: Playlist segments are different from the shared segment assets 
that are listed in the Asset Browser’s Segments root category. Shared 
segment assets are stored on the Xmedia Server and made available 
in the Asset Browser for creating rundowns, while playlist segments 
are only available to the playlist in which they are a part of.
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When Xplay is in Standard playlist view, you can add playlist segments (sometimes called 
embedded segments) into your playlists to group together related playlist elements under 
common headings.

To add a segment to the playlist:
1 Be sure that Xplay is set to Standard playlist view.
2 Load a playlist into the Playlist Editor, or create a new playlist and add the necessary 

pages, templates and/or clips.
3 Select the playlist row where you want the segment to be inserted (the segment 

heading will be inserted above the selected row).
4 Right-click on the row and select the Add Segment command from the context menu 

that appears. 
The segment heading is added above the selected row with the name open for editing.

Fig. 3-11: Use the Add Segment command to insert a segment heading into the playlist

5 Enter a name for the segment and press ENTER. 
At this point the segment is empty, even if pages, templates, or clips appear to be 
beneath it. You now need to add items to the segment.

Fig. 3-12: Segment heading has been added, but it is still empty
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6 Click and drag the selected playlist element into the desired segment. As you drag, a 
Insert Line indicates where the element will be placed. Before you drop it, take note of 
the following:

• Whether or not the segment heading changes color. If the segment heading does 
change color, the element will become part of the segment. If it does not, then the 
element will be placed outside of the segment.

• The length of the insert line (red by default). If the insert line runs the entire width 
of the playlist, then the element is being moved outside the segment. If the line 
shortens, it means that the element is being moved into the segment (see below).

• Blue box: Once elements have been added to a segment, they are bordered at left 
by a blue box (see below).

When the insert line is fully extended, the element will be moved outside of the segment.

When the insert line is not fully extended and the border changes color, the element will be inserted into the segment.
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Repositioning playlist segments and their elements
The instructions on page 34 explain how to add playlist segments (sometimes called 
embedded segments) to your playlists to group together related playlist elements under 
common headings. 

Fig. 3-13: Playlist segments help organize playlist elements into thematic groupings

Not only does grouping playlist elements within segments improve the organization of the 
playlist, it also allows you to move or reposition the contents of a segment all at once. This is 
useful if, for example, at the last minute you decide that the pages organized under 
Business should be placed before the Sports segment.

To reposition a segment row within a playlist:
1 Select the segment’s heading row. 

The segment and all of the elements that belong to the segment are highlighted.
2 Click and drag the selected segment to the desired playlist row. 

As you drag, an insert line (red line by default) extends across the table, which indicates 
where the segment will be placed (figure Figure 3-14 on page 37). 

Fig. 3-14: Drag the segment and its elements to a new location within the playlist

3 Release the mouse button to drop the item in its new location.

Note: In ByDevice playlist view, you can reposition a segment within 
its own device playlist, but you cannot move it to another device’s 
playlist. Also, note that repositioning a segment in one device playlist, 
also repositions the equivalent segments in the other device playlists.

Segment 1

Segment 2
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Deleting playlist segments from a playlist
When Xplay is in Standard playlist view, deleting a playlist segment and its elements from a 
playlist is pretty straightforward. However, when Xplay is in ByDevice playlist view, the 
segment’s elements might be targeting several devices, which changes the deletion 
procedure slightly (see below).

When Xplay is in Standard playlist view and you want to delete a playlist segment: 
1 Select the segment’s heading row. The segment and all of the elements that belong to 

the segment are highlighted.
Or,
Select all of the elements within the playlist segment.

2 Right-click on the segment and select the Delete command.
Or,
Press the Delete key on your keyboard.

3 The Confirm Delete dialog box appears. Select Yes to immediately delete the segment 
and its elements from the playlist, or select No to cancel the delete action.

Fig. 3-15: Use the Delete command (or the Delete keyboard key) to delete a playlist segment

Note: Please refer to Deleting playlist elements, on page 50 if you only 
want to delete a single element within a playlist segment (i.e. a page, 
clip or comment).
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When Xplay is in ByDevice playlist view and you want to delete a playlist segment: 

As is described on page 23, when a playlist is loaded into the Playlist Editor that contains a 
playlist segment whose elements target more than one device, the segment and its 
elements are displayed in each of the relevant devices. As a consequence of splitting the 
segments into different playlists, the segment in each device’s playlist becomes 
independent of the others. This means that you can delete a segment in one device playlist 
without affecting the segment in another device’s playlist.

Fig. 3-16: The elements within a segment are distributed to their target device’s playlist

1 Select the segment’s heading row. The segment and all of the elements that belong to 
the segment in that device playlist are highlighted.
Or,
Select all of the elements within the playlist segment.

2 Right-click on the segment and select the Delete command.
Or,
Press the Delete key on your keyboard.

3 The Confirm Delete dialog box appears. Select Yes to immediately delete the segment 
and its elements from the playlist, or select No to cancel the delete action.

Note: To delete the entire segment from each of the device playlists, 
you must repeat the above procedure in each of the device playlists.

The “Financial” segment’s

Device Playlist 1

Device Playlist 2

Device Playlist 3

Device Playlist 4

elements are distributed
to their target devices
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Adding comment rows to the playlist
When Xplay is in Standard playlist view, you can annotate your playlist by adding comment 
rows. Your comments should be concise, yet identify the purpose or behavior of elements 
in your playlist.

To add comments to the playlist:
1 Be sure that Xplay is set to Standard playlist view.
2 Load a playlist into the Playlist Editor, or create a new playlist and add the necessary 

pages, templates and/or clips.
3 Select the playlist row where you want the comment to be inserted (the comment will 

be inserted above the selected row).
4 Right-click on the row and select the Add Comment command from the context menu 

that appears. 
The comment row is added above the selected row with the text ready for editing.

5 Type the text for the comment and press ENTER. 

To edit the text of a comment row that is already inserted into the playlist:
1 Select the comment row who’s text is to be edited.
2 Right-click on the row and select the Edit Cell command from the context menu that 

appears. The comment row text becomes ready for editing.
3 Type the new text for the comment and press ENTER.

Note: Comment rows can only be added to a playlist when Xplay is in 
Standard playlist view. When Xplay is in ByDevice playlist view, the 
Add Comment command is disabled thereby not allowing you to add 
comment rows to the device playlists. Similarly, when a playlist that 
contains comment rows in loaded into Xplay’s ByDevice playlist view, 
the comment rows are not displayed.
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Repositioning playlist elements within the playlist
Pages and clips are added to playlists as primary scheduled events. Once added to the 
Playlist Editor, you can reposition these elements within the playlist by dragging and 
dropping them to the desired row location. In Standard playlist view, you can move an 
elements to any location within the playlist. In ByDevice playlist view however, you can 
reposition an element within its own device playlist, but you cannot move it to another 
device’s playlist. 

When a clip is a primary event in the playlist, you can reposition pages within the playlist to 
become secondary events to the clip. Making a page a secondary event to a clip allows you 
to set the page’s offset and duration with respect to the clip (primary event), rather than to 
the beginning of the playlist.

The following sections provide instructions for repositioning items within the playlist:
• Repositioning primary playlist elements (clips, pages or comments), on page 41
• Adding secondary elements to a clip in the playlist, on page 42

Repositioning primary playlist elements (clips, pages or comments)
To reposition a playlist elements:

1 Select the playlist element that you want to move to a new location.
2 Click and drag the selected playlist element into the desired playlist row. 

As you drag, an insert line (red line by default) extends across the table, which indicates 
where the item will be placed. 

3 Release the mouse button to drop the item in its new location.

Fig. 3-17: Drag and drop the playlist element to the desired row location

Note: In ByDevice playlist view, you can reposition an element within 
its own device playlist, but you cannot move it to another device’s 
playlist.
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Adding secondary elements to a clip in the playlist
Making a page a secondary event to a clip allows you to set the page’s offset and duration 
with respect to the clip (primary event), rather than to the beginning of the playlist. 

To add a secondary event (page) to a primary event (clip):
1 Add a clip to the playlist as a primary event by dragging the clip asset from the Asset 

Browser and dropping it into the desired location in the playlist.
2 Add a page to the playlist as a secondary event to the clip by dragging the page asset 

from the Asset Browser to the row below the clip’s name in the playlist. 
Before you drop it, take note of the following:

• Whether or not the primary event heading changes color. If the primary event 
heading changes color, the page will become a secondary event. If it does not, then 
the element will be placed below the primary event as an additional primary event.

• The length of the insert line (red by default). If the insert line runs the entire width 
of the playlist, then the page is being moved outside the primary event. If the line 
shortens, it means that the page will become a secondary event (see below).

• Blue box: Once page has been added to the primary event, it is bordered at left by 
a blue box (see below).

3 Drop the page into the playlist by releasing the mouse button.

Note: Secondary elements can only be added to a playlist and shown 
in playlists when Xplay’s Playlist view is set to Standard. When Xplay is 
in ByDevice playlist view, secondary elements are not permitted to be 
added to a playlist. As well, secondary elements are removed from the 
playlist when the playlist is loaded in the ByDevice layout and the 
following message in the Message Log window confirms that the 
secondary elements were removed. 
“The playlist contained secondary elements in clips that were 
removed on...”

Note: To make a page that already exists as a primary event in the 
playlist a secondary event of a clip in that same playlist, simply drag 
the page from its current location to the row under the clip in the 
same way that is described in step 2 and 3 above.

A fully extended insert line adds the page as a primary object

A partially extended insert line adds the page as a secondary object to the primary object
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Configuring and editing the playlist columns
Each row in playlist represents a single playlist element, segment heading or comment; 
while the columns display properties associated with the playlist item. 

Which columns are displayed in the Playlist Editor can be configured using the Column 
Layout dialog box. As well, you can also edit several of the properties associated with the 
playlist items from within the Playlist Editor.

• Configuring the Playlist Editor’s column layout, on page 43
• Editing a playlist element’s properties, on page 47

Configuring the Playlist Editor’s column layout
The Column Layout dialog box allows you to configure which columns are displayed or 
hidden in the playlist. You can also determine the order in which the columns appear in the 
playlist.

Column headings that are currently displayed in the playlist are listed in the Selected 
Columns text box (on the right), while hidden column headings are listed in the Available 
Columns text box (on the left). Customizing the playlist column means simply moving the 
headings from on side to the other (see the instructions below). The Column Layout dialog 
box conveniently also offers two (2) standard layouts: Basic and Full.

The following sections explain how to customize the playlist’s columns:
• Adding columns to a playlist, on page 43
• Removing columns from a playlist, on page 44
• Creating, renaming, and deleting your custom column headings, on page 44
• Reordering the columns in a playlist, on page 45
• Using the standard column layouts: Basic or Full, on page 45

Adding columns to a playlist

Complete the following steps to add one or many columns to a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select the desired column heading(s) from the Available Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Right Arrow  button.
The selected column headings immediately move to the Selected Columns text box.

4 Click Apply to implement the changes immediately to the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
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Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Removing columns from a playlist

Complete the following steps to remove one or many columns from a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select the desired column heading(s) from the Selected Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Left Arrow  button.
The selected column headings immediately move to the Available Columns text box.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Creating, renaming, and deleting your custom column headings
To better reflect the particular contents of your playlist, the Column Layout dialog box 
allows you to create your own (user defined) column headings. Once it has been created, 
you can also rename the column heading or delete it from the Column Layout dialog box 
by right-clicking on the name and selecting either the Rename or Delete command from 
the context menu.

To create a custom playlist column heading:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears.
2 Click the Add button.

The Add Column dialog box appears.
3 Type the name of the new column in the text box and click OK.

The new column heading’s name immediately appears in the Selected Columns text 
box on the Column Layout dialog box.

4 Click Apply to immediately add the new column to the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,

Note: Only custom column headings can be renamed and deleted 
from the Column Layout dialog box.
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Click OK to immediately add the new column to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Reordering the columns in a playlist
The order in which the column appear in the Playlist Editor is determined by the column 
heading’s position in the 

Complete the following steps to reorder one or many columns in a playlist:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in order 
the Selected Columns text box.

2 Select the column heading(s) that you want to move to another position from the 
Selected Columns text box.
The column heading’s name is highlighted in blue when it is selected. To deselect, 
simply click the heading again.

3 Click the Up Arrow  button once for each position that you want to move the 
column to the left in the playlist.
Or, 
Click the Down Arrow  button once for each position that you want to move the 
column to the right in the playlist.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.

Using the standard column layouts: Basic or Full
The Column Layout dialog box offers two (2) preset standard layouts:

• Basic - Includes only the Name, Device and Status columns.
• Full - Includes all columns.

These standard layouts are convenient ways of populating or removing columns from the 
Playlist Editor.

To select a standard layout playlist format:
1 Select Tools>Configure Playlist Columns.

The Column Layout dialog box appears. The current playlist columns are listed in the 
Selected Columns text box, while hidden column headings are listed in the Available 
Columns text box.

2 Select either Basic or Full from the Standard Layout drop-down list.
3 Click the Select button.
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The Selected Columns and Available Columns text boxes are immediately 
appropriately populated.

4 Click Apply to implement the changes immediately in the playlist, while keeping the 
Column Layout dialog box open for further edits to the playlist columns.
Or,
Click OK to implement the changes immediately to the playlist and close the Column 
Layout dialog box.
Or, 
Click Cancel to abort the changes and maintain the playlist as it was.
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Editing a playlist element’s properties
When a playlist is loaded in the Playlist Editor, you can change certain properties that 
belong to playlist elements. The following table defines the property/column and explains 
how to edit each playlist column.

Playlist column Definition and how to edit the playlist element’s property

Description Displays a user provided text that describes the playlist item. The 
description text is originally created by filling in the Description field on 
the Save dialog box when the item is originally saved as an asset.
• Shared pages & Embedded pages: You can edit a page’s Description 

property by right-clicking the element in the playlist and selecting the Edit 
Page command. The Edit Page window allowing you to edit the page’s 
Description field. Then, you must click the Commit and Close button 
(embedded page) or the Save Page, and Close button (shared page) to apply 
the change and close the Edit Page window.

• Templates: You cannot edit the Description property of a template from within 
the playlist.

• Clips: You can change the Description property of a clip in the playlist by right-
clicking the clip’s Description cell and selecting the Edit Cell command. Then 
type the new description directly in the playlist.

Device Identifies the device to which the page, template, scene or clip will be 
sent.
This column is based on the element’s Target Device property, which is set 
in Xstudio when the asset’s template is created. If the template’s Target 
Device property was not specified (empty), then the asset is appended to 
the first device’s playlist. 
• Standard playlist view: When Xplay is in Standard playlist view, you can edit 

the target device for any playlist element type by right-clicking the element’s 
Device cell in the playlist and selecting the Edit Cell command. Then, you can 
type the name of the target device.

• ByDevice playlist view: When Xplay is in ByDevice playlist mode, the playlist 
elements are naturally sorted using their Target Device settings. You are not 
permitted to edit a playlist elements device setting once the element is in a 
device’s playlist nor move it to another device’s playlist.

Duration Identifies the length of time that the page, template, scene or clip stays on 
air during the playout of the playlist.
• Embedded pages, Shared pages and Templates: You can edit a page’s 

or template’s duration value from within the playlist by right-clicking on the 
element’s Duration cell and selecting the Edit Cell command. Then, type the 
new duration value directly in the playlist.

• Clips: You cannot select or edit the Duration property for clips from within the 
Playlist Editor.
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Mark In / Mark 
Out

Displays the frame location that will be used as a starting and ending 
points when the clip asset is played out in the playlist. This property is set 
using the MarkIn/Out Editor. 
• Embedded pages, Shared pages and Templates: You cannot edit the 

Mark In or Mark Out values for pages or templates since this property only 
applies to clip assets.

• Clips: There are two (2) ways in which you can edit the Mark In or Mark Out 
values for a clip from within the Playlist Editor.

• Right-click on the element’s Mark In or Mark Out cell and 
select the Edit Cell command. Then, type the new value 
directly in the playlist.

• Right-click on the element’s Mark In or Mark Out cell and 
select the Visual Mark In/Mark Out command. The Mark 
In/Out Editor opens, allowing you to set the Mark In and Mark 
Out values using the Trim In and Trim Out handles. When you 
click Apply on the Mark In/Out Editor, these values are 
reported back to the Playlist Editor.

Name Displays the name of the playlist item.
• Shared pages & Templates: You cannot rename a shared page or template 

since their name is a fundamental property of the asset. 
• Embedded pages: Except for when the embedded page is automatically 

named, you can edit the name of embedded pages by right-clicking the element 
in the playlist and selecting the Edit Page command. The Edit Page window 
allowing you to edit the page’s Name field. Then, you must click the Commit 
and Close button to apply the change and close the Edit Page window.

• Clips: You can change the name of a clip in the playlist by right-clicking the 
element and selecting the Edit Cell command. Then type the new name 
directly in the playlist.

Offset Identifies the amount of time delay between the playout of two 
consecutive playlist elements. 
You can change the offset value of any of the playlist elements from 
within the playlist by right-clicking on the element’s Offset cell and 
selecting the Edit Cell command. Then, type the new offset value directly 
in the playlist.

Overflow Identifies the difference between the total time of the content in a 
timeslot and the time available in the timeslot. When the total time of the 
content in a timeslot exceeds the time available, there is an overflow.
A playlist element’s overflow cannot be edited from within the playlist.

Playlist column Definition and how to edit the playlist element’s property
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Playout Type Indicates the method by which the playlist item (i.e page, template or clip) 
be cued to air. The Playout Type for playlist elements can be changed in 
the Playlist Editor by right-clicking on the element’s Playout Type cell, 
and then selecting the Playout Type command. Select one of the 
following transition types: 
• Sequential : The playlist element is played when the previous element has 

completed (possibly with an offset).
• Hard Start : The playlist element is played at the specified time of day. If 

required, the currently playing element will be preempted. When a hard start 
element is played the playlist is synchronized with the system clock. The time of 
day is specified by entering it into the Offset column.

• Manual : The playlist element is played when a Resume command is sent 
to the playlist. If this command arrives earlier than expected, the currently 
playing element is preempted. If the command arrives later than expected, the 
playlist waits before resuming playout. The Resume command can be sent 
from the Play button in Xplay, or from logic in the Panel.

Recall ID Displays the Recall ID for the page, template or clip, which is used as a 
shortcut identifier for calling up pages and templates.
The Recall ID is originally created by filling in the Recall ID field on the 
Save dialog box when the page, template or clip is originally saved as an 
asset.
• Shared pages: You can set or edit the page’s Recall ID property by right-

clicking the element in the playlist and selecting the Edit Page command. The 
shared page’s editing window appears, allowing you to type in the Recall ID field. 
Click the Save Page, and Close button to apply the new Recall ID value to the 
asset. 
Note that each Recall ID value must be unique. If the new Recall ID value is 
already assigned to another asset, an error message appears giving you the 
option of either entering another value or overriding the Recall ID of the other 
asset.

• Embedded pages, Templates and Clips: You cannot edit the Recall ID 
property for embedded pages, templates, or clips from within the playlist.

Status A playlist element’s status cannot be edited from within the playlist. The 
status changes only when the element is verified, cued, taken to air or 
cleared. 
When the Verify playlist setting is enabled, each element in the playlist is 
verified when the playlist is loaded to ensure that it is available and ready 
for use. The results of the verification are displayed in the Status column 
for each element. See page 25 for more information.

User-defined 
columns

All user-defined columns that have been added to the Playlist Editor can 
be edited by right-clicking on the element’s cell and selecting the Edit 
Cell command. Then, type the new value directly in the playlist

Playlist column Definition and how to edit the playlist element’s property
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Deleting playlist elements
While building or using the playlist, you may want to delete an element that was previously 
added to the playlist (e.g. a page, template, clip, playlist segment, or comment). 

To delete an individual element from the playlist:
1 Select the element that you would like to delete from the playlist.
2 Right-click on the element’s row and select the Delete command.

Or,
Press the Delete key on your keyboard.

3 If Xplay’s Confirm page deletion property (Tools>Settings>Automation) is enabled, 
the Confirm Delete dialog box appears. Select Yes and the element is immediately 
deleted from the playlist, or select No to cancel the delete action.
If however Xplay’s Confirm page deletion property (Tools>Settings>Automation) is 
disabled, then the element is immediately deleted from the playlist.

To delete multiple elements from the playlist:
1 Select the first element that you would like to delete from the playlist.
2 While holding down the Ctrl key, select the various elements that you would like to 

delete from the playlist.
3 Right-click on one of the selected elements and select the Delete command.

Or,
Press the Delete key on your keyboard.

See page 37 for instructions on how to delete a playlist segment from a playlist.

Reloading the playlist
If you’ve had a playlist open for a while you may need to reload it to ensure that it’s still up-
to-date. For example, additional items may have been appended to the playlist by a user at 
another workstation while the playlist was also open at your workstation.

How you reload and whether it’s necessary at all depends on how Xplay has been 
configured. There are three possible scenarios:

• The Playlist update interval setting has not been activated. In this case, Xplay will not 
be checking for updates. For changes made at remote workstations to take effect, the 
playlist must be manually reloaded by clicking the Reload button  in the Playlist 
Editor’s toolbar.

• The Playlist update interval setting has been activated, but not the Auto reload 
playlists setting. This means that Xplay will periodically check the Xmedia Server for 
updated versions of the playlist but will not automatically reload the new version for 

Note: If the page, template, or clip that is to be deleted is a saved asset, 
deleting the item from the playlist does not remove the asset from the 
system, only from the playlist. However, embedded pages, playlist 
segments, and comments that were added to the playlist, but are not 
assets, will be completed deleted from the system.
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you. Instead, the Reload button  will turn orange to indicate that a new version has 
been detected. Click the button in the Playlist Editor’s toolbar to reload.

• Both the Playlist update interval and Auto reload playlists settings have been 
activated. Xplay will check the Xmedia server for an updated version of the current 
playlist and will automatically reload it when it finds a newer version.

Note that the currently airing and cued pages stay on air and cued even if they have been 
moved to new locations in the playlist, or have been removed altogether.

Saving the playlist
For a playlist to be available for future use, or accessible to other Vertigo Suite applications 
(i.e. Xbuilder), the playlist must be saved to the Xmedia Server. Newly created playlists are 
given a generic name (i.e. Playlist1) until they are saved and you specify a unique name.

As well, any edits that are performed to existing playlists are not permanent until the 
playlist has been saved. A playlist with unsaved edits is indicated by an asterisks beside the 
playlist’s name in Xplay’s Status bar. 

When a playlist is saved to the system, it becomes a playlist asset. Playlist assets are stored 
and accessed from within the Playlists root category (and sub-categories) in the Asset 
Browser.

To save a newly-created playlist:
1 Select the File>Save Playlist command from Xplay’s menu commands. 

Or,
Press Ctrl+S.
Or,
Press the Save Current Playlist  button in the Playlist Editor’s toolbar.
The Save Playlist dialog box appears.

2 In the Name field enter a new name for the playlist.
3 Enter your name in the Author field (optional).
4 Enter a short description for the playlist in the Description field (optional).
5 Link the playlist to the Playlists root category or to sub-categories by selecting the 

check box for each place where you want the playlist to be accessible from.
6 Click OK to save the playlist and exit the dialog box.

Or,
Click Cancel to discard all entered information and return to the unsaved playlist.

To save the changes to an existing playlist:
• Select the File>Save Playlist menu command. 

Or,
• Press Ctrl+S.

Or,
• Click the Save Current Playlist  button in the Playlist Editor’s toolbar.
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To save an existing playlist under a different name or into another category:
1 Select the File>Save Playlist As menu command. 

Or,
Click the Save Current Playlist As  button in the Playlist Editor’s toolbar.
The Save Playlist dialog box appears.

2 In the Name field enter a new name for the playlist.
3 Enter your name in the Author field (optional).
4 Enter a short description for the playlist in the Description field (optional).
5 Link the playlist to the Playlists root category or to sub-categories by selecting the 

check box for each place where you want the playlist to be accessible from.
6 Click OK to save the playlist and exit the dialog box.

Or,
Click Cancel to discard all entered information and return to the unsaved playlist.

Note: If you only want to move an existing playlist to another 
category, you don’t necessarily have to perform a Save As. Simply drag 
and drop the playlist from its current category to another within the 
Asset Browser.
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Xplay is the Vertigo Suite’s application for previewing and controlling the playout of 
content that has been organized into playlists. Operators use Xplay’s Playlist Editor and 
Device Views to view and control the playlist elements that are then cued and/or taken to 
the output device(s). 

To accommodate different control and playout situations, the layout of Xplay’s Playlist 
Editor and Device Views can be configured for previewing and controlling the playout on 
one or multiple devices. 

The following sections instruct operators how to control the preview and playout of playlist 
content on a single device, or manage the playout on multiple devices, multiple channels, 
and/or multiple layers on a channel. An additional section describes supplemental tasks 
that operators can perform to edit the content of playlist elements “on the fly”, as well as 
other playout control and management techniques.

• Preview and playout on a single device, on page 54
• Preview and playout on multiple devices, channels or layers, on page 58
• Additional operator controlled tasks, on page 65
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Preview and playout on a single device
When Xplay is intended to be used to control the playout on only a single playout device, 
we recommend that you use Xplay’s OnAir-Preview layout. The OnAir-Preview layout 
provides operators with two Device View windows (On Air and Preview) and the Toolbar 
Panel.

• Toolbar panel: While the Toolbar Panel is not specific to the OnAir-Preview layout, it is 
optionally used in conjunction with the On Air device. The Toolbar panel allows you to 
load a control panel asset, which can then be used to control the content and playout 
of an additional keyer level on the same On Air playout device.

• On Air: The On Air Device View is associated with a specific keyer level on a playout 
device. When a playlist item is taken to air, the item is displayed in the On Air Device 
View window. 

• Preview: The Preview Device View is associated with a device is used for previewing the 
playout of playlist item that has been cued and is being sent next to air. The preview 
window not only lets you see which item is next, but you can also make and save last-
minute edits to the playlist item, just before taking the playlist item to air.

Fig. 4-1: On Air - Preview layout’s device views and Toolbar Panel

The following sections provides instructions for how operators can set up and control Xplay 
to preview and control the playout of a playlist on a single device:

• Preparing to preview and playout on a single device, on page 55
• Previewing and taking playlist elements to air on a single device, on page 56

Toolbar Panel

On Air

Preview
Device View

Device View
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Preparing to preview and playout on a single device
Before using Xplay to preview and take a playlist to air on a single device, we suggest that 
you perform the following preliminary configuration and verification procedures to ensure 
that Xplay is properly configured and setup:

1 Verify that Xplay is currently in the OnAir-Preview layout and that the On Air and 
Preview Device Views are assigned to the desired devices.

Fig. 4-2: OnAir-Preview layout displays two Device Views: On Air and Preview

If Xplay is not in the OnAir-Preview layout and/or the proper devices are not assigned 
to the Device Views, consult Adding and connecting Xplay to playout devices, on 
page 9 and follow the configuration procedures for a single device and OnAir-Preview 
layout.

2 Verify that both the On Air and Preview Device Views have a green LED next to the 
device name to indicate that they are actively connected to the devices.
If the LED is red, follow the instructions on page 16 to reconnect Xplay to the device.

3 Ensure that the Keyer State button of the On Air and Preview Device Views are both On.
The Keyer State button allows you to control whether the device’s keyer is on or off. 
When the keyer is On, the Keyer State button is pink, which indicates that the loaded 
element is actively displayed on the device. When the keyer is Off, the Keyer State 
button is grey, which indicates that the loaded element is not being displayed on the 
device.

To change the Keyer State:
• Double-click the Keyer State button

Or, 
• Right-click on the Keyer State button and select the Turn Keyer On command.

1 Select Tools>Settings and verify that the Xplay settings are configured as follows. Once 
finished, click OK to close the Settings dialog box.

• Xplay>Layout>Playlist view>Standard
The playlist is displayed in the Playlist Editor as a single list, showing all elements in the 
order in which they were saved or positioned (not separated by device assignment).  

Keyer State: On
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The Playlist Editor’s global control buttons, Cue and Take, allow operators to cue and 
playout the playlist elements in the order in which they are listed in the Playlist Editor.

• Xplay>Playout>Auto cue next item>Enabled
After a manual take, the next playlist element will automatically be cued on the Preview 
device.

• Xplay>Playout>Cue On Load Playlist>Enabled
Xplay automatically cues the first element in the playlist when it is loaded. Note that 
since the Cue look ahead setting is enabled, the first element on will be cued when the 
playlist is loaded.

• Xplay>Playout>Initial playout mode>Manual
Configures Xplay so that operators have full manual control over what and when 
playlist elements are cued and taken to air.

Previewing and taking playlist elements to air on a single device
After completing the preparation procedure on page 55, Xplay is in a state where you can 
create or load a playlist into the Playlist Editor. Using the Playlist Editor’s global playout 
buttons (Cue and Take), you can control the pace of the playlist’s sequential playout by 
cueing and previewing the playout of playlist items on the Preview device and then taking 
them to air on the playout device.

Notice that the control-side of the page or template is displayed in the Device Views. This 
allows operators to easily identify the playlist elements, as well as allowing them to make 
(and save) on-the-fly changes to the asset’s editable fields before they are taken to air. 

Fig. 4-3: Previewing cued playlist elements and then taking them to air on the playout device

To manually control the sequential preview and playout of a playlist on a single device:
1 Ensure that Xplay is properly configured and setup for previewing and playing out on a 

single device.
2 Create a new playlist or load an existing playlist into the Playlist Editor.

Cue: Loads the next element
in the playlist to the On Air
playout device.

Take: Plays the currently cued
element on the On Air
playout device.
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Since the Cue On Load Playlist setting is enabled, when the playlist is loaded, the first 
playlist element is cued onto the Preview Device View and previewed on the connected 
preview device. 

3 Optional: When a playlist element is cued in the Preview Device View, you can make last 
minute edits to the element’s editable fields directly in the Device View before bringing 
it to air on the playout device.

4 Click the Take button to take the cued playlist element to air on the playout device.
Since the Auto cue next item setting is enabled, the next element in the playlist that is 
assigned will automatically be cued to the Preview device when the currently cued 
element moved to on air.

5 Optional: If while the playlist element is playing out on the On Air Device, you notice an 
error in the content of one of the editable fields (i.e. a spelling mistake or incorrect 
picture), you can make “on-the-fly” edits directly in the Device View.

6 Since the playlist is played out in sequential order, clicking the Take button again 
brings the next element in the playlist to air and the next element on that device 
becomes cued.
Continue clicking the Take button at the pace at which you want to control the playout 
of the playlist elements.

7 Optional: If you want to force an element to be cued or taken, but it is not the next in 
the playlist (e.g. skip forward or return backwards); simply double-click the element 
that you want to be cued as the next element to air. The Playlist Editor’s current 
position arrow moves to the new location and the element is cued on the Preview 
device. Clicking the Take button resumes the playout of the playlist from this point.

8 If the Playlist Editor’s Set Playlist Wrap Property button  is enabled, once you have 
reached the last element in the playlist, you can keep looping through the playlist by 
clicking the Take button.
However, if the Set Playlist Wrap Property button  is disabled, you can only 
continue until all of the elements have gone to air once.

Note: The first element in the playlist does not have to be the first item 
played out. You can determine the starting point for the sequential 
playout by selecting the element and then clicking the Cue button.

Note: As an alternative to clicking the Playlist Editor’s Cue and Take 
control buttons, you can also use Xplay’s Actions>Cue (F2) and 
Actions>Take (F1) menu commands and keyboard shortcuts.

Note: If you have configured Xplay’s Device Manager to allow a panel 
to control an additional keyer layer of the On Air playout device, you 
can load a panel into Xplay’s Toolbar Panel and use the panel to 
control the playout on the specified keyer. See Using a panel to 
control an additional keyer level on a device, on page 69 for more 
information.
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9 Optional: You can remove the cued item from the Preview Device View by clicking the 
Uncue button  or selecting Xplay’s Actions>Clear Preview menu command.
Similarly, you can use the Clear button  or Xplay’s Actions>Clear All (F4) menu 
command to remove the currently playing element from the On Air playout device.

Preview and playout on multiple devices, channels or layers
Use Xplay’s Multi-Device layout when Xplay is to be used to control the preview and 
playout on multiple devices, multiple channels, and/or multiple layers on a channel. 

In Multi-Device layout, each device, channel and/or keyer is represented in Xplay by a 
Device View, which allows operators to visualize and independently control the selection 
and pace at which playlist elements are cued and played out on the various devices. For 
example in the graphic below, Xplay with four (4) Device Views since it was configured to 
control a dual-channel Vertigo XG with 2 keyer layers for each channel.

Fig. 4-4: Xplay is configured in a Multi-Device layout to control 2 channels, each with 2 keyer layers

When Xplay is set to the Multi-Device layout, the appearance and functionality of the 
Playlist Editor and Device Views can be changed to accommodate different operator 
preferences and playout situations. 

For example:
• Playlist items can be organized in the Playlist Editor in a Standard or By Device view. 
• The layout of the Device Views can provide a view of the Preview, On Air or both the 

OnAir-Preview devices.
• If the Playlist Editor is in Standard view, operators can control the playlist using the 

Playlist Editor’s global controls (Cue and Take) to playout the playlist elements 
sequentially on their assigned devices. If the Show manual playout buttons setting is 
also enabled, operators can also use the Device View’s Manual Playlist buttons to force 
the playout of an element on any device, regardless of the device assignment.

The following sections provides instructions for how operators can set up and control Xplay 
to preview and control the playout of a playlist on a multiple devices, channels and/or 
layers:

• Preparing to preview and playout using the Multi-Device layout, on page 59
• Previewing and taking playlist elements to air on multiple devices, on page 61
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Preparing to preview and playout using the Multi-Device layout
Before using Xplay to preview and take a playlist to air on a multiple devices, channel 
and/or layers, we suggest that you perform the following preliminary configuration and 
verification procedures to ensure that Xplay is properly configured and setup:

1 Verify that Xplay is currently in the Multi-Device layout and that appropriate number of 
Device Views are displayed and assigned to the correct devices.

Fig. 4-5: Verify the Multi-Device layout, Device Views and device assignments

If Xplay is not in the Multi-Device layout, the proper number of devices are not 
displayed, and/or the proper devices are not assigned to the Device Views, consult 
Adding and connecting Xplay to playout devices, on page 9 and follow the 
configuration procedures for a multiple devices and Multi-device layout.

2 Verify that all of the devices in the Device Views have a green LED next to the device 
name to indicate that they are actively connected to the devices.
If the LED is red, follow the instructions on page 16 to reconnect Xplay to the device.

3 Ensure that the Keyer State button of each of the Device Views are On.
The Keyer State button allows you to control whether the device’s keyer is on or off. 
When the keyer is On, the Keyer State button is pink, which indicates that the loaded 
element is actively displayed on the device. When the keyer is Off, the Keyer State 
button is grey, which indicates that the loaded element is not being displayed on the 
device.

To change the Keyer State:
• Double-click the Keyer State button

Or, 
• Right-click on the Keyer State button and select the Turn Keyer On command.

4 Select Tools>Settings and verify that the Xplay settings are configured as follows. Once 
finished, click OK to close the Settings dialog box.

Xplay>Layout>Playlist view
• Standard: A single list, showing all of the playlist elements in the order in which 

they were positioned. This list does not separate elements by their device 
assignments. The Playlist Editor’s global playout controls (Cue and Take) are also 
displayed and can be used to control the playlist in sequential order. Note that 
when using the global controls, you are restricted by the element’s device 
assignment. In other words, you cannot cue and take an element assigned to one 
device (e.g. device1) on another device (e.g. Device2). To cue and take on another 
device, you must enable and use the Manual Playout buttons in the Device Views.

Device Manager
59



Operator controlled preview and playout techniques
Preparing to preview and playout using the Multi-Device layout
• ByDevice: The playlist is broken down and displayed as multiple playlists, with one 
list for each device configured in Xplay. The device’s playlist is shown opposite the 
Device View for the corresponding device. Each list only shows those elements that 
target the associated device. To control the playlist, you must enable and use the 
manual playout buttons within each individual Device View.

• Xplay>Layout>Show manual playout buttons>Enabled
Displays the manual playout buttons within each Device View window. The Manual 
Playout buttons allow you to override playlist order, default device assignments and 
the current position by controlling or forcing the content onto the specific Device View.

• Xplay>Layout>MultiDevice Layout
• Preview: The Device View consists of only the Preview window, which displays the 

element that is currently cued on the device.
• OnAir: The Device View consists of only the On Air window, which displays the 

element that has been brought to air on the device.
• OnAirPreview: The Device View consists of both the Preview and On-Air windows, 

therefore displaying the elements that are cued and playing out on the device.

 
Cues the selected playlist element to the Device View’s connected 
device. The element then becomes the playlist’s current position. 
This button can also be used to cue an element to a device that is not 
the element’s default target device. 
An element cannot be cued to more than one device at a time.

 
Takes the playlist element that is cued on the device to the default or 
assigned channel. It does not alter the current position in the playlist.
If no element has been cued on the device, it clears the currently 
airing element from the default channel.

 
Clears the element that is currently on air on this device. Clicking this 
button does not alter the current position of the playlist.

Standard Playlist View ByDevice Playlist View

Preview or OnAir OnAirPreview
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• Xplay>Playout>Cue look ahead>Enabled
Determines if Xplay cues elements on every device when a cue is performed. Enabling 
this setting and then performing a general cue allows the element that is selected for 
cueing to be cued first. Then a search is made for the next element targeting each 
remaining device, starting after the selected element. Each element that is located is 
cued, but only if it is not already cued. After a manual take, the next element on the 
same device where the take occurred is cued. 
If this setting is disabled and a general cue is executed, only the element selected for 
cueing is cued. After a manual take, no element is cued on the device.

• Xplay>Playout>Cue On Load Playlist>Enabled
Xplay automatically cues the first element in the playlist when it is loaded. Note that 
since the Cue look ahead setting is enabled, the first element on will be cued when the 
playlist is loaded.

• Xplay>Playout>Initial playout mode>Manual
Configures Xplay so that operators have full manual control over what and when 
playlist elements are cued and taken to air.

Previewing and taking playlist elements to air on multiple devices
After completing the preparation procedure on page 59, Xplay is in a state where you can 
create or load a playlist into the Playlist Editor and begin to control the preview and playout 
of the playlist elements on multiple devices. 

Since the Playlist View setting (Standard or ByDevice) significantly changes Xplay’s 
appearance and functionality, the following procedures guide you through an identical 
procedure for controlling playout only using difference playlist views.

• Controlling playout on multiple devices using Standard playlist view, on page 61
• Controlling playout on multiple devices using ByDevice playlist view, on page 64

Controlling playout on multiple devices using Standard playlist view
The following procedure guides you through the steps for controlling a playlist on multiple 
devices using the Playlist Editor’s global controls, as well as the Device View’s Manual 
playout buttons in Standard Playlist View.

These Xplay settings are used in this example:
• Xplay>General>Layout>Multi-Device
• Xplay>General>Number of devices>4
• Xplay>Layout>Playlist view>Standard
• Xplay>Layout>Show manual playout buttons>Enabled
• Xplay>Layout>MultiDevice Layout>PreviewOnAir
• Xplay>Playout>Cue look ahead>Enabled
• Xplay>Playout>Cue On Load Playlist>Enabled

To preview and playout a multi-device playlist using the Standard playlist view:
1 Load a playlist into the Playlist Editor. 
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Previewing and taking playlist elements to air on multiple devices
Each playlist element’s Device cell displays the particular device that they were 
assigned to be played out on.
Since the Cue On Load Playlist setting is enabled, the first playlist element for each 
device is cued onto their assigned output device. The arrow  along the left-side of the 
playlist, indicates the current position within the playlist. In other words, the next 
operation will apply to the element it is pointing to.
Also note that since Device1 and Device 2 are connected to both an output device and 
a Preview device, a preview of the cued elements’ playout is run on the Preview device 
when the element is cued.

2 Optional: You can modify the cued elements’ editable fields in the Device Views before 
bringing them to air on the device.

3 Click the global Take button at the bottom of the Playlist Editor to take the first playlist 
element (indicated by the  arrow in the playlist) that is cued on the devices to air.
Since the Auto cue next item setting is enabled, the next element in the playlist that is 
assigned to the device will automatically be cued to the device when the currently 
cued element moved to on air. The element will stay on air until the playlist reaches the 
cued element in the playlist.

4 Since the global cue and take buttons at the bottom of the playlist run through the 
playlist in sequential order, clicking the Take button again brings the next cued 
element in the playlist to air and the next element on that device becomes cued.

5 Continue clicking the Take button at the pace at which you want to control the playout 
of the playlist elements on their devices. You will also continue to make your way down 

Changed from Cued Device1
to On Air Device1

This element is now cued on 
Device1 since it will be the next
element to be taken on Device1

On air on Device3

Cued on Device3
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the playlist. So the next the next element in the playlist would be taken to air on 
Device2 and so on.
If the Playlist Editor’s Set Playlist Wrap Property button  is enabled, once you have 
reached the last element in the playlist, you can keep looping through the playlist by 
clicking the Take button.
However, if the Set Playlist Wrap Property button  is disabled, you can only 
continue until all of the elements have gone to air once.

6 Optional: You can remove the cued items from the Preview Device View by clicking the 
Uncue button  in each Device View.
As well, you can use Xplay’s Actions>Clear menu commands or each Device View’s 
Clear button to remove the currently playing element from the connected playout 
device.

If you need a playlist element to immediately playout on its assigned device (breaking 
the playlist order):

1 Double-click the desired playlist element. 
The playlist element is immediately cued on the assigned device and the playlist’s 
current position arrow  moves to this element.

2 Click the Playlist Editor’s Take button or the Take button in the element’s assigned 
Device View. The element is immediately taken to air and the playlist resumes from this 
new location.

If you need a playlist element to immediately playout, but on a device that is different 
from its assigned device:

1 Select the desired playlist element.
2 Click the Cue button in the Device View that is associated with the device that you want 

to play the element on.
The playlist element is immediately cued on the new device as indicated by the 
element’s status in the playlist. 
Note that the element’s device assignment (Device column) remains unchanged.

Note: During playout, the playlist scrolls and shows the most recently 
taken element. In a multi-device setup, when many consecutive takes 
are made on the same device, the cued and on-air elements on other 
devices may scroll out of view. To scroll the playlist down to view the 
cued and on-air elements on a particular device, right-click the device 
name on the right-side of Xplay and select the Scroll Into View menu 
command. 
If both the cued and on-air elements cannot be visible at the same 
time because they are too widely spaced, then the cued element is 
made visible. If there is no cued or on-air element on the chosen 
device, no scrolling is performed. 
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Previewing and taking playlist elements to air on multiple devices
3 Click the Take button in the Device View assigned to the device that it is to be played 
out on and the element is immediately taken to air. 
The element is immediately taken to air and the playlist resumes from this new 
location.

Controlling playout on multiple devices using ByDevice playlist view
If you would prefer to focus on managing the playout of a multi-device playlist on the 
individual devices, rather than controlling it in sequential order, you may consider setting 
Xplay’s Playlist View setting to ByDevice.

When the Playlist Editor is in ByDevice view, the multi-device playlist is broken down into 
multiple playlists, with one list for each device configured in Xplay. Each playlist only shows 
those elements that target the associated device. Each device’s playlist is displayed 
opposite to its corresponding Device View. 

Unlike Standard view which allows you to control the whole playlist using global controls or 
individual devices using the manual playout buttons, ByDevice view only allows you to 
focus on controlling each device separately using the manual playout buttons. Therefore, 
for operators to control the playlist, Xplay’s Show manual playout buttons setting must be 
enabled (see page 61 for a functional description of these buttons). 

The following procedure guides you through the steps for controlling a multi-device 
playlist when the Playlist Editor is set to ByDevice view.

These Xplay settings are used in this example:
• Xplay>General>Layout>Multi-Device
• Xplay>General>Number of devices>4
• Xplay>Layout>Playlist view>ByDevice
• Xplay>Layout>Show manual playout buttons>Enabled
• Xplay>Layout>MultiDevice Layout>PreviewOnAir
• Xplay>Playout>Cue look ahead>Enabled
• Xplay>Playout>Cue On Load Playlist>Enabled

To preview and playout a multi-device playlist using the ByDevice playlist view:
1 Load a playlist into the Playlist Editor. 

Note: When the Playlist Editor is in ByDevice view, you are restricted 
by the element’s device assignment. In other words, you cannot cue 
and take an element assigned to one device (e.g. device1) on another 
device (e.g. Device2).  
It is possible, however, to cue and take a playlist element on a device 
that is different from the assigned target device if the Playlist Editor is 
in Standard view. 
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The playlist is immediately divided up and each playlist element is placed in a playlist 
according to its assigned or target device.
Since the Cue On Load Playlist setting is enabled, the first playlist element for each 
device is cued onto their assigned output device. 
Also note that since Device1 and Device 2 are connected to both an output device and 
a Preview device, a preview of the cued elements’ playout is run on the Preview device 
when the element is cued.

2 Control each device separately using each Device View’s manual playout buttons.

Fig. 4-6: Use the manual playout buttons (Cue and Take) to control the playlist elements for the device

Additional operator controlled tasks
In addition to the operator controlled or initiated playout techniques described in the 
previous sections, Xplay allows operators to perform a few other control and playout tasks.

The following sections describe how operators can make last minute or on-the-fly changes 
to the cued playlist element’s editable fields; use a panel to control an additional keyer on a 
playout device; refresh/reload the playlist elements to ensure that the most updated 
versions are being used; and track which playlist elements have already been to air.

• Editing playlist elements that are displayed in a Device View, on page 65
• Using a panel to control an additional keyer level on a device, on page 69.
• Reloading and refreshing playlist elements, on page 70.
• Marking / Unmarking playlist elements as Aired, on page 71

Editing playlist elements that are displayed in a Device View
While the Device Views display the playlist elements that are currently cued or on air on a 
specific device, they also provide a workspace upon which you can make last minute 
changes to the element’s editable content. For example, you can change the text in a text 
box, make selections from drop-down lists, replace the existing image or clip...etc.

Preview Device View • Page: You can make changes to the page’s elements, and then either save the 
changes and/or take the page to air.

• Template, Scene, and Clip: You can make changes to the template’s 
elements or substitute the video clip, and then take the template/clip to air. You 
cannot, however, save the changes that were made to the template or clip.

On-Air Device View • Page: You can make changes to the page’s elements and apply them 
immediately to the on-air device’s playout. There is also an indirect way in which 
you can save the changes that were made to the page.

• Template and Clip: You can make changes to the template’s elements or 
substitute the video clip and apply the changes immediately to the on-air 
device’s playout. You cannot, however, save the changes that were made to the 
template or clip.
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The following topics describe how to edit the playlist elements in the Device Views, as well 
as how to save or apply the changes:

• Zooming in/out and repositioning in the device view, on page 66
• Editing text and other contents elements in the device view, on page 67
• Changing an image, clip, or cel animation in the device view, on page 68
• Saving changes made to playlist elements in the Device Views, on page 68

Zooming in/out and repositioning in the device view
To view the details of an element displayed in the Device View window, you can zoom in 
and out of the element. As a result of zooming in/out, portions of the element may become 
hidden outside of the window’s frame. If this happens, you can reposition the element 
within the device view window.

To zoom in or out of a playlist element that is displayed in the device view window:
1 Click within the device view.
2 Use your mouse’s wheel to zoom in or out.

• Roll the mouse wheel forward to zoom in.
Or,

• Roll the mouse wheel backward to zoom out.

To reposition the playlist element within the device view window:
1 Click within the device view.
2 While holding the Alt key, press the direction arrow keys to move the element toward 

the desired position. Or, holding the Alt key you can hold down the left-mouse button 
and drag the element to its new position.

Original Zoom in Zoom in & reposition

Note: Pressing the Space bar or Home key on your keyboard, resets the 
device view’s zoom to the original scale (1:1) and repositions the 
element to the center of the window.
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Editing text and other contents elements in the device view
If the page or template that is displayed in the Device View contains content elements 
(primitives) whose Allow Edit property are set to True, then you can make changes to these 
elements. 

Some of the edits that are possible in the Device View are:
• setting text in text boxes by clicking within the text box and typing the new text
• selecting an item from a drop-down list 
• selecting check boxes or a radio button to indicate a choice or enable a setting
• replacing existing images, cel animations, or clips with another of the same type

Fig. 4-7: You can make changes to the current settings on a page or template in the Device Views

Note: The new settings appear immediately in the device view and 
the changes are stored in a cached version of the playlist element. If 
the changes are being made in the On-Air Device View, then the 
changes are immediately viewed in the device’s playout. While you 
cannot permanently save the changes made to templates or clips in 
the Device Views, you can save the changes to a page’s content 
elements.

Drop-down lists

Text boxes

Radio buttons

Check boxes

Images

Text
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Changing an image, clip, or cel animation in the device view
If page or template that is in the Preview or On-air Device View window contains an image, 
clip, or cel animation element whose Allow Edit property is set to True, then you can 
substitute the current image, clip, or cel animation for another without having to clear and 
reload the Device View.

Although the following procedure only describes how to replace an image, we suggest that 
you use the same instructions for replacing a clip or cel animation in the Device View 
window since the procedure is generally the same in all three cases.

To change an image on the page from within the Device View window:
1 Right-click on the image in the device view window.

The Select an image dialog box appears.
2 Navigate through the Images root folder until the desired image is displayed (Proxy 

view ) or listed (Detail view ) in the Select an image dialog box.
3 Double-click the desired image, or select the desired file and click OK. 

The Select an image dialog box closes and the image is immediately updated in the 
device view.

Saving changes made to playlist elements in the Device Views
Xplay allows you can make changes to the content elements within a page, template, or 
clip asset that is currently displayed in the Preview and On-Air Device Views. The changes 
appear immediately in the Device Views and they are also temporarily stored in a cached 
version of the playlist element. If the changes are being made to a playlist element in the 
On-Air Device View and the element has been taken to air on the device, the changes will 
immediately be applied to the on-air playout.

As was stated above, these changes are temporarily stored in a cache version of the playlist 
element, but they have not yet been permanently saved. You must intentionally save the 
changes, otherwise they will be lost when Xplay is closed.

You can save the changes that were made to a page that is loaded in the Preview Device 
View by clicking the Save button  in the Device View’s toolbar. If the page was loaded in 
the On-Air Device View, the Save button  in the Device View’s toolbar is unfortunately 
disabled to encourage users to make most long lasting edits in the Preview Device View 

Note: The new image appears immediately in the device view and the 
changes are stored in a cached version of the playlist element. If the 
change was made in the On-Air Device View, then the change is 
immediately viewed in the device’s playout. While you cannot 
permanently save the changes made to templates or clips in the 
Device Views, you can save changes to a page’s content elements.

Note: Regardless of whether the edits where made in the Preview or 
the On-Air Device View window, edits to a template or clip playlist 
element cannot be save to the asset. In fact, the Save button  in the 
Device View’s toolbar will be disabled when editing a template or clip 
asset in the Device Views.
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rather than on-air. If however, you really must save changes that were made in the On-Air 
Device View, you can use the Xplay’s File>Save Pages command. Be aware however, that 
the Save Pages command not only saves the page of interest, but all pages that have 
unsaved edits.

Using a panel to control an additional keyer level on a device
In addition to using manual control techniques to send playlists to air on one or more 
playout devices in real-time, Xplay also allows you to use a control panel to playout and 
control an additional keyer layer on a specified output device.

Control panel assets are created in Xstudio, and allow operators to interact with content 
and control the playout while it is played out on air. Control panels can also contain logic 
that executes actions based on events received from the playout. For example, a control 
panel can control the appearance of a ticker crawl as well as provide the content from an 
RSS feed.

When Xplay is connected to a Panel device and a control panel asset is opened, the panel 
appears in the Toolbar Panel section of the Xplay interface. 

Fig. 4-8: Xplay can use a panel to playout and control graphics on an additional keyer layer

To use a panel in Xplay to playout and control an additional keyer layer on a specified 
output device:

1 Open Xplay’s Device Manager. 
Add and configure a device to the Panel device in Active Device table.

2 Load a control panel asset into the Toolbar Panel by navigating through the Asset 
Browser’s Panels root category and double-clicking the desired control panel asset.
The control panel immediately opens in Xplay’s Toolbar Panel. 

3 To playout of the specified device, Xplay’s Toolbar Panel must be actively connected to 
the device. Therefore, ensure that the connection LED in the Toolbar Panel is green. If 
the LED is red, see page 16 for instructions on reconnecting to the device.

Note: Xplay can be configured to load a specific control panel into the 
Toolbar Panel upon startup. Simply specify panel asset in Xplay’s 
Startup Panel setting.

Control Panel
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4 Depending upon what the panel was designed to do, operators can interact with the 
panel’s editable fields and control buttons and/or the panel will receive events during 
playout and react according to the programmed logic.

Reloading and refreshing playlist elements
If the loaded playlist or one of the playlist elements that is currently cued has been changed 
by another user on a different workstation, you can still obtain the latest saved version 
quickly and easily at any time by reloading the playlist or element. 

When the Auto reload playlists command is enabled and Xplay detects that the currently 
loaded playlist has changed, it automatically reloads the playlist. However, if this setting is 
disabled and Xplay detects that the currently loaded playlist has changed, the Reload 
button  in the Playlist Editor’s toolbar turns orange and you must click the Reload 
button to reload the playlist.

Similarly, if a playlist element is linked to a data source, you can refresh the cued element, 
which forces objects with data links to read the latest values in the database in order to 
display the latest information.

To reload the playlist:
• Click the Reload Playlist button  in the Playlist Editor’s toolbar.

Or,
• Select Xplay’s Actions>Reload Playlist command.

Or,
• Press F5 on your keyboard.

To reload a playlist element that is currently cued on a device:
• Click the Reload Playlist button  in the Device View’s toolbar.

Or,
• Select one of the following commands according to the device that the element is cued 

on:
• Select Xplay’s Actions>Reload Cued command.
• Select Xplay’s Actions>Reload Cued Device 1 command.
• Select Xplay’s Actions>Reload Cued Device 2 command.

To refresh a playlist element that is currently cued on a device:
• Click the Refresh button  in the Device View’s toolbar.

Or,
• Select one of the following commands according to the device that the element is cued 

on:
• Select Xplay’s Actions>Refresh Cued command, or press F3 on your keyboard.
• Select Xplay’s Actions>Refresh Cued Device 1 command, or press Shift + F3.
• Select Xplay’s Actions>Refresh Cued Device 2 command, or press Ctrl + F3.

Note: Xplay can be configured to send events to a control panel using 
keyboard shortcuts. The keys used to send the events are Ctrl-Shift+0 
up to Ctrl-Shift+9.
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Marking / Unmarking playlist elements as Aired
Xplay contains an optional feature that allows you to visually distinguish between the 
playlist elements that have already been played on air and those that have not. You can 
configure Xplay so that once an element has been taken to air, its Status column changes 
color and reports “Aired”.

Fig. 4-9: The Status of an element reads “Aired” once the element has completely played on air

When Xplay’s Playlist>Highlight>Show Aired setting is enabled, each time a playlist 
element has finished playing out on air, the element’s Status column automatically 
changes color and reports “Aired”. The color that the Status changes to is determined by 
the Playlist>Highlight>Aired color setting (figure Figure 4-10 on page 71).

Fig. 4-10: The “Show Aired” setting must be enabled for this feature to be available

• To remove the “Aired” Status from a playlist element, select the playlist element in the 
Playlist Editor and then select Actions>Unmarked as Aired or press Ctrl + U.

• To manually reinstate the element’s Status as “Aired”, select the playlist element in the 
Playlist Editor and then select Actions>Mark as Aired or press Ctrl + R.

Mark As Aired
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Controlling Xplay devices using 
automation protocols
Vertigo playout devices (Vertigo XG and Intuition XG) can be remotely controlled by 
external automation systems using Xplay and an automation protocol. Automation 
commands are sent using an automation protocol from the automation system to the 
device’s Xplay either through a serial or TCP/IP connection. Xplay then acts as an interpreter 
by receiving control commands from automation to control the device and the device 
sends back status messages.

Fig. 5-1: Xplay supports the remote control of devices via automation protocols

To use automation for device control, you must first configure Xplay’s Automation settings 
and the device’s Dashboard settings for automation compatibility. Instructions for 
accomplishing these tasks are provided in Specifying Automation settings in Xplay, on 
page 75.

Then you must use the Xplay Automation Configuration window to associate the device 
that is to be controlled with an automation protocol. Xplay offers a series of automation 
protocol properties that can be edited, as well as a mechanism for forwarding automation 
commands to other devices.

The Xplay Automation Configuration window is accessed by selecting the 
Tools>Configure Automation command. If Xplay has already been associated with one or 
more devices, then the Xplay Automation Configuration window appears.

If Xplay has not been associated with any devices, the following error message appears:
Automation cannot be used without devices attached to Xplay. 
Please use the device manager to configure Xplay and try again.

Note: To facilitate integration, Xplay supports several different 
protocols. In most cases however, we recommend using the Oxtel 
Protocol.

Station automation

Automation
protocol

Xplay

(Serial or TCP/IP)
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Controlling Xplay devices using automation protocols
Close the Xplay Automation Configuration window’s error message and use Xplay’s 
Device Manager to associate one or more devices to Xplay (see Adding and connecting 
Xplay to playout devices, on page 9). Then, try again to open the Xplay Automation 
Configuration window.

Once the Xplay Automation Configuration window is open and displays the devices, you 
can add and configure the protocol settings for each device. The following sections provide 
instructions for configuring Xplay’s automation protocol settings:

• Configuring Xplay to use the Evertz protocol over Serial, on page 76
• Configuring Xplay to use the Oxtel protocol over Serial, on page 79
• Configuring Xplay to use Xprotocol over TCP/IP, on page 82
• Configuring Xplay to use the Oxtel serial protocol over TCP/IP, on page 83
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Specifying Automation settings in Xplay
For automation to control a Vertigo playout device, Xplay must run on the same device that 
is to be controlled. To ensure frame accuracy during playout, you must configure both 
Xplay and the device’s Automation settings to be complementary. Note that frame 
accuracy is not supported when using playlists.

To configure Xplay’s Automation settings: 
1 Open Xplay on the rendering machine that will be controlled by the automation 

system.
2 Select the Tools>Settings from the Xplay menu commands to open the Settings 

dialog box. 
3 Navigate through Xplay>Automation to display Xplay’s Automation settings.
4 Enable the Automation (No Message boxes) setting, which overrides the behavior of 

the four (4) settings below it and prevents message boxes from appearing during Xplay 
operations.

5 Optional: if you are planning on using the Evertz protocol, then you must specify the 
Dead band setting (otherwise ignore this setting). The Dead band setting allows you to 
synchronize the taking and clearing of multiple templates within the Evertz protocol.

6 Select from the TV Format setting’s drop-down list the format target TV format for the 
execution of automation commands and page creation. This is used to determine the 
number of frames per second and to display timecode values. This TV Format should 
match the TV Format of the templates that you build and the Rendering Resolution 
setting of your rendering device.

7 Click OK.

To configure the Vertigo rendering device’s Automation settings:
1 Open the Vertigo rendering device’s Dashboard application by selecting the 

Tools>Launch Dashboard command from the device’s Control Panel.
2 Select the device from the Device Discovery table. If the device does not appear in the 

table, perform a Device Discovery (Tools>Settings>Device Discovery).
3 With the Settings Mode still set to Simple, ensure that the Output Resolution setting 

to the same as the TV Format setting in the Xplay Automation settings.
4 Change the Settings Mode by selecting Advanced from the drop-down list.
5 On the General page, select the System Counter option in the Automation Mode 

settings.
6 Set the Automation > Preroll setting to match that of the automation system. 

Automation systems will send and clear events ahead of time; preroll corresponds to 
the number of frames used by the automation system.

7 Click the Apply Changes button and close the Dashboard application.

Note: See Automation settings, on page 109 for further information 
regarding Xplay’s Automation settings.
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Configuring Xplay to use the Evertz protocol over Serial
Xplay can be configured to support the Evertz protocol as a means of controlling the 
playout of graphics content to Vertigo output devices. Thus far, Grass Valley has used 
Encoda Automation System running the Evertz protocol (Evertz 9525 DSK-LG) controlling 
Xplay.

To configure Xplay to use the Evertz protocol over Serial to control a device:
1 Open Xplay’s Device Manager and verify that the devices and device keyers that the 

Evertz protocol will control are properly configured and assigned (see Adding and 
connecting Xplay to playout devices, on page 9). 

2 Verify that Xplay’s Automation settings and the renderer’s automation settings are 
appropriate for automation control (see Specifying Automation settings in Xplay, on 
page 75).

3 Open Xplay’s Automation Configuration window and create an instance of the Evertz 
protocol for the device that is to be controlled by automation. 

a Select Tools>Configure Automation.  
The Xplay Automation Configuration window appears.

b In the Device to protocol mappings section, click the Add Protocol button next to 
the device that you want to map the Evertz protocol to.

c Select Evertz over Serial from the drop-down list that appears and press Enter.
The Properties section now displays the Communication, Protocol, Logging and 
Device Forwarding settings.

4 Set the following Communication settings:

Note: The Evertz protocol is somewhat limited in that there is no real 
control over layering of templates on the device. Therefore, in the 
current implementation there is no guarantee that a particular 
template will be loaded onto a particular keyer. If strict layering 
control is desired then another protocol, such as Xprotocol, should be 
considered. 

COM Port Select the communication port upon which Xplay will interact with 
the automation system. The default value is 1.

Baud Rate Select the expected transmission rate between the automation 
system and Xplay. Consult with the automation system and select the 
Baud rate that matches the baud rate used by the system. The default 
value is 19200.

Parity The parity setting normally offers the option of error checking during 
transmission between the automation system and Xplay. This setting 
is disabled since it is provided by the Evertz protocol.

Stop Bits The stop bits value represents the last bit in a character in 
asynchronous transmission to indicate the ending of the character. 
This setting is determined by the protocol and therefore it has been 
disabled.
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5 Set the Protocol Settings:

Data Bits The number of bits that make up a character of data that is 
transmitted. This setting is determined by the protocol and therefore 
it has been disabled.

Flow Control Select the process for managing the rate of transmission of data 
between the receiver and Xplay to prevent congestion. Choose from 
the following settings/techniques: None, CTS/RTS, Hardware, or 
Software.

Keyers Specify the keyers (layers) of a particular device that the Evertz 
protocol will control. These keyers must be configured in advance in 
Xplay using the Device Manager (see Adding and connecting Xplay 
to playout devices, on page 9).
Since there is no keyer specified by the Evertz protocol, the Evertz 
driver in Xplay will decide where to put the next element and does 
this by looking for the first of the configured keyers that has nothing 
cued nor on air. If every available keyer has something on air then 
Xplay will select the first keyer that does not have any element cued.
Note: If a template is loaded onto a keyer external to the protocol, 
the Evertz protocol driver has no knowledge of this and therefore 
will incorrectly consider this keyer as an available keyer.

Verify Multiple To reduce the number of verification calls made to the Xmedia 
Server, the Evertz protocol may send a verify request for a particular 
element multiple times in rapid succession (once a second, for 
example). This value sets a throttle on the number of incoming 
Evertz requests for an item that result in a call to the XMS. Xplay will 
reply with a cached value for that item on every verify request for 
the item until the number of repeat request received is equal to the 
Verify Multiple value. The recommended value for this setting is 5.
Note that for playlists, verify only verifies that the playlist exists on 
the Xmedia Server – it does not verify that all the playlist content is 
published on a device.

Playlist ID Range Specify an inclusive range if you want to cue and take playlists via 
the Evertz protocol. The range can be either numeric or 
alphanumeric, although currently playlists do not fully support 
Recall IDs so the lookup of a playlist will always by name. 
When an element is identified to be within the playlist range, a cue 
command opens the playlist and puts Xplay in Automatic playout 
mode. The playlist is then played out on the Take command and 
play out ceases when a Clear command is received. 

Ignore Playlist Clear This setting is used in conjunction with the Playlist ID Range 
setting that allows you to cue and take playlists via the Evertz 
protocol. 
Since a Clear command from the Evertz protocol stops the playlist 
from playing out abruptly, enabling this setting allows Xplay to 
ignore the Clear commands, thereby letting the playlist to finish on 
its own.
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6 Optional: Select the Enable Advanced Logging setting to supplement the Xplay*.log 
files with additional information regarding the interaction between the Evertz protocol, 
Xplay and the output devices.
A prerequisite to using the Enable Advanced Logging setting is that the Enable 
Debug Logging > Automation category must be enabled in Xplay’s Logging settings. 
See Logging settings, on page 113 for more information.

7 Optional: Set the device forwarding feature, which allows you to use the Evertz 
protocol to control multiple devices. See Device forwarding of automation commands, 
on page 85 for instructions.

8 Once you are finished setting the Evertz over Serial properties, click OK and restart 
Xplay.

9 Verify that the automation configuration has been applied to the Xplay device(s).
Once Xplay has been restarted, the devices that have been configured for automation 
should now display the automation icon  in the Device View’s toolbar. If there is no 
communication between the automation system and Xplay, the automation icon 
remains grey. However, when communication between the Evertz protocol and Xplay is 
successful, the blue automation icon is displayed in blue.

Note: Xplay should be restarted after any changes to the Xplay 
Automation Configuration window’s Device to protocol mappings or 
protocol properties. 
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Configuring Xplay to use the Oxtel protocol over Serial
As the Oxtel protocol is Grass Valley’s proprietary protocol, we recommend that you use this 
automation protocol to allow an automation system to control Grass Valley playout devices. 

The following instructions describe how to configure Xplay to use the Oxtel protocol over a 
dedicated serial connection between the automation system and Xplay. Note however, that 
Xplay can also be configured for use over a TCP/IP (see Configuring Xplay to use the Oxtel 
serial protocol over TCP/IP, on page 83).

To configure Xplay to use the Oxtel protocol over Serial to control Xplay devices:
1 Open Xplay’s Device Manager and verify that the devices and device keyers that the 

Oxtel protocol will control are properly configured and assigned (see Adding and 
connecting Xplay to playout devices, on page 9). 

2 Verify that Xplay’s Automation settings and the renderer’s automation settings are 
appropriate for automation control. For XG devices, see Specifying Automation settings 
in Xplay, on page 75.

3 Open Xplay’s Automation Configuration window and create an instance of the Oxtel 
protocol for the device(s) that are to be controlled by automation. 

a Select Tools>Configure Automation. 
The Xplay Automation Configuration window appears .

b In the Device to protocol mappings section, click the Add Protocol button next to 
the device that you want to control using the Oxtel protocol.

c Select Oxtel over Serial from the drop-down list that appears and press Enter.
The Properties section of the Xplay Automation Configuration window now displays 
the Communication, Protocol, Logging and Device Forwarding settings.

4 Set the following Communication settings:

COM Port Select the communication port upon which Xplay will interact with 
the station automation system. The default value is 1.

Baud Rate Select the expected transmission rate between the automation 
system and Xplay. Consult with the automation system and select 
the Baud rate that matches the baud rate used by the system. The 
default value is 19200.

Parity The parity setting normally offers the option of error checking during 
transmission between the automation system and Xplay. This setting 
is disabled since it is provided by the Oxtel protocol.

Stop Bits The stop bits value represents the last bit in a character in 
asynchronous transmission to indicate the ending of the character. 
This setting is determined by the protocol and therefore it has been 
disabled.
79



Controlling Xplay devices using automation protocols
Configuring Xplay to use the Oxtel protocol over Serial
5 Set the Protocol Settings:

6 Optional: Select the Enable Advanced Logging setting to supplement the Xplay*.log 
files with additional information regarding the interaction between the Oxtel protocol, 
Xplay and the output devices.
A prerequisite to using the Enable Advanced Logging setting is that the Enable 
Debug Logging > Automation category must be enabled in Xplay’s Logging settings. 
See Logging settings, on page 113 for more information.

7 Optional: If you want to append a postfix (i.e. _HD) to playlist element names when 
sending Oxtel protocol commands to the main device, enable the Use Postfix check 
box and type the postfix in the Selected Device Postfix field.
If you want to append a prefix (i.e. HD_) to playlist element names when sending Oxtel 
protocol commands to the main device, disable the Use Postfix check box and type the 
prefix in the Selected Device Prefix field.

8 Optional: Set the Device Forwarding features, which allow you to use the Oxtel 
protocol to control multiple devices. See Device forwarding of automation commands, 
on page 85 for instructions. 

Data Bits The number of bits that make up a character of data that is 
transmitted. This setting is determined by the protocol and therefore 
it has been disabled.

Flow Control Select the process for managing the rate of transmission of data 
between the receiver and Xplay to prevent congestion. Choose from 
the following settings/techniques: None, CTS/RTS, Hardware, or 
Software.

Timer Value (ms) The timer value can be used to set a heartbeat time interval in 
milliseconds so that if the Oxtel protocol driver in Xplay has not 
received some sort of message in this timeframe it will disconnect 
the Oxtel series protocol and the protocol indicator will appear 
disabled in Xplay. This is a way of alerting you of communication 
problems between the automation system sending Oxtel protocol 
commands and Xplay. By default, the timer value is 0 meaning no 
heartbeat interval is set. No heartbeat timer means that, as long as 
Xplay has a valid serial connection, the indicator will always appear 
enabled even if no messages are coming across the serial cable.

Preload XMS Assets 
(full R4/R5 command 
support)

Builds a cache in memory of all the assets in the Xmedia Server. 
Since the R4/R5 commands query the device for the assets, enabling 
this preload setting caches the assets, which makes the query 
response faster, but it also takes up memory. Disabling this preload 
setting results in the assets not being cached and therefore the 
query is slower.

Initial Keyer State Sets the state of a keyer when you first connect to a Vertigo XG, 
Intuition XG or Software CG device.
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9 Once you are finished setting the Oxtel over Serial properties, click OK and restart 
Xplay.

10 Verify that the automation configuration has been applied to the Xplay device(s). Once 
Xplay has been restarted, the devices that have been configured for automation should 
now display the automation indicator  in the Device View’s toolbar. If there is no 
communication between the Oxtel protocol and Xplay, the automation indicator 
remains grey. However, when communication between the Oxtel protocol and Xplay is 
successful, the blue automation indicator is displayed in blue.

Note: Xplay should be restarted after any changes to the Xplay 
Automation Configuration window’s Device to protocol mappings or 
protocol properties. 

Note: Serial Layer Mapping 
The Xplay.ini or XplayPro.ini files contain a setting called Layer 
Mapping, which can be used with the Oxtel protocol. This setting is 
used to map Oxtel layers to device keyers. Since the Oxtel protocol 
commands controlling an Imagestore can only specify layer 0 and 1, it 
may be necessary to map the Oxtel layers to the keyers actually used 
on the device.  
For instance, suppose that Xplay is configured with two views using 
keyers 1 and 2. In this case, layer 0 could be mapped to keyer 1 and 
layer 1 could be mapped to keyer 2. This is done using the 
LayerMapping setting in the [Protocol#] section that corresponds to 
the Oxtel protocol. The syntax is shown below: 
[Protocol#] 
LayerMapping=0,1|1,2 
Each pair of numbers separated by a “|” character is a layer mapping. 
The first number is the Oxtel layer number while the second number 
is the corresponding device keyer number.
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Configuring Xplay to use Xprotocol over TCP/IP
The Vertigo Xprotocol is a TCP protocol that allows external communication with Xplay. The 
packets are composed of a 24 byte TCP packet header followed by the Xprotocol command. 

An external program may connect to Xplay and control Xplay through Xprotocol 
commands. The listening port and Xprotocol server must be configured in Xplay’s Xplay 
Automation Configuration window. The external control must successfully open a socket 
connection to the IP address of the Xplay system at the configured port. An Xprotocol 
connection can control one device in Xplay. Control of multiple devices via Xprotocol 
requires multiple Xprotocol connections, one for each device. A device connection is 
necessary in order to be able to both configure and connect to an Xprotocol server in Xplay.

To configure Xplay to use Xprotocol over TCP/IP to control Xplay devices:
1 Open Xplay’s Device Manager and verify that the devices and device keyers that 

Xprotocol will control are properly configured and assigned. 
2 Verify that Xplay’s Automation settings and the renderer’s Automation settings are 

appropriate for automation control.
3 Open Xplay’s Automation Configuration window and create an instance of the 

Xprotocol for the device(s) that are to be controlled by automation. 
a Select Tools>Configure Automation. 

The Xplay Automation Configuration window appears.
b In the Device to protocol mappings section, click the Add Protocol button next to 

the device that you want to control using the Xprotocol.
c Select Xprotocol over TCP/IP from the drop-down list that appears and press 

Enter.
The Properties section of the Xplay Automation Configuration window now displays a 
single TCP setting.

4 In the TCP Port setting, specify the port number that you want the Xprotocol server to 
run on. The default value is 9000.

5 Click OK and restart Xplay.

6 Verify that the automation configuration has been applied to the Xplay device.
You should see a disabled Xprotocol indicator above the configured views in Xplay 
(below the device indicator). This indicates that you have an Xprotocol server running; 
the grey disabled color indicates there is not a connected client.
When a client successfully connects to an Xprotocol server in Xplay, the Xprotocol icon 
will change from light gray to purple.

Note: Xplay should be restarted after any changes to the Xplay 
Automation Configuration window’s Device to protocol mappings or 
protocol properties. 

The client is connected to an XProtocol server in Xplay

The client is not connected to an XProtocol server in Xplay
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To configure Xplay to use the Oxtel serial protocol over TCP/IP to control Xplay devices:

1 Open Xplay’s Device Manager and verify that the devices and device keyers that Oxtel 
protocol will control are properly configured and assigned. 

2 Verify that Xplay’s Automation settings and the renderer’s Automation settings are 
appropriate for automation control.

3 Open Xplay’s Automation Configuration window and create an instance of the 
Xprotocol for the device(s) that are to be controlled by automation. 

a Select Tools>Configure Automation. 
The Xplay Automation Configuration window appears.

b In the Device to protocol mappings section, click the Add Protocol button next to 
the device that you want to control using the Oxtel protocol.

c Select Oxtel over TCP/IP from the drop-down list that appears and press Enter.
The Properties section of the Xplay Automation Configuration window now displays 
the TCP setting and Device Forwarding settings.

4 In the TCP Port setting, specify the port number that you want the Oxtel server to run 
on. The default value is 5006.

5 Set the Protocol Settings:

6 Optional: Select the Enable Advanced Logging setting to supplement the Xplay*.log 
files with additional information regarding the interaction between the Oxtel protocol, 
Xplay and the output devices.
A prerequisite to using the Enable Advanced Logging setting is that the Enable 
Debug Logging > Automation category must be enabled in Xplay’s Logging settings. 
See Logging settings, on page 113 for more information.

7 Optional: If you want to append a postfix (i.e. _HD) to playlist element names when 
sending Oxtel protocol commands to the main device, enable the Use Postfix check 
box and type the postfix in the Selected Device Postfix field.
If you want to append a prefix (i.e. HD_) to playlist element names when sending Oxtel 
protocol commands to the main device, disable the Use Postfix check box and type the 
prefix in the Selected Device Prefix field.

8 Optional: Set the Device Forwarding features, which allow you to use the Oxtel 
protocol to control multiple devices. See Device forwarding of automation commands, 
on page 85 for instructions. 

Preload XMS Assets 
(full R4/R5 command 
support)

Builds a cache in memory of all the assets in the Xmedia Server. Since 
the R4/R5 commands query the device for the assets, enabling this 
preload setting caches the assets, which makes the query response 
faster, but it also takes up memory. Disabling this preload setting 
results in the assets not being cached and therefore the query is 
slower.

Initial Keyer State Sets the state of a keyer when you first connect to a Vertigo XG, 
Intuition XG or Software CG device.
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9 Click OK and restart Xplay.

10 Verify that the automation configuration has been applied to the Xplay device(s).
11 Once Xplay has been restarted, the devices that have been configured for automation 

should now display the automation indicator  in the Device View’s toolbar. If there is 
no communication between the automation system and Xplay, the automation 
indicator remains grey. However, when communication between the Oxtel protocol 
and Xplay is successful, the blue automation indicator is displayed in blue.

Note: Xplay should be restarted after any changes to the Xplay 
Automation Configuration window’s Device to protocol mappings or 
protocol properties. 

Note: TCP Layer Mapping 
The Xplay.ini or XplayPro.ini files contain a setting called Layer 
Mapping, which can be used with the Oxtel protocol. This setting is 
used to map Oxtel layers to device keyers. Since the Oxtel protocol 
commands controlling an Imagestore can only specify layer 0 and 1, it 
may be necessary to map the Oxtel layers to the keyers actually used 
on the device.  
For TCP layer mapping, the OxtelTCPLayerMapping variable shown 
below is required in the Device section of the first configured oxtel 
layer for a device: 
[Device1] 
... 
OxtelTCPPort=5006 
OxtelTCPAdvancedLogging=True 
OxtelTCPLayerMapping=0,1|1,2 
Each pair of numbers separated by a “|” character is a layer mapping. 
The first number is the Oxtel layer number while the second number 
is the corresponding device keyer number.
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If the device that is to be controlled by automation is a dual-channel Vertigo XG, Xplay’s 
device forwarding allows you to use the automation protocol to control both channels by 
configuring one device channel and then forwarding the automation commands from the 
assigned device to the other device channel. It also allows a single command to control 
different content on two or more devices through the use of a postfix or prefix (HD/SD) that 
is appended to the playlist element’s name.

To set the device forwarding feature:
1 Click in the Device column and select from the drop-down list the Xplay device that 

you want to forward the commands to.
2 Specify the postfix or the prefix:

• If you want to use a postfix, ensure that the Use Postfix option is selected, then 
double-click in the device’s Postfix column and specify a postfix. 

• If you want to use a prefix, disable the Use Postfix option, then double-click in the 
device’s Prefix column and specify a prefix.

Specifying a postfix of HD on one device and SD on another, when the protocol sends 
cue 1000 to Xplay, Xplay will cue template 1000_SD on the SD device and cue 
1000_HD on the HD device.

Note: If you intend to use device forwarding to control different 
content, ensure that the playlist elements have identical names, but 
append a prefix (e.g. HD_clip1) or postfix (e.g. clip1_HD) to the 
element that is intended for the device in the Device Forwarding 
table.
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Xplay’s menus and settings
Although many of Xplay’s menu commands and settings are described within the main 
chapters of this document in the context and/or procedures to which they apply, the 
following sections provide a quick reference to their functional descriptions:

• Xplay’s menu commands, on page 88
• Xplay’s settings, on page 98
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Xplay’s menu commands
Many of Xplay’s key features and commands are thematically organized within the menu 
bar command structure at the top of the main interface window.

The following sections provide functional definitions of the Xplay menu commands:
• File menu, on page 88
• View menu, on page 90
• Actions menu, on page 91
• Tools menu, on page 96
• Help menu, on page 97

File menu
The File menu contains commands that are related to opening, inserting, creating and 
saving playlists and pages.

Each of the File menu commands is described in the following table:

New Playlist Opens a new, empty playlist in the Xplay Playlist Editor.
Alternative access:
• Keyboard shortcut: Ctrl+N
•  Create New Playlist button in the Playlist window toolbar.

Open Playlist Opens the Open Playlist dialog box, which lets you select an existing 
playlist to open.
Alternative access:
• Keyboard shortcut: Ctrl+O
•  Open Existing Playlist button in the Playlist window toolbar.

Append Playlist Opens the Append Playlist dialog box, which lets you select a 
playlist to add to the end of the currently opened playlist.
Alternative access:
• Keyboard shortcut: Ctrl+P

Insert Playlist Opens the Insert Playlist dialog box, which lets you select a playlist 
to insert above the currently selected row in the currently opened 
playlist.
Alternative access:
• Keyboard shortcut: Ctrl+I

Save Playlist Saves any recent changes to the currently opened playlist. If the 
playlist is new and has not yet been saved, the Save Playlist dialog 
box appears and lets you specify the playlist’s properties, like name, 
author, and category.
Alternative access:
• Keyboard shortcut: Ctrl+S
•  Save Current Playlist button in the Playlist window toolbar.

Save Playlist As Opens the Save Playlist dialog box to allow you to save a new copy 
the currently opened playlist using a new name and/or category.
Alternative access:
• Keyboard shortcut: Ctrl+T
•  Save Current Playlist As button in the Playlist window toolbar.
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New Pages This command allows you to add multiple embedded pages. The 
Select A template for the new graphic and the Insert New Page 
dialog boxes stay up after adding a page to the playlist, so that you 
can keep adding more.
Alternative access:
• Keyboard shortcut: Ctrl+G

Insert New Page This command allows you to add a single embedded page. The 
Select A template for the new graphic dialog box closes once a 
template is selected and the Insert New Page dialog box closes once 
the page is added. 
Alternative access:
• Keyboard shortcut: Ctrl+E
•  Insert New Page button in the Playlist window toolbar.

New Shared Pages This command allows you to add multiple shared pages. The Select 
A template for the new graphic and the Insert New Page dialog 
boxes stay up after adding a page to the playlist, so that you can 
keep adding more. You can also use this command to create shared 
pages without being required to add them to the playlist (i.e. save 
the shared pages to the XMS). 
Alternative access:
• Keyboard shortcut: Ctrl+H

Save Pages This command goes through the list of pages that have been cached 
in Xplay and saves them.
When you cue and take pages, you have the ability to make 
modifications to them in the cue window (and on-air window too). 
These changes are preserved in the version of the page cached in 
Xplay, but are not saved back to XMS. The Save Pages command 
allows you to save all these changes.

Exit Closes the current Xplay session.
Alternative access:
• Keyboard shortcut: Ctrl+Q
•  Close button in the top-right corner of the Xplay window.
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View menu
The View menu contains commands that are related to displaying or hiding windows and 
tools that are used to create and/or operate playlists and troubleshoot any problems that 
might occur along the way.

Each of the View menu commands is described in the following table:

Open Message Log When selected, this command displays the message log dialog box, 
which documents the processes and errors that occur during your 
Xplay session. When cleared, this command hides the log.
Alternative access:
• Keyboard shortcut: Ctrl+M

Open Log File When selected, this command opens the current log file in Notepad 
from: C:\Documents and Settings\All Users\Application 
Data\VertigoXmedia\Logs. The log file stores the processes and 
errors that occurred during your Xplay session and is useful when 
debugging.
Alternative access:
• Keyboard shortcut: Ctrl+L

Asset Browser Displays or hides the Asset Browser. The Asset Browser is a 
collapsible panel on the lower-left side of the Xplay interface that 
allows you to view and access assets according to their type.
Alternative access:
• Keyboard shortcut: Ctrl+A
• Click the handle along the lower-left portion of the Xplay interface.

Toolbar Panel When a control panel is loaded, this command displays or hides the 
area for the control panel. This command is disabled if a panel is 
currently not loaded.
Alternative access:
• Keyboard shortcut: F12

Quick Recall Displays the Quick Recall field at the bottom of the playlist window, 
right above the Cue and Take buttons. The Quick Recall field allows 
you to instantly call up a page, clip, scene, or template asset using 
the page’s Recall ID property.

Search Opens the Search Tool, which allows you to find assets stored on the 
Xmedia Server by building and executing a search query based on 
the asset’s properties and/or metadata. 
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Actions menu
The Actions menu contains commands that allow you to control or perform tasks related to 
your playlist. Many of the commands are also available within the appropriate windows as 
buttons, or as key combinations.

Cue Cues the highlighted element in the playlist to the default device(s).
Alternative access:
• Keyboard shortcut: F2
•  Cue button in the Playlist Editor when Xplay is in Manual 

playout mode.

Cue Device 1 Cues the highlighted element in the playlist to device 1. 
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Shift+F2
•  Cue button in Device 1’s manual override buttons.

Cue Device 2 Cues the highlighted element in the playlist to device 2.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Ctrl+F2
•  Cue button in Device 2’s manual override buttons.

Take Takes the most recently cued page to air on the default channel of 
the device on which it is cued, or executes the cued action. If no 
pages have been cued yet, this cues the element first.
Alternative access:
• Keyboard shortcut: F1
•  Take button in the Playlist Editor when Xplay is in Manual 

playout mode.

Take Device 1 Takes the cued element to air on device 1. There must be an element 
already cued on the device for this to work.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Shift+F2
•  Take button in Device 1’s manual override buttons.

Take Device 2 Takes the cued element to air on device 2. There must be an element 
already cued on the device for this to work.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Ctrl+F2
•  Take button in Device 2’s manual override buttons.

Skip Multi Takes In cases where the playlist element consists of multiple takes, this 
command keeps the current graphic on air while bypassing all 
remaining takes and cueing the next playlist element.
Alternative access:
• Keyboard shortcut: F9
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Skip Multi Takes 
Device 1

In cases where the playlist element that is playing on Device 1 
consists of multiple takes, this command keeps the current graphic 
on air while bypassing all remaining takes and cueing the next 
playlist element.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Shift+F9

Skip Multi Takes 
Device 2

In cases where the playlist element that is playing on Device 2 
consists of multiple takes, this command keeps the current graphic 
on air while bypassing all remaining takes and cueing the next 
playlist element.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Ctrl+F9

Clear All Removes the elements that are currently on-air from all devices. 
Before this command is executed, the Clear All dialog box appears 
and asks you to confirm your intention to clear the contents from all 
devices.
Alternative access:
• Keyboard shortcut: F4

Clear Device 1 Removes the playlist element that is currently on-air from Device 1.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Shift+F4
•  Clear button in Device 1’s manual override buttons.

Clear Device 2 Removes the playlist element that is currently on-air from Device 2.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Ctrl+F4
•  Clear button in Device 2’s manual override buttons.

Clear Preview Removes the playlist element that is currently displayed in the 
Preview window.
This command is only available when Xplay’s General>Layout 
setting is set to OnAir-Preview.

Reload Playlist Reloads the last saved version of the playlist, while maintaining the 
current cued and on air elements.
Alternative access:
• Keyboard shortcut: F5
•  Reload Playlist button in the Playlist Editor’s toolbar.

Refresh Cued Forces objects with data links to read the latest values in the 
database in order to refresh the page.
Alternative access:
• Keyboard shortcut: F3
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Refresh Cued Device 1 Refreshes the page cued on device 1 by forcing all of its objects with 
data links to read the latest values from the database.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Shift+F3
•  Refresh button in Device 1’s toolbar.

Refresh Cued Device 2 Refreshes the page cued on device 2 by forcing all of its objects with 
data links to read the latest values from the database.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.
Alternative access:
• Keyboard shortcut: Ctrl+F3
•  Refresh button in Device 2’s toolbar.

Reload Cued Reloads the last saved version of the element cued on all devices.

Reload Cued Device 1 Reloads the last saved version of the element cued on device 1.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.

Reload Cued Device 2 Reloads the last saved version of the element cued on device 2.
This command is only available when Xplay’s General>Layout 
setting is set to Multi-Device.

Mark as Aired This command enables the selected playlist element’s status as 
“Aired” if the playlist element has already been brought to air.
This command is only available when Xplay’s 
Playlist>Highlight>Show Aired setting is enabled.
Alternative access:
• Keyboard shortcut: Ctrl+R
• Playlist Editor context menu command - Mark as Aired

Unmark as Aired This command removes the status of “Aired” from a playlist element 
that is marked as “Aired”.
This command is only available when Xplay’s 
Playlist>Highlight>Show Aired setting is enabled.
Alternative access:
• Keyboard shortcut: Ctrl+U
• Playlist Editor context menu command - Unmark as Aired
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Cue on Device Provides access to the following submenu commands, which cue the 
highlighted element in the playlist on the device identified by the 
command. 
• Cue on Device 1 Ctrl+Alt+A
• Cue on Device 2 Ctrl+Alt+B
• Cue on Device 3 Ctrl+Alt+C
• Cue on Device 4 Ctrl+Alt+D
• Cue on Device 5 Ctrl+Alt+E
• Cue on Device 6 Ctrl+Alt+F
• Cue on Device 7 Ctrl+Alt+G
• Cue on Device 8 Ctrl+Alt+H
These commands are only executed when Xplay’s General>Layout 
setting is set to Multi-Device. Also, if the device requested in the 
action does not exist, no action is performed.
Alternative access:
•  Cue button among the device’s manual override buttons.

Take on Device Provides access to the following submenu commands, which take 
the highlighted element in the playlist on the device identified by 
the command. 
• Take on Device 1 Ctrl+Shift+A
• Take on Device 2 Ctrl+Shift+B
• Take on Device 3 Ctrl+Shift+C
• Take on Device 4 Ctrl+Shift+D
• Take on Device 5 Ctrl+Shift+E
• Take on Device 6 Ctrl+Shift+F
• Take on Device 7 Ctrl+Shift+G
• Take on Device 8 Ctrl+Shift+H
These commands are only executed when Xplay’s General>Layout 
setting is set to Multi-Device. Also, if the device requested in the 
action does not exist, no action is performed.
Alternative access:
•  Take button among the device’s manual override buttons.

Skip Multi Takes on 
Device

In cases where the playlist element that is playing on a specific 
device consists of multiple takes, the following submenu commands 
can be used to keep the current graphic on air while bypassing all 
remaining takes and cueing the next playlist element.
• Skip Multi Takes on Device 1 Ctrl+Alt+I
• Skip Multi Takes on Device 2 Ctrl+Alt+J
• Skip Multi Takes on Device 3 Ctrl+Alt+K
• Skip Multi Takes on Device 4 Ctrl+Alt+L
• Skip Multi Takes on Device 5 Ctrl+Alt+M
• Skip Multi Takes on Device 6 Ctrl+Alt+N
• Skip Multi Takes on Device 7 Ctrl+Alt+O
• Skip Multi Takes on Device 8 Ctrl+Alt+P
These commands are only executed when Xplay’s General>Layout 
setting is set to Multi-Device. Also, if the device requested in the 
action does not exist, no action is performed.
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Clear on Device Provides access to the following submenu commands, which 
removes the playlist element that is currently on-air from the device 
identified by the command. 
• Clear on Device 1 Ctrl+Shift+I
• Clear on Device 2 Ctrl+Shift+J
• Clear on Device 3 Ctrl+Shift+K
• Clear on Device 4 Ctrl+Shift+L
• Clear on Device 5 Ctrl+Shift+M
• Clear on Device 6 Ctrl+Shift+N
• Clear on Device 7 Ctrl+Shift+O
• Clear on Device 8 Ctrl+Shift+P
These commands are only executed when Xplay’s General>Layout 
setting is set to Multi-Device. Also, if the device requested in the 
action does not exist, no action is performed.
Alternative access:
•  Clear button among the device’s manual override buttons.

Scroll into View on 
Device

Provides access to the following submenu commands, which 
immediately scrolls the playlist down to view the cued and on-air 
elements on the device identified by the command. 
• Scroll into View on Device 1 Ctrl+Shift+Q
• Scroll into View on Device 2 Ctrl+Shift+R
• Scroll into View on Device 3 Ctrl+Shift+S
• Scroll into View on Device 4 Ctrl+Shift+T
• Scroll into View on Device 5 Ctrl+Shift+U
• Scroll into View on Device 6 Ctrl+Shift+V
• Scroll into View on Device 7 Ctrl+Shift+W
• Scroll into View on Device 8 Ctrl+Shift+X
If both the cued and on-air elements cannot be visible at the same 
time because they are too widely spaced, then the cued element is 
made visible. If there is no cued or on-air element on the chosen 
device, no scrolling is performed. 
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The Tools menu contains commands that allow you to specify some of the settings that 
affect the aesthetic and behavioral properties of Xplay. It also allows you to configure Xplay 
to interact with other devices and applications.

The following table describes the functionality of the Tools menu commands:

Settings Displays the Settings dialog box, which allows you to make changes 
to the look and behavior of many of the Xplay features. See 
Configuring Xplay’s settings, on page 8 for detailed descriptions of 
each of Xplay’s settings.

Configure Playlist 
Columns

Displays the Column Layout dialog box, which allows you to 
determine what categories of information will be displayed in the 
Playlist Editor for each element. See Configuring the Playlist Editor’s 
column layout, on page 43 for a description of each column 
category, as well as instructions for adding/removing columns from 
the Playlist Editor.

Plugins Opens the Plugin Manager, which is used for registering or de-
registering plugins that support or enhance Xplay. Once a plugin is 
registered, it becomes a sub-menu element under the Plugins menu 
element.

Device Manager Displays the Device Configuration dialog box, which allows you to 
define and add new output devices to the Device Manager. Once 
devices are added to the Device Manager, you can connect a device 
to Xplay to be used for previewing and/or playing out playlist 
elements that have been published to the device. See Adding and 
connecting Xplay to playout devices, on page 9.

Configure Automation Xplay supports remote control of devices via automation protocols. 
Configuration of automation consists in associating automation 
protocols with devices to be automated, optionally adjusting 
configuration parameters and specifying devices where automation 
commands are to be forwarded. See Controlling Xplay devices using 
automation protocols, on page 73.
• Oxtel over Serial
• Xprotocol over TCP/IP
• Oxtel over TCP/IP

Configure EAS Emergency Alert System (EAS) is supported within the Vertigo Suite 
through Xplay, which adds support for cueing/taking and event-
sending to a specific template on incoming broadcast. 
Configuration of EAS support is performed in the Emergency Alert 
System Configuration dialog box, which displays the relevant 
options for a selected EAS receiver. See Emergency Alert System 
(EAS) Support, on page 129.
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Configure GPI Vertigo XG devices can be equipped with an optional GPI card, which 
provides you with up to eight (8) inputs for manually controlling a 
series of content playout actions. 
Xplay’s GPI Configuration window allows you to match GPI inputs to 
specific playlist control actions. See Configuring GPI inputs, on 
page 135.

Enable GPI Enables or disables a GPI input to Xplay. A check mark appears on the 
left side of the menu item when GPI is currently enabled. Note that 
for GPI input to be enabled, the GPI server must be configured and 
running.

About Displays the product information regarding what the version of the 
Vertigo Suite you are using.

License Opens the License Manager dialog box, which allows you to install 
and view the required application licenses for Xplay. See Installation 
and licensing information, on page 4 for specific instructions on how 
to acquire and install licenses for Xplay.
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Xplay’s settings
Although Xplay’s default settings are appropriate for most operating circumstances, you 
may want to customize the look and behavior of the application using Xplay settings. Note 
that modifying these settings is entirely optional.

Changes to Xbuilder settings are made within the Settings dialog box, which can be 
accessed by selecting Tools>Settings from the Xbuilder menu commands. 

This Settings dialog box contains a tree-structure of thematic settings. Each of the settings 
is defined in the following sections:

• General settings, on page 99
• Layout settings, on page 101
• Playout settings, on page 102
• AFD settings, on page 104
• Display settings, on page 105
• Template Favorites settings, on page 107
• Panel Events settings, on page 108
• Automation settings, on page 109
• As Run Logging settings, on page 111
• Logging settings, on page 113
• Plugins settings, on page 114
• Servers settings, on page 115
• Playlist > Basic settings, on page 116
• Playlist > Status settings, on page 117
• Playlist > Highlight settings, on page 118

Note: Some settings will require you to restart Xplay for the changes 
to be applied.
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• Startup panel: If you will be using Xplay to operate a control panel, you can use this 

field to specify which panel you would like automatically opened when you launch 
Xplay. To do so, click the  button beside the field to display the Select Panel dialog 
box, then make your selection. The panel will load right away. You can clear this field at 
any time to launch Xplay without a startup panel.

• Layout: To facilitate preview and playout control on one or more devices, Xplay features 
two layout modes, which change the format and functional views on the right-hand 
side of the Xplay interface. Select one of the following layout modes from the drop-
down list:

• OnAir-Preview: OnAir-Preview is appropriate for controlling one device with only 
one keyer. This option makes the bottom window display the element cued as 
next-to-air for the device, and the upper window display the element currently on 
air. See On Air Preview Layout, on page 41 for more information.

• Multi-Device: Multi-Device mode is appropriate if controlling more than one 
device, or a device with multiple keyers. Each window becomes a preview window 
displaying the playlist element that is next to air and/or what is currently on air on 
the device or device’s keyer. If you select this option, you must also set the Number 
of devices and MultiDevice Layout settings. See On Air Preview Layout, on page 41 
for more information.

• Number of devices: When the Layout setting is set to Multi-Device, the value in this 
setting determines the number of device views that will be displayed in the Xplay 
interface. These Xplay devices may represent either an output device or a keyer on a 
device. Note that this setting is ignored if the Layout setting is set to OnAir-Preview. See 
On Air Preview Layout, on page 41 for more information.

• Spell check on cue: When enabled, this setting executes a spell check on the playlist 
element when the element is cued. If a potentially misspelled word is detected, a 
colored line appears below it.

• Spell check color: Specifies the RGB color that the Spell check on cue setting uses for the 
line color to identify potentially misspelled words.

• Use default offset after zero duration: This setting affects the offset applied to playlist 
elements after edits. When the playlist is edited, the offsets of affected elements are 
adjusted to avoid any gaps in the playlist. The rule applied when setting the offset of a 
playlist element that follows a page element is to make the offset equal to the duration 
of the preceding page element. In cases where the duration of the preceding page 
element is zero then the Use default offset after zero duration setting is consulted. If it is 
true, then an offset of 10 seconds is used, otherwise, an offset of 0 is used.

• Sync with device on connect: When Xplay is connected to Vertigo XG device, Xplay 
receives callbacks from the XG identifying what is currently cued and on-air on each 
keyer (and also if the keyer is on/off ). When this setting is enabled, the control side is 
loaded in the cue and on-air buffers, as well the keyer state is set to match what is on 
the device.

• Enable limit for page cache: A cache is available for storing pages, which makes for 
quicker access. By default this cache grows without limit, and can use a lot of memory. 
Enabling this setting limits the cache size by keeping a maximum number of elements 
in this cache. The maximum number of elements in the cache is determine by the Limit 
for page cache setting (below).
99



Xplay’s menus and settings
General settings
• Limit for page cache: This setting is only used when the Enable limit for page cache 
setting is enabled. The value represents the maximum number of elements in that are 
kept in the cache. elements that have not been used for the longest time are discarded 
first and anything that is currently visible inside a view is not discarded.

• User Defined Application Title: This setting allows you to append a personalize title to 
the Xplay window title bar (upper-left corner).

• Always get pages from server: Xplay automatically makes local copies of all pages 
included in the currently active playlist. Any unsaved changes made to a page in the 
preview or on-air windows are preserved in the cached version of the page. Enable this 
setting to bypass the cache and have pages loaded directly from the server every time.

• Only allow one instance: When the Only Allow One Instance option is checked, only one 
instance of Xplay may run at a time. If an attempt to launch a second Xplay is made, a 
message box appears and informing you to exit this instance of Xplay before opening 
another. By default this option is unchecked (disabled) and multiple instance of Xplay 
can run simultaneously. 
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• Playlist view: This setting determines how the currently loaded playlist is displayed in 

the Playlist Editor. Xplay offers the following three (3) playlist views in the Playlist Editor:
• None - The Playlist Editor is not displayed at all in the Xplay window. No playlists 

can be manually loaded or displayed. See page 25 for more information.
• Standard - The playlist is displayed in the Playlist Editor as a single list, showing all 

elements in the order in which they were saved or positioned. See page 26 for 
more information.

• ByDevice - The playlist is broken down and displayed in the Playlist Editor as 
multiple playlists, with one list for each device configured in Xplay. The device’s 
playlist is shown opposite the View for the corresponding device. Each list only 
shows those elements that target the associated device. See page 26 for more 
information.

• Show embedded message window: Displays the message window as an embedded 
window below the playlist, rather than a pop-up window.

• Show enlarge window: Opens an embedded window below the playlist. When Xplay is 
in Multi-Device Layout mode, the contents of a device’s device pane can be displayed in 
this enlarged window by enabling the Enlarge command. When Xplay is in OnAir-
Preview Layout mode, the enlarged window is black and not available for use.

• Show manual playout buttons: Shows or hides the manual playout buttons in Xplay’s 
Device Views. See Manual Playout buttons, on page 48.

• MultiDevice Layout: Determines the layout of the display pane windows when 
Multi-Device selected for the Layout setting (see page 41 for more information).  
The possible settings are: 

• Preview - Only the preview window is shown. This displays the element that is cued 
on the device.

• OnAir - Only the on-air window is shown. This displays the element that is on-air on 
the device.

• PreviewOnAir - Both the preview and on-air windows are shown. This displays the 
elements that are cued and on-air on the device.
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• Cue look ahead: Determines if Xplay cues elements on every device when a cue is 

performed. Enabling this setting and then performing a general cue allows the element 
that is selected for cueing to be cued first. Then a search is made for the next element 
targeting each remaining device, starting after the selected element. Each element that 
is located is cued, but only if it is not already cued. After a manual take, the next 
element on the same device where the take occurred is cued. 
If this setting is disabled and a general cue is executed, only the element selected for 
cueing is cued. After a manual take, no element is cued on the device.

• Cue on Load Playlist: When this setting is enabled, Xplay automatically cues the first 
element in the playlist when it is loaded. Note that if the Cue look ahead setting is 
enabled, then the first element on each device will be cued. 
When this setting is disabled, Xplay does not cue any elements when a playlist is 
loaded. 

• Verify Playlist: Determines if playlists are verified when they are loaded. 
When this setting is disabled, the playlist elements are loaded into Xplay without going 
through the verification process. However, when it is enabled, each element in the 
playlist goes through the following verification steps: 

• Checks if the assets used by the playlist element exist. 
• Checks if the assets used by the playlist element require the completion of a Work 

Order before they can be used. 
• Checks if the assets used by the playlist element are published. If not, it initiates 

publishing of the assets. 
• The results of the verification are displayed in the Status column of the playlist 

element. 
• Filter pages by device: Xplay is configured with a set of “devices” to which elements are 

cued and taken. Each device is assigned a name that appears in the Device Views area 
for that device.
Every element in a playlist specifies a target device with a name. By enabling the Filter 
pages by device setting, when a playlist is loaded, any playlist element that does not 
target one of the devices in the Xplay configuration is removed from the playlist. This 
filtering actually modifies the loaded playlist by removing elements. If this occurs the 
text [Filtered] appears in the status area after the playlist name (see page 54). The Save 
button is disabled, since saving would permanently remove the filtered elements; only 
save-as is permitted.

• Initial playout mode: Determines the method by which the playlist is loaded and 
controlled in Xplay. Manual mode provides you with Cue and Take buttons, which 
provide you with full manual control over what and when playlist elements are cued 
and taken to air. 

• Playlist update interval: The interval, in seconds, at which Xplay checks to see if the 
currently loaded playlist has changed. The interval must be an integer. Specify 0 to 
indicate that no checking should be performed. When a non-zero value is used, the 
action taken if the playlist has changed is determined by the Auto reload playlists 
setting. 
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• Auto reload playlists: Determines the action taken when Xplay has detected that the 
currently loaded playlist has changed.  
Note: this setting is ignored if the Playlist update interval setting is zero.
If this setting is enabled and Xplay detects that the currently loaded playlist has 
changed, it automatically reloads the playlist. However, if this setting is disabled and 
Xplay detects that the currently loaded playlist has changed, the Reload button  
turns orange and you must click the Reload button to reload the playlist. 

• Auto cue next item: When this setting is enabled, a take is automatically followed by a 
cue of the next playlist element. This is the most common setting for interactive use of 
the playlist. When this setting is disabled, no automatic cue is performed after a take. 
This option is intended for use with automation systems that explicitly send separate 
take and cue commands. 
Note: this only applies to a general take done with the main Take button. For a manual 
take to be followed by a cue of the next element on the device, the Cue look ahead 
setting must be enabled. 

• Manual Scroll Style: Determines the policy used to control automatic scrolling of the 
playlist as elements are cued and taken. 
Select one of the following from the drop-down list:

• NewestTake - Scroll when necessary to keep the element that has most recently 
been put on-air visible. 

• HighestTake - Scroll automatically to keep the on-air element that is closest to the 
top of the playlist visible. The position of this element in the visible portion of the 
playlist is determined by the HighestTakeScrollFraction setting.

• FollowDevice - Scroll such that the cued and on-air elements on the device 
specified in the Manual Scroll Device setting are visible. Note that if the Manual 
Scroll Device setting is blank, then the element at the arrow is scrolled into view. If 
the Manual Scroll Device setting contains an unrecognized device name, no 
scrolling is performed.

• None - Never scroll automatically. 
• Clear secondary on complete primary: Determines if secondary events that were aired 

while airing a primary event are cleared from air when the primary event completes. 
When this setting is enabled and a primary event completes, Xplay clears all of its 
secondary events. However, when this setting is disabled and a primary event 
completes, Xplay allow its secondary events to remain on-air. 

• Recue after reload style: Controls the way that recueing occurs when the playlist has 
been reloaded after editing.

• None: No attempt is made to change the items that are cued in the playlist after a 
reload. However, if a currently cued item has been modified it will be recued. If a 
currently cued item is deleted, nothing is recued in its place.

• Next Unaired: (Default) Cue the next unaired item in the playlist. This is done by 
locating the last aired item in the playlist in order to determine how far into the 
playlist playout has progressed and then cueing the next unaired item after this 
point.

• First Unaired: Cue the first item in the playlist that has not been aired, wherever it 
occurs in the playlist. This may result in the playout jumping to an earlier point in 
the playlist if new content is added at the top of the playlist.
103



Xplay’s menus and settings
AFD settings
AFD settings
• Enable XG Output AFD monitoring: When enabled, Xplay is able to monitor the output 

AFD of the XG and raise the following event to the panel loaded in Xplay: 
NotifyOutputAFDCode(devName, previousAFDCode, NewAFDCode)

• Enable XG Input AFD monitoring: When enabled, Xplay can receive an AFD value 
notification from the XG input selected in the XG Input AFD Source Type setting. Xplay 
can then use this information to control on-air graphics for logo positioning, DVE 
squeezes... etc.

• XG Input AFD Source Type: Allows you to select which one of the three XG inputs Xplay 
will use as a source for receiving the AFD value. 
Choose from the drop-down list: Video A, Video B, or Clip. 

• For Video A and Video B sources, you must configure the XG device to generate the 
AFD code by enabling the Generated VANC setting on the XG’s Dashboard 
(Hardware>Ancillary).

• If Clip is chosen, you must also specify the clip object’s name in the setting below.
• XG Input AFD Source ClipObject Name: When Clip is selected in the “XG Input AFD 

Source Type” setting, this setting specifies the clip object’s name from the template 
where Xplay will read the AFD value.
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Although the Display setting page has various settings, the bulk of the settings deal with 
the overflow and underflow properties, which are set on this page and reported in the 
Overflow column in the Playlist Editor.

At the center of the overflow/underflow discussion are timeslots. A timeslot is a set of 
playlist elements between two hard-starts (a hard-start is a playout type for bringing 
playlist elements to air). The total time available in the timeslot is determined by the 
difference of the two hard-start times. Ideally, the timeslot should be filled with enough 
content to exactly fill this time. 

Overflow (or underflow) refers to the difference between the total time of the content in a 
timeslot and the time available in the timeslot. When the total time of the content in a 
timeslot exceeds the time available, there is an overflow. Similarly, when the total time of 
the content in a timeslot is less than the time available, there is an underflow.

The overflow column in the playlist indicates if a timeslot has an overflow or an underflow. 
The time difference is displayed as a positive value for overflows and a negative value for 
underflows. Furthermore, it is possible to specify thresholds for overflow and underflow. 
When the overflow or underflow in a timeslot exceeds the threshold, the overflow column 
is colored to draw attention to the problem.

• Overflow/underflow error color 1 - Specifies the color used to in the playlist’s Overflow 
column to indicate that a timeslot contains an overflow or underflow that exceeds 
acceptable thresholds. 

• Overflow/underflow error color 2 - Specifies a second color used to indicate that a 
timeslot contains an overflow or underflow that exceeds acceptable thresholds. The 
need for a second/alternating color is to distinguish between successive timeslots that 
contain an error. 

• Normal status color 1 - Specifies a color used to in the playlist’s Overflow column to 
indicate that a timeslot does not contain an overflow or underflow that exceeds 
acceptable thresholds. 

• Normal status color 2 - Specifies a second color used to indicate that a timeslot does not 
contain an overflow or underflow that exceeds acceptable thresholds. The need for a 
second/alternating color is to distinguish between successive timeslots that do not 
contain an error. 

• Overflow tolerance - Specifies the threshold (in milliseconds) above which an overflow 
in a timeslot is considered an error. 

• Underflow tolerance - Specifies the threshold (in milliseconds) above which an 
underflow in a timeslot is considered an error. 

• Offset display format - Specifies how the Offset column of the playlist is formatted. The 
following settings are available: 

• Standard: When hard-starts are used, elements display the time of day at which 
they will play. If there are no hard-starts, elements display the time relative to the 
start of the playlist at which they will play. Secondary elements display the time at 
which they will play, relative to the start of the primary element that contains them. 

• Raw: Displays the offset between the start of the playlist element and the 
preceding element. If the preceding element is a clip, the offset is with respect to 
the end of the clip (usually this value is zero). If the preceding element is a page, the 
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offset is with respect to the start of the page, that is, when the page was taken. 
Normally, this value is equal to the duration of the preceding page.

• Number rows: Determines the format of the first column in the Playlist Editor, which can 
be used for identifying the playlist element rows by row number or MOS story number. 
Choose from the following:

• None: The column is empty and no numbers are associated with the playlist 
element rows in the Playlist Editor.

• Row Number: Each row in the Playlist Editor in numbered sequentially in the first 
column for quick and easy reference.

• MOS Story Number: If the playlist element is associated with a MOS story, its story 
number will be displayed in the first column of the Playlist Editor for quick and easy 
reference.

• Mos StoryNumber Column Width: The value entered determines the width of the first 
column of the Playlist Editor when the Number rows setting (above) is set to MOS Story 
Number.
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The Template Favorites settings allow you to assign particular templates to control key 
sequences (Ctrl+1, Ctrl+2...). This provides a convenient shortcut for opening templates 
that are frequently used for creating and adding embedded pages to broadcast playlists. 
The Template Favorites settings allows you to assign shortcut for up to (10) templates.

To assign a specific template to a control key sequence:
1 Open the Settings dialog box: Tools>Settings

2 Select Template Favorites from the tree menu in the left panel.
3 Click in the text box of one of the Control key sequence (i.e. Ctrl+1) rows that you want 

to assign the template to.
4 Press the  button next to the text box. 

The Select Template dialog box appears.
5 In the Select Template dialog box, navigate to the desired template. Select the template 

and click OK.
Now when you are working in Xplay and you press the Control key sequence, the 
template assigned to that shortcut will open in the Insert New Page window.
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Panel Events settings
Xplay can be configured to send events to a control panel using keyboard shortcuts. The 
keys used to send the events are Ctrl-Shift+0 up to Ctrl-Shift+9.

The events that are sent to the control panel for each key are specified in the Panel Events 
settings. Each setting should be set to the name of an event on the panel to be triggered. 
For example, if the control panel contains an event name UpdateRows, it can be triggered 
by pressing Ctrl-Shift+1 by setting the appropriate Panel Event setting to UpdateRows. 

It is also possible to specify event parameters in the name if they are expected by the event 
on the panel, for instance ShowItems(Sports).

Note: Due to a restriction on Microsoft’s Windows Vista and 
Windows 7, the last panel event assignment, Ctrl-Shift+0, does not 
work unless you perform the following procedure: 
1. Click Start > Control Panel on the Desktop. 
2. Double-click Region and Language. 
3. Click Keyboards and Languages and then click Change keyboards. 
4. Click Advanced Key Settings and select Between input languages. 
5. Click Change Key Sequence. 
6. For Switch Keyboard Layout, select Not Assigned. 
7. For Switch Input Language, select Not Assigned. 
8. Clock OK to close each dialog box.Note:
108



Xplay
User Manual
Automation settings
Xplay automation settings allow you to determine whether or not you would like messages 
to display while working in Xplay. While these messages may become redundant, they 
often serve as an important confirmation step. Therefore, in most cases, we recommend 
that you leave these settings selected.

• Automation: When this setting is enabled, Xplay enters into Automation mode, by 
ensuring that all modal message boxes are suppressed. This prevents Xplay from being 
suspended when no operator is present to respond to a message box. Also note that 
when this setting is enable, it supersedes the Prompt For Clear All, Confirm playlist clear 
and Confirm page deletion settings. 
When this setting is disabled, Xplay is not in Automation mode and therefore the 
display of modal message boxes is permitted. 

• Confirm page deletion: Enable this setting to be prompted for confirmation whenever 
you delete a page. Be sure that the Automation setting is disabled, otherwise it will 
override this setting.

• Confirm playlist clear: Enable this setting to be prompted for confirmation whenever 
you clear a playlist. Be sure that the Automation setting is disabled, otherwise it will 
override this setting.

• Confirm Clear All: Enable this setting to be prompted for confirmation whenever you 
clear all elements from a playlist. Be sure that the Automation setting is disabled, 
otherwise it will override this setting.

• Prompt for save on new playlist: Enable this setting to be prompted to save the current 
playlist, if it is modified, before opening a new playlist. Be sure that the Automation 
setting is disabled, otherwise it will override this setting.

• Dead band (Frs): This setting is used in association with the Automation setting. It 
specifies a time interval, in frames, within which commands are considered to occur at 
the same time. For instance, an automation system may send commands that are 
intended to be executed simultaneously. However, the commands may arrive at 
slightly different times. If both times differ by an amount less than or equal to the 
deadband, they will be executed at the same time.

• TV Format: The target TV format for execution of automation commands and page 
creation. This is used to determine the number of frames per second and to display 
timecode values. Choose from the following settings:

• NTSC: NTSC (720x486) at 29.97 fps, 0.9 pixel aspect ratio
• PAL: PAL (720x576) at 25 fps, 1.094 pixel aspect ratio
• HDTV_720_60: HD 720p at 60 fps, 16:9 aspect ratio
• HDTV_720_60M: HD 720p at 59.94 fps, 16:9 aspect ratio
• HDTV_720_50 HD: 720p at 50 fps, 16:9 aspect ratio
• HDTV_1080_30: HD 1080i at 30 fps, 16:9 aspect ratio
• HDTV_1080_30M: HD 1080i at 29.97 fps, 16:9 aspect ratio
• HDTV_1080_25: HD 1080i at 25 fps, 16:9 aspect ratio
• ITV

• NTSC_16_9: NTSC (720x486) at 29.97 fps, 1.2 pixel aspect ratio
• PAL_16_9: PAL (720x576) at 25 fps, 1.4587 pixel aspect ratio
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The following options will also be available but a 4K license is required and they are 
exclusively used when Vertigo XG is integrated with iTX (XG Inside):

• UHDTV_2160_60M: UHD 2160 at 59.94 fps, 16:9 aspect ratio
• UHDTV_2160_50: UHD 2160 at 50 fps, 16:9 aspect ratio
• UHDTV_2160_30M: UHD 2160 at 29.97 fps, 16:9 aspect ratio
• UHDTV_2160_25: UHD 2160 at 25 fps, 16:9 aspect ratio
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Xplay can automatically generate As Run Log files, which provides a record of all of the 
elements that were played during the execution of a playlist. The As Run Log is often used 
by management and billing departments to document that commercials or programs were 
actually played on-air.

The As Run Logs are saved on your system using a.asr file extension and they can be 
opened by a standard text editor application, like NotePad.

The following sections describe how to enable and specify the As Run Logging settings.
• Setting the As Run Logging settings, on page 111
• Vertigo File Format, on page 111
• OSi File Format, on page 112

Setting the As Run Logging settings
For Xplay to generate an As Run Log file, you must enable and specify the following As Run 
Logging settings.

• Turn On As Run Logging: When this setting is enabled, any files played by a playlist will 
be written to an As Run Log file. When this setting is disabled, Xplay will not generate 
any As Run Logs. 

• As Run Log Path: This setting allows you to specify the folder where as run logs will be 
saved. Although the default path is C:\AsRun, you may specify any directory location 
on your system. Note that the default folder may not already exist on your system. 
Therefore, it is recommended that you verify, and possibly create the folder, prior to 
using the As Run Logging feature. 

• As Run Log Format: The As Run Log files can be created in either the Vertigo or OSI 
formats, which are described in Vertigo File Format (below) and OSi File Format, on 
page 112. To set the format, select either Vertigo or OSI from the drop-down list.

• As Run Log Frequency: Determines when a new As Run Log file is generated, as well as 
into which As Run Log file the current entries will appear. You may choose from either 
Per Playlist or Weekly. Note that the Frequency setting also has an effect on the log file’s 
naming convention. See Vertigo File Format (below) and OSi File Format, on page 112 
for more information.

• First Day Of Week:
• Write As Run Log Header: When OSI is selected as the As Run Log Format and this 

setting is enabled, a header record is added within a newly created As Run Log file. 
Note that if a playlist stops and restarts, no new header is created. When this setting is 
disabled, no header is created in the As Run Log file.

• Station Call Letters: Enter the station’s call letter that you want to appear in the As Run 
log header. 

Vertigo File Format
When the Vertigo format is selected, the name of the As Run log file depends upon the As 
Run Log Frequency setting. If the As Run Log Frequency setting is set to Per Playlist, then the 
file name is based upon the date of the first log entry (e.g. 30-09-2009.asr). However, if 
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the As Run Log Frequency setting is set to Weekly, the log file is automatically named using 
the 52-week calendar convention (e.g. week40.asr).

Each time a playlist element is taken to air, an entry is recorded in the log file. The format 
the entries is in Vertigo format is as follows:

• Date played: The date that the element was played on air. (DD-MM-YYYY)
• Timestamp: The time at which the element was played on air. (HH:MM:SS, on a 24-hour 

clock)
• Duration: Not implemented. The length of time that the element was played on air. 

(HH:MM:SS, on a 24-hour clock)
• Item’s name: The name of the page or clip that was played out.

OSi File Format
When the OSI format is selected, the name of the As Run log file depends upon the As Run 
Log Frequency setting. If the As Run Log Frequency setting is set to Per Playlist, then the file 
name is based upon the playlist’s name (e.g. News6PM.asr). However, if the As Run Log 
Frequency setting is set to Weekly, the log file is automatically named using the 52-week 
calendar convention (e.g. week40.asr).

Each time a playlist element is taken to air, an entry is recorded in the log file. The format 
the entries is in OSI format is as follows:

• Event Sequence: The element’s Event Sequence number from the playlist.
• Timestamp: The time at which the element was played on air. (HHMMSS, on a 24-hour 

clock)
• Duration: Not implemented. The length of time that the element was played on air. 

(HHMMSS, on a 24-hour clock)
• Item’s name: The name of the page or clip that was played out.
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Xplay’s logging settings allow you to specify the categories of events that you want to be 
recorded in the Xplay log files, as well as the maximum number and size of Xplay log files 
that will be archived. 

As Xplay operates, Xplay events are recorded to a log text file, which is stored in the 
following directory location: C:\Documents and Settings\All Users\Application 
Data\VertigoXmedia\Logs

Since the Xplay log files thoroughly track and record Xplay’s events during operation, they 
are a great tool to use for diagnosing error conditions or unexpected behaviors. In fact, our 
Technical Support team will often ask its customers to send them the Xplay log file to help 
them troubleshoot any unexpected behavior that you may be experiencing.
Note:It is strongly recommended not run full logging while ON AIR as it unnecessarily 
increases the CPU usage, which can decrease your system’s performance.

• Rollover count: Specifies the maximum number of Xplay*.log files that will be stored. 
A large enough number should be chosen to store over a day's worth of logs. This way 
if a problem happens the relevant log files will be available. Once the maximum 
number of files is reached, the oldest log file will be replaced by a new one. The default 
value is 5.

• Log file size (bytes): Sets the maximum memory size for each log file created per run. 
The default value is 3145728 bytes.

• Log Level: This sets the default log level used by all logging categories except those 
that have been checked in the Debug Categories list. The choices are:

• Error - Only log errors and major successful operations.
• Warn - Log unsuccessful operations that may indicate a problem (in addition to all 

messages logged at the Error level).
• Info - Log important events that occur during normal conditions (in addition to all 

messages logged at the Warn level).
It is recommended to set the Log Level to Info in order to provide enough information 
in the logs to diagnose common problems without affecting performance.

• Enable Debug Logging: Click the  button to open the Verbose Logging window, 
which lets you select which logging categories for debugging activities.
Each category checked will log at the Debug level instead of the default log level. A 
category should only be checked when further information is required in the logs in 
order to investigate a problem. Note that the log messages generated at the Debug 
level contain technical information intended for developers. Activating Debug logging 
increases the amount of information written to the log files and may impact 
performance.
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Plugins settings
Xplay’s functionality can be extended through plugins. All plugins that are meant to be 
used with Xplay must be stored in one directory location. The directory location must be 
specified in the Plugins Path setting.

While the Plugin Path value can be any full path directory location on your system, the 
default Plugin Path value is: C:\Program Files\VertigoXmedia\Apps\Plugins\

To register a plugin:
1 Select Tools>Plugins>Plugin Manager. 

This displays the Plugin Manager dialog box. The Available Plugins box at left displays 
all plugin files that were found in the Plugins directory for Xplay.

2 Select the plugin from the Available Plugins list.
3 Click the right arrow button . 

The plugin appears in the Plugins in use box on the right.
4 Optional - Select the plugin’s check box if you would like the plugin to launch when 

Xplay is started.
5 Click OK. 

To unregister a plugin:
1 Open the Plugin Manager window by selecting Tools>Plugin Manager. 

This displays the Plugin Manager dialog box.
2 Select the plugin from the Plugins is use box on the right side.
3 Click the left arrow button . 

The plugin now appears in the Available Plugins box on the left.
4 Click OK.

Note: For plugins to be integrated into Xplay, they must be registered 
using the Plugin Manager window. Plugins are available for 
registration only if they are custom-built by Grass Valley, or by 
someone from your organization using the API. 
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The Xmedia Server is the central graphics asset management server for the Vertigo Suite 
system. Along with the Data Server, the Xmedia Server manages the communication and 
content that allows Xplay to build/edit playlists and pages, as well as playout the contents 
of playlists to output devices.

You must be connected to the Xmedia Server and Data Server before Xplay can be 
launched (Starting Xplay and connecting to the Xmedia Server, on page 4). Once you have 
specified these settings (upon installation), you should not need to modify them, unless 
you need to connect to a server on a different machine (e.g. in the event of a crash). You 
must restart Xplay for any edits to the Servers settings to take effect.

• XmediaServer IP Address - Specifies the IP address of the machine running the Xmedia 
Server. 

• XmediaServer Port - Specifies the port on which the Xmedia Server is listening.
• Backup XMedia Server IP Address - Specifies the backup server’s IP address used in case 

of failure of the primary Xmedia Server.
• Backup XMedia Server Port - Specifies the backup server’s port used in case of failure of 

the primary Xmedia Server.
• Data Server IP Address - Specifies the IP address of the Data Server.
• Data Server Port - Specifies the port on which the Data Server is listening.
• Backup Data Server IP Address - Specifies the backup data server’s IP address used in 

case of failure of the primary data server.
• Backup Data Server Port - Specifies the backup data server’s port used in case of failure 

of the primary data server.

Note: To access the Xmedia Server and Data Server interfaces, select 
Start>Settings>Control Panel. Then select the VertigoXmedia Data 
Server or VertigoXmedia Xmedia Server icons.
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Playlist > Basic settings
The Playlist’s Basic settings determine the background and text colors for everything in 
your playlist -- pages, actions, segments, comments, and titles. You can also choose a font 
for the playlist.

To edit the default color for these playlist settings, click the  button to the right of each 
color field. Select the desired color from the Color selection dialog box and click OK. 

• Page Color: Specifies the background color of a page in the playlist.
• Page Text Color: Specifies the text color of a page in the playlist.
• Action Color: This setting has been deprecated.
• Action Text Color: This setting has been deprecated.
• Segment Color: Specifies the background color of a playlist segment.
• Segment Text Color: Specifies the text color of a playlist segment.
• Comment Color: Specifies the background color of a playlist comment.
• Comment Text Color: Specifies the text color of a playlist comment.
• Title Color: Specifies the background color of the playlist header row.
• Title Text Color: Specifies the text color of the playlist header row.
• Main Font: Specifies the font to be used throughout the playlist.
• Shows hours in duration column: Determines how the duration values are displayed (i.e. 

hours, minutes, seconds, frames). When selected, the duration values are displayed 
using the following format: MM:SS.FF. However, if the duration exceeds one hour, the 
duration value is shown in an HH:MM:SS.FF format. For example 01:12.23. If this setting 
is not selected, durations values are always shown in HH:MM:SS.FF format. For example 
00:01:12.23.
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The status of each playlist element is reported in the Playlist Editor’s Status column. During 
playout, it is often difficult to keep track of which playlist elements are cued or on-air and 
on which device(s). 

Xplay allows you to assign different colors to the Cue and Take actions on specific devices, 
so that you can visually reference the status column to determine which playlist elements 
are being played out of which devices. You can also assign color to alert you to the invalid 
status of a playlist element.

To edit the default color for a status setting, click the  button to the right of each color 
field. Select the desired color from the Color selection dialog box and click OK.

• Cued Device1 Color: The color used to indicate that the element is cued to Device 1.
• On Air Device1 Color: The color used to indicate that the element is on air on Device 1.
• Cued Device2 Color: The color used to indicate that the element is cued to Device 2.
• On Air Device2 Color: The color used to indicate that the element is on air on Device 2.
• Cued Device3 Color: The color used to indicate that the element is cued to Device 3.
• On Air Device3 Color: The color used to indicate that the element is on air on Device 3.
• Cued Device4 Color: The color used to indicate that the element is cued to Device 4.
• On Air Device4 Color: The color used to indicate that the element is on air on Device 4.
• Show Status As Highlight: Enable this setting if you would like the status color to 

highlight the entire row, instead of the Status column only.
• Checking Text Color: When performing a verification of the playlist, this is the color 

used to draw the text of playlist elements that are currently checking their status and 
have not yet received a reply to their query.

• Invalid Color: After performing a verification of the playlist, this is the color of the 
background of the playlist elements that have a status of Invalid. Invalid elements are 
not able to be cued or taken, since they refer to an XMS asset that is missing.

• Invalid Text Color: After performing a verification of the playlist, this is the color of the 
text of the playlist elements that have a status of Invalid. Invalid elements are not able 
to be cued or taken, since they refer to an XMS asset that is missing.
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Playlist > Highlight settings
The Highlight settings allow you to associate some playlist tasks and events with a 
highlight color that helps draw your attention to and identify a playlist event, like which 
playlist elements have already aired. Depending upon the task or event, a highlight may be 
in the form of a line that helps guide you, a cell or row in the Playlist Editor that changes 
color, or text added to the playlist element’s Status.

• Insert Line Color: When an element is being dragged to a new position in the playlist, 
the insert line indicates where the element will be placed once the mouse key is 
released.

• Select Color: The background color of a selected playlist element.
• Select Text Color: The text color of a selected playlist element.
• Segment Drag Over Color: The background color of the segment heading when an 

element is being dragged over it.
• Edit Color: The background color of a playlist cell when its contents are being edited.
• Edit Text Color: The text color of a playlist cell when its contents are being edited.
• Cueing Color: The color that is displayed during the process of cueing a playlist 

element. 
• Show Aired: When enabled, a playlist element’s Status cell will read “Aired” after the 

playlist element has been taken to air on a device. This is useful for quickly determining 
which elements have gone to air, or how many are left to air.

• Aired Color: When the Show Aired setting is enabled, the color specified in this setting 
is displayed for a playlist element that has already been taken to air. This is useful for 
quickly determining which elements have gone to air, or how many are left to air.

• Show Next To Air: Determines whether or not the device on which the next general take 
will occur is indicated by highlighting the color square beside the device name.

• Next To Air Color: Determines the color used to highlight the color square beside the 
device name when Show Next to Air setting is enabled.

• Select On Cue: Determines if a playlist element is also selected when it gets cued. 
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While most graphic pages are created and added to playlists in Xbuilder, Xplay does offer 
you the ability to create and add embedded and/or shared pages to a loaded playlist. See 
Embedded versus Shared pages below for a brief description of these two types of pages.

All pages that are created in Xplay, whether embedded or shared, are based upon existing 
templates. As the following sections describe, the procedure that you use to create and add 
pages to a playlist in Xplay depends upon whether you want to create a single embedded 
page, multiple embedded pages, or a shared page.

• Creating and adding embedded pages to a playlist, on page 121
• Creating and adding shared page assets to a playlist, on page 124
• Editing pages in Xplay, on page 127

Note: Which device’s playlist a new page is added to is determined by 
the template’s Target Device property, which is normally set in 
Xstudio when the template is created. If a new page is created in Xplay 
from a template that does not specify a target device, the page is 
automatically added to the first device’s playlist in Xplay’s Playlist 
Editor.
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Embedded versus Shared pages
Before creating a graphics page, you must decide whether the new page will be an 
embedded page or and a shared page. Note that both types of pages provide the same 
playout performance in a playlist. The main consideration that should be taken into 
account is whether the page is intended to be included in only one or many playlists.

Embedded pages exist only within a playlist, and it is the playlist that is saved as a whole in 
the Xmedia Server. As a result, the individual page does not exist anywhere else, not even in 
the Pages root category of the Asset Browser. Embedded page can be reused outside of its 
playlist if its playlist is inserted or appended to another playlist, or if the page converted 
into a shared page using the Save as Shared page command in Xbuilder. An advantage of 
using embedded pages is cleanup - once the playlist is deleted, all the pages in it are gone 
too.

Shared pages exist in the Xmedia Server (accessed from the Asset Browser) as distinct 
assets and can be used in many different playlists as a common element. An application 
example of using shared pages is a sports scoreboard that is used in the playlists for many 
different rundowns (i.e. news show, sports show, late sports, etc.). In such a case, the shared 
page would only be created once, updated automatically (or manually), but only one 
“copy” of that page needs to be updated for the updates to apply to all of the shows. One of 
the drawbacks for shared pages is that deleting the shared page asset from the Xmedia 
Server affects all shows that used that page.
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If you require a graphic page for an individual playlist, and you are sure that the page will 
never be used outside of the playlist, then we suggest that you create an embedded page. 
Embedded pages exist only within a playlist, and it is the playlist that is saved as a whole in 
the Xmedia Server. As a result, the individual page does not exist anywhere else, not even in 
the Pages root category of the Asset Browser.

Although most embedded pages are created in Xbuilder, Xplay does offer the ability to 
create and add embedded pages to a playlist. The following sections describe the various 
methods that you can use to create and add embedded pages to a playlist in Xplay:

• Creating and adding a single embedded page, on page 121
• Creating and adding multiple embedded pages, on page 122
• Using Template Favorites to create and add embedded pages, on page 123

Creating and adding a single embedded page
The following procedure describes how to create a single embedded page in Xplay by 
selecting a template, editing template’s variable fields and then adding it to the currently 
loaded playlist. 

If it is your intention to create more than one new embedded page, we recommend that 
you use the procedure described on page 122. 

To create and add a single embedded page to the playlist:
1 Select File>Insert New Page.

Or,
Press Ctrl+E.
Or,
Select the Insert New Page button  in the Playlist window toolbar.
The Select A template for the new graphic dialog box appears.

2 Navigate through the Templates root category and double-click the template that you 
want to base your new page upon.

3 Make the necessary changes to the page’s content using the template’s editable fields.
4 Optional: Type a description and/or specify an offset for the page in the fields in the 

upper portion of the dialog box.
5 Click the Insert In Playlist and Close button  in the top-left corner of the dialog box.

The new embedded page is immediately appended to the playlist and the dialog box 
closes.

Note: When Xplay’s Playlist Editor is in the ByDevice playlist view, 
which device’s playlist the page is appended to is determined by the 
template’s Target Device property, which is set in Xstudio when the 
template is created. If the template’s Target Device property was not 
specified (empty), then the page is appended to the first device’s 
playlist.
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Creating and adding multiple embedded pages
The following procedure describes how to create a multiple embedded pages in Xplay by 
selecting a template, editing template’s variable fields, adding it to the currently loaded 
playlist, and then repeat the process without having to reopen the template browser. 

If it is your intention to create and add only one new embedded page to the playlist, we 
recommend that you use the procedure described on page 121. 

To create and add multiple embedded pages to the playlist:
1 Select File>New Pages.

Or,
Press Ctrl+G.
The Select A template for the new graphic dialog box appears.

2 Navigate through the Templates root category and double-click the template that you 
want to base your new page upon.
The Create page dialog box appears and displays the new page that was created based 
upon the selected template.

3 Make the necessary changes to the page’s content using the template’s editable fields.
4 Optional: Type a description and/or specify an offset for the page in the fields in the 

upper portion of the Create Page dialog box.
5 Optional: Enable (orange) or disable (blue) the Enable Insert Page after Selected button 

to determine whether the new page will be inserted or appended to the device’s 
playlist. When enabled, the Create Page dialog box displays Insert in the lower-right 
corner; when disabled the word Append is displayed in the same location. 

6 Click the Append to / Insert in Playlist and Start New Page button  in the top-left 
corner of the Create Page dialog box.
When the playlist view is set to By Device, the new embedded page is immediately 
appended or inserted into the device’s playlist as assigned by the template’s Target 
Device property (which is set in Xstudio when the template is created). If the template’s 
Target Device property was not specified (empty), then the page is appended or 
inserted into the first device’s playlist.

7 Since that the Create Page dialog box has remained open, you can either create 
another new page using this same template, or create another new page using a 
different template.

Selecting the Enable Insert Page after Selected
button allows you to place the new page below
the selected playlist element

When the Enable Insert Page after Selected
button is not selected, the new page is
appended to device’s playlist

Append Insert
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• To create a new page using the same template, simply edit the template’s variable 
fields and click the Append to / Insert in Playlist and Start New Page button .

• To create a new page using a different template, close the Create Page dialog box 
by clicking the Close button . Use the Select A template for the new graphic 
dialog box once again to select a template upon which to base the new page. Edit 
the template’s variable fields and add the page to the playlist as before.

8 Once you are finished creating and adding new embedded pages to the playlist, simply 
close the Create Page and Select A template for the new graphic dialog boxes.

Using Template Favorites to create and add embedded pages
The Template Favorites settings allow you to assign particular templates to control key 
sequences (Ctrl+1, Ctrl+2...). This provides a convenient shortcut for opening templates 
that are frequently used for creating and adding embedded pages to broadcast playlists. 
The Template Favorites settings allows you to assign shortcut for up to (10) templates.

To create and add an embedded page to a playlist using the Template Favorites 
commands:

1 Create Template Favorites commands by assigning templates to the control key 
sequences in Xplay’s Template Favorites settings.

2 Load the playlist into the Playlist Editor and select the playlist element above where 
you want to insert the new embedded page.

3 Press the Control key sequence (e.g. Ctrl+1) that is associated with the template that 
you want to based the new embedded page on. 
The Insert New Page dialog box appears with the template already loaded in it.

4 Make the necessary changes to the page’s content using the template’s editable fields.
5 Optional: Type a description and/or specify an offset for the page in the fields in the 

upper portion of the Insert New Page dialog box.
6 Click the Insert In Playlist and Close button  in the top-left corner of the Insert New 

Page dialog box.
The new embedded page is immediately inserted into the playlist and Insert New Page 
dialog box closes. Note that if you did not select a specific insertion point in the playlist, 
the new embedded page is appended to the end of the playlist.
When Xplay’s Playlist Editor is in the ByDevice playlist view, which device’s playlist the 
page is inserted into or appended to is determined by the template’s Target Device 
property, which is set in Xstudio when the template is created. If the template’s Target 
Device property was not specified (empty), then the page is appended to the first 
device’s playlist.
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Creating and adding shared page assets to a playlist
Shared page assets are stored on the Xmedia Server, which allows them to be added 
directly to any playlist in Xplay. See Embedded versus Shared pages, on page 120 for more 
information about shared pages.

While there is only one way in which to create a new shared page in Xplay, there are several 
ways in which to add a shared page to a playlist that is loaded in the Playlist Editor. Which 
method you choose depends entirely upon how you have set up Xplay, as well as which of 
Xplay’s interface components you prefer to work with.

The following sections provide instructions for how to create and add shared pages to a 
playlist in Xplay:

• Creating and adding new shared pages, on page 124
• Using the Asset Browser to add shared pages to a playlist, on page 126

Creating and adding new shared pages
The following procedure describes how to create a single or multiple shared pages in Xplay 
by selecting a template and editing template’s variable fields. You can save the page to the 
Xmedia Server and optionally add it to the playlist. Once the newly created page is saved/
added, you can either create other shared pages or return to your Xplay session.

If it is your intention to create and add a page(s) to the playlist that will only be used in this 
playlist, we recommend that you use the procedure described on page 121 to create 
embedded pages.

To create a single or multiple shared pages and add them to the playlist:
1 Select File>New Shared Pages.

Or,
Press Ctrl+H.
The Select A template for the new graphic dialog box appears.

2 Navigate through the Templates root category and double-click the template that you 
want to base your new page upon.
The Graphic1 dialog box appears and displays the new page that was created based 
upon the selected template.

3 Make the necessary changes to the page’s content using the template’s editable fields.
4 Optional: Type a description, Recall ID, and/or specify an offset for the page in the fields 

in the upper portion of the Graphic1 dialog box.
5 Save the page to the Xmedia Server.  

There are two (2) ways in which you can save the new shared page: one allows you to 
specify the page’s name and category before it is saved as asset on the Xmedia Server, 
while the other automatically provides a default name and saves the page, then the 
page is inserted/appended to the playlist that is currently open in the Playlist Editor.

Note: Additional methods for adding shared pages to a playlist in 
Xplay are described in Adding playlist elements to a playlist, on 
page 26.
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• To only save the new shared page as an asset on the Xmedia Server, simply click the 
Save Page button . The Save Page dialog box appears allowing you to specify 
the new page’s name, information and category. After you have completed the 
page’s information and category fields, click OK. The page is saved to the Xmedia 
Server and the generic title of the Graphic1 dialog box is replaced with the name of 
the page.

• You can automatically save the new shared asset to the Xmedia Server’s Pages root 
category and then append/insert the page into the playlist that is currently loaded 
in the Playlist Editor. Simply set the Enable Insert Page after Selected button, and 
then click the Save Page, Insert in Playlist button . The new shared page is 
immediately saved to the Xmedia Server using the template’s name appended 
with a timestamp, and then the page is added to the playlist. 

6 Optional: Create additional new shared pages either based on the same or a different 
template that is stored on the Xmedia Server. Repeat this step as for as many new 
shared pages that you want to create.

• To create a new shared page based on the same template as before, edit the page’s 
editable fields and then click the New Page button . The Page Not Saved dialog 
box appears and asks you if you want to save the current page. Click Yes. The new 
shared page is immediately saved to the Xmedia Server using the template’s name 
appended with a timestamp.

• To create a new shared page based on a different template that is stored on the 
Xmedia Server, close the page’s dialog box by clicking the Close button . Use the 
Select A template for the new graphic dialog box once again to select a template 
upon which to based the new page. Edit the template’s variable fields and save the 
page according to the instructions in step 5.

Once you are finished creating and/or adding new shared pages to the playlist, return 
to your Xplay session by simply closing the page’s and the Select A template for the new 
graphic dialog boxes.

Note: When Xplay’s Playlist Editor is in the ByDevice playlist view, the 
new shared page is immediately appended or inserted into the 
device’s playlist as assigned by the template’s Target Device property, 
which is set in Xstudio when the template is created. If the template’s 
Target Device property was not specified (empty), then the page is 
appended or inserted into the first device’s playlist.
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Using the Asset Browser to add shared pages to a playlist
The Pages root category in Xplay’s Asset Browser provides access to all of the shared pages 
that are stored on the Xmedia Server. As such, the Asset Browser is a practical tool for 
finding and adding pages to the playlist. As is described below, where within the playlist a 
shared page is added depends upon whether Xplay is set to Standard or ByDevice playlist 
view.

There are three (3) methods by which you can add shared pages to a playlist using the Asset 
Browser:

• Double-click the page’s heading in the Asset Browser category.
• Right-click on the page’s heading in the Asset Browser category and select the Open 

command.
• Drag the page’s heading from the Asset Browser and drop it into the playlist row where 

you want to page to be located.

When Xplay is in the Standard playlist view and you add a shared page by double-clicking 
or using the Open command, the page is appended to the end of the playlist loaded in the 
Playlist Editor. You can then reposition it within the playlist by following the instructions on 
page 42. If you choose to drag and drop the page into the Playlist Editor from the Asset 
Browser, you can immediately choose its location within the playlist.

When Xplay is in the ByDevice playlist view and you add a shared page by double-clicking 
or using the Open command, the new shared page is immediately appended to the device’s 
playlist as assigned by the template’s Target Device property, which is set in Xstudio when 
the template is created. If the template’s Target Device property was not specified (empty), 
then the page is appended to the first device’s playlist. You can then reposition it within its 
device view, however, you cannot move it to another device’s playlist. 

If you choose to drag and drop the page into the Playlist Editor from the Asset Browser, you 
can immediately choose its location within the playlist. Regardless of what the page’s 
Target Device was, it is now assigned the device that you placed it into. Note that once the 
page is dropped into the device’s playlist, you cannot move it to another device’s playlist.
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Editing pages in Xplay
You can edit embedded and shared pages that have been added to a playlist up until the 
page is taken to air. In most cases, you will edit a pages variable fields or basic properties 
within the playlist, but Xplay also allows you to make on-the-fly edits to a page when it is 
cued in the Device View.

The following sections provide instructions for editing embedded and shared pages:
• Editing a page within a playlist using the Edit Page command, on page 127
• Editing a page when it is cued on a device, on page 128

Editing a page within a playlist using the Edit Page command
To edit a page within a playlist using the Edit Page command:

1 With the playlist loaded in the Playlist Editor, right-click on the page in the playlist and 
select the Edit Page command.
If the page is an embedded page, the Edit Page dialog box appears. However, if the 
page is a shared page, an editing dialog box appears that uses the shared page’s name 
as its title.

2 Make the necessary edits to the page’s variable fields (e.g. text, images, drop-down 
selections) and/or to its Description or Offset properties.

3 Save the edits by clicking the Commit and Close button  (embedded pages) or the 
Save Page, and Close button  (shared pages).

Note: If the Edit Page command is enabled in the menu, but it does not 
open an editing dialog box, this indicates that the playlist element is 
a template, not an embedded or shared page. Templates cannot be 
edited in Xplay, only in Xstudio. 
If the Edit Page command is disabled, this indicates that the page is 
currently cued or on-air and it cannot be edited using this command. 
While pages cannot be edited in Xplay while they are on-air, cued 
pages can be edited in the Xplay Device Views.

The Edit Page dialog box for embedded pages The editing dialog box for shared pages
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Editing a page when it is cued on a device
You can make edits to a page when it is cued on a device’s view or enlarged window. The 
edited page can either be taken directly to air with or without saving the changes. This 
method of editing pages is very useful for making on-the-fly or last minute edits right 
before the page is taken to air on the device.

To edit a page that has been cued to a device:
1 Cue the page to a device.

To view the cued page, Xplay must either be set to OnAirPreview layout, or Multi-
Device layout with the Multi-Device Layout setting to either Preview or PreviewOnAir.
The cued page appears in the Preview pane of the device’s view, or in the Enlarged 
window (if it is enabled).

2 Optional: Zoom in/out of the page by clicking on the page using your mouse’s scroll 
wheel. You can also reposition the page by holding down the Ctrl key while pressing 
the keyboard arrow keys.

3 Make the necessary edits to the page’s variable fields (e.g. text, images, drop-down 
selections).

4 You can save the edits to the page immediately by selecting File>Save Pages. Note that 
this command saves all pages in the playlist that have been edited during this session.

5 You can take the page to air immediately and the page will display the edits (regardless 
of whether or not you saved the changes). 

Cued in the
Device view

Cued in the
Enlarged Window
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The Emergency Alert System (EAS) is a federal United States of America notification system 
used by government-approved entities to broadcast important warnings to the entire 
nation. The television industry is required to respond to such notifications by suspending 
its programming and displaying the incoming messages, optionally broadcasting EAS-
supplied audio as well. EAS broadcasts are received via a receiving device, of which several 
versions are offered by various vendors in the United States. 

Emergency Alert System (EAS) is supported within the Vertigo Suite through Xplay, which 
adds support for cueing/taking and event-sending to a specific template on incoming 
broadcast from TFT Incorporated’s EAS 911 receivers. 

More specifically, upon acquiring an incoming broadcast from a receiver, Xplay cues and 
takes a specified template on a specified device and keyer. Then as the broadcast is played, 
Xplay raises events at the template level, and the template executes the required actions. 

The following list identifies the EAS events (in chronological order) that Xplay may 
potentially raise during an EAS broadcast: 

• EAS_INCOMING() -- The start of an EAS warning. 
• EAS_TRANSLATED_HEADER(eas_originator_code, eas_event_code, 
eas_county_location_code, eas_alert_duration, eas_datetime, eas_id) -- 
The text components of the warning. Please refer to the SAME header definition for 
further details (http://en.wikipedia.org/wiki/Specific_Area_Message_Encoding). 

• EAS_AUDIOHDRATTSIGNAL_BEGIN() -- The audio attention signal begins broadcasting 
from receiver. 

• EAS_AUDIOHDRATTSIGNAL_END() -- The audio attention signal is finished. 
• EAS_ALERTVOICEAUDIOEOM_BEGIN() -- The voice message and the end of message 

audio begins broadcasting. 
• EAS_ALERTVOICEAUDIOEOM_END() -- The voice message and the end of message audio 

are finished. 

Note: While Xplay only supports connectivity with a single receiver at 
a time; EAS support does include device forwarding, which allows the 
EAS receiver to target more than one device with a single warning 
broadcast. 
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Configuring Xplay’s EAS settings
The configuration of Xplay’s EAS support is performed in the Emergency Alert System 
Configuration dialog box, which is available by selecting the Tools>Configure EAS menu 
command. 

The initial Emergency Alert System Configuration dialog box prompts you to select an EAS 
receiver from the drop-box. Currently the only receiver available is TFT Incorporated’s EAS 
911. Once the receiver is selected, the Emergency Alert System Configuration dialog box 
displays the relevant options for configuring the EAS settings for this receiver.

The EAS configuration settings within Emergency Alert System Configuration dialog box are 
displayed in thematic groupings. Each of the settings is described in detail in the following 
sections:

• Communication Settings, on page 130
• Target Device Settings, on page 131
• Protocol Settings, on page 132
• Device Forwarding, on page 132

Communication Settings 
In the case of the EAS911, only the serial COM port can be changed via the graphical 
interface, as the other serial port parameters are fixed for the device. However, should you 
need to change them for any reason, Xplay will honor the configuration information saved 
in the .ini file. Saving any modifications via the configuration dialog will overwrite any such 
change. 

The following list describes each of the EAS Communication settings:
• COM Port: The port on which Xplay communicates with the EAS 911 receiver.
• Baud Rate: The expected transmission rate between the receiver and Xplay. This setting 

is determined by the protocol and fixed at 9600 bps.

Note: Additional information regarding the Emergency Alert System 
(EAS) and the TFT Inc. EAS 911 receiver can be found on the world 
wide web at http://www.fcc.gov/pshs/services/eas/ and http://
www.tftinc.com/easproducts.html.
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• Parity: The parity setting offers the option of error checking during transmission 
between the receiver and Xplay. This setting is determined by the protocol and 
disabled (None).

• Stop Bits: The stop bits value represents the last bit in a character in asynchronous 
transmission to indicate the ending of the character. This setting is determined by the 
protocol and fixed at 1.

• Data Bits: The number of bits that make up a character of data that is transmitted. This 
setting is determined by the protocol and fixed at 8.

• Flow Control: The process for managing the rate of transmission of data between the 
receiver and Xplay to prevent congestion. Choose from the following settings/
techniques: None, CTS/RTS, Hardware, or Software.

Target Device Settings 
The Target Device Settings allow you to specify which device, keyer, and template to use for 
the primary EAS playout broadcast. 

Note that your devices must be properly configured in Xplay prior to specifying the Target 
Device settings.

• Target Device: The name of the device on which the EAS template will be taken/cued. 
Select one of the connected Xplay devices from the drop-down list.

• Target Keyer: The keyer number (layer) onto which to load the EAS template. 
• EAS Template: Identifies the EAS-aware template to cue/take upon event.  

Clicking the  button allows you to navigate and select the appropriate template for 
EAS use.

Three pre-formatted EAS templates are available to be used with Xplay for EAS playout. 
Each of the EAS templates represents a different playout format (1080i, 720p, and 
NTSC). The templates are designed to load a basic crawl onto the topmost keyer and 
display incoming EAS data.
While the EAS templates are installed on most factory configured Vertigo hardware 
devices, you can also import them from the Vertigo Suite’s Demo Content DVD, or from 
the following directory location: C:\Program 
Files\VertigoXmedia\Apps\Support\VXM_Export_EAS.zip. Unzip the files to a 
directory and import them to the Xmedia Server using Xplorer or Xstudio.
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Protocol Settings 
While the television industry is required to respond to EAS notifications by suspending its 
programming and displaying the incoming messages, they can choose whether or not to 
broadcast the EAS-supplied audio message. If the broadcaster chooses to play the audio 
portion, they must enable the Request Audio Message setting to request the EAS voice 
messages from the EAS911 device when an event notification comes in from the EAS 
system. 

Enabling this setting also enables the following optional events:
• EAS_AUDIOHDRATTSIGNAL_BEGIN 
• EAS_AUDIOHDRATTSIGNAL_END 
• EAS_ALERTVOICEAUDIOEOM_BEGIN 
• EAS_ALERTVOICEAUDIOEOM_END 

Device Forwarding 
Although Xplay only supports connectivity with a single receiver at a time; EAS support 
does include device forwarding, which allows the EAS receiver to target more than one 
device with a single warning broadcast. 

The Device Forwarding table allows you to create the definition of devices onto which the 
EAS functionality (cue/take and events) will be chained. To add a device to the table, click 
the Device column and select from among Xplay’s connected devices.

Note that the devices must be properly configured in Xplay for them to appear in the 
Device column’s drop-list.

Incoming EAS events will be forwarded to all devices in this list.

Device Forwarding can extend the transmission not only to other devices, but it also allows 
you to use different templates on these devices by specifying an optional pre/postfix that is 
appended to the template name.

Xplay uses device forwarding to cue and take the EAS template on an SD output device 
(XG2). However, during the same transmission, Xplay forwards the transmission to the XG1 
device, which uses the EAS_HD template.

Fig. C-1: Device forwarding allows you to assign a different EAS template to a device

EAS Template 
(SD format to XG2 device)

EAS_HD Template 
(HD format to XG1 device)
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To assign a template to a device that is listed in the Device Forwarding table:
1 Create the templates in Xstudio. Be sure to use the exact same name for each template, 

but append a prefix (EAS > HD_EAS) or postfix (EAS > EAS_HD) to the template that is 
intended for the device in the Device Forwarding table. 

2 If your template uses a prefix, disable the Use Postfix setting. However, if your template 
uses a postfix, enable the Use Postfix setting.

3 Double-click the Postfix or Prefix cell next to the device that you want to assign the 
template to. Type the prefix or postfix in the cell.

4 Click OK.

Type in Prefix column => HD_
Enable Prefix by unchecking Use Postfix

Type in Postfix column => _HD
Enable Postfix by checking Use Postfix
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EAS status bar in the Xplay interface
Once the Emergency Alert System (EAS) receiver has been configured in Xplay, a collapsible 
status bar appears along the bottom of the Xplay user interface to provide operators with a 
quick visual of the EAS receiver’s status and the current EAS event massage.

The EAS status bar consists of four sections/components:
• Connection status icon: A blue background and idle message indicate that the 

communication port is open and awaiting EAS events. A red background and error 
message indicate that the port is closed or malfunctioning.

• Event message: The middle portion of the status bar displays the various incoming 
events messages from the EAS receiver.

• View log button: Launches the EAS log history viewer, which displays a list of EAS 
events that have occurred.

• EAS tab: A toggle switch that collapses and expands the EAS status bar.
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Vertigo XG devices can be equipped with an optional GPI card, which provides you with up 
to eight (8) inputs for manually controlling a series of content playout actions. See the 
“Vertigo XG Configuration Guide” for more information about the GPI card option.

The Vertigo Suite includes a GPI Server, which is an independent service that listens for GPI 
triggers coming from the GPI card and then routes the trigger either to the playout device 
for hardware bypass, or to Xplay which has been configured to match GPI inputs up to 
specific playout actions.

The following sections provide instructions for configuring the GPI functionality using the 
GPI Server and Xplay:

1 Configuring and controlling the GPI Server, on page 136
2 Specifying the Video Bypass settings for the GPI inputs, on page 136
3 Starting, stopping, and refreshing the GPI Server, on page 137
4 Opening the GPI Configuration window in Xplay, on page 138
5 Adding states for each GPI input, on page 138
6 Adding a rule to a GPI input state, on page 138
7 Enabling and disabling GPI in Xplay, on page 139
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Configuring and controlling the GPI Server
The GPI Server Control Panel is used to configure the GPI hardware and the video bypass 
option.

To open the GPI Server Control Panel:
• Select Start>Programs>Vertigo>Control Panels>GPI Server Control Panel

Setting the GPI Server’s General and Device Type settings
Selecting the Tools>Options menu in the GPI Server Control Panel allows you to configure 
the GPI hardware via the General and Device Type settings.

Expand the GPI Server heading to display the General and Device Type options categories.

General options
Selecting the General category displays the following parameter:

• Maximum Number of Clients: Specifies the number of programs that can connect to the 
GPI Server.

Device Type
Selecting the Device Type category displays the parameters that identify and configure the 
PCI card that the GPI Server will be monitoring.

Although the interface allows you to select either PCI or Serial, only the PCI parameters are 
currently supported.

• Board Number: Since Vertigo XG device can host multiple GPI cards, this parameter 
allows you to identify which of the GPI cards the GPI Server will monitor. The default 
value of 0 refers to the GPI card in the first slot.

• Sample Interval (us): Specifies the frequency at which the GPI card verifies the state of 
the GPI inputs to see which are active/inactive. The default value is 1000 microseconds.

Specifying the Video Bypass settings for the GPI inputs
The Vertigo XG devices are equipped with a hardware video bypass mechanism which can 
route the input video content directly through to the output channels. The GPI Server 
Control Panel offers you the ability to configure GPI inputs to control the state of the 
device’s video bypass for specific output channels.

Fig. D-1: The Vertigo XG’s hardware video bypass
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To configure the Video Bypass option for the GPI inputs:
1 Open the GPI Server Control Panel and select the Tools>Options menu command. 

Expand the GPI Server heading and select Video Bypass.
2 Click the New button to add a new Video Bypass definition.

3 Define the video bypass definition for a specific GPI input by setting the following 
parameters:

• the state of the video bypass (enable or disable)
• the output channel (A or B)
• the GPI input number (1, 2, 3...etc.)
• the state of the GPI input (High or Low)

For example: Enable video bypass on channel A when input # 1 is High.

4 Optional: Click the New button to add additional video bypass definitions.
5 Click OK.

A message box appears informing you that you must restart the GPI Server for the 
changes to the video bypass settings to be applied to the hardware.

6 Click OK in the message box and return to the GPI Server Control Panel. Click the 
Refresh button to restart the GPI Server and apply the new settings to the hardware.

Starting, stopping, and refreshing the GPI Server
The GPI Server is a service application which must be started and running for the GPI inputs 
to perform their defined playout control actions. Similarly, if you make any changes to the 
settings on the GPI Server Control Panel, the GPI Server must be restarted (refreshed) for 
these new settings to be applied to the hardware.

The current state of the GPI Server is always displayed in the GPI Control Panel’s Service 
Status field. As well, you can control the starting, stopping, and restarting of the GPI Server 
using the Start, Stop, and Refresh buttons.

Note: To remove a Video Bypass definition, click the  icon next to 
the definition that you want to delete. If that definition was previous 
applied to the hardware, you must refresh the GPI Server for the 
changes to be applied.
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Opening the GPI Configuration window in Xplay
For each of the GPI inputs’ states (High or Low), you can define a rule (a set or actions) that is 
sent via the GPI Server to Xplay. Upon receipt of the trigger, Xplay then performs the 
specified actions.

You assign and define the rules for the GPI inputs is performed in Xplay’s GPI Configuration 
window. To open the GPI Configuration window, open Xplay and select the 
Tools>Configure GPI menu command.

Adding states for each GPI input
For GPI inputs to control the playout through Xplay, you must add a state for each of the GPI 
inputs in the GPI Configuration window.

To add a new state for a GPI input:
1 Click the New State button.

The New State dialog box appears.
2 Select the Input Number and the Input State and then click OK.

The input’s state is added to the GPI Configuration dialog box.
3 Optional: Click the New State button to add additional states to the remaining GPI 

inputs.

Adding a rule to a GPI input state
Once a state has been added for a GPI input, you must define a rule that dictates what 
actions will occur when the GPI input is in that state. For example, when GPI input #1 is 
high, then the playlist item will be cued up on device 1.

To add a rule to a GPI input state:
1 In the left-hand column of the GPI Configuration window, select the input state that 

you want to add the rule to and click the New Rule button.
An action is added to the right-hand column of the GPI Configuration window.

2 Select a GPI input action from the Action drop-down list. See GPI input actions, on 
page 139 for a description of each available action.

3 If applicable, set any additional parameters associated with the selected action.
4 Optional: Click the New Rule button to add additional actions to the input state’s rule.
5 Click OK to apply the changes.

Note: To remove an input’s state from the GPI Configuration dialog 
box, select the state to be removed and then click the Remove button. 
The state is immediately removed. Click OK to apply the changes.

Note: To remove an action from the input state’s rule, select the state 
and then click the  icon next to the action that you want to delete. 
The action is immediately removed. Click OK to apply the changes.
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GPI input actions
The following table provides brief descriptions of each action that can be assigned to a GPI 
input state’s rule (see Adding a rule to a GPI input state, on page 138):

Enabling and disabling GPI in Xplay
After configuring the GPI inputs and ensuring that the GPI server is running, you must 
enable GPI in Xplay by selecting Enable GPI from Xplay’s Tools menu. Once enabled, a check 
mark appears beside the Enable GPI menu command.

To disable GPI in Xplay, simply select the Tools > Enable GPI command again and the check 
mark is removed, indicating that GPI is now disabled.

Clear Playlist Removes the current playlist from Xplay’s Playlist Editor.

Cue Down Removes the currently cued playlist item from the playout device 
specified in this action’s Device parameter.

Cue Page Cues the page specified in the action’s Page Name parameter on 
the playout device that is specified in the action’s Device 
parameter.

Cue Recall ID Cues the page specified in the action’s Page Name parameter 
(enter the page’s Recall ID # in this parameter) on the playout 
device that is specified in the action’s Device parameter.

Cue Selected Cues the playlist item that is currently selected in the open playlist 
on the playout device that is specified in the action’s Device 
parameter.

Cue Up Cues the next item in the playlist on the playout device that is 
specified in the action’s Device parameter.

End Moves the playlist selection to the last item in the open playlist.

Event Executes the events or script that is specified in the action’s Name 
parameter.

Home Moves the playlist selection to the first item in the open playlist.

Load Playlist Loads the playlist that is specified thee action’s Playlist parameter 
into Xplay’s Playlist Editor.

Move Down Moves the playlist selection to the next item in the open playlist.

Move Up Moves the playlist selection to the previous item in the open 
playlist.

Page Down Moves the playlist selection down in increments, usually to the last 
item on the displayed in Xplay’s Playlist Editor.

Page Up Moves the playlist selection up in increments, usually to the top 
item on the displayed in Xplay’s Playlist Editor.

Take Takes the currently cued playlist item to air on the playout device’s 
channel that is specified in the action’s Device and Channel 
parameters.
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Contact Us
Grass Valley Technical Support
For technical assistance, contact our international support center, at 
1-800-547-8949 (US and Canada) or +1 530 478 4148.

To obtain a local phone number for the support center nearest you, please consult the 
Contact Us section of Grass Valley’s Web site (www.grassvalley.com).

An online form for e-mail contact is also available from the Web site.

Corporate Head Office
Grass Valley
3499 Douglas-B.-Floreani
St-Laurent, Quebec  H4S 2C6
Canada
Telephone: +1 514 333 1772
Fax: +1 514 333 9828
www.grassvalley.com
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